19:01:18 <ianw> #startmeeting infra
19:01:19 <openstack> Meeting started Tue Jan 31 19:01:18 2017 UTC and is due to finish in 60 minutes.  The chair is ianw. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:23 <openstack> The meeting name has been set to 'infra'
19:01:45 <ianw> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:01:54 <ianw> #topic Announcements
19:02:14 <ianw> I do not think there are any announcements
19:02:36 <ianw> #topic Actions from last meeting
19:02:45 <ianw> #link http://eavesdrop.openstack.org/meetings/infra/2017/infra.2017-01-03-19.02.log.html#l-9
19:02:45 <zaro> o/
19:02:59 <ianw> fungi to announce the infra ptg pike etherpad to relevant mailing lists.
19:03:06 <ianw> #link http://lists.openstack.org/pipermail/openstack-dev/2017-January/110992.html
19:03:07 <AJaeger> done
19:03:20 <ianw> fungi to plumb https for docs.o.o and developer.o.o
19:03:27 <AJaeger> working nicely - done ;)
19:03:29 <ianw> #link https://review.openstack.org/424893
19:03:46 <ianw> yep, that's all nice and green-locky :)
19:03:59 <ianw> clarkb to make a gerritbot release
19:04:09 <ianw> #link http://git.openstack.org/cgit/openstack-infra/gerritbot/tag/?h=0.3.0
19:04:50 <ianw> seems fine, i'm not sure if we restarted though?  are we getting the branch in the log messages
19:06:15 <jeblair> gerrit2   76257  0.1  0.0 396140 37816 ?        Sl   Jan26  13:34 /usr/bin/python /usr/local/bin/gerritbot /etc/gerritbot/gerritbot.config
19:06:15 <ianw> maybe no from a quick look, and i think that was the major feature.  i won't action item that but will take a look later
19:06:51 <jeblair> that seems to be 2 days after the release?
19:07:12 <jeblair> gerritbot==0.2.1.dev13
19:07:23 <jeblair> so maybe hasn't upgraded on the server
19:07:49 <ianw> ahh, that would explain it
19:07:59 <ianw> https://review.openstack.org/#/c/417450/4/gerritbot/bot.py <- is the bit i'm thinking of
19:08:45 <ianw> let me add that then since we figured it out
19:09:14 <ianw> #action ianw ensure gerritbot upgrade is deployed for new release (0.3.0)
19:09:30 <ianw> ok
19:09:54 <ianw> #topic Specs approval
19:10:05 <ianw> #info APPROVED "Update zuulv3 spec to include job repo information" spec
19:10:14 <ianw> #link http://specs.openstack.org/openstack-infra/infra-specs/specs/zuulv3.html#jobs
19:10:34 <ianw> I think that is it for this week?
19:11:57 <ianw> ok, moving on
19:12:48 <ianw> priority efforts ... i don't have anything specific to say, but we can go through the topics quickly and pipe up if you do
19:13:04 <ianw> #topic Priority efforts: Ansible Puppet Apply
19:13:39 <ianw> #topic Priority efforts: A Task Tracker for OpenStack
19:14:20 <ianw> #topic Priority efforts: Zuul v3
19:14:30 <ianw> just so everyone knows, there's a specific zuul meeting
19:14:40 <ianw> #link agenda https://wiki.openstack.org/wiki/Meetings/Zuul
19:14:53 <jeblair> i don't think there's anything we need to chat about this meeting
19:15:11 <ianw> #topic Priority efforts: Gerrit 2.13 Upgrade
19:15:36 <zaro> I’ll pipe up here.
19:16:14 <zaro> pabelanger: was working on making moving zuul-launcher to openstack-ci repo, so this is kinda blocked on that task
19:16:22 <zaro> not sure where he’s at on that.
19:16:43 <zaro> but if he’s not around then maybe note to ask him next time.
19:17:48 <ianw> yes i think he's travelling ATM
19:18:33 <ianw> just for the record, why does that block the gerrit upgrade?
19:21:12 <zaro> it allows review-dev.o.o to work with zuul-dev.o.o again.  right now it zuul isn’t communicating with review-dev.
19:21:23 <zaro> zuul/zuul-dev
19:22:10 <zaro> gerrit upgrade path is to upgrade it on review-dev and make sure it works with current version of Zuul on Zuul-dev.
19:22:51 <ianw> ok
19:23:07 <ianw> let's make it an action item so we don't forget, but will follow up
19:23:48 <ianw> #action pabelanger update on zuul-launcher to openstack-ci move and zuul-dev for gerrit upgrade
19:24:01 <zaro> specifically this thing, #link https://review.openstack.org/#/c/386745/
19:24:22 <ianw> ah, cool
19:24:42 <ianw> anything else?
19:24:49 <zaro> nope.
19:24:54 <ianw> #topic General topics
19:25:14 <ianw> i have one on our disconnects to static.o.o
19:25:20 <ianw> #link http://lists.openstack.org/pipermail/openstack-infra/2017-January/005103.html
19:25:28 <ianw> #link https://review.openstack.org/#/c/426639/
19:25:54 <ianw> i think the first mail explains it, but i feel like switching mpm's on static.o.o will be the easiest thing
19:26:16 <ianw> but ... i'm sure plenty of people have more experience apache wrangling than me, so any input appreciated
19:28:50 <mordred> ianw: yah - the explanation seems reasonable, but I don't have a ton of real useful feedback on that one
19:29:49 <ianw> no worries, just a callout if anyone had experience since it seems a commonish issue, at least enough to make it into the apache docs
19:29:53 <ianw> ok, moving on
19:30:06 <ianw> #topic Open Discussion
19:30:50 <ianw> #link https://review.openstack.org/#/c/423904/
19:30:50 <bkero> ianw: we can try to move mpms and see if the issue arises. If it does I'm sure we can tweak the settings for it.
19:31:17 <ianw> we did talk about ^ last week, that was adding bindep to the wheel builders
19:31:42 <jlvillal> Review request: https://review.openstack.org/425458   gerritbot-puppet  :)
19:32:36 <jlvillal> Or puppet-gerritbot to be correct.
19:33:31 <ianw> the wheel build jobs also now output a failure log file like -> http://logs.openstack.org/periodic/wheel-build-centos-7-amd64-python2/2420b36/logs/failed.txt.gz
19:34:13 <ianw> for example that shows old branches don't like the libvirt that ships with centos7.3
19:34:56 <ianw> jlvillal: oh, cool, that was my action item :)
19:35:58 <jlvillal> ianw: :)
19:37:32 <AJaeger> ianw: do you have logs why something fails? spec-cleaner is part of OpenStack, so could you file a bug for the failure, please?
19:38:11 <ianw> AJaeger: yes, the build logs are compressed into -> http://logs.openstack.org/periodic/wheel-build-centos-7-amd64-python2/2420b36/logs/build-logs.tar.bz2
19:39:15 <ianw> AJaeger: i'm not sure about spec-cleaner.  the NSS related ones need libraries installed ... which are specified in the requirements bindep ... which is why i started down this path :)
19:41:26 <ianw> oh yeah, that's right, the spec-cleaner one gives a odd setup.py error : http://paste.openstack.org/show/597080/
19:41:37 <ianw> anyway, we can look into that later
19:41:54 <ianw> last call, otherwise I think we're done a little early here
19:42:49 <AJaeger> ianw: oh, spec-cleaner is not in OpenStack - let me file the bug then...
19:44:17 <ianw> ok, as always we'll be in #openstack-infra for your infra needs
19:44:21 <ianw> #endmeeting