19:04:15 <fungi> #startmeeting infra
19:04:16 <openstack> Meeting started Tue Jan 10 19:04:15 2017 UTC and is due to finish in 60 minutes.  The chair is fungi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:04:20 <openstack> The meeting name has been set to 'infra'
19:04:25 <fungi> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:04:33 <fungi> #topic Announcements
19:04:48 <fungi> i don't have any for this week, which is pretty sad
19:04:49 <jlvillal> o/
19:04:58 <fungi> as always, feel free to hit me up with announcements you want included in future meetings
19:05:08 <fungi> #topic Actions from last meeting
19:05:35 <fungi> #link http://eavesdrop.openstack.org/meetings/infra/2016/infra.2016-12-20-19.03.html
19:05:48 <fungi> "1. (none)"
19:06:01 <fungi> #topic Specs approval
19:06:12 <fungi> we don't seem to have anything new up this week
19:06:44 <fungi> #topic Priority Efforts: Nodepool: Use Zookeeper for Workers (jeblair)
19:06:54 <fungi> something something release something something
19:07:09 <jeblair> hi!
19:07:16 <fungi> is this spec effectively implemented now, btw?
19:07:22 <morgan> fungi: orly
19:07:58 <jeblair> fungi: huh, i reckon it is
19:08:18 <jeblair> cause the next phase of nodepool work is covered in the zuulv3 spec
19:08:42 <fungi> i like crossing things off the priority efforts list, so feel free to propose a change marking this spec implemented
19:08:48 <jeblair> #action jeblair mark http://specs.openstack.org/openstack-infra/infra-specs/specs/nodepool-zookeeper-workers.html implemented
19:08:57 <fungi> danke
19:09:04 <jeblair> to celebrate that, we also want to make a release
19:09:11 <zaro> o/
19:09:12 <fungi> early and often
19:09:37 <jeblair> we'll be asking people to upgrade to it and use the new zookeeper-based nodepool image builders
19:09:51 <jeblair> so it will require some action on the part of nodepool operators
19:10:18 <fungi> will this be a major version bump for nodepool?
19:10:22 <jeblair> and i think once the release is out, we should start moving openstackci's default configuration to it
19:11:05 <pabelanger> ++
19:11:13 <jeblair> fungi: i think we wanted to hold version 1.0 for the zuulv3 implementation?
19:11:21 <fungi> assuming puppet-openstackci takes care of setting up zk accordingly, that seems fine to me. though it's a disruptive upgrade insofar as state tracking will be lost right?
19:12:03 <pabelanger> it doesn't today. But it is a simple install using an upstream puppet-zookeeper module
19:12:24 <fungi> probably qualifies as a minor version bump then, especially considering semver only really starts with your 1.0.0 release anyway and 0.x.x releases are a bit of an anything-goes scenario
19:12:29 <clarkb> fungi: its disruptive beacuse we haven't written a data migraion between zk and mysql
19:12:39 <jeblair> fungi: yes, we don't have an automatic migration; however, it's okay to lose this data though, nodepool will just start building new images
19:13:35 <fungi> okay, so planning for this as nodepool 0.4.0?
19:13:43 <jeblair> yep
19:13:52 <fungi> works for me
19:14:02 <jeblair> we're looking to land one more change (deprecating the --no-builder cli option)
19:14:17 <jeblair> and then i'll write up a release announcement to make sure people know about the differences
19:14:26 <fungi> is --no-deletes already deprecates?
19:14:28 <jeblair> i'll poke people in #openstack-infra to help review a draft
19:14:29 <fungi> deprecated
19:15:03 <jeblair> fungi: the --no-deletes, --no-launches, --no-images, and --no-webapp were never documented because they were added due to our instance of nodepool being overwhelmed by capacity
19:15:18 <jeblair> (--no-builder, otoh, was a real option)
19:15:31 <jeblair> fungi: the others will be silently removed as part of the v3 effort
19:15:42 <fungi> okay
19:16:13 <fungi> so non-public features don't really need deprecating
19:16:13 <jeblair> i think --no-images is arleady gone
19:16:27 <jeblair> that's my feeling
19:16:34 <pabelanger> yes, it has been removed
19:17:29 <fungi> cool, so we'll review the --no-builder deprecation, then 0.4.0 will be tagged and after that we can mark this priority spec implemented and focus on the zuul v3 spec for remaining nodepool-related bits?
19:17:45 <jeblair> fungi: yep
19:18:05 <jeblair> (and work on that has started in the zuulv3 branch)
19:18:40 <fungi> #info Once the --no-builder deprecation merges, nodepool 0.4.0 will be tagged; after that we can mark this priority spec implemented and focus on the zuulv3 branch for remaining nodepool-related bits.
19:19:05 <fungi> anything else for this we need to cover in-meeting?
19:19:42 <jeblair> fungi: eot from me
19:20:24 <fungi> #topic Priority Efforts: Docs Publishing via AFS (jeblair, pabelanger, AJaeger)
19:20:38 <fungi> seems like we're close to being ready to switch dns now?
19:20:48 <AJaeger> Looking at http://lists.openstack.org/pipermail/openstack-docs/2017-January/009440.html, only one point is missing:
19:20:52 <AJaeger> Switching DNS!
19:21:05 <fungi> i'd call that close to ready ;)
19:21:06 <AJaeger> (and then testing that everything works)
19:21:17 <pabelanger> Ya, I was just looking at DNS
19:21:24 <pabelanger> want to confirm our vhost was correct
19:21:26 <AJaeger> so, anytime somebody wants to change DNS, go ahead and tell all of us ;)
19:21:34 <jeblair> oh neat!
19:21:37 <pabelanger> but can pull the trigger after the meeting
19:22:02 <AJaeger> great, pabelanger !
19:22:08 <jeblair> fungi: looks like we might be about ready to strike another off the list ;)
19:22:17 <fungi> #action pabelanger Switch DNS for docs.openstack.org from CloudSites to files01.openstack.org.
19:22:29 <fungi> that look right?
19:22:48 <jeblair> the docs traffic should be significantly higher than the developer docs traffic, so it's worth keeping an eye on performance
19:22:55 * AJaeger will sent an email as followup to their request from August - could somebody update the Racksapce ticket as well, please?
19:22:59 <AJaeger> See http://lists.openstack.org/pipermail/openstack-infra/2016-August/004690.html
19:23:11 <pabelanger> fungi: WFM
19:23:12 <AJaeger> their= Cloudsites operators
19:23:18 <jeblair> i recommend making the new ttl small (5 mins) at first so we can switch back quickly
19:23:28 <fungi> ahh, yep. they'll want to know they can delete things
19:23:28 <pabelanger> jeblair: agree
19:23:50 <jeblair> (and if there are performance problems, we can either tune the files01 server or add files02 fairly quickly)
19:23:52 <AJaeger> we still publish to *both*, so not directly deleting - but we should give them a heads up
19:24:23 <clarkb> AJaeger: after about a week or so we can stop publishing to both?
19:24:25 <jeblair> yeah, we should let this stabilize, then remove cloudsites publishing, then tell them we're done
19:24:40 <fungi> #action AJaeger follow up to http://lists.openstack.org/pipermail/openstack-infra/2016-August/004690.html letting them know we're ready for site deletion.
19:24:40 <AJaeger> clarkb: yes, one week should be enough.
19:24:42 <jeblair> 1week sounds good to me
19:25:02 <fungi> wfm
19:25:28 <pabelanger> TTL dropped to 5mins on docs.o.o
19:25:32 <AJaeger> ok, then let's do it ;)
19:25:36 <AJaeger> Thanks!
19:25:36 <fungi> thanks pabelanger
19:26:17 <jeblair> pabelanger: you mean you just dropped the current ttl?
19:26:31 <pabelanger> jeblair: yes, from 60 to 5
19:26:46 <pabelanger> still confirming vhost settings on files.o.o
19:26:53 <jeblair> i would have recommended keeping 60 on the current address
19:26:58 <fungi> not strictly necessary, just increases the rate at which people will hit the new ip address once we switch that
19:27:14 <fungi> so yes we may see a much more rapid adoption of the new server
19:27:23 <pabelanger> okay, I can revert here
19:27:56 <jeblair> by doing that, and then switching to a shorter ttl for the new address, we get the luxury of slowly ramping up traffic over 1 hour, but being able to switch back in 5 minutes.  now we will get all of the new traffic within 5 minutes, so if things go bad, they will go bad quickly.
19:29:24 <pabelanger> ack, I have reverted to 60 TTL. IP address has not changed yet
19:29:40 <jeblair> cool
19:30:49 <fungi> anything else we need to cover on this priority effort?
19:31:01 <fungi> hopefully next week we can discuss marking it implemented
19:31:16 <AJaeger> and then I'll ask for https ;)
19:31:29 <AJaeger> but yes, let's move on.
19:31:52 <fungi> AJaeger: i have a couple certs i need to renew within the next few weeks and a couple more from a few months ago i need to expense, so happy to tack docs.o.o on while i'm at it ;)
19:32:13 <fungi> #action fungi Obtain docs.openstack.org X.509 certificate.
19:32:15 <AJaeger> fungi, please do! A week or two longer does not hurt
19:32:25 <AJaeger> fungi: and developer.openstack.org a swell, please
19:32:53 <fungi> added both to my to do list
19:32:58 <jeblair> also, ipv6?
19:32:59 <fungi> #action fungi Obtain developer.openstack.org X.509 certificate.
19:33:28 <fungi> we'll have ipv6 from files01.o.o automatically right?
19:33:32 <jlvillal> I'm guessing don't use letsencrypt then.
19:33:35 <jeblair> derp, yes.
19:33:42 <fungi> jlvillal: not until it stabilizes, no
19:33:44 <clarkb> if its a cname yes
19:33:51 <jlvillal> Ah, okay
19:33:51 <AJaeger> files01 has IPv6
19:34:15 * jlvillal likes the dns-01 auth method with the dehydrated client
19:34:19 <fungi> jlvillal: worth revisiting next year though, maybe
19:34:44 <fungi> catch me outside the meeting for various reasons we've shied away from le so far
19:34:50 <jlvillal> okay
19:35:29 <fungi> any other docs-on-afs issues need discussing today?
19:35:38 <AJaeger> not that I know
19:35:41 <AJaeger> thanks
19:36:04 <fungi> #topic PTG planning (fungi)
19:36:38 <fungi> #link https://wiki.openstack.org/wiki/PTG/Pike/Etherpads
19:36:56 <fungi> #link https://etherpad.openstack.org/p/infra-ptg-pike
19:37:21 <fungi> i primed it with the infra priority specs i don't expect to drop off the list in the next couple weeks
19:37:47 <fungi> but anyone who expects to attend at least monday/tuesday of the pike ptg in atlanta next month feel free to add ideas
19:38:14 <fungi> i expect to handle this in a mostly unconference fashion like we've done with design summit fridays previously
19:38:32 <jeblair> i'm pushing to get zuulv3 runnable by then with the hope that we can start alpha-testing it against the zuul project during the ptg
19:38:43 <clarkb> I would like to have a semi scheduled braindumping on debugging test failures and openstack
19:38:53 <jeblair> so, hoping that we are able to do some installation/configuration work on it
19:39:02 <fungi> i personally expect to spend a lot of those two days on zuul v3 mainly because it's our highest-priority ongoing effort right now
19:39:04 <clarkb> with the idea that devs from other projects can drop in and hopefully learn some useful things about how we go about that
19:39:14 <fungi> but there's room to do other stuff too, obviously
19:39:50 <fungi> clarkb: that offers a great catch-all for vertical contributors who show up early in the week, so good addition
19:40:31 <fungi> worth noting the qa team is running in parallel to us on monday/tuesday
19:40:58 <clarkb> ya I brought it up with them too and they liked the idea. Probably we just need to set a rough time for when a subset of both groups convere in a place that is advertised to toehr devs to drop in
19:41:31 <fungi> so anything that needs their coordination should probably be scheduled with oomichi
19:42:05 <fungi> if it's time-bounded then the fishbowl venue seems appropriate
19:42:44 <clarkb> I think its less about being time bound and more like office hours. Let people know that others interested in helping with such things are going to be around and willing to help with it
19:42:53 <fungi> ttx: not sure how you planned to schedule slots for the fishbowl, but maybe linking from the ptg etherpads list would be a good idea?
19:43:06 <clarkb> but maybe fishbowl is best fit for that?
19:43:22 <jeblair> clarkb: maybe talk with some horizontal ptls to try to get them on board and push people to the session; we've not had great success with people just dropping into infra sessions at summits at least.
19:43:22 <ttx> I was thinking setting up an ethercalc instance
19:43:25 <fungi> (also entirely likely the scheduling mechanics for the fishbowl are already defined and i wasn't paying enough attention)
19:43:46 <fungi> ttx: excellent excuse to start running ethercalc! ;)
19:43:51 <ttx> I know, right :)
19:43:54 <clarkb> jeblair: good point, I can do that
19:44:07 <jeblair> ttx: ++
19:44:09 * fungi has been looking for an excuse for having ethercalc.o.o
19:44:42 <ttx> That will definitely help to keep that etherpad under control
19:44:43 <fungi> i'm happy to help puppeting that, seems like we can mostly just crib from our puppet-etherpad repo
19:46:33 <fungi> probably showing my age, but i like that the name reminds me somewhat of visicalc
19:47:35 <fungi> okay, so anyway, people seem to be adding to the pad. that's what i was looking for. i'll also announce it to the ml right after the meeting
19:48:06 <fungi> #action fungi announce the infra ptg pike etherpad to relevant mailing lists
19:49:36 <fungi> #topic Repo renaming (fungi)
19:49:50 <fungi> carried over from last week where everyone seemed to be asleep
19:50:17 <fungi> we have four repos up for renaming, split across two project-config cganges
19:50:19 <fungi> changes
19:50:49 <fungi> this week is a dead week in the release schedule
19:51:11 <fungi> #link https://releases.openstack.org/ocata/schedule.html
19:51:28 <fungi> anybody up for a repo renaming maintenance, say... friday?
19:51:39 <clarkb> I will be around, Friday is fine with me
19:51:43 <pabelanger> as will I
19:51:54 <fungi> 20:00 utc?
19:52:11 <fungi> maybe that overlaps lunch for west-coasters
19:52:14 <fungi> 21:00 utc?
19:52:26 <pabelanger> either is fine for me
19:52:26 <ianw> thu i could help, but fri puts it in sat morning, but looks like enough anyway
19:52:27 <clarkb> both times are good for me ( will just eat early or late)
19:52:42 <jeblair> i'll be around as backup but would prefer not to drive
19:52:45 <fungi> ianw: happy to have your help if a little later is better
19:53:24 <fungi> ianw: or earlier so you can do it on friday? we could do north american thursday afternoon
19:54:14 <fungi> dhellmann: ^ would that be painful this week, to have a brief gerrit outage and maybe a couple hours (your) thursday afternoon where you should avoid approving new releases?
19:54:26 <ianw> that works for me
19:54:54 <dhellmann> fungi : this is probably the best time to do it before the ptg, so we can make it work
19:55:05 <ttx> dhellmann: +1
19:55:25 <fungi> dhellmann: that was my thinking too. it's teh last dead week in the schedule other than r-2
19:55:39 <dhellmann> given the compressed rc period this cycle, we're not going to have a lot of dead time until march
19:56:07 <dhellmann> yeah, r-2 is during the rc period, so not a great time to take things offline
19:56:14 <fungi> any objections to, say, 20:00 utc thursday (apac friday morning)?
19:56:23 <dhellmann> that time works for me
19:56:24 <ianw> +1
19:56:54 <fungi> i don't know how zomg-early that is for you ianw, feel free to tell me if it should be later
19:57:11 <ianw> 6am, all good
19:57:21 <clarkb> sounds good
19:57:35 <fungi> ianw: you want to send a maintenance announcement to the -dev ml this morning?
19:57:45 <ianw> can do
19:57:50 <fungi> brief outage between 20:00-20:30 utc
19:58:33 <fungi> #info The Gerrit service on review.openstack.org will be offline briefly for project renaming between 20:00 and 20:30 UTC this Thursday, January 12, 2017.
19:58:55 <fungi> thanks ianw!
19:58:59 <fungi> #topic Open Discussion
19:59:03 <jlvillal> Review request for gerritbot patch to add the branch name to the IRC message that announces submitted and merged patches: https://review.openstack.org/#/c/417450/
19:59:05 <jlvillal> :)
19:59:06 <fungi> we have a minute left ;)
19:59:11 <olaph> I am hoping an additional core can find the time to review https://review.openstack.org/#/c/407100/
19:59:26 <pabelanger> I'm still working on the zuul-launcher patch for openstackci.... I promise this week
19:59:57 <clarkb> zaro: you need more reviews on gerrit things for the upgrade?
20:00:06 <fungi> aaaaaaand, we're out of time. thanks everyone! discussions can continue in #openstack-infra, or stay tuned for the tc meeting up next here in #openstack meeting!
20:00:10 <clarkb> zaro: maybe reping people in #openstack-infra for that so we make sure it doesn't get lost in the busyness
20:00:13 <fungi> #endmeeting