19:03:12 <fungi> #startmeeting infra
19:03:13 <openstack> Meeting started Tue Dec 20 19:03:12 2016 UTC and is due to finish in 60 minutes.  The chair is fungi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:03:16 <openstack> The meeting name has been set to 'infra'
19:03:20 <fungi> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:03:22 <fungi> #topic Announcements
19:03:30 <fungi> #info The OpenStack Infra team will not meet on Tuesday, December 27, 2016; our next meeting will occur on Tuesday, January 3, 2017 at 19:00 UTC in the #openstack-meeting channel as usual.
19:03:40 <fungi> (as decided in last week's meeting)
19:03:45 <fungi> as always, feel free to hit me up with announcements you want included in future meetings
19:04:03 <fungi> #topic Actions from last meeting
19:04:10 <fungi> #link http://eavesdrop.openstack.org/meetings/infra/2016/infra.2016-12-13-19.03.html previous meeting minutes
19:04:18 <fungi> pabelanger add openstackci::zuul_launcher puppet class
19:04:22 <pabelanger> Yes!
19:04:24 <fungi> how did you get on?
19:04:30 <pabelanger> I have started working on this locally
19:04:33 <asselin> o/
19:04:38 <pabelanger> just doing a few tests before pushing it up
19:04:43 <pabelanger> but, looks to be straightforward
19:04:59 <pabelanger> will be ready for reviews on thursday
19:05:02 <fungi> okay, cool. maybe we can mark it off by the time we meet again in a couple weeks
19:05:14 <pabelanger> ++
19:05:34 <fungi> i likely won't be doing much in the way of reviews on thursday, but give me a heads up and i'll try to look when i'm online
19:05:44 <pabelanger> sure
19:05:52 <fungi> thanks for working on that!
19:05:57 <fungi> #topic Specs approval
19:06:06 <fungi> #info APPROVED "Zuul v3: update with Ansible role information"
19:06:12 <fungi> #link https://review.openstack.org/381329 "Zuul v3: update with Ansible role information" spec update
19:06:18 <fungi> also i finally marked the artifact signing spec as implemented
19:06:21 <jlvillal> o/
19:06:23 <fungi> #link https://review.openstack.org/409906 "Artifact signing is now implemented" change
19:07:08 <fungi> #link http://lists.openstack.org/pipermail/openstack-dev/2016-December/109111.html "Signing Keys for Ocata Release" announcement
19:07:39 <fungi> doesn't look like we have any new specs going up for a vote this week
19:07:59 <fungi> #topic Priority Efforts
19:08:28 <fungi> nothing is called out on the agenda, but our next discussion topic covers something we may want to consider as an addition
19:08:40 <fungi> #topic Cross-project goal to support Python 3.5 in Pike (fungi)
19:08:47 <fungi> #link https://review.openstack.org/349069 proposed cross-project goal to support Python 3.5 in Pike
19:09:08 <fungi> the latest patchset for that proposed pike goal mentions infra
19:09:15 <AJaeger> we have quite a few repos without python35 jobs
19:09:24 * AJaeger hasn't done any detailed analysis
19:09:41 <fungi> we do have rather a lot of python-based tooling, at least some of which is probably not tested at all for py3k compliance, and certainly most of it is not regularly running all its tests under 3.5
19:10:29 <fungi> i haven't responded positively to the goal wearing my infra ptl hat yet, since i wanted to bring it up with the team first and figure out if we think it's feasible by the end of pike
19:10:59 <jeblair> fungi: i don't think we belong in there
19:11:30 <fungi> i can certainly make that case, given sufficient explanation
19:11:59 <jeblair> i imagine that this sort of goal is to make openstack itself more operationally consistent
19:12:01 <fungi> exemption along the same lines as the licensing argument?
19:12:21 <jeblair> fungi: indeed, and even language -- i mean, our java code isn't going to be py3 any time soon
19:13:12 <fungi> well, sure, this is primarily about making sure we don't get caught without a solution when python 2.7 reaches end of life
19:13:34 <jeblair> i'm not disputing its importance, merely the need to synchronize with openstack itself on tihs
19:15:16 <clarkb> its probably not a bad idea to start thinking about it though?
19:15:28 <jeblair> oh, we've been thinking about it, and indeed doing a lot of work
19:15:49 <fungi> yeah, so for infra projects we generally don't use coordinated global requirement synchronization, have projects under other (even apache-incompatible) free licenses, have projects in languages not officially sanctioned by the tc for openstack deliverables
19:16:00 <jeblair> but we've also been deferring some of it because we know that the initial cut of zuulv3 is more urgent
19:16:00 <DavidPurcell> Might also want to update the creator's guide templates to include or require 3.5 http://docs.openstack.org/infra/manual/creators.html#configure-zuul-to-run-jobs
19:16:48 <clarkb> one thing we could do is require any new code to be python3
19:16:55 <jeblair> no we can't
19:16:58 <clarkb> like possible new bug organizing report dashboard
19:17:01 <clarkb> jeblair: why not?
19:17:02 <jeblair> oh like that
19:17:04 <fungi> DavidPurcell: yep, agreed, in fact we've already started including gate-{name}-python35 in the python-jobs job-template in jjb and have talked about adding it to the python-jobs project-template in zuul's config
19:17:06 <AJaeger> DavidPurcell: I just updated that page, wonder why it's not up yet...
19:17:07 <jeblair> i thought you meant new patches
19:17:16 <clarkb> sorry not new patches, new project repos/code bases
19:17:41 <jeblair> clarkb: possibly. i mean, we should at least try.  :)
19:18:13 <fungi> so i guess there's a couple of major axes to this problem from our (infra's) perspective
19:18:18 * AJaeger investigates why infra-manual publishing fails
19:18:21 <clarkb> we could also likely port our jobs that check things about our repos to python3 easily as that should be self testing maybe
19:18:22 <DavidPurcell> AJaeger: It is now...  That was quick.
19:18:36 <fungi> first is whether _our_ tools need to all support python 3 asap, and it sounds like that's maybe a harder sell
19:18:38 <AJaeger> DavidPurcell: ;)
19:19:03 <fungi> the other is whether our ci supports and workflow documentation encourages python 3 support in other projects
19:19:11 <fungi> which i think we've already mostly met?
19:19:36 <clarkb> yes, I don't think anything prevents our users from running python3
19:19:41 <AJaeger> we should double check the documents
19:20:35 <fungi> certainly implying that it's acceptable for completely new python projects to start out without python 3 support is something we should avoid
19:22:18 <jeblair> fungi: there's a reference to an un-logged #openstack-python3 channel in there
19:22:31 <fungi> a rough count says we have somewhere around 40 infra repos with a setup.py in them, and even auditing those for py3k compliance before the end of the pike cycle strikes me as a tall order
19:22:46 * AJaeger just did https://review.openstack.org/413211 to promote python35-jobs a bit
19:22:48 <fungi> jeblair: oh, fun
19:23:03 <jeblair> fungi: which violates the tc irc channel policy: https://governance.openstack.org/tc/reference/irc.html
19:23:56 <pabelanger> okay, that took me way to long to find Infrastructure in that review
19:24:10 <AJaeger> before we enforce it, we need to extend meetbot setup to handle all channels...
19:24:32 <pabelanger> Agreed, that is going to be a fair amount of work for us I think.
19:24:39 <pabelanger> with zuulv3 effort
19:24:51 <fungi> jeblair: agreed, i've asked dhellmann and haypo in that channel whether there's a change to add logging for it
19:25:10 <fungi> dhellmann thinks it's an oversight we should correct
19:25:17 <clarkb> right I think a good place to start is where it is easy
19:25:32 <clarkb> require new code bases be python3, update simple scripts that are already self testing, and so on
19:25:35 <jeblair> there are some significant py3 challenges with gear that need to be resolved before systems that use it can/should switch to py3
19:25:56 <jeblair> this is one of the things we have deferred so that we can make progress on the basics in zuulv3
19:26:36 <jeblair> i think they are solvable, but they are going to take some real care and thought, and should not be rushed
19:26:37 <AJaeger> at least all infra repos that have python35 set up , have it as voting ;)
19:26:42 <fungi> jeblair: yeah, i think the fact that we don't use global requirements and the py3k goal hinges on making sure the global requirements list of deps support it is a good indication of the situation we're in there
19:28:26 <jeblair> fungi: yeah, and i like the idea of the goals, and i like this one.  i don't want us to be a distraction for it.
19:29:22 <fungi> #agreed The Infra team is actively working toward Python 3 support across its tooling, but has far more diverse requirements from the general body of OpenStack services and libraries and so does not expect to complete that effort by the end of the Pike development cycle; however making sure our CI automation supports the Python 3 testing needs of other projects is a very high priority (and already
19:29:23 <fungi> basically solved).
19:29:28 <fungi> hrm, that was too long
19:29:30 <fungi> #undo
19:29:31 <openstack> Removing item from minutes: <ircmeeting.items.Agreed object at 0x7fc5685a3d10>
19:29:52 <fungi> #agreed The Infra team is actively working toward Python 3 support across its tooling, but has far more diverse requirements from the general body of OpenStack services and libraries and so does not expect to complete that effort by the end of the Pike development cycle.
19:29:53 * jlvillal notices another thing to to add a __str__ method to
19:30:20 <fungi> #agreed Making sure our CI automation supports the Python 3 testing needs of other projects is a very high priority (and already basically solved).
19:30:41 <fungi> everyone comfortable with those two stated agreements?
19:30:51 <AJaeger> yes
19:30:52 <clarkb> yup
19:30:56 <jeblair> ++
19:31:08 <pabelanger> ++
19:31:15 <jhesketh> Yep
19:31:26 <fungi> thanks! this was very helpful
19:31:47 <jeblair> fungi: thank you for interfacing!
19:32:03 <fungi> anybody else have anything they want to say on the python 3 goal front before i yield teh floor to clarkb's topic?
19:32:49 <fungi> #topic Switch review.o.o openid to login.ubuntu.com (clarkb)
19:33:14 <fungi> we were originally talking about doing this late last week or early this week i guess
19:33:34 <clarkb> ya basically we should be thinking about this so lp doesn't berak us again as supposedly we are using the wrong url
19:33:44 <clarkb> (we should also be thinking about storyboard and wiki)
19:33:57 <zara_the_lemur__> yeah, I've +1'd a patch for storyboard
19:33:59 <jeblair> 'wrong' but not 'deprecated' :)
19:33:59 <zara_the_lemur__> I can't merge it
19:34:10 <zara_the_lemur__> since it's in the system config repo
19:34:22 <clarkb> zara_the_lemur__: ya and the tricky part is we have to update the config, and db at roughly the same time
19:34:47 <clarkb> gerrit is a bit easier because we can update db while it is running as gerrit allows for more than one openid
19:35:20 <fungi> right, with gerrit we can basically just leave the "old" openid urls in the db forever
19:35:28 <clarkb> for gerrit I think our rough plan should be 1) update db 2) merge config change 3) restart gerrit when config is applied.
19:35:53 <clarkb> and then question si do we want to schedule a more formal downtime, get everything done ahead of time so that when GC problems occur we do restart then or something else?
19:36:21 <jeblair> clarkb: that's still a little racy if people make new accounts during then
19:36:30 <fungi> the tricksy timing for gerritses comes down to minimizing the window between the db additions and the config change, since new accounts created between them could end up broken/duplicated
19:36:37 <fungi> er, what jeblair just said
19:36:39 <jeblair> fungi:  :)
19:36:44 <clarkb> jeblair: oh good point
19:37:00 <clarkb> so maybe is best to stop gerrit, update db, update config, start gerrit
19:37:02 <jeblair> clarkb: so we may want a second 'update the db' change to catch any new accounts; or maybe we just want to take a brief outage and do the db update and config change while offline
19:37:27 <fungi> it's not as if gerrit's under heavy use this time of year
19:39:12 <clarkb> jeblair: problem with catch new accounts is they won't work in the interim
19:39:28 <clarkb> actually maybe they will I think monty mentioned he tested the old and new things accept the old and new urls both
19:39:30 <jeblair> yeah, i lean toward the outage idea
19:39:31 <fungi> rather, they'll get duplicated
19:39:34 <clarkb> but outage will be safer
19:40:17 <fungi> i did test that the lp api calls used in jeepyb support user lookups via openid interchangeably with both
19:40:34 <fungi> so we can patch those any time we like
19:41:29 <clarkb> are people around tomorrow?
19:41:39 <jeblair> yep
19:41:48 <fungi> i am not around tomorrow, but if other people are and want to work on it then please feel free to do so
19:41:59 <fungi> i'll be driving a good chunk of the day
19:42:08 <clarkb> mordred: did the review-dev change, any chance you will be around tomorrow and we can do the prod server?
19:42:14 <clarkb> I will be around
19:42:28 * jhesketh isn't but can be if needed
19:42:32 <clarkb> jeblair: we could do it if you are willing to
19:42:38 <mordred> clarkb: yah
19:43:05 <jeblair> clarkb: wfm
19:43:16 <clarkb> great what time works tomorrow? say 1800UTC?
19:43:33 <mordred> clarkb: I'm free all day
19:43:51 <clarkb> ok I should be awake by 1800UTC but will ping mordred and we can get it done
19:44:43 <jeblair> 1800 is good for me
19:44:50 <clarkb> I will also likely poke at storyboard-dev at some point tomorrow as well
19:45:28 <clarkb> sounds good. Thats mostly what I wanted out of this topic. How do we want to go about it and when and those have both been answered
19:46:24 <zara_the_lemur__> :)
19:47:27 <fungi> i'm already comfortable this should be pretty straightforward. the main trick which mordred already solved is the etl to add/replace rows keeping some substring constant while altering another substring
19:47:55 <pabelanger> I won't be around much tomorrow to help, a heads up
19:48:03 <fungi> happy to just find out the next time i get to the internet that it's done and behind us ;)
19:48:09 <mordred> \o/
19:50:18 <fungi> okay, anything else need hashing out for the openid url replacement?
19:50:28 <ianw> not that i have any great insights into it, but i will be around .au time if everything goes cray cray and you want to go to bed :)
19:50:55 <fungi> thanks, everyone who's working on updating this
19:50:58 <fungi> #topic Open discussion
19:51:03 <jlvillal> I notice on #openstack-meeting-5 that 'openstack' is not an operator. Which seems incorrect.
19:51:32 <clarkb> I think that got traced back to the accessbot not having its nick set properly?
19:51:39 <clarkb> I know I +2'd the change to fix that
19:51:40 <fungi> jlvillal: i believe it gets topic modifying permission anyway so shouldn't bother
19:51:55 <fungi> s/bother/matter/
19:52:03 <fungi> maybe we do that through chanops?
19:52:19 <fungi> i thought we just added the specific mode for topic
19:52:27 <jlvillal> I just did a 'testing' meeting there and the topic stays the same
19:53:23 <jlvillal> And doing the #topic command didn't seem to do anything
19:53:35 <fungi> oh, meetbots get +O so are auto-opped
19:53:46 <fungi> but that only takes effect on /join i think
19:54:19 <fungi> so probably needs a restart or might be able to just /kick and let it rejoin?
19:54:34 <fungi> or else it'll take effect the next time a change merges to its own configuration
19:54:42 <clarkb> and make sure it is setting its nick properly now
19:55:07 <clarkb> er I guess if it has the proper access in that channel that that did work /me checks
19:55:27 <jeblair> it's not on the access list for that channel
19:55:43 <jeblair> so accessbot is broken or its config is broken or has not run
19:58:16 <clarkb> https://review.openstack.org/#/c/410975/ did merge so possibly we just have to restart the accessbot?
19:58:35 <fungi> oh, as mentioned i'm not around much tomorrow. i'll be mostly spotty with my online activity for the coming week, but should be around again normally from the 29th onward
19:59:36 <clarkb> and change your freenode password
19:59:36 <dims> happy holidays everyone!
19:59:53 <fungi> thanks dims
20:00:04 <fungi> aaaaand we're out of time--thanks everyone!
20:00:06 <fungi> #endmeeting