#openstack-meeting: infra

Meeting started by fungi at 19:03:01 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting (fungi, 19:03:07)

  1. Announcements (fungi, 19:03:13)
    1. Our "Ocata Cycle" [2048R/0x8B1B03FD54E2AC07] signing key has been generated; infra-root admins are requested to follow our attestation process as soon as possible. (fungi, 19:03:20)
    2. https://sks-keyservers.net/pks/lookup?op=vindex&search=0xd47bab1b7dc2e262a4f6171e8b1b03fd54e2ac07&fingerprint=on OpenStack Infra (Ocata Cycle) <infra-root@openstack.org> (fungi, 19:03:28)
    3. http://docs.openstack.org/infra/system-config/signing.html#attestation Attestation process (fungi, 19:03:34)

  2. Actions from last meeting (fungi, 19:04:01)
    1. http://eavesdrop.openstack.org/meetings/infra/2016/infra.2016-11-01-19.03.html (fungi, 19:04:07)
    2. ACTION: fungi send summit session summary to infra ml (fungi, 19:04:23)
    3. http://lists.openstack.org/pipermail/openstack-dev/2016-November/106668.html important changes to pep8 python jobs (fungi, 19:04:36)
    4. ACTION: pabelanger send followup announcement for wheel-less pep8 job transition (fungi, 19:05:00)

  3. Specs approval (fungi, 19:05:36)
    1. APPROVED "Neutral governance website" spec (fungi, 19:05:44)
    2. http://specs.openstack.org/openstack-infra/infra-specs/specs/neutral-governance-website.html "Neutral governance website" spec (fungi, 19:05:51)

  4. Specs approval: PROPOSED "Automate Creating Branches" spec (dhellmann) (fungi, 19:06:19)
    1. https://review.openstack.org/369643 "Automate Creating Branches" spec review (fungi, 19:06:25)
    2. The "Automate Creating Branches" spec is open for Infra Council vote until 19:00 UTC Thursday, November 10. (fungi, 19:07:45)

  5. Priority Efforts (fungi, 19:11:05)
    1. https://review.openstack.org/393492 Mark openstackci spec as complete (fungi, 19:14:28)

  6. Ensuring projects adhere to the Consistent Testing Interface (fungi) (fungi, 19:16:35)
    1. https://review.openstack.org/394620 Make sure opportunistic DB use in unit tests works (fungi, 19:16:50)
    2. http://governance.openstack.org/reference/cti/python_cti.html#specific-commands Consistent Testing Interface: Python (Specific commands) (fungi, 19:26:20)
    3. AGREED: Infra consensus is that jobs adding custom database configuration or special filesystems prior to running CTI-mandated test commands do not necessarily violate the CTI as worded; clarification in the CTI on this point would be a welcome addition. (fungi, 19:34:47)
    4. ACTION: fungi propose clarification about project-specific test preconditions (databases, filesystems) for cti (fungi, 19:39:13)

  7. Open discussion (fungi, 19:40:16)
    1. ACTION: fungi purchase cert for pholio.openstack.org (fungi, 19:41:43)
    2. http://lists.openstack.org/pipermail/openstack-dev/2016-November/106827.html pycrypto vs cryptography (fungi, 19:48:15)
    3. https://review.openstack.org/#/c/391588/ (flaper87, 19:53:11)
    4. http://git.openstack.org/cgit/openstack-infra/system-config/tree/modules/openstack_project/templates/static-governance.vhost.erb erb template for governance.o.o site (fungi, 19:58:14)


Meeting ended at 19:59:59 UTC (full logs).

Action items

  1. fungi send summit session summary to infra ml
  2. pabelanger send followup announcement for wheel-less pep8 job transition
  3. fungi propose clarification about project-specific test preconditions (databases, filesystems) for cti
  4. fungi purchase cert for pholio.openstack.org


Action items, by person

  1. fungi
    1. fungi send summit session summary to infra ml
    2. fungi propose clarification about project-specific test preconditions (databases, filesystems) for cti
    3. fungi purchase cert for pholio.openstack.org
  2. openstack
    1. fungi purchase cert for pholio.openstack.org
  3. pabelanger
    1. pabelanger send followup announcement for wheel-less pep8 job transition


People present (lines said)

  1. fungi (118)
  2. jeblair (40)
  3. clarkb (24)
  4. flaper87 (22)
  5. dhellmann (12)
  6. mordred (8)
  7. ianw (6)
  8. openstack (4)
  9. pabelanger (3)
  10. bkero (2)
  11. zaro (2)
  12. rcarrillocruz (2)
  13. SotK (1)
  14. persia (1)
  15. asselin (1)


Generated by MeetBot 0.1.4.