19:02:06 <pleia2> #startmeeting infra
19:02:07 <openstack> Meeting started Tue Oct 11 19:02:06 2016 UTC and is due to finish in 60 minutes.  The chair is pleia2. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:10 <openstack> The meeting name has been set to 'infra'
19:02:14 <pleia2> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:03:29 <pleia2> #topic Announcements
19:03:38 <pleia2> so I'm here chairing because
19:03:42 <pleia2> #info reminder: fungi is on vacation October 8-16, ask pleia2 if you need things done prior to his return
19:03:54 <clarkb> fungi ran away from hurricane olaph
19:04:04 <anteaya> to Canada
19:04:05 <rcarrillocruz> :S
19:04:06 <pleia2> and in other news...
19:04:08 <anteaya> on a boat
19:04:10 <pleia2> #info Our infrastructrure made it through another OpenStack release, hooray Newton!
19:04:15 <Zara> \o/
19:04:16 <pleia2> so congrats everyone :)
19:04:22 <anteaya> yay
19:04:26 <pleia2> any other announcements?
19:04:46 <clarkb> the summit is in 2 weeks
19:04:53 <rcarrillocruz> can't wait ^
19:04:56 <rcarrillocruz> :-)
19:05:16 <pleia2> #info The Summit is coming up in 2 weeks
19:05:29 <pleia2> (we have an agenda item on that later)
19:05:47 <pleia2> #topic Actions from last meeting
19:05:50 <pleia2> #link http://eavesdrop.openstack.org/meetings/infra/2016/infra.2016-10-04-19.03.log.html
19:05:55 <pleia2> 1. (none)
19:05:59 <pleia2> done and done ;)
19:06:05 <pleia2> #topic Specs approval
19:06:11 <pleia2> #link https://review.openstack.org/381330 Zuul v3: correct vagueness in describing job inheritance
19:06:34 <pleia2> since this was a "sync with reality change" it was only supposed to stay open until Thursday, October 6, but I think between hurricane prep and trip prep, fungi didn't get to it, folks can still chime in if they want
19:06:46 <pleia2> I imagine he'll approve when he gets back
19:07:00 <pleia2> #link https://review.openstack.org/381329 Zuul v3: update with Ansible role information
19:07:31 <pleia2> on behalf of jeblair, this one is also open from the last meeting, but no deadline was set on it so just know that it's still out there if you haven't looked at it yet
19:07:44 <pleia2> any other specs to look at?
19:08:34 <pleia2> and it doesn't look like we have anything from the Priority Efforts this week, so I'll just move on to the other topics unless anyone comes up with anything in the next couple minutes
19:08:56 <rcarrillocruz> infracloud is related to my cacti item, so i'll just wait
19:09:06 <pleia2> sounds good
19:10:40 <pleia2> alright then, we'll move along to the other topics
19:10:44 <pleia2> #topic Ocata Summit Planning (pleia2, c/o fungi)
19:10:58 <pleia2> fungi sent an email last week about firming up our design summit sessions
19:11:07 <pleia2> #link http://lists.openstack.org/pipermail/openstack-infra/2016-October/004768.html
19:11:52 <pleia2> he made a proposal there as to what to do, please read it if you haven't yet, there were crickets on the mailing list :)
19:12:03 <Zara> ah, sorry, it worked for me so I just didn't say anything
19:12:08 <pleia2> me too
19:12:35 <pleia2> I have keys to add them to the schedule, just want to make sure we have some vague consensus here
19:12:36 <rcarrillocruz> erm , yeah
19:12:37 <SotK> me also
19:12:44 <rcarrillocruz> i could have just nod about th einfracloud items myself
19:12:49 <bkero> Maybe fungi needs to do a worse job so we have something to complain about next time. :)
19:12:55 <anteaya> pleia2: I'm not attending so I have no opinion
19:13:00 <rcarrillocruz> i'll reply afterwards
19:13:02 <clarkb> ya I didn't really have any opposition to what was there
19:13:10 <pleia2> nibalizer, jhesketh?
19:13:12 <rcarrillocruz> bkero: haha, that'll be a tough one :-)
19:14:26 <jhesketh> pleia2: sadly I won't be at the summit :-(
19:14:45 <anteaya> jhesketh: :(
19:14:46 <pleia2> a lot of that this time around
19:14:54 <Zara> :(
19:14:58 <anteaya> jhesketh: we can be not at the summit together
19:15:00 <nibalizer> ill be at the summit, yes
19:15:12 <nibalizer> but cant see the sechedule becauae phone--
19:15:31 <clarkb> nibalizer: your apple device can't look at http://lists.openstack.org/pipermail/openstack-infra/2016-October/004768.html ?
19:15:34 <jhesketh> anteaya: oh exciting, I'll get to see Canada instead :-)
19:15:45 <anteaya> jhesketh: would love to have you here
19:16:03 <pleia2> clarkb: you and your fancy web
19:16:22 <clarkb> I just have to give nibalizer a hard time for his apple device >_>
19:16:27 <pleia2> hehe
19:16:32 <bkero> Next time maybe a device that can open URLs.
19:16:55 <nibalizer> its more loke i switched to weechat
19:17:09 <nibalizer> ans cant get the nicklist to go away, so i cant click the url
19:17:13 <pleia2> alright, that's consensus enough and we all did collaborate on the etherpad, I'll work on figuring out the UI for this scheduling thing this afternoon and add stuff
19:17:22 <nibalizer> this worked fine on my irssi >.>
19:17:32 <clarkb> nibalizer: I can help after meeting if you like
19:17:36 <nibalizer> kk
19:17:36 <anteaya> nibalizer: that large nicklist
19:17:56 <nibalizer> pleia2: thanks
19:18:15 <pleia2> #action pleia2 to add infra summit schedule
19:18:26 <pleia2> ok, let's move along then
19:18:31 <pleia2> #topic Replacement of cacti node (rcarrillocruz)
19:18:37 <pleia2> rcarrillocruz: floor is yours :)
19:18:38 <rcarrillocruz> so, our cacti is sad
19:18:43 <rcarrillocruz> we need a bigger instance
19:18:47 <rcarrillocruz> which I have created
19:18:50 <rcarrillocruz> i have two changes for that
19:18:50 <nibalizer> yay
19:18:53 <pleia2> oh good
19:19:00 <rcarrillocruz> https://review.openstack.org/#/c/383761/
19:19:05 <rcarrillocruz> https://review.openstack.org/#/c/378996/
19:19:13 <pleia2> #link https://review.openstack.org/#/c/383761/
19:19:15 <pleia2> #link https://review.openstack.org/#/c/378996/
19:19:22 <rcarrillocruz> and i'd like to hear how people want to proceed
19:19:31 <rcarrillocruz> should we schedule a schdule window or we just do it?
19:19:49 <rcarrillocruz> i believe it's struggling regardless, not that we will miss much functionality
19:19:52 <rcarrillocruz> also , INFRACLOUD
19:20:00 <pleia2> afaict it's useless at the moment
19:20:01 <clarkb> rcarrillocruz: on the firewall front I think you should keep both IPs in the fireawll to start
19:20:06 <clarkb> then remove the old one when things are happy
19:20:11 <rcarrillocruz> i've held up chocolate setup on nodepool just to not worsen things
19:20:24 <rcarrillocruz> clarkb: good call
19:20:38 <pleia2> I'm inclined to suggest we do this ASAP
19:20:46 <pleia2> but we do have a pretty lean crew this week
19:20:51 <rcarrillocruz> so as soon as we get a new cacti, we can get chocolate rolling (and start looking at newton redeploy)
19:21:15 <clarkb> rcarrillocruz: I will leave comments, as for scheduling we don't have any major outages planned between now and summit where we might want to avoid cacti outages so I think we can just do it
19:21:30 <rcarrillocruz> the process would be stop cacti, umount fs, detach cinder volume, attach on new machine, mount fs and start cacti as far as i can see
19:21:34 <clarkb> rcarrillocruz: basically get the two needed changes in then when you have some time go for it
19:21:43 <rcarrillocruz> sweet
19:22:01 <rcarrillocruz> i can do that tonight then, since tomorrow is bank holiday in Spain
19:22:10 <pleia2> yeah, tomorrow is a holiday for me too
19:22:24 <clarkb> I think there was some gotcha related to removing the cinder volume from the old host
19:22:32 <rcarrillocruz> i'll ping folks for final reviews after i push a patchset for the iptables change
19:22:33 <clarkb> where if you don't do some step it takes horus to timeout?
19:22:33 <pleia2> permissions is the big one, right?
19:22:40 <pleia2> oh, that
19:23:28 <nibalizer> (thanks everyone who has pmmed me the answer to my weechat issue btw)
19:24:29 <pleia2> rcarrillocruz: we don't want it to be broken on the holiday, so want to do it tonight, or Thursday?
19:24:47 <pleia2> is getting late
19:25:00 <rcarrillocruz> yeah, thursday works too
19:25:12 <pleia2> maybe just write up a quick plan tonight in case we remember cinder weirdness issues
19:25:13 <clarkb> I will be around thursday (all week too)
19:25:18 <pleia2> me too
19:25:24 <rcarrillocruz> ++ thx
19:25:29 <ayoung> lbragstad, Gerrit is unclear in the patch ordering.  THe first of your patches is "Make sure all v3 tokens are validated the same"  right?
19:25:31 <pleia2> thanks rcarrillocruz
19:25:48 <ayoung> and the last is "One validate method to rule them all..."
19:25:52 <anteaya> ayoung: you are in the infra meeting
19:25:55 <ayoung> sorry
19:26:05 <pleia2> ok, sounds like we have a plan for Cacti
19:26:17 <pleia2> #topic Open discussion
19:26:25 <pleia2> look at all this time for open discussion :)
19:26:32 <rcarrillocruz> heh
19:27:39 <clarkb> we are running with tls-proxy enabled on a few tempest jobs now. We still need to sort out why apache restarts and reloads break on centos but not fedora or ubuntu. Also there is an issue with nova api talking to neutron for port listings being tracked by e-r
19:27:48 <clarkb> (more of a general FYI than anyone needing to take action)
19:28:17 <zaro> i don't remember now, but did we agree on waiting until after openstack release or after summit to try gerrit version with fixed jgit?
19:28:43 <clarkb> zaro: after summit because we weren't erally comfortable cramming it in before summit especialyl with all the travel/vacation people seem to be doing beforehand
19:29:02 <zaro> ok.
19:29:14 <rcarrillocruz> how people feels about looking at redeploying chocolate infracloud on newton?
19:29:16 <rcarrillocruz> pre-summit
19:29:27 <rcarrillocruz> or a nice item to hack on *during* summit
19:29:29 <rcarrillocruz> ?
19:30:11 <crinkle> i could try to help with that during the summit
19:30:27 <clarkb> I dno't have a ton of time between nwo and summit
19:30:39 <rcarrillocruz> k, i'll just look at other stuff then
19:30:41 <clarkb> but would likely help with that during summit sprint day
19:31:00 <pleia2> same, time until summit is busy for me
19:31:04 <clarkb> rcarrillocruz: that mgiht be a good excuse to do that "how to deploy" infracloud thing that we have talked about?
19:31:04 <pleia2> but at summit is good
19:31:33 <rcarrillocruz> yeah
19:33:00 <pleia2> any other things?
19:33:16 <clarkb> yes, something that just popped up in -infra
19:33:21 <clarkb> neutron + multinode testing is still broken
19:33:30 <clarkb> and I think it would be good to fix that before adding new multinode jobs
19:33:51 <pleia2> yeah
19:38:34 <ttx> while in open discussion, I have a review to promote
19:38:47 <ttx> https://review.openstack.org/#/c/382447/
19:38:48 <pleia2> hah, ok :)
19:39:07 <pleia2> ah, a spec
19:39:20 <ttx> It's something I planned to work on but wanted some quick confirmation that I crossed all ts
19:40:09 <ttx> basically pushing TC documents under /tc and setting up redirects, so that all three sites (tc, uc, election) are served from a neutral / index page
19:40:20 <ttx> (without breaking existing links)
19:40:38 <ttx> so if you have a few spare cycles, please consider reviewing
19:40:50 <ttx> </shamelessplug>
19:41:14 <pleia2> probably would have made sense to talk about the structure of things more formally earlier, but fixing it now is good
19:42:00 <pleia2> ok, I think we'll wrap up early if no one has anything else
19:43:11 <rcarrillocruz> i'm good
19:43:18 <clarkb> nothing more from me
19:43:30 <pleia2> alright, thanks everyone
19:43:35 <pleia2> #endmeeting