19:03:08 <fungi> #startmeeting infra
19:03:09 <openstack> Meeting started Tue Jul 26 19:03:08 2016 UTC and is due to finish in 60 minutes.  The chair is fungi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:03:13 <openstack> The meeting name has been set to 'infra'
19:03:19 <fungi> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:03:24 <fungi> #topic Announcements
19:03:24 <mordred> o/
19:03:26 <pleia2> I was interviewed for the Super User blog, talked about us some, hoping to raise visibility again of the fact that support for our team is essential to openstack: http://superuser.openstack.org/articles/why-infrastructure-is-the-key-to-openstack-s-big-tent
19:03:29 <jhesketh> o/
19:03:39 <Zara> \o/
19:03:52 <fungi> pleia2: thanks for your tireless efforts marketing us! ;)
19:03:58 <pleia2> hehe
19:04:01 <anteaya> pleia2: thank you
19:04:08 <corvus> pleia2: cool!
19:04:23 <rcarrillocruz> \o/
19:04:23 <fungi> i haven't read it yet, but it's probably way better than my superuser interview
19:04:24 <bkero> Good stuff, thanks pleia2
19:04:24 <prometheanfire> nice :D
19:04:43 <fungi> #info Reminder: late-cycle joint Infra/QA get together to be held September 19-21 (CW38) in at SAP offices in Walldorf, DE
19:04:45 <fungi> #link https://wiki.openstack.org/wiki/Sprints/QAInfraNewtonSprint
19:04:54 <clarkb> we have started the xenial as default test platform switchover
19:05:02 <fungi> oh, good one
19:05:11 <clarkb> had a minor issue getting job + branch selection correct for openstack-ansible which we fixed
19:05:14 <clarkb> no one else has screamed
19:05:24 <fungi> i should start having people submit announcements to me (or add them to the agenda) ahead of time
19:05:27 <clarkb> so uh if you have time/interest feel free to help write chagnes to switch us over
19:05:31 <bkero> clarkb: is that for stable releases as well, or are those in-time?
19:05:41 <clarkb> bkero: no stable remains on trusty so we roll forward on xenial
19:05:49 <anteaya> fungi: that sounds reasonable
19:05:59 <bkero> So once newton is cut it will be xenial, then o, etc
19:06:03 <clarkb> yup
19:06:07 <bkero> okay
19:06:09 <fungi> we could discuss this (xenial testing) under the priority efforts if there's a lot of questions
19:06:29 <fungi> #topic Actions from last meeting
19:06:35 <fungi> #link http://eavesdrop.openstack.org/meetings/infra/2016/infra.2016-07-19-19.02.html
19:06:41 <fungi> pleia2 Submit a spec to host an instance of limesurvey
19:06:43 <fungi> i didn't see one in review... keep for next week?
19:06:52 <pleia2> it's half written, I'll finish it before friday (when I am traveling)
19:06:59 <fungi> #action pleia2 Submit a spec to host an instance of limesurvey
19:07:07 <fungi> right on
19:07:15 <fungi> #topic Specs approval
19:07:24 <fungi> none new this week
19:07:31 <fungi> #topic Priority Efforts: A Task Tracker for OpenStack (Zara, SotK, anteaya, markus_z)
19:07:35 <fungi> there was interest from markus_z in specifying a minimum warning period (maybe one month?) between tc acceptance and migration date
19:07:40 <fungi> anybody think this is unreasonable to add to the spec?
19:08:06 <SotK> I think its sensible
19:08:11 <anteaya> I do not think it is unreasonable
19:08:11 <Zara> I'm fine with it :)
19:08:21 <fungi> basically providing some stability for the community to finish up tool rewrites that were using the lp api so that they work with sb
19:08:36 <fungi> without the api risking changing out from under them
19:08:46 <pleia2> makes sense
19:09:02 <fungi> anteaya: are you up for writing that spec patch?
19:09:13 <fungi> just adding a sentence will do
19:09:26 <anteaya> sure I will do so
19:09:46 <fungi> we ideally would do some widespread announcement to the community once the tc accepts the migration plan anyway
19:09:53 <anteaya> oh yes
19:10:05 <anteaya> currently in talking to stakeholders
19:10:12 <anteaya> next step is tc
19:10:12 <fungi> so just stating that there would be a minimum of one month from that until the actual migration or something
19:10:36 <fungi> in reality i expect it will end up being well more than a month regardless
19:10:37 <anteaya> part of getting it on the tc agenda involves a post to the ml
19:10:52 <anteaya> I also think it will be well more than a month
19:11:06 <anteaya> but don't see any harm in stating a one month minimum
19:11:08 <fungi> okay, anything else we need to cover on this effort in the meeting?
19:11:11 <anteaya> to ally fears
19:11:17 <anteaya> not from me
19:11:19 <SotK> nor me
19:11:26 <Zara> _o_
19:11:56 <fungi> clarkb: bkero: did you need me to squeeze the "Newton testing on Xenial" effort into today's agenda or were your questions basically addressed during the announcements?
19:13:02 <clarkb> I am good, but could use volunteers to help write teh changes likely
19:13:15 <clarkb> since I am traveling next week and much of the week after anddon't expect to have consistent internets
19:13:25 <bkero> fungi: I'm good
19:13:35 <clarkb> so uh ping me if you can help
19:13:36 <fungi> i expect those volunteers will come out of the woodwork anyway
19:13:38 <bkero> clarkb: what changes are you referring to?
19:13:52 <clarkb> bkero: the changes to project-config that switch jobs to run on xenial
19:14:00 <bkero> Got it, thanks.
19:14:01 <fungi> #topic Priority Efforts: Newton testing on Xenial (clarkb)
19:14:27 <fungi> #info Volunteers needed to draft project-config changes to switch more jobs to run on xenial
19:14:29 <clarkb> basically just need to update jjb and zuul togetehr to switch things, there are a few examples up and merged now
19:14:44 <bkero> o/ I'll see if I can help out with that this week.
19:14:51 <fungi> thanks clarkb, bkero!
19:14:54 <clarkb> because we decided to go explicit in the config its not a single 90 line python script we are modifying so lots of typing typing
19:14:56 <clarkb> bkero: thanks
19:15:12 <fungi> #topic Infra mascot/logo (fungi)
19:15:14 <bkero> typing typing typing and much seddings
19:15:18 <fungi> #link https://etherpad.openstack.org/p/infra-mascot-ideas Infra mascot/logo ideas
19:15:23 <fungi> looks like we have a bunch more now
19:15:36 <fungi> are we all set for me to do a civs poll so we can rank preferences?
19:15:51 <fungi> should i send ballots to the ptl electorate for infra?
19:15:58 <fungi> or limit it to council members?
19:16:02 <clarkb> fungi: there is a deadline for tomorrow I think? so we better be ready?
19:16:16 <fungi> yeah, i've talked to heidijoy about it
19:16:17 <clarkb> I would let everyone interested vote on it
19:16:22 <anteaya> on the voting does the top item win?
19:16:36 <anteaya> like if everything gets one vote and one thing gets 2 votes, does it win?
19:16:54 <fungi> we need fallback choices in case of conflicts either within or (in some situations) outside the community
19:17:05 <clarkb> which is why you wanted to use civs which I think makes sense
19:17:14 <fungi> so a condorcet ranking is a sane way to do that fairly, yes
19:17:19 <pleia2> yeah
19:17:48 <fungi> i'll send ballots to our ptl electorate then and any of them who care can register their preferences
19:17:55 <clarkb> ++
19:18:02 <fungi> how long would make sense to leave it open? one week?
19:18:12 <anteaya> max one week
19:18:14 <pleia2> sounds good to me
19:18:15 <rcarrillocruz> yeaha
19:18:17 <clarkb> assuming thats fine with heidi that seems like a good time period
19:18:21 <anteaya> I think most folks will vote in 3 days
19:18:35 <fungi> okay, i'll get that going right after the meeting, making it 6 days so i can close it before next week's meeting
19:18:42 <Zara> yay
19:18:53 <fungi> #action fungi start a poll for infra mascot
19:18:58 <pleia2> thanks fungi
19:19:18 <fungi> #topic Contributor survey (pleia2)
19:19:25 <fungi> #link https://etherpad.openstack.org/p/infra-newton-contrib-survey Contributor survey draft
19:19:31 <pleia2> not much new here, thanks to people who chimed in on the pad
19:19:44 <fungi> next steps?
19:19:45 <pleia2> once we have a survey server up I'll put the questions in it
19:19:54 <fungi> ahh, right-o
19:19:58 <pleia2> we can likely chat about it again before we announce it
19:20:13 <fungi> sounds good. can come off the agenda for now i guess?
19:20:17 <pleia2> yes, thanks
19:20:19 <fungi> and you'll readd it once we're close
19:20:25 <fungi> perfect
19:20:25 * pleia2 nods
19:20:35 <fungi> pabelanger: are you back yet?
19:21:04 <fungi> i'll reorder these two topics to give pabelanger a chance to get back to his computer
19:21:12 <fungi> #topic Gerrit 2.11.4 updates (zaro)
19:21:29 <fungi> looks like we have several fixes merged, a couple still under review
19:21:30 <zaro> so it's been a while since we updated gerrit
19:21:46 <zaro> i thought i would see what we are interested in updating.
19:21:49 <fungi> yep, as we discussed a few weeks ago, this seems like a good idea
19:22:07 <anteaya> what would be involved in updating?
19:22:11 <zaro> the gson update is needed for storyboard plugin
19:22:15 <Zara> :D
19:22:33 <zaro> anteaya: it means reving the version of gerrit we have on review.o.o
19:22:36 <corvus> zaro: what's the deal with maven and bouncy castle?
19:22:39 <fungi> #link https://review.openstack.org/345540 re=nofollow spam deterrent (merged)
19:22:42 <zaro> it would involve a patch to make that update
19:22:56 <fungi> #link https://review.openstack.org/260324 puppet code highlighting (merged)
19:22:57 <anteaya> zaro: right, so how much downtime, do we need db backups, what steps are we following?
19:23:19 <fungi> #link https://review.openstack.org/311903 fix bouncy castle lib download (merged)
19:23:22 <anteaya> or just restart gerrit once patches are merged?
19:23:26 <Zara> (I am watching the its-storyboard patches like an oversized hawk; thanks again for working on those)
19:23:28 <corvus> yeah that one :)
19:23:49 <zaro> corvus: the libs disappeared from the repo so we needed to update the link in gerrit. i don't know why it disappeared though
19:23:57 <fungi> #link https://review.openstack.org/340157 update gson lib, required for its-storyboard plugin (open)
19:23:58 <corvus> did they update that upstream too?
19:24:04 <zaro> anteaya: no reindex required
19:24:11 <anteaya> zaro: thank you
19:24:14 <fungi> #link https://review.openstack.org/#/q/status:open+project:openstack-infra/gerrit+branch:openstack/2.11.4 other open changes for 2.11.4
19:24:22 <corvus> zaro: or does upstream use a different version of bouncy castle...?
19:25:11 <zaro> yes, upstream was fixed the same way
19:25:51 <corvus> ok cool
19:25:59 <corvus> i mean, weird, but cool.  :)
19:26:11 <zaro> the first 3 changes on the infra meeting page is required, so i'm wondering about the others open changes for 2.11.4.
19:26:34 <anteaya> zaro: the first three changes have all merged
19:26:42 <fungi> i would like to see https://review.openstack.org/267927 go into the next build too, as that makes our election process more transparent
19:26:51 <zaro> opps i mean first 4 changes. including the open gson lib update change
19:26:54 <fungi> #link https://review.openstack.org/267927 Remove required access permission to list account emails
19:27:08 <anteaya> fungi: that would be awesome
19:27:14 <anteaya> zaro: ah okay
19:27:25 <zaro> i think we also wanted https://review.openstack.org/#/c/267927/ or maybe at least anteaya wanted it
19:27:34 <fungi> i believe that's the only remaining blocker for the revised electoral roll script to be runnable by non-gerrit-admins
19:28:07 <corvus> are we okay with that from a privacy perspective?
19:28:24 <anteaya> zaro: yes, I fungi linked it above, and yes it would be awesome to have in
19:28:31 <anteaya> s/I//
19:28:37 <zaro> ohh didn't fungi want this one too? https://review.openstack.org/#/c/277538/
19:28:56 <corvus> i guess most emails are already publically accessible -- either as the primary account email (is displayed on most pages in the ui) or as emails to match git authors (displayed on git commits)
19:29:04 <corvus> i can't think of any other cases...
19:29:06 <fungi> corvus: so gerrit already makes your preferred e-mail address queryable
19:29:09 <fungi> yes
19:29:11 <fungi> that
19:29:24 <mordred> ++
19:29:28 <fungi> this just extends it to the additional non-preferred addresses too
19:29:28 <corvus> sounds good then
19:29:29 <mordred> that's what I was thinking
19:29:56 <anteaya> zaro: can we get a consistent topic on all the patches you want to see merged prior to the update?
19:30:02 <fungi> zaro: oh! right, 277538 while not necessary, will simplify the electoral roll generation script significantly
19:30:15 <fungi> takes out a lot of the current guessing around figuring out when a change actually merged
19:30:21 <zaro> well ok, i conclude that we want 340157, 267927 and 277538 merged?
19:30:39 <anteaya> zaro: sounds fine to me
19:30:42 <fungi> #link https://review.openstack.org/277538 Append submitted info to the change REST endpoint.
19:31:10 <fungi> zaro: those three sound great, yes
19:31:37 <fungi> anybody have a vested interest in "
19:31:39 <fungi> er
19:31:46 <zaro> ok, infra-core do your thing and i'll prep a patch for the update
19:31:55 <fungi> anybody have a vested interest in "Increase default HTTP incoming connection queue" or "Init plugins' AllRequestFilters, even if they are loaded after startup"?
19:32:37 <zaro> ohh, maybe this one too? https://review.openstack.org/#/c/268689/  fix javamelody plugin updates
19:33:19 <fungi> is that a significant bump in javamelody featureset over what we have now?
19:33:50 <zaro> no changes to javamelody itself it just fixes a problem with updating the javamelody plugin while gerrit is running
19:34:37 <zaro> it's a fix to the mechanism of deploying the plugin.
19:35:30 <zaro> also i can prep a change to update on review-dev.o.o and test it out there first before we update review.o.o
19:35:31 <fungi> was it causing a problem for us, or is it likely to do so if we don't approve that backport?
19:35:50 <fungi> just wondering what the impetus was for backporting that
19:36:08 <zaro> currently if we attempt to update the javamelody plugin without restarting gerrit it won't work.
19:36:22 <fungi> i can't remember having done that
19:36:34 <clarkb> I thought the plugin version was tied to the war build anyways
19:36:41 <zaro> ok, then it's probably not important.  we can just restart gerrit when updating javamelody
19:37:18 <fungi> to clarkb's point, i think our current process for updating gerrit plugins has an implicit gerrit restart baked into its assumptions
19:37:31 <zaro> clarkb: it is build against our fork of gerrit core but it's not packaged with the war
19:37:54 <fungi> so yeah, this seems like something we can probably drop. we'll consume the fix the next time we upgrade to a newer gerrit release containing it
19:37:57 <zaro> ok, then we should skip it.
19:38:18 <zaro> i think it only failing for javamelody anyways.
19:38:46 <fungi> thanks. anything else you wanted to cover on gerrit upgrades in the meeting? we should likely get the outstanding changes we've identified reviewed/merged prior to scheduling an upgrade maintenance
19:39:29 <zaro> so action is to merge 340157, 267927 and 277538 ?
19:39:35 <fungi> yep
19:39:48 <zaro> cool, that's it.
19:39:59 <fungi> #info We want 340157, 267927 and 277538 merged before we schedule a production Gerrit upgrade maintenance
19:40:08 <zaro> ohh do we need to identify a date?
19:40:12 <fungi> #undo
19:40:13 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x7f5bbfd22550>
19:40:16 <fungi> #agreed We want 340157, 267927 and 277538 merged before we schedule a production Gerrit upgrade maintenance
19:40:26 <fungi> wanted to make that an agreement, not an info
19:41:10 <fungi> zaro: we can probably leave scheduling for after those changes merge. it ought to be a relatively quick outage so lengthy warning announcement is probably not warranted. a few days heads up should be sufficient
19:41:22 <zaro> ++
19:41:47 <fungi> pabelanger: are you back at your keyboard yet?
19:42:45 <fungi> #topic Release git-review (fungi)
19:42:56 <fungi> giving pabelanger a few more minutes to get back
19:43:10 <fungi> i want to tag a new git-review release later this week
19:43:37 <rcarrillocruz> will that come with voting ? i.e. git review plus wip'it ?
19:43:42 <fungi> anybody feel like reviewing probably non-impacting open changes for any we should squeeze in?
19:43:48 <rcarrillocruz> i kind of remember a change for doing that in review
19:43:51 <clarkb> fungi: do you think its worth adding a note about gerrit without bouncy castle and newer git support in git-review?
19:43:54 <fungi> #link https://review.openstack.org/#/q/status:open+project:openstack-infra/git-review open git-review changes
19:43:54 <clarkb> er newer ssh support
19:44:13 <clarkb> I don't actually know how supporting gerrit without bouncy castle is considered
19:44:14 <zaro> what's included in that git-review release?
19:44:21 <fungi> clarkb: to the readme/manpage? probably wouldn't hurt
19:45:38 <clarkb> fungi: ok I can try to write that up quickly since I know at least one other person/group was affected
19:45:48 <zaro> rcarrillocruz: #link https://review.openstack.org/#/c/281504/
19:45:55 <fungi> zaro: see stuff above the 1.25.0 tag for what's already landed in master
19:46:01 <fungi> #link https://git.openstack.org/cgit/openstack-infra/git-review/log/ git-review log
19:46:23 <rcarrillocruz> oh, there you go, thx
19:47:40 <fungi> rcarrillocruz: we want to avoid baking openstack community gerrit configuration assumptions into git-review features, so i don't expect a "wip" feature in git-review until we have a generic way of setting wip status in gerrit
19:48:24 <zaro> fungi: i suggest this one, #link https://review.openstack.org/#/c/285620/
19:48:29 <fungi> a compromise has been floated to add a feature for submitting an arbitrary review comment/vote immediately following a patchset push
19:48:31 <rcarrillocruz> yeah, makes sense
19:48:46 <Kiall> fungi: <drive by>add a --wip=Workflow-1 into .gitreview</drive by>
19:49:34 <corvus> not a bad idea
19:49:36 <zaro> fungi: i don't understand your stament
19:49:59 <zaro> is the 'wip' vote the issue?
19:50:16 <zaro> that feature is generic to set any vote, not specific to wip
19:50:28 <fungi> zaro: proposing a git-review feature where you can ask it to submit a review comment with vote (e.g. workflow -1) when pushing a patchset
19:51:00 <zaro> that feature is not specific to wip vote. you can set Code-Review vote or verified vote or any vote
19:51:18 <zaro> you can do that with gerrit itself
19:52:04 <fungi> zaro: yes, this comes on the heels of prior patches proposing "wip" features to git-review where our advice was to implement what 281504 is doing
19:52:55 <fungi> zaro: i was probably not being clear. 281504 makes sense, and it's a good compromise
19:53:38 * rcarrillocruz went straight to the commit msg example and didn't realize the change is about setting whatever vote
19:53:44 <rcarrillocruz> so ++
19:54:08 <zaro> we can change the example to Verified vote to ease your concern
19:54:12 <fungi> pabelanger: back yet?
19:54:38 <rcarrillocruz> heh
19:54:42 <rcarrillocruz> no need :P
19:54:48 <fungi> zaro: i don't have any concern. i'm in favor of the idea of 281504 i just haven't reviewed the implementation yet. it's on my short list now
19:55:32 <zaro> sounds good, and i think i've already reviewed just about all of the oustand changes.
19:55:33 <fungi> #topic Open discussion
19:55:44 <fungi> thanks zaro, it's a huge help
19:55:54 <clarkb> Just a heads up I am likely to be AFK for all of next week and much of the week after. Visiting family and they live without Internets
19:56:09 <prometheanfire> I'd like to see a lesser puppet run for simpler image builds
19:56:14 <anteaya> clarkb: yay a break for you
19:56:17 <anteaya> clarkb: have fun
19:56:40 <fungi> prometheanfire: can you elaborate?
19:56:46 <zaro> clarkb: those are the family i avoid visiting :)
19:56:51 <prometheanfire> adding gentoo support to all the puppet modules is becoming a real pain
19:57:10 <fungi> prometheanfire: we're trying to unpuppetize our image builds over time
19:57:44 <prometheanfire> I realize that, and that'd likely help
19:57:54 <fungi> this is mostly an artifact of the bad old days when we only had static job nodes and they were built the same way as our other servers
19:57:55 <clarkb> zaro: I have no idea how they survive (well really I do they live on a mountain side in hawaii and don't need Internets)
19:57:58 <prometheanfire> it the thing I've been stumbling on
19:58:45 <pleia2> I'm also AFK next week, conference+giving a tutorial in Mumbai and then may try to dodge rain as I attempt to tourist a bit during monsoon season
19:58:57 <rcarrillocruz> :S
19:59:15 <anteaya> pleia2: yay, break for you too
19:59:38 <zaro> clarkb: well, i would compromise for hawaii though :)
19:59:40 <fungi> pleia2: clarkb: don't get washed away!
19:59:44 <fungi> we need you back soon
19:59:46 <mtreinish> clarkb: aren't the mountains in hawaii volcanoes? :)
19:59:47 <prometheanfire> all that puppet needs to do with the gentoo image is create a user
19:59:55 <clarkb> mtreinish: they are and its active, all good fun
19:59:58 <fungi> okay, that's it for times
19:59:59 <prometheanfire> so adding support for everything else seems excessive
20:00:04 <fungi> #endmeeting