19:02:43 <fungi> #startmeeting infra
19:02:44 <openstack> Meeting started Tue Jul 19 19:02:43 2016 UTC and is due to finish in 60 minutes.  The chair is fungi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:48 <openstack> The meeting name has been set to 'infra'
19:02:51 <fungi> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:02:56 <fungi> #topic Announcements
19:03:01 <fungi> #info Reminder: late-cycle joint Infra/QA get together to be held September 19-21 (CW38) in at SAP offices in Walldorf, DE
19:03:03 <fungi> #link https://wiki.openstack.org/wiki/Sprints/QAInfraNewtonSprint
19:03:09 <fungi> #topic Actions from last meeting
19:03:13 <fungi> #link http://eavesdrop.openstack.org/meetings/infra/2016/infra.2016-07-12-19.02.html
19:03:14 <anteaya> confirm the space has enough seats
19:03:15 <pleia2> if this team has a birthday, I think it was last week on July 14th with the first commit to syste-config http://git.openstack.org/cgit/openstack-infra/system-config/commit/?id=5d85125bf7739a38c788256ccfba7877b46d2132
19:03:15 <fungi> (none)
19:03:24 <pleia2> ^^ re: announcements
19:03:24 <anteaya> pleia2: ah
19:03:28 <fungi> anteaya: heh, we don't want a repeat of the nova mid-cycle
19:03:32 <anteaya> happy birthday team
19:03:35 <anteaya> fungi: indeed
19:03:45 <pleia2> 5 years, woo
19:03:46 * anteaya types from her hotel room
19:03:56 <Zara> hehe
19:03:56 <fungi> pleia2: oh, yep that's a good one
19:04:01 <zaro> o/
19:04:20 <fungi> #topic Infra config 5 year birthday (pleia2)
19:04:28 * pleia2 passes around cake
19:04:31 <fungi> link us proper like
19:04:38 <pleia2> #link http://git.openstack.org/cgit/openstack-infra/system-config/commit/?id=5d85125bf7739a38c788256ccfba7877b46d2132
19:04:52 * markus_z throws emergency-confetti
19:04:58 <fungi> #info 5 years since the first config repo patch
19:04:58 * anteaya puts on a funny hat
19:05:02 <anteaya> markus_z: whew
19:05:18 <pleia2> ok, we can move along :)
19:05:23 * fungi gets down to "srs bznz"
19:05:31 <fungi> #topic Specs approval
19:05:40 <fungi> #topic APPROVED: Newton testing on Xenial
19:05:48 <fungi> #link http://specs.openstack.org/openstack-infra/infra-specs/specs/newton-on-xenial.html Newton testing on Xenial
19:06:12 <fungi> i've also updated the priority list in our agenda to have a slot for this as needed
19:06:20 <fungi> #topic APPROVED: Firehose: A unified message bus for Infra services
19:06:26 <fungi> #link http://specs.openstack.org/openstack-infra/infra-specs/specs/firehose.html Firehose: A unified message bus for Infra services
19:06:40 <fungi> #topic Priority Efforts: A Task Tracker for OpenStack (Zara)
19:06:46 <fungi> #link https://storyboard.openstack.org/#!/worklist/129 current blocking tasks
19:06:47 <fungi> On the agenda you wrote: "A couple of questions from talking with the Nova bugs team"
19:06:54 <Zara> hi!
19:06:59 <Zara> yeah, okay, so etherpad here
19:07:02 <Zara> #link https://etherpad.openstack.org/p/nova-bugs-team
19:07:06 <Zara> question is line 174
19:07:21 <Zara> 'assumed we transition tomorrow to storyboard, what's happening with the current open bug reports of Launchpad? The bug report numbers are used in a lot of commit messages of changes in Gerrit. Gerrit also links comments, like "bug 123" to the bug report 123 in LP. '
19:07:21 <openstack> bug 123 in Launchpad itself "There's no direct way to see the project info when translating it" [Medium,Fix released] https://launchpad.net/bugs/123
19:07:31 <Zara> hahaha
19:07:38 <mordred> :)
19:07:45 <Zara> what a beautiful demonstration
19:07:57 <fungi> there was a plan for this!
19:08:12 <fungi> basically when we import, we preserve the lp bug number as the imported story number
19:08:13 <mordred> Zara: so - I think we had, at some point in the past, talked about transitioning the lp bugs to storyboard so that they had identical bug numbers (which is why all the new bugs stsart at 2 million)
19:08:52 <mordred> that way things like bug links in gerrit that reference by id can get new urls
19:09:00 <jeblair> so we have to move off of lp before it hits 2 million bugs :)
19:09:05 <Zara> hahaha
19:09:16 <markus_z> OK, that would be great. I asked that question because I wanted to avoid that Nova (or any other project) has to adjust several hundred commit messages.
19:09:22 <fungi> yeah, the only reason we haven't don ethat yet is because it's a global change to gerrit and we can't do that while only infra projects are in sb
19:09:24 <mordred> markus_z: totally
19:09:28 <mordred> markus_z: that would be terrible
19:10:05 <fungi> was that all we needed to cover? or were there more questions/concerns?
19:10:27 <anteaya> markus_z: are you happy? is E011 addressed for you?
19:10:27 <markus_z> We had the catch22 when transitioning.
19:10:32 <markus_z> anteaya: no, not yet
19:10:36 <anteaya> okay
19:10:47 <Zara> okay, that's all from me, the other question was covered in-channel (it was originally 'when do we want to have a cross-project discussion about this' but anteaya has said she will organise that)
19:10:59 <anteaya> Zara: thanks
19:11:11 <markus_z> background for the others: there are a lot of scripts out there which interact with the API of LP
19:11:24 <markus_z> I don't yet see how the transition looks like for those scripts
19:12:13 <Zara> we have a python client to talk to the storyboard api, so I imagine you'd want to import that
19:12:16 <markus_z> I was asking for some kind of "staging area" where people can test their rewritten scripts against.
19:12:27 <fungi> as an example, we have scripts which comment on, change status and reassign bugs in lp when changes referencing them are proposed or merged. in that case we're replacing those scripts with a gerrit plugin that talks to the sb api
19:12:27 <markus_z> Zara: yep
19:12:27 <anteaya> I don't think that the storyboard team has the ability to transition people's individual scripts
19:12:32 <clarkb> markus_z: there is a dev storyboard server you can use for that
19:12:36 <markus_z> anteaya: no, I'm not asking for that
19:12:39 <anteaya> markus_z: that is the dev server
19:12:41 <SotK> we should migrate some real data into storyboard-dev
19:12:46 <Zara> +1
19:12:49 <markus_z> +1
19:12:52 <SotK> and use that for staging
19:13:09 <SotK> by some I may mean all, idk
19:13:21 <clarkb> would be a good test of current state of migration too
19:13:24 <fungi> SotK: in the past we considered exporting a db dump from production and loading that in dev, though i suppose a script to create a variety of content may also make sense
19:13:31 <anteaya> okay, who is the person or persons that has the ability to migrate production data into -dev?
19:13:36 <fungi> oh, or migrate from lp, sure
19:13:49 <clarkb> I would do lp to storybpard again just to make sure it works
19:14:05 <anteaya> clarkb: to storyboard -dev?
19:14:06 <clarkb> since both lp and storybaord have been changing
19:14:10 <clarkb> anteaya: yes
19:14:12 <SotK> thats what I was thinking
19:14:17 <anteaya> great
19:14:22 <markus_z> It doesn't need to be acurate at all points in time, but it should reflect reality (from one single point in time)
19:14:28 <anteaya> who can help with this?
19:14:28 <fungi> anteaya: the awesome people listed at http://git.openstack.org/cgit/openstack-infra/system-config/tree/modules/openstack_project/manifests/storyboard/dev.pp#n40 plus all of infra-root
19:14:42 <anteaya> fungi: wonderful thank you
19:15:09 <fungi> anything else?
19:15:15 <anteaya> so which are we doing, storyboard production to -dev?
19:15:22 <anteaya> or lp to storyboard-dev?
19:15:29 <fungi> i think test the lp migration/import script on dev
19:15:34 <SotK> +1
19:15:37 <markus_z> +1
19:15:37 <anteaya> okay thank you
19:15:43 * anteaya creates a story
19:15:47 <fungi> that kills several birds with one command
19:16:04 <fungi> or something
19:16:28 <fungi> #agreed We plan to keep LP bug numbers as SB story numbers on import
19:16:54 <anteaya> #link https://storyboard.openstack.org/#!/story/2000677
19:17:10 <fungi> #agreed Test the migration script on storyboard-dev so as to also provide a useful dataset that interested parties can use for validating replacement tooling
19:17:24 <markus_z> Is time for another question?
19:17:28 <fungi> sure
19:18:22 <markus_z> I was wondering if we plan to migrate all projects or just a subset. Especially when working with Nova, quite a lot of issue affect other projects too (Glance, Cinder, Neutron, ...).
19:18:33 <fungi> markus_z: the plan is all of them at the same time
19:18:44 <markus_z> ok, cool, that resolves the issue I've seen
19:18:54 <fungi> because of the prevalence of cross-project bugs like you describe
19:19:00 <markus_z> (to split one issue over SB + LP)
19:19:01 <fungi> otherwise we'd end up very disjointed
19:19:07 <markus_z> yes, great
19:19:17 <fungi> we migrated infra early because our bugs have very little overlap outside infra projects
19:19:28 <fungi> so we could serve as a sort of island to dogfood sb
19:19:46 <fungi> but the rest of openstack would need to happen all at once
19:19:53 <mordred> island of dogfood
19:19:55 <anteaya> markus_z: do you feel your concerns including E011 have been addressed?
19:19:58 <fungi> that's part of the reason coordinating this decision is so complicated
19:20:05 <Zara> :D
19:20:42 <fungi> #agreed We can't migrate some projects' bugs at different times--it's an all-or-nothing situation
19:21:38 <markus_z> anteaya: There wasn't yet an "agreed" on giving folks time to rewrite their scripts, or did I miss it?
19:21:39 <clarkb> though mny other potential islands have asked to use sb but we turned them away. Might be worth it if a specific group knows what they are getting into
19:21:57 <anteaya> markus_z: how much time would you like us to give?
19:22:27 <fungi> clarkb: yeah, we came to an agreement not too long ago that we wouldn't tell ancillary projects they couldn't use sb as that was crippling interest
19:22:46 <markus_z> anteaya: after the -dev server has real life data, 4-6 weeks?
19:22:56 <anteaya> can we agree to 4 weeks?
19:23:11 <anteaya> after the -dev server has real data?
19:23:16 <markus_z> I can rewrite mine in that time, I cannot speak for the release team
19:23:17 <anteaya> it might be more than that
19:23:28 <anteaya> that is fine, I'll check with the release team
19:23:47 <anteaya> markus_z: can we create an agreement next meeting after I talk with the release team?
19:23:55 <markus_z> sure
19:23:59 <anteaya> thank you
19:23:59 <fungi> yeah, given that this is still the requirements collection phase, we still need some development after the gap analysis is done and convincing the tc
19:24:25 <anteaya> fungi: yes, but I think we can hope to create the agreement markus_z is asking for next week
19:24:30 <fungi> i have a feeling 4 weeks from when we test the migration script is a lot less than what we'll actually end up with for a timeline anyway
19:24:38 <anteaya> fungi: me too
19:24:50 <fungi> okay, thanks Zara, anteaya, SotK, markus_z!
19:24:57 <Zara> thank you! :)
19:25:01 <anteaya> which is why I have no issue working towards the agreement markus_z wants
19:25:03 <fungi> #topic Intel/Mellanox Barcelona talk proposal: Openstack CI - testing SRIOV/NFV (wznoinsk)
19:25:04 <anteaya> thank you
19:25:26 <fungi> wznoinsk: i left this on the agenda as i wasn't sure whether you got the discussion you needed after the meeting in #openstack-infra
19:25:33 <fungi> do you still need this as a meeting topic?
19:26:16 <fungi> i'm guessing wznoinsk is not around. i'll move on and we can come back to this during open discussion if necessary
19:26:26 <fungi> #topic Infra mascot/logo (fungi)
19:26:32 <fungi> #link https://etherpad.openstack.org/p/infra-mascot-ideas Infra mascot/logo ideas
19:26:38 <fungi> i'm thinking the easy way for this would be to distill the ideas proposed there so far and do a civs poll to provide a ranked list of our preferred options
19:26:45 <fungi> maybe just use infra contributors over the past year like we do for infra ptl elections (those people seem to make good choices!)
19:27:09 <anteaya> hehe
19:27:11 <fungi> any other preferences?
19:27:18 <anteaya> keystone seems to want a turtle
19:27:25 <pleia2> there aren't many ideas on the pad
19:27:32 <fungi> we could ask keystone to choose a mascot for us i guess
19:27:37 <anteaya> according to their post to the mailing list
19:27:37 <fungi> they seem to be good at this
19:27:43 <pleia2> hehe
19:27:46 <AJaeger> ;)
19:27:47 <anteaya> that could work
19:28:03 <AJaeger> as long as we could veto ;)
19:28:32 <fungi> should this get deferred another week for the purpose of collecting more ideas?
19:28:44 <fungi> or just go with the list we have now and vote this week?
19:29:03 <anteaya> I'm meh on the whole idea actually
19:29:14 <anteaya> I think neutron voted in favour of not having a mascot
19:29:33 <fungi> and yes, keystone leaning toward a turtle which was also on our list is what makes me think a ranked list via civs would be good, as we may not get our first choice
19:29:50 <anteaya> we naturally gravitate to things anyway, I'm fine if we gravitated to something
19:29:57 <anteaya> this just feels imposed to me
19:29:59 <fungi> i'm happy with "no mascot" being an option in the list too
19:30:05 <Zara> +1
19:30:10 <anteaya> I would support that option
19:30:14 <pleia2> I like mascots a lot
19:30:44 <fungi> i wonder if any other projects have dibs on homo sapiens as a mascot
19:30:55 <HenryG> Where did neutron vote against a mascot?
19:30:56 <fungi> some of them can be cool
19:31:01 <Zara> it is banned
19:31:05 <Zara> ;_;
19:31:28 <fungi> aww, the only animal in nature we can't choose i guess
19:31:43 <AJaeger> wonder how our stickers would look like with a big "no mascot" on it ;)
19:31:45 <HenryG> Neutron has an etherpad to collect ideas for a mascot, https://etherpad.openstack.org/p/neutron-project-mascot
19:31:45 <anteaya> HenryG: wasnt' that part of a thread to the mailing list about mascots?
19:31:51 <pleia2> AJaeger: haha
19:31:56 <anteaya> HenryG: or am I mis-remembering?
19:32:33 <markus_z> fungi: http://i.imgur.com/mBkT1qd.png ;)
19:32:39 <anteaya> HenryG: I'm remembering something on the mailing list and I had thought it was neutron
19:32:46 <pleia2> markus_z: nice
19:32:47 <fungi> markus_z: yep
19:32:56 <anteaya> markus_z: ha ha ha
19:33:25 <HenryG> anteaya: looking now, because I was not aware of it
19:33:46 * krotscheck wants to create a font with all the logos/mascots as custom UTF code points.
19:33:54 <anteaya> HenryG: I might be wrong, in which case thank you for providing facts to refute my vague recollections
19:35:05 <anteaya> fungi: I also wonder if "maybe later" should be an option, leaving us the chance to gravitate to something later
19:35:08 <fungi> i'm sensing not a lot of excitement over the current list. i'm on the fence about whether there will be more exciting things a week from now, or whether we should just go with the list we
19:35:11 <fungi> 've collected
19:35:31 <anteaya> I'm not excited nor am I expecting to be more excited next week
19:35:35 <pleia2> fungi: I'd appreciate a push for more ideas through next week
19:35:44 <fungi> anteaya: yeah, that's sort of what i meant with "no mascot" as an option (decide not to decide now)
19:36:01 <pleia2> and we don't seem to be good about being serious about this :)
19:36:02 <anteaya> fungi: okay cool
19:36:04 <HenryG> anteaya: All I can find with neutron + mascot on the mailing list is http://lists.openstack.org/pipermail/openstack-dev/2016-July/099281.html
19:36:14 <pleia2> so, more serious ideas please, add them
19:36:32 <fungi> pleia2: the marketing people i've talked to say this is serious business, or something. i'm inclined to believe them
19:36:38 * pleia2 nods
19:36:43 <anteaya> HenryG: oh okay, guess I'm wrong then, I had thought I remembered something though
19:36:57 <anteaya> HenryG: thanks for the reasearch and sorry to give the wrong impression
19:37:11 <HenryG> anteaya: no worries
19:37:27 <fungi> okay, so pleia2 is in favor of giving it another week to drum up some better ideas. anyone want to second that, or oppose?
19:37:42 <anteaya> may as well give her the week if she wants it
19:37:45 <anteaya> seconded
19:37:48 <pleia2> thanks
19:37:54 <fungi> hearing no objections
19:37:55 <anteaya> welcome
19:38:05 <clarkb> wfm
19:38:15 <markus_z> how about a network of veins? (not sure how the correct medical term is). Without it, the other projects die?
19:38:17 <fungi> #agreed We'll give the mascot ideas collection an additional week and revisit in our next meeting
19:38:24 <anteaya> markus_z: ha h aha ha ha
19:38:38 <pleia2> infra wins for grosses mascot
19:38:41 <pleia2> +t
19:38:51 <fungi> markus_z: the human circulatory system. i like it
19:39:04 <mordred> fungi: I cannot imagine the marketing people not liking that
19:39:06 <krotscheck> Maybe a honeycomb?
19:39:12 <fungi> honeycomb's big
19:39:22 <fungi> (yeah, yeah, yeah)
19:39:28 <anteaya> krotscheck: a honeycomb is good
19:39:30 <AJaeger> bees or ants
19:39:32 <anteaya> fungi: ha ha ha
19:39:39 <fungi> okay, ideas discussion -> etherpad
19:39:48 <anteaya> well bees aren't collaborative
19:39:54 <anteaya> neither are ants
19:40:00 <anteaya> the both are ruled by queens
19:40:05 <fungi> for those who need it again, https://etherpad.openstack.org/p/infra-mascot-ideas
19:40:10 <anteaya> I don't think the group would like that implication
19:40:18 <Zara> btw, I assumed 1 thing each, if we want *loads* of ideas maybe it's worth saying it can be more than that?
19:40:18 <fungi> #topic Proposed: Contributor survey (pleia2)
19:40:18 * krotscheck has graphical skillz in case they're required.
19:40:30 <fungi> #undo
19:40:30 <timrc> You have to admit though that mind controlling pheramones are pretty cool. </hides>
19:40:31 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x7f5bbf3a47d0>
19:40:39 <fungi> thanks Zara! good idea
19:40:47 <anteaya> Zara: I didn't assume one idea each
19:40:50 <fungi> #agreed Multiple ideas from one person are fine
19:40:55 <anteaya> and yeah sounds like pleia2 wants lots
19:41:01 <fungi> the more the merrier
19:41:05 <Zara> fungi: yw :)
19:41:31 <fungi> #topic Proposed: Contributor survey (pleia2)
19:41:34 <fungi> #link https://etherpad.openstack.org/p/infra-newton-contrib-survey Contributor survey draft
19:41:54 * fungi is genuinely excited
19:42:06 <pleia2> some background here: there have been a few folks who are unhappy with contributing to our team, which makes me sad
19:42:38 <fungi> yes, i would love to have a better understanding of why, so this is a good way of figuring that out (i think)
19:42:39 <pleia2> broadly speaking I don't think it's just us, OpenStack has a whole toolset and testing infrastructure that can be difficult, but I don't actually know
19:43:00 <zaro> i've gotten the same feedback
19:43:03 <pleia2> so I drafted up this survey to figure out why, then passed it around to a couple of my broader open source buddies who do this sort of thing to weigh in
19:43:15 <pleia2> and fungi chimed in too
19:43:19 <timrc> Contributing as in significant contributions, drive-by contributions, all of the above?
19:43:35 <pleia2> timrc: all of the above, the survey gathers which the participate currently is
19:43:37 <fungi> timrc: also unsuccessful contributions
19:44:01 <anteaya> I'm fine gathering data and anaylsing it, the bit I would like to avoid is simialr to a working group deciding they dont' want to learn irc so we should all move off of it
19:44:20 <mordred> anteaya: ++
19:44:25 <pleia2> so this agenda item is to present the etherpad to the rest of the team to weigh in, and get the ball rolling on how we'd share such a survey
19:44:30 <fungi> i doubt that's likely in our case ;)
19:44:34 <pleia2> other teams have wanted survey software, we don't run any
19:44:54 <anteaya> so if we are actually looking at things to fix but we need more input on how to fix them or what output folks want, a survey is great
19:45:00 <fungi> yeah, it's been discussed before that we could configure limesurvey or something
19:45:17 <anteaya> but if the data says respondants all want to submit patchest to github not gerrit that actually puts us in a hole
19:45:17 <pleia2> I see a survey as a first step, I think the results will determine where we go from there
19:45:26 <jesusaur> while our tooling does have a certain learning curve, i think getting reviews / getting reviewers attention can also be a large hurdle
19:45:26 <mordred> pleia2: ++
19:45:39 <pleia2> jesusaur: yeah, this is the kind of feedback we want
19:46:01 <anteaya> yes the ux team mentioned limesurvey to me about a year ago
19:46:02 <timrc> anteaya: Excuse me ma'am, do you have a moment to talk about Slack with me?
19:46:09 <anteaya> I haven't had a good chat with piet in a while
19:46:14 <anteaya> timrc: no
19:46:17 <timrc> :P
19:46:20 <anteaya> :)
19:46:21 <mordred> jesusaur: yah. I mean, I have a hard time finding reviews sometimes, and I know ALL of you people
19:46:23 <rcarrillocruz> Imho, a key factor is that is hard to get a dev infra to play with
19:46:43 <rcarrillocruz> (hi from a restaurant)
19:46:44 <fungi> i expect to discover very little through this process that we can fix with more technology or process. it's likely almost all going to be human interaction/conflict (or lack thereof) at issue
19:46:54 <anteaya> timrc: when the jehovah's witnesses come to my house I walk past them informing them I am going for a walk and they are welcome to sit in the yard if they wish
19:47:05 <mordred> fungi: I expect the same - although I do think that gathering the data will be useful/interesting
19:47:06 <anteaya> timrc: they haven't returned since I extended that invitation
19:47:06 <pleia2> fungi: that's my guess too, but we can fix humans too :)
19:47:14 <pleia2> (at least some of us)
19:47:30 <rcarrillocruz> So reviewng stuff can be daunting
19:47:37 <mordred> pleia2: I thought having humans fixed was generally frowned on
19:47:40 <fungi> pleia2: absolutely--my take is that we may learn ways we can adjust our behavior to be more friendly and welcoming to new contributions
19:47:42 <rcarrillocruz> For newcomers
19:47:45 <pleia2> mordred: haha
19:47:48 <mordred> fungi: ++
19:48:00 <timrc> jesusaur: I feel like Gerrit topics are good, but there needs to be some higher level, logical way of looking down into infra, zooming in, and seeing activity.
19:48:01 <anteaya> pleia2: I think tat was the point of the leadership training at zingermans
19:48:12 <pleia2> anyway, I don't want to get into actually talking about the things, but if folks can look at the survey and we can agree that we can set up limesurvey or something, that would be good :)
19:48:21 <anteaya> which I would love to start practicing some of the items like how to give feedback
19:48:26 <krotscheck> Any tool will be judged against the one with the simplest user experience. In a world with Github, nothing more complicated will ever measure up.
19:48:27 <mordred> fungi: often times we are familiar enough with things that we forget how many things we know that newcomers don't - even when we have docs for a given subject
19:48:30 <timrc> pleia2: ++
19:48:31 <pleia2> s/the things/the issues
19:48:59 <clarkb> krotscheck: I had to use github the other day. Not sure it is very simple. I think familiarity is more at play with github than simplicity
19:49:05 <mordred> clarkb: ++
19:49:06 <clarkb> I couldn't figure out how to push to a gist
19:49:06 <anteaya> timrc: well if you can concive of a storyboard feature that shows that, that is worth discussing
19:49:10 * mordred finds github quite hard to use
19:49:11 <clarkb> I spent 20 minutes on that
19:49:11 <Zara> +1, I actually still don't know how to use it
19:49:16 * mordred also finds macs quite hard to use
19:49:25 <krotscheck> clarkb: Habituation matters, yes.
19:49:32 <fungi> yeah, github has a sort of ubiquity and mindshare going for it, not necessarily simplicity
19:49:39 <pleia2> mordred: me too, confounding machines
19:49:48 <anteaya> krotscheck: I agree with you, github users want everything to work like github
19:50:04 <mordred> anteaya: to be fair, I want github to work like gerrit - so I can see where they are coming from :)
19:50:14 <anteaya> so yeah, if we actually have a problem we want to fix, then a survey is great
19:50:20 <timrc> anteaya: Maybe a firehose project :) aggregate review topics to queues which map to specs or other topics.  I dunno... but yeah, maybe I should think more about it :)
19:50:21 <anteaya> mordred: yes, I can see your point
19:50:23 <krotscheck> It's a complicated topic. Windows people want windows. Mac people want macs. Linux people want linux
19:50:32 <clarkb> (I actually still don't know how to push to a gist, I gave up)
19:50:33 <mordred> yah. so - this brings up a good point
19:50:39 <pleia2> only 10 minutes left and I think we're tangenting a bit
19:50:39 <anteaya> timrc: did you look at the firehose spec that merged last week?
19:50:42 <clarkb> (and I really know how git works so ya...)
19:50:46 <mordred> which is that it's really quick to fall into discussing tools and tooling
19:50:49 <timrc> anteaya: Indeed.
19:50:56 <fungi> pleia2: so anything else you wanted to get out of this in today's meeting?
19:51:01 <fungi> a timeline?
19:51:01 <mordred> but as fungi said earlier, it's likely to be more human issues that will come up
19:51:07 <anteaya> timrc: it would be awesome to build a dashboard out of that
19:51:15 <fungi> did you want to write up a spec for hosting a limesurvey instance
19:51:17 <fungi> ?
19:51:18 <pleia2> fungi: if people can look at the survey by next meeting, that would be good, and maybe a spec for limesurvey setup?
19:51:19 <mordred> as we look at any results, it'll be good to remind ourselves to not immediatley fall into the "fix the tool" response
19:51:24 <mordred> pleia2: ++
19:51:34 <pleia2> I can work on a spec
19:51:39 <timrc> mordred: That is a solid point.
19:51:39 <anteaya> pleia2: limesurvey
19:51:52 <anteaya> pleia2: thank you, piet would be a stakeholder in that spec
19:51:55 <anteaya> the ux ptl
19:51:57 <fungi> #agreed Revisit survey questions at next meeting
19:51:57 <pleia2> anteaya: good to know!
19:52:01 <anteaya> pleia2: thank you
19:52:17 <fungi> #action pleia2 Submit a spec to host an instance of limesurvey
19:52:21 <fungi> yeah?
19:52:26 <pleia2> wfm
19:52:32 <pleia2> thanks all
19:52:38 <anteaya> and I do thnk sharing some of the zingtrain things with the infra team would be great
19:52:44 * fungi refreshes agenda to spot last-minute additions
19:52:51 <anteaya> since me and mordred and jeblair attended
19:53:02 <fungi> #topic Open discussion
19:53:17 <pleia2> anteaya: ++ I would have liked to attend, but I had a conflict
19:53:27 <anteaya> pleia2: I understand, perhaps next time
19:53:42 <anteaya> I can book the sprint channel some friday for sharing if there is interest
19:54:01 <fungi> i have a mental block against "leadership training" after encountering a number of people in the past who were brainwashed into multi-level marketing cults masquerading as "leadership seminars"
19:54:01 <ianw> https://review.openstack.org/#/c/316175/ <- gerrit commit msg length checking -- seems this is stuck between "have a parameter" and "hardcode".  don't care which but we should pick one and do it
19:54:10 <anteaya> I think the constructive feedback bit is useful
19:54:26 <anteaya> fungi: understood, and I share the same feelings
19:54:36 <clarkb> I am going to try restarting nodepool again today for the new demand calculations unless I am told not to
19:54:42 <anteaya> I can share the info and we can do buffet style
19:54:47 <anteaya> pick the bits you like
19:54:49 <fungi> given that none of you have yet mentioned having a quota for how many people you need to sign up for the next session, i'm encouraged
19:54:54 <pleia2> anteaya: I'd show up on friday
19:54:59 <zaro> ianw: param would be better for 3rd party to reuse our manifests
19:55:04 <anteaya> and if mordred and jeblair attended too, perhaps they also would share
19:55:30 <anteaya> pleia2: thanks, after nova mid-cycle I'll look at the sprint channel availablity
19:55:38 <pleia2> anteaya: after 1800utc (I have a morning thing)
19:55:48 <anteaya> fungi: :)
19:56:01 * persia thought the quota was 3
19:56:07 <anteaya> pleia2: oh um sorry I meant I would look next week
19:56:14 <timrc> Maybe we should develop a series of DVDs and books and take infra on the road!
19:56:14 <anteaya> not that I would book next week
19:56:20 <zaro> all patches for its-storyboard is ready if anybody is interested, #link https://review.openstack.org/#/q/topic:its-storyboard
19:56:23 <anteaya> pleia2: but noted, thanks
19:56:25 <pleia2> anteaya: ah, ok
19:56:29 <Zara> zaro: yaaaayyy!
19:56:38 <anteaya> Zara: zaro yay!
19:56:48 <anteaya> yes its-storyboard reviews please
19:56:55 <rockyg> fungi, if the leadership attendees start using common terms in strange ways, you better run
19:56:58 <anteaya> and thank you crinkle for your puppety feedback
19:57:07 <pabelanger> clarkb: ++
19:57:07 <clarkb> ianw: I have no opinion on that :P
19:57:07 <crinkle> you're welcome
19:57:20 <fungi> rockyg: things like "triple-bottom line"
19:57:26 <pleia2> hee
19:57:43 <pabelanger> Did HPE move infracloud yet?
19:57:52 <pabelanger> I haven't heard anything recently
19:57:52 <anteaya> yet/still
19:57:52 <crinkle> they are working on it
19:57:52 <fungi> ooh, good question
19:58:03 <pleia2> there's a jira ticket that I didn't look at
19:58:04 <fungi> thanks crinkle!
19:58:08 <rcarrillocruz> They are
19:58:12 <rcarrillocruz> Lulz
19:58:13 <clarkb> ianw: zaro but will that globally reject commits that don't fit under the limits?
19:58:13 <crinkle> there seems to have been some confusion about how urgently we needed it
19:58:15 <fungi> pleia2: i find that's the best way to use jira
19:58:18 <timrc> "jira ticket that I didn't look at"... par for the course re: jira :)
19:58:22 <timrc> fungi: ++
19:58:25 <rcarrillocruz> Unracked, moved, but not racked
19:58:34 <clarkb> ianw: zaro refusing commits for that does seem like not a such a great idea if globally applied
19:58:35 <pabelanger> rcarrillocruz: thanks
19:58:49 <pleia2> crinkle, rcarrillocruz: thanks
19:59:03 <pabelanger> crinkle: thank too
19:59:30 <fungi> 30 seconds left
19:59:43 <pleia2> thanks for chairing, fungi
19:59:47 <zaro> clarkb: refusing commits?
19:59:55 <fungi> we're out of time--thanks everyone!
19:59:59 <anteaya> thank you for the meeting
19:59:59 <fungi> #endmeeting