19:02:07 <fungi> #startmeeting infra
19:02:08 <openstack> Meeting started Tue May  3 19:02:07 2016 UTC and is due to finish in 60 minutes.  The chair is fungi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:09 <nibalizer> o
19:02:10 <nibalizer> o/
19:02:11 <openstack> The meeting name has been set to 'infra'
19:02:15 <jhesketh> Morning
19:02:18 <fungi> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:02:25 <fungi> welcome back from the summit! (for those of you who were there, and for those who weren't we missed you but we'll catch you up)
19:02:31 <fungi> the agenda today is pretty light
19:02:46 <fungi> also lots of people are semi-around or not at all
19:02:50 <jesusaur> o/
19:02:57 <fungi> #topic Announcements
19:03:07 <fungi> none for this week
19:03:16 <fungi> #topic Actions from last meeting
19:03:22 <fungi> #link http://eavesdrop.openstack.org/meetings/infra/2016/infra.2016-04-19-19.02.html
19:03:29 <fungi> jeblair investigate mail filtering by recipient options for infra-root@o.o inbox
19:03:43 <mordred> p/
19:03:43 <fungi> i'm guessing our summiting has delayed it, so going to just put it back on the queue for now
19:03:45 <mordred> gah
19:03:47 <mordred> o/
19:03:50 <fungi> #action jeblair investigate mail filtering by recipient options for infra-root@o.o inbox
19:04:02 <fungi> #topic Specs approval
19:04:07 <fungi> none new this week
19:04:15 <fungi> #topic Priority Efforts
19:04:29 <fungi> no updates this week according to the agenda, but we should probably plan to do a brief review of priorities next week when people are more around and conscious again
19:05:16 <fungi> oh, there's a couple more stale entries on the agenda i missed cleaning up
19:06:01 <fungi> #topic Stackviz deployment patches (austin81, timothyb89)
19:06:28 <timothyb89> ah, this topic might be a bit outdated :)
19:06:43 <fungi> yeah, i was looking for the updated patches on this one just now
19:07:02 <timothyb89> the un-revert patch is here: https://review.openstack.org/#/c/311815/
19:07:05 <fungi> the other two topics i know are outdated so skipped straight to this
19:07:38 <timothyb89> I'm currently in the process of building images manually to test, so far it is running successfully on Ubuntu and Fedora is running right now
19:07:47 <fungi> #link https://review.openstack.org/311815 Create stackviz element and script in nodepool
19:07:52 <clarkb> so we merged the thing friday then reverted it in the mean time?
19:08:08 <clarkb> if so how is this un revert different?
19:08:09 <fungi> yeah, it apparently had some dependency/bootstrapping issues
19:08:23 <timothyb89> clarkb: yes, that is correct, it was causing nodepool build failures due to a pkg-map configuration issue
19:08:47 <clarkb> timothyb89: is the new pkg-map different?
19:08:50 <timothyb89> clarkb: the unrevert fixes the file naming issue, and we've also fixed a race condition in our build script
19:09:11 <timothyb89> clarkb: it is the same, but the name of the file was wrong. we had named it 'pkg-map.json' by accident, when it should have been just 'pkg-map'
19:09:14 * clarkb is just going to have to diff the diffs
19:09:18 <anteaya> clarkb: https://review.openstack.org/#/c/311768/
19:09:23 <clarkb> timothyb89: gotcha
19:09:50 <fungi> yeah, so dib was ignoring that file, and using its fallback behavior of assuming the package name didn't need mapping to anything
19:10:05 <ttx> clarkb: I recommend interdiff
19:11:33 <fungi> anything else on this one? if not, i'll go to open discussion and maybe we can do a lazy summit sessions recap
19:11:55 <anteaya> I have a thing that didn't get on the agenda, but no more on this one
19:12:02 <anteaya> so open discussion is fine
19:12:51 <fungi> what's your topic? we can hit it and then i'll try to do per-session items afterward
19:13:08 <anteaya> pick a week for sprinting for control plane os upgrade
19:13:26 <anteaya> https://etherpad.openstack.org/p/newton-infra-distro-upgrade-plans
19:13:29 <fungi> #topic control plane os upgrade sprint scheduling
19:13:46 <anteaya> clarkb: this was your suggestion, do you have a week you like for this?
19:13:49 <fungi> oh, related to a summit session
19:13:54 <anteaya> yes, sorry
19:14:02 <fungi> i guess we'll start recapping summit sessions in that case ;)
19:14:05 <anteaya> do you want to jsut cover it with other summit sessions?
19:14:11 <fungi> we already are!
19:14:16 <clarkb> I was thinking get it done during a non rc week and fairly early in cycle
19:14:18 <anteaya> okay thanks
19:14:24 <anteaya> clarkb: sounds good
19:14:38 <clarkb> the next 3 weeks aren't great for me (but don't let that stop everyone else)
19:14:59 <fungi> yeah, i agree early in the cycle would be best. we probably should defer trying to make any decisions in this week's meeting since it's a downtime week for lots of people
19:15:00 <anteaya> #link newton release schedule: http://releases.openstack.org/newton/schedule.html
19:15:06 <clarkb> fungi: +q
19:15:08 <clarkb> er
19:15:10 <clarkb> +1
19:15:24 <fungi> but discussing options can't hurt
19:15:34 <pabelanger> I think if we start with a n+1 logstash-worker I'd be okay with help with that
19:15:44 <clarkb> R-19 maybe
19:15:59 <anteaya> I like R-19
19:16:08 <fungi> yeah, i think the plan was to cram on all the easy upgrades and then try to tackle the more painful ones after lessons are learned
19:16:20 <anteaya> fungi: that also was my understanding
19:16:32 <clarkb> lets aim for R-19 and confirm next week
19:16:35 <pleia2> I'll be traveling at the end of that week
19:16:39 <anteaya> clarkb: works for me
19:16:48 <anteaya> pleia2: can you join at the beginning?
19:17:02 <pleia2> flying out wednesday night
19:17:04 <pleia2> anteaya: yep
19:17:05 <pabelanger> Isn't R-19 a holiday weekend for Canada (Victoria Day)
19:17:10 <anteaya> pleia2: wonderful
19:17:22 <anteaya> pabelanger: I would still work
19:17:26 <fungi> pabelanger: beginning or end of r19 for the holiday?
19:17:28 <anteaya> I'm away R-20
19:17:29 <pleia2> May 30th (the week after) is a holiday in the US
19:17:34 <pabelanger> fungi: the monday
19:17:37 <anteaya> fungi: beginning
19:17:48 <pleia2> I'll be in (and working on) east coast time R-20
19:17:48 <pabelanger> anteaya: not sure I can make the monday. Might be traveling
19:17:49 <anteaya> pleia2: and milestone one
19:17:59 <anteaya> pabelanger: understood
19:18:07 <anteaya> week long sprint, lots of days to play
19:18:40 <anteaya> anyway, I got what I needed on this topic, thank you
19:18:44 <fungi> alternative might be r17 since it'll be right after n1
19:18:54 <anteaya> R-17 can work for me too
19:19:09 <clarkb> fungi: we will be traveling then
19:19:11 <fungi> oh, wait, i think clarkb and i are travelling for foundation things
19:19:13 <fungi> yep
19:19:14 <clarkb> ya
19:19:19 <anteaya> oh that works less well
19:19:32 <morgan> =/
19:19:39 <morgan> post n1 would have been nice.
19:19:47 <anteaya> morgan: why?
19:19:51 <clarkb> I think aim for R-19 currently, see how many can participate based on show of hands next week
19:19:53 <morgan> since there is usually a lull in things.
19:20:03 <anteaya> morgan: not anymore
19:20:07 <fungi> i'm around r16 but that's getting well further into the cycle
19:20:09 <clarkb> we don't need everyone
19:20:09 <morgan> anteaya: ah =/
19:20:13 <anteaya> clarkb: works for me
19:20:16 <pleia2> clarkb: sounds good
19:20:22 <clarkb> we just need a critical mass of people that are able to devote most of their time to the problem
19:20:23 <anteaya> morgan: yeah, no downtime anymore
19:20:29 <anteaya> morgan: just summit weeks
19:20:34 <morgan> heh
19:20:37 <fungi> sounds good. defer to next week
19:20:38 <pleia2> I'm around mon-wednesday at least, hopefully that will get through the worst of it
19:20:44 <pabelanger> If R19 works for more people, I'm okay with that.
19:20:56 <mordred> R19 works for me
19:20:58 <anteaya> pleia2: wonderful
19:21:10 <anteaya> pabelanger: and joining Tuesday is great
19:21:21 <fungi> #topic Summit Recap: Community Task-Tracking
19:21:46 <fungi> #link https://etherpad.openstack.org/p/newton-infra-community-task-tracking Community Task-Tracking
19:21:55 <fungi> for this one, we decided to decide
19:22:04 <anteaya> yay us
19:22:11 <SotK> \o/
19:22:13 <Zara> :D
19:22:22 <fungi> ttx volunteered to write a spec-like thing and work toward a tc resolution on moving openstack to something
19:22:28 <anteaya> Zara gets a steak everytime we decide to decide
19:22:37 <mordred> that's so many steaks
19:22:41 <Zara> wfm
19:22:56 <fungi> jeblair and i are backups on that task
19:23:04 <mordred> fungi: aim is having something votable by next infra meeting, yeah?
19:23:17 <anteaya> mordred: that was what I remembered
19:23:36 <fungi> mordred: sounds right. at least we said "next couple weeks" so that's a reasonable interpretation
19:24:09 <rcarrillocruz> o/
19:24:14 <rcarrillocruz> around now
19:24:37 <anteaya> rcarrillocruz: yay
19:24:45 <anteaya> sleepy children
19:25:18 <fungi> anyway, that's the distillation of the session. there were also some related discussions with regard to dashboard needs for the project management working group (noted in that pad), and also some ad hoc discussion on friday about vmt embargo bug workflows
19:25:35 <fungi> er, s/project management/product management/
19:25:46 <rcarrillocruz> anteaya: finally! ;-)
19:25:58 <anteaya> rcarrillocruz: you're a good father :)
19:26:00 <fungi> #topic Summit Recap: Landing Page for Contributors
19:26:13 <fungi> #link https://etherpad.openstack.org/p/newton-infra-landing-page-for-contributors Landing Page for Contributors
19:26:22 <rcarrillocruz> ;-)
19:26:41 <fungi> this ended up being a little about publication/maintenance mechanisms, and mostly about picking a non-contentious hostname
19:26:59 <fungi> and the discussion continued after the session ended, well into the lunch line
19:27:33 <fungi> thingee was unable to attend, but ttx and jeblair had strong opinions on selecting a hostname for the landing page url
19:27:40 <anteaya> sorry I missed a good name picking session
19:28:55 <fungi> also jamesmcarthur from the openstack foundation volunteered to help with layout/formatting challenges to make it more visually appealing
19:29:13 <mordred> \o/
19:30:09 <fungi> the initial plan is to just throw some ugly static html (maybe locally generated with a templating engine and then committed) into a repo and push that up to a vhost, but not publicize it until it gets a little more polish
19:31:28 <fungi> also thingee has a new contributor workflow/walkthrough targeted at low barrier to entry audiences we might incorporate or borrow from
19:33:35 <pleia2> great stuff in that, we used portions for the git+gerrit lunch on wednesday
19:33:42 <anteaya> nice
19:38:26 <pleia2> shall we move along?
19:39:02 <clarkb> I have nothing else on this topic, I wasn't able to make the session (provided coverage elsewhere), but seems liek a reasonable plan
19:39:14 <nibalizer> yag
19:39:19 <nibalizer> er, yah
19:40:25 <anteaya> agreed
19:40:28 <pleia2> fungi may have been eaten by a grue
19:40:34 <anteaya> may have
19:40:41 <pleia2> #topic Summit Recap: Launch-Node, Ansible and Puppet
19:40:50 <clarkb> you may need to add yourself as a hcair before that will work
19:40:56 <clarkb> there is a way t odo that but meh
19:40:56 <pleia2> #chair pleia2
19:40:59 <pleia2> hah
19:41:02 <pleia2> oh well
19:41:07 <nibalizer> bahahahaha
19:41:10 <anteaya> I think only chairs can add chairs
19:41:10 <pleia2> #link https://etherpad.openstack.org/p/newton-infra-launch-node-ansible-and-puppet
19:41:15 <pleia2> we'll just pretend it worked :)
19:41:22 <anteaya> I remember pretty pictures at this session
19:41:39 <nibalizer> i think that was the other session actually
19:41:47 <clarkb> I think we have a good handle on the work that needs to happen here, I even tracked down one of the issues with inventory and mordred figured it out. Hosts in the emergency file are assumed to exist
19:41:51 <anteaya> oh sorry
19:41:58 <pleia2> yeah, that was the thursday one
19:42:04 <clarkb> and I wrote another fix for launch node
19:42:09 <pleia2> cool
19:42:17 <clarkb> which nibalizer is going to test shortly and if that works I think we are good on launch node front
19:42:28 <clarkb> and can finish work to remove the puppet master
19:42:32 <clarkb> (env selection stuff)
19:42:58 <nibalizer> ee can test clarks fixes ehen we launch storyboard-dev
19:42:58 <nibalizer> puppetdb upgrde got rolled in and is progressing slowly
19:43:11 <anteaya> etherpad is erroring for me at https://etherpad.openstack.org/p/newton-infra-launch-node-ansible-and-puppet
19:43:16 <nibalizer> and the 'finglonger' spec got written and is posted
19:43:31 <clarkb> anteaya: works here, maybe try a hard refresh?
19:43:34 <rcarrillocruz> i landed the cloud launcher role on gerrit. Will add tests and all, but i'm hoping to work with someone on getting rid of low hanging fruit servers (logstash workers for example) and use the role to launch new ones
19:43:38 <bkero> anteaya: I had to refresh to get it to work
19:43:56 <anteaya> refresh worked, thank you clarkb and bkero
19:44:13 <clarkb> so ya slow but steady progress here
19:44:19 <nibalizer> cool
19:44:22 <pleia2> ok, let's keep this moving then
19:44:26 <nibalizer> gj on all that clarkb
19:44:36 <pleia2> #topic Summit Recap: Wiki Upgrades
19:44:41 <pleia2> #link https://etherpad.openstack.org/p/newton-infra-wiki-upgrades
19:44:51 <pleia2> long term we're going to kill it \o/
19:45:00 <anteaya> \o/
19:45:08 <pleia2> short term we do need to do some triage work to get it upgraded and limp along
19:45:21 <pleia2> (thanks pabelanger for volunteering to work on this)
19:45:26 <anteaya> pabelanger: how do you want to address status on that?
19:45:42 <anteaya> pabelanger: do you want to do a weekly update at meetings so folks can help if need be?
19:46:01 <pleia2> ttx has stepped up to socialize the fact that we're doing away with it in a year, and I'll help as we try to pair people/teams up with tools to replace the wiki
19:46:18 <pabelanger> Sure
19:46:25 <anteaya> pleia2: neutron is already off the wiki except for the meeting agenda
19:46:28 <anteaya> pabelanger: thank you
19:46:41 <pleia2> anteaya: one down... :)
19:46:48 <anteaya> pleia2: dougwig is going to socialize to the drivers to get their team pages off the wiki
19:46:53 <pleia2> great
19:47:02 <pabelanger> I suspect we'll end up rolling the upgrade into the week of all other precise upgrades
19:47:15 <anteaya> pabelanger: I think that is a great idea
19:47:15 <pleia2> pabelanger: yeah, that makes sense
19:47:21 <ttx> Not sure what's best to use to compile meeting agendas... Etherpad ?
19:47:34 <pleia2> ttx: I'm not sure either, but it may be etherpad
19:47:36 <anteaya> ttx, yeah I don't know either
19:48:00 <pleia2> with time in mind, going to move on to the thursday sessions
19:48:23 <pleia2> work session on proposal jobs is next, yeah?
19:48:32 <anteaya> I think so
19:48:44 <pleia2> #topic Summit Recap: Proposal Jobs
19:48:53 <pleia2> #link https://etherpad.openstack.org/p/newton-infra-proposal-jobs
19:49:10 <nibalizer> basically gonna scale this back
19:49:16 <pleia2> (also, I can't help but think fungi is continuing to run a parallel meeting on some other side of the netsplit)
19:49:33 <ttx> the cool guys are on this side
19:49:42 <nibalizer> when possible we'll have jobs that post a datafile and the apps will use it
19:49:43 <ttx> or cool humans
19:49:53 <nibalizer> oh is that what happened? hahahahhahaha
19:49:56 <anteaya> ttx :)
19:49:59 * ttx slaps himself
19:50:02 <nibalizer> thats amazing
19:50:06 <bkero> Quick, someone bridge the split
19:50:10 <anteaya> ajeager has a patch up: https://review.openstack.org/#/c/310929/
19:50:28 <ttx> do we have meetbot on our side ?
19:50:29 <anteaya> for documenting reviewing things
19:50:35 <pleia2> ttx: we do
19:50:40 <ttx> then we win obviously
19:50:46 <anteaya> ha ha ha
19:50:53 <ttx> their alternate reality in fact doesn't exist
19:50:59 <anteaya> ha ha ha
19:51:13 <pleia2> nibalizer: sounds good, anything else to add?
19:51:50 <Zara> eep
19:51:55 <anteaya> fungi: you are back
19:51:59 <pleia2> wb fungi
19:52:01 <pleia2> going to move on to robustifying
19:52:07 <nibalizer> no
19:52:15 <pleia2> #topic Summit Recap: Robustify Ansible-Puppet
19:52:19 <pleia2> #link https://etherpad.openstack.org/p/newton-infra-robustify-ansible-puppet
19:52:24 <pleia2> this is the one with the pretty pictures :)
19:52:30 <anteaya> ah thank you
19:52:34 <pleia2> thanks to mordred and nibalizer for giving us a tour https://c2.staticflickr.com/2/1537/26422736050_b34b196164_k.jpg
19:52:41 <mordred> so many pictures
19:52:58 * rcarrillocruz has a quick update on infra-cloud, when pleia2 goes thru all remaining agenda topics
19:53:03 <clarkb> this too is making progress, I have a patch up that needs the important bits filled in that *should* make puppetboard reports happen
19:53:15 <anteaya> clarkb: yay!
19:53:33 <nibalizer> and we are moving our report processor into puppetdb core
19:53:42 <mordred> nibalizer: WOOT!
19:53:47 <mordred> nibalizer: that's great news
19:54:16 <nibalizer> i mean will be, once it works with latest etc etc
19:54:21 <pleia2> ok, I think we just have a couple more
19:54:38 <pleia2> #topic Summit Recap: OpenID/SSO for Community Systems
19:54:48 <pleia2> #link https://etherpad.openstack.org/p/newton-infra-openid-sso-for-community-systems
19:54:53 <fungi> jeblair and phschwartz volunteered to handle that part
19:55:03 * pleia2 hands the chair back to fungi
19:55:13 <fungi> hrm, the netsplit has unsplit it looks like?
19:55:19 <pleia2> seems so
19:55:21 <clarkb> on this one I recall the plan was to sync up with foundation side to figure out what the functional requirements are and go from there with a strong prefernece from the infra side to not be on the hook for auth
19:55:27 <anteaya> fungi: you seem to be here again
19:55:35 <ttx> our meeting was a lot better
19:55:39 <fungi> at least partially (judging from the lurker count)
19:55:54 <anteaya> clarkb: that also is my recollection
19:56:05 <anteaya> and a preference for moving to ipsilon
19:56:21 <fungi> other outcomes were puppetboard failure reporting needs to be debugged (nibalizer volunteered)
19:56:36 <nibalizer> yah me and the puppet crew are on it
19:56:37 <fungi> and we need to start cleaning up defunct entries in puppetdb
19:56:40 <nibalizer> yep
19:56:43 <phschwartz> fungi: which one did I volunteer for? your comments before were lost to me due to a client crash
19:57:01 <fungi> pleia2: i've been rambling this entire time, so have a bunch of recap written up to paste into the meeting log after
19:57:08 <anteaya> what topic are we on?
19:57:12 <pleia2> fungi: haha
19:57:16 <anteaya> can we sync on topic?
19:57:39 <fungi> i was about to move onto the sso/openid recap
19:57:45 <anteaya> okay
19:57:51 <fungi> but we're down to a couple minutes, so maybe we can save teh rest for e-mail or next week
19:58:01 <nibalizer> yeo
19:58:03 <nibalizer> yes
19:58:05 <anteaya> rcarrillocruz: has an infra cloud update
19:58:17 <rcarrillocruz> so
19:58:17 <mordred> ooh! have the servers dried out?
19:58:28 <fungi> #topic Open Discussion
19:58:30 <rcarrillocruz> i got a handful of ips and credentials for servers
19:58:34 <rcarrillocruz> a couple of hours ago
19:58:38 <rcarrillocruz> i'm missing quite a bit of servers
19:58:39 <nibalizer> i deleted all the infracloud dns records, when we get the new ones ill be happy to out them back
19:58:40 <anteaya> yay
19:58:43 <rcarrillocruz> but we'll have a bunch to play with
19:59:03 <rcarrillocruz> i'm hoping to give more info on that tomorrow
19:59:07 <mnaser> also i just wanted to poke if the discussion started regarding the -infra requirements for control plane
19:59:21 <fungi> remember when we put the records for *.ic.openstack.org back let's create a new ic.openstack.org zone for them
19:59:24 <crinkle> \o/
19:59:26 <nibalizer> yep
19:59:38 <clarkb> mnaser: we can continue that in the infra channel
19:59:39 <nibalizer> rcarrillocruz: awesome
19:59:46 <mnaser> clarkb: sure
19:59:54 <fungi> mnaser: i think pabelanger was interested in putting a freeswitch server running ubuntu xenial in there to start out?
19:59:54 <nibalizer> hugops to the hpe datacenter people
19:59:56 <clarkb> mnaser: tl;dr is we have things like git backends and long lived jenkins slaves that probably make senes for the initial start to that
20:00:02 <fungi> anyway, we're out of time!
20:00:09 <nibalizer> thabks everyone
20:00:14 <fungi> thanks everyone, and sorry about the netsplit
20:00:19 <fungi> #endmeeting