19:01:55 <fungi> #startmeeting infra
19:01:57 <openstack> Meeting started Tue Nov  3 19:01:55 2015 UTC and is due to finish in 60 minutes.  The chair is fungi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:01 <openstack> The meeting name has been set to 'infra'
19:02:17 <fungi> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:02:22 <mordred> topol: ah. maybe it's time to become a panthers fan
19:02:30 <fungi> #topic Announcements
19:02:41 <ianw> o/
19:02:53 <fungi> #info crinkle added to infra-puppet-core
19:03:01 <yolanda> woot!
19:03:07 <jeblair> crinkle: yay!
19:03:08 <fungi> thanks to crinkle for agreeing to help as an infra-puppet-core reviewer!
19:03:13 <mordred> woot
19:03:14 <pleia2> welcome, crinkle!
19:03:19 <jesusaurus> crinkle: congrats
19:03:20 <topol> mordred... getting close
19:03:22 <crinkle> :)
19:03:33 <pabelanger> /me claps
19:03:39 <fungi> her insightful review work has already been a huge help to us, and i'm pleased that she's willing to take on more responsibility there
19:03:53 <jhesketh> +1
19:04:07 <SotK> congrats crinkle
19:04:39 <fungi> #topic Actions from last meeting
19:04:49 <tsymanczyk_> o/
19:05:15 <fungi> there were none, though we did implicitly have a "meet in tokyo and do infra stuff" action item, which i think we accomplished
19:05:30 <mordred> I did stuff, so I concur
19:05:39 <fungi> #topic Specs approval
19:06:12 <fungi> based on discussions in tokyo with some of the other infrastructure core reviewers, i've drafted an update to our priorities list
19:06:23 <fungi> #link https://review.openstack.org/241331
19:06:52 <fungi> the tl;dr is that we kept the remaining four priorities which were lingering from liberty, and added four new ones to our plate
19:07:27 <fungi> those are ansible puppet apply, gerrit 2.11 upgrade, infra-cloud and zuul v3
19:07:35 <clarkb> several of which should be able to get finished quickly (puppet apply, gerrit upgrade, openstackci)
19:07:38 <mordred> ++
19:07:40 <jeblair> clarkb: ++
19:08:02 <fungi> right, a lot of the lingering ones and some of the new additions are "easy wins" in terms of being able to wrap them up early in mitaka
19:08:17 <fungi> so it's not as daunting at is might look
19:08:27 <zaro> o/
19:08:31 <anteaya> congratulations crinkle
19:09:28 <fungi> #info council voting is open on Infra Mitaka Priority Updates until 19:00 UTC Thursday, November 5
19:09:43 <fungi> just so we can register any objections
19:10:05 <fungi> also, that meditation room we found in the garden was very nice
19:10:25 <olaph> hai
19:10:30 <fungi> hopefully the zen from that bleeds through in our cycle planning ;)
19:10:41 <jeblair> and meetings of the infra council should really happen in wood paneled rooms with fireplaces
19:10:58 * jeblair hangs wood panels in #openstack-meeting
19:11:01 <fungi> barefoot on tatami mat floors
19:11:12 <cody-somerville> \o
19:11:19 <pleia2> fungi: that was pretty fun :)
19:11:38 * jhesketh agrees
19:11:44 <fungi> #agreed #openstack-meeting will be outfitted with wood paneling and tatami mats
19:12:23 <fungi> also that change adds a dummy spec for the gerrit upgrade just so we have something to link in the priorities and to document the review topic
19:12:41 <fungi> it's probably rife with typos and i don't really care much
19:12:51 <fungi> also extremely light on detail
19:13:04 <fungi> we've discussed it to death in other venues already
19:13:31 <clarkb> and eve ndone it once
19:13:41 <fungi> #topic Priority Efforts: maniphest migration (ruagair)
19:13:58 <fungi> ruagair: i see you added some updates on this... anything critical?
19:14:22 <pleia2> thanks to ruagair for taking a lead here
19:15:02 <anteaya> I have a question is this called maniphest or phabricator?
19:15:11 <anteaya> when I call it one I am told to call it the other
19:15:13 <mordred> yes
19:15:15 <fungi> it's worth noting that the outcome of the task tracker discussion in tokyo is that we will continue working on implementing maniphest (as evidenced by the priorities list)
19:15:17 <anteaya> so I'm confused
19:15:18 <pleia2> anteaya: maniphest is a component of phabricator
19:15:19 <mordred> the entire thing is called phabricator
19:15:24 <fungi> anteaya: phabricator is a suite of tools
19:15:25 <mordred> yeah. what pleia2 said
19:15:27 <pleia2> we're just deploying maniphest for now
19:15:51 <anteaya> okay thank you maniphest
19:16:04 <jeblair> (but i think pholio will soon follow)
19:16:11 <fungi> #info from Tokyo: task tracker effort will continue on the storyboard to maniphest migration
19:16:18 <mordred> well, pholio is also enabled in the current deployment
19:16:29 <mordred> so - it might be worth just calling it phabricator
19:16:33 <anteaya> task tracker?
19:16:34 <jeblair> mordred: what current deployment?
19:16:41 <anteaya> can it that?
19:16:44 <mordred> jeblair: the puppet that is driving ruagair's work
19:16:52 <jeblair> mordred: ah cool.
19:17:04 <mordred> jeblair: it includes phabricator configs that disable/enable components and whatnot
19:17:10 <jeblair> so not following very far behind at all.
19:17:21 <fungi> #info from Tokyo: the Infra team will try not to get in the way of the new Storyboard dev team, and will be much more flexible about new featureset/design plans there following Maniphest migration for OpenStack
19:17:38 <mordred> http://git.openstack.org/cgit/openstack-infra/puppet-phabricator/tree/templates/local.json.erb#n10
19:17:43 <mordred> for anyone who is interested
19:18:25 <mordred> (that section says "please turn these off")
19:18:27 <jeblair> mordred: (pholio not in uninstalled-applications == pholio installed?)
19:18:29 <anteaya> mordred: thank you
19:18:33 <mordred> jeblair: yes
19:19:19 <fungi> anything else on this topic? it looks like ruagair is not around to discuss
19:19:50 <tchaypo> it’s 5:20am his time :(
19:20:01 <clarkb> also jetlag
19:20:02 <fungi> yep, understandable
19:20:10 <zaro> does anybody know ETA on turning on?
19:20:10 <clarkb> though not so bad for people on that half of the owrld
19:20:11 <fungi> i slept through a meeting this morning myself
19:20:25 <jeblair> fungi: was it this one?
19:20:26 <anteaya> I almost slept through this one
19:20:33 <fungi> jeblair: zzzzz
19:20:55 <jeblair> zaro: eta for making the phabricator instance available?
19:20:58 <mordred> I believe he wants to get auth working before he opens the gates on letting people poke at a beta
19:21:05 <zaro> jeblair: yes.
19:21:08 <fungi> zaro: your question is missing too many words for me to be confident i'm parsing it accurately
19:21:21 <jeblair> zaro: yeah, what mordred said, which i read as "pretty soon now"
19:21:23 <mordred> ruagair now has the phabricator side working
19:21:32 <mordred> and just needs to put cauth in front of it
19:21:37 <fungi> excellent
19:22:11 <fungi> though it sounded from the discussion at the summit like cauth was potentially abandonware and in need of some fixing?
19:22:22 <mordred> I think that was the phab plugin
19:22:26 <fungi> oh, got it
19:22:28 <mordred> cauth is an enovance thing
19:22:46 <mordred> https://github.com/redhat-cip/cauth
19:22:59 <fungi> wmf is using it for their deployment though, right?
19:23:14 <mordred> I do not believe so, no
19:23:38 <mordred> we need to use it because we want to integrate with an openid SSO provider
19:23:51 <mordred> but phab does not suppor that. with the help of a plugin, phab _does_ support REMOTE_USER auth
19:24:04 <mordred> which is how cauth provides auth to applications it works with
19:24:21 <mordred> so the easiest path forward that did not involve us writing PHP
19:24:25 <fungi> got it
19:25:00 <fungi> okay, so discussion on this update seems to be winding down. any other points that need covering before we move on?
19:25:47 <fungi> #topic stackalytics.o.o (pabelanger)
19:26:22 <fungi> i guess this is going well?
19:26:35 <fungi> i saw discussion on the infra ml about database dumps...
19:27:07 <pabelanger> Yup
19:27:13 <mordred> \o/
19:27:13 <anteaya> there is a patch
19:27:16 <anteaya> #link https://review.openstack.org/#/c/190708/
19:27:24 <pabelanger> We are at the point for people to review code, and then spin up instances
19:27:25 <fungi> a couple if the agenda is to be believed
19:27:50 <pabelanger> still needs some work before production ready, but could use some help launching the node, and eyes on puppet reviews
19:28:23 <pleia2> pabelanger: I'm around all week and can help with the node launch
19:28:24 <fungi> any infra-root admins willing to volunteer to launch the stackalytics.openstack.org production server?
19:28:28 <pleia2> o/
19:28:38 <fungi> right on!
19:28:45 <pabelanger> perfect
19:28:46 <fungi> i'm looking forward to this
19:29:20 <fungi> anything else you wanted to talk about wrt stackalytics?
19:30:04 <pabelanger> Not too much. going to need some tuning for the server, but think mirantis will help more with that
19:30:11 <fungi> sounds good
19:30:12 <pabelanger> all and all, works as expected
19:30:43 <fungi> #topic Project Renames and Moves
19:30:56 <fungi> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Upcoming_Project_Renames
19:31:05 <fungi> we've got a few queued up
19:31:22 <fungi> a typo slipped through in the puppet-openstack_health module's repo name
19:31:41 <clarkb> we should consider moving pbr to openstack/
19:31:44 <fungi> networking-bigswitch and compass-install want to be unretired and moved to openstack
19:31:44 <mordred> should we attempt to get openstack-dev/pbr -> openstack
19:31:47 <clarkb> so that we don't have to special case it everywhere
19:31:47 <mordred> clarkb is quicker
19:31:54 <anteaya> who asked about compass-monit?
19:32:08 <jeblair> where do we special case pbr?
19:32:11 <anteaya> compass-monit never indicated they needed to be moved that I saw
19:32:22 <fungi> networking-bagpipe-l2 apparently wants a slightly shorter repo name
19:32:24 <clarkb> jeblair: in the install lib from source jobs
19:32:33 <jeblair> k
19:32:35 <fungi> and akanda is now astara
19:32:43 <clarkb> jeblair: so that we can stop cloning all the libs on every d-g run and install them from pypi anyways
19:32:55 <fungi> i agree, rolling these up with some openstack-dev namespace moves would be swell
19:33:35 <jeblair> clarkb: wait i don't understand what you just said about cloning...
19:33:38 <anteaya> fungi: did you ask about compass-monit?
19:33:47 <fungi> anteaya: i added the question about compass-monit mainly because i don't want the compass devs to come back next and ask us to unretire it after the compass-install unretirement
19:33:50 <clarkb> jeblair: every single d-g job clones the entire default PROJCETS list which is huge
19:34:02 <clarkb> jeblair: this list includes a large number of projects that are never used from source on most runs
19:34:03 <jeblair> clarkb: right, i think you're shortening it?
19:34:12 <clarkb> jeblair: primarily the oslo libs and python clients
19:34:13 <fungi> anteaya: if we already asked them about the second repo and they said they definitely don't need it, i'll take it off the bullet list there
19:34:16 <anteaya> fungi: oh okay fair, I was concerned I missed something
19:34:17 <clarkb> jeblair: yup
19:34:32 <anteaya> I didn't ask them about compass-monit, no
19:34:48 <clarkb> jeblair: one of the things I did was in the -src jenkins jobs which install a specific component from source I add openstack/{name} to PROJECTS
19:34:54 <clarkb> jeblair: that works in all but one case: pbr
19:34:57 <jeblair> clarkb: got it
19:35:04 <jeblair> i understand the connection now :)
19:35:08 <fungi> anteaya: mostly assuming it was the same people responsible for both repos, so if they missed notifications about one then they might have missed both
19:35:38 <anteaya> fungi: okay fair I will get some specific feedback about compass-monit
19:35:43 <fungi> thanks anteaya!
19:36:36 <fungi> so, anyway, i was going to suggest a short-notice maintenance window to knock out the pending renames/moves listed there, so we could squeeze it in prior to the upgrade maintenance, but if we want to bundle it with the openstack-dev moves then maybe we should consider waiting until after the upgrade?
19:37:17 <fungi> i know at least a few projects in -dev wanted to move to openstack proper
19:37:30 <anteaya> I'm available the 13th, 14th, 20th and 21st
19:37:53 <fungi> devstack being the most painful, the others might be a lot simpler (based on discussions with mtreinish and sdague in tokyo)
19:38:36 <anteaya> sorry we are moving all of openstack-dev? I missed that
19:38:57 <fungi> the 21st is our gerrit upgrade maintenance, so best not to comingle those i expect
19:39:24 <anteaya> I thought the 18th was the upgrade?
19:39:25 <pleia2> er, isn't that the 18th?
19:39:36 <fungi> oh, right
19:39:40 <fungi> we made it wednesday
19:39:44 * pleia2 nods
19:39:55 <zaro> is that bad?
19:40:00 <anteaya> #link http://lists.openstack.org/pipermail/openstack-infra/2015-November/003357.html
19:40:04 <jeblair> nibalizer announced the 18th
19:40:15 <fungi> well, anyway i'm not around the 13th/14th or 20th/21st either, but if people are eager to get these out of the way then you don't necessarily need me for it
19:40:52 <clarkb> would it be worthwhile doing all but devstack?
19:41:03 <clarkb> just wondering if we have enough time to do devstack on say the 13th
19:41:08 <clarkb> and if not maybe go ahead with all the others
19:41:08 <anteaya> clarkb: it would be easy to do all but devstack
19:41:11 <fungi> zaro: we settled on wednesday for the upgrade because of availability of participants and scheduling (per the meeting a couple weeks ago)
19:41:31 <mordred> I have a weird suggestions with devstack ...
19:42:07 <mordred> what if we special-cased it somehow and had gerrit replicate to both openstack/devstack and openstack-dev/devstack for a while
19:42:17 <mordred> mainly because ther eare SO MANY getting started with devstack guides out there
19:42:29 <mordred> that all start "git clone git://git.openstack.org/opentack-dev/devstack"
19:42:34 <fungi> i did brainstorm that we might be able to symlink it on the filesystem
19:42:48 <jeblair> mordred: that seems reasonable
19:42:48 <fungi> talking about it with sdague
19:42:52 <mordred> I think gerrit can do name mapping in replication config yeah?
19:42:57 <fungi> might be easier than double-replicating
19:43:25 <jeblair> mordred: i'm not certain we can configure gerrit to replicate like that, but worth looking into
19:43:29 <mordred> (I think we need to have it show up in github too ... unless we put a tiny script in github/openstack-dev/devstack that is a script that clones from github/openstack/devstack
19:43:33 <mordred> jeblair: ++
19:43:53 <clarkb> mordred: github will automagically redirect
19:43:55 <fungi> github we'd just transfer it to the openstack prg and their redirects should solve it
19:43:57 <jeblair> mordred: with github we can take advantage of the redirect
19:44:03 <mordred> oh! duh
19:44:11 <mordred> nm then - symlinks would probably work just fine then
19:44:19 <jeblair> cool
19:44:55 <fungi> we should probably perform a simple test to make sure git:// handles a symlinked repo name
19:46:05 <fungi> i can give that a try tomorrow probably unless someone beats me to it
19:46:20 <mordred> so ... while we're at it ...
19:46:56 <mordred> maybe we should just move all the retired stackforge projects to be retired openstack projects so that if ever any of them need to be unretired we don't have to do a rename?
19:47:45 <mordred> (sine we have a rename event planned anyway)
19:47:45 <jeblair> mordred: i can see arguments either way on that; but i lean toward thinking they were never in openstack so it's weird/unintuitive to put them there when they are abandoned.
19:47:50 <fungi> it might make their retired status less discoverable
19:48:03 <mordred> ya - I don't feel strongly about it at all
19:48:10 <mordred> just thought I'd mention as an option
19:48:18 <fungi> we did briefly discuss it months ago when the rename plan was being drafted
19:48:24 <mordred> nod
19:48:28 <mordred> I was probably drunk
19:48:40 <fungi> i'm sure i was
19:48:42 <anteaya> I'm in favour of not having to do more reviews than I have to, as I don't want to make mistakes
19:48:53 <mordred> anteaya: good point
19:49:29 <anteaya> if we want to do it another time, I'm fine with that, i just don't favour competition for review time with something more important
19:49:35 <fungi> also i expect that it's been long enough now and few enough projects actually came forward saying they missed/misunderstood the announcements that i don't expect many more (if any)
19:51:00 <fungi> okay, so did we want to consider a rename batch this coming weekend? or one of the weekends immediately before/after the rename, or push it off until late november/later?
19:51:26 <anteaya> I'm at pyconca this weekend, but y'all don't need me
19:51:37 <fungi> if we want to batch it up with openstack-dev moves then this weekend is probably too soon
19:51:51 <anteaya> I'm in favour of splitting them
19:52:04 <anteaya> -dev with be big and the other renames should be simple
19:52:14 <anteaya> but I'm thinking about reviewing not downtime
19:52:48 <fungi> i lean toward expecting we need to provide a bit more advance notice of moving teh contents of openstack-dev since they're pretty widely used compared to the other stuff on the roster
19:53:00 <anteaya> I agree with that point
19:53:00 <mordred> fungi: yah
19:53:22 <anteaya> if someone is able to do renames this weekend I can review patches before I go
19:54:01 <fungi> also the weekend before the gerrit upgrade may be a bad idea because that's only a handful of days to iron out any problems resulting from, e.g., the devstack move and it could encroach on upgrade preparations
19:54:03 <clarkb> I will likely be around this weekend if we do a first batch
19:54:13 <fungi> yeah, i'm here this weekend as well and can help
19:54:26 <anteaya> i'll prep the current renames, nothing from -dev
19:54:44 <anteaya> and get stuff set up if fungi and clarkb want to do the downtime bit
19:55:03 <anteaya> I will be away Friday and all weekened
19:55:08 <jeblair> i'm gerrit conferencing this weekend and will not be around
19:55:31 <fungi> since we'd be sticking to the simple renames, a couple of us should be plenty
19:55:33 <fungi> so let's plan for moving what we can this weekend, and anything which isn't ready for that window will get batched up with an openstack-dev move in late november?
19:55:36 <zaro> i'm @ gerrit with jeblair as well
19:56:02 <fungi> s/moving/renaming or moving/
19:56:05 <anteaya> fungi: I can live with that
19:56:14 <zaro> heads up, watch for this after gerrit restart: https://review.openstack.org/#/c/236056/
19:56:25 <anteaya> I'll do as much prep as I can and sync with you and clarkb on Thursday
19:56:56 <anteaya> zaro: thank you
19:57:01 <fungi> zaro: that's only happening on review-dev at the moment, right?
19:57:21 <zaro> nope, should be for both review and review-dev
19:57:47 <anteaya> has review-dev been restarted with that change yet?
19:58:03 <zaro> yes.
19:58:09 <clarkb> zaro: did it fix the cgit linkage?
19:58:16 <zaro> yes
19:58:19 <clarkb> yay
19:58:22 <fungi> where are the cgit links on review.o.o? i only see it doing gitweb there
19:58:35 <clarkb> fungi: review.o.o isn't cgit yet iirc
19:58:37 <clarkb> because of this thing
19:59:28 <fungi> and this is going to turn it on?
19:59:41 <clarkb> no, this just fixes pathing for if/when we turn it on
19:59:49 * mordred is excited about turning that on
19:59:59 <fungi> my confusion is over zaro's comment to watch out for it when restarting gerrit
20:00:17 <clarkb> I think just make sure that gitweb still works
20:00:20 <zaro> i just meant, check that it works.
20:00:24 <clarkb> so mabe we want to check that on review-dev too
20:00:31 <mordred> yeah - I think the subject of the patch is bong
20:00:47 <mordred> it's also about fixing gitweb links
20:00:47 <fungi> ahh, thanks. make sure that change didn't break gitweb links and/or the config parsing at startup. got i
20:00:48 <anteaya> I'm clicking things in review-dev, what should I be clicking?
20:00:49 <fungi> y
20:01:12 <fungi> we're waay over time
20:01:13 <zaro> mordred: yes, could have been more general with that.
20:01:20 <fungi> let's move this to #-infra
20:01:23 <fungi> thanks all!
20:01:24 <mordred> zaro: no worries :)
20:01:28 <fungi> #endmeeting