19:01:16 <fungi> #startmeeting infra
19:01:17 <openstack> Meeting started Tue Oct  6 19:01:16 2015 UTC and is due to finish in 60 minutes.  The chair is fungi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:20 <openstack> The meeting name has been set to 'infra'
19:01:22 <rfolco> o/
19:01:24 <dougwig> o/
19:01:25 <ruagair> o/
19:01:30 <fungi> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:01:33 <zaro> o/
19:01:38 <mmmpork> o/
19:01:42 <krtaylor> o/
19:01:48 <fungi> #topic Announcements: Stackforge namespace retirement
19:02:04 <fungi> #link https://wiki.openstack.org/wiki/Stackforge_Namespace_Retirement
19:02:23 <jeblair> (i still need to send a follup mail; hoping to do that today)
19:02:24 <fungi> just a reminder, this is still scheduled for october 17
19:02:30 <fungi> thanks jeblair
19:03:01 <fungi> #action jeblair send followup reminder to lagging stackforge projects about namespace retirement
19:03:10 <anteaya> did we ever set a time on oct 17?
19:03:19 <anteaya> or shall we discuss that later?
19:03:29 <fungi> we can discuss it now i suppose
19:03:29 * anteaya notes we are still in announcemnents
19:03:37 <fungi> if we keep it brief
19:03:47 <anteaya> anyone have any thoughts about what time gerrit should go offline?
19:03:57 <fungi> 18:00 utc?
19:04:01 <anteaya> wfm
19:04:08 <fungi> who expects to be working on it?
19:04:11 <anteaya> me
19:04:14 <mmmpork> how is the project name change going to be run?
19:04:22 <fungi> we probably want to leave ourselves plenty of time given the scale of the change
19:04:23 <jeblair> me, and 1800 works, so does earlier
19:04:39 <anteaya> fungi: I'm guessing about 2 hours downtime anyway
19:04:40 <jeblair> (but we also might need extended prep before, so maybe not schedule the outage too early)
19:04:41 <fungi> i didn't want to pick something too early for west-coasters
19:04:43 <anteaya> is that too much?
19:05:28 <mordred> o/
19:05:29 <fungi> though if SergeyLukjanov, yolanda or jhesketh are wanting to pitch in on the maintenance we can consider less americentric windows
19:05:34 <mmmpork> also have we defined a verification process for checking the change result before it goes live?
19:05:40 <mordred> (on a plane, landing in 30 minutes, fwiw)
19:06:00 <pleia2> I'll be on a flight to japan during the rename, so one less west-coaster to worry about
19:06:06 <jeblair> mordred: are you indicating you are here, or that you will be around on oct 17? :)
19:06:27 <anteaya> pleia2: thanks for letting us know, safe travels
19:06:29 <jeblair> pleia2: that sounds fun, we should all go
19:06:38 <pleia2> jeblair: yeah, let's do it
19:06:48 <fungi> for those without a calendar (or the `cal` utility) handy, keep in mind this is one week from saturday
19:07:04 <yolanda> fungi, i cannot be here on 17th october, i have some family appointments. But thanks for the consideration, and i'll try to help in other future tasks
19:07:25 <anteaya> fungi: looks like it is you me and jeblair so far
19:07:27 <fungi> yolanda: no problem. i'm sure we have lots of people on hand, and thanks for the heads up
19:07:31 <anteaya> I'll do as much prep as I can
19:07:40 <mmmpork> i'll be around for it
19:07:50 <mmmpork> but i'd like some answers to the questions i just asked :)
19:08:13 <clarkb> I will be around
19:08:14 <fungi> okay, to rephrase. any objections to 18:00 utc (or think there's a better time)?
19:08:22 <anteaya> no objections
19:08:23 <clarkb> 1800 wfm
19:09:00 <mmmpork> no objections here
19:09:07 <fungi> #agreed Stackforge namespace retirement maintenance will commence at 18:00 UTC, Saturday, October 17
19:09:07 <vmbrasseur> mmmpork Those are great questions.
19:09:36 <fungi> mmmpork: non-scheduling-related questions can be handled later in the meeting or in #-infra
19:09:37 * ruagair is around too
19:09:44 <mmmpork> fungi: ok thanks :)
19:09:53 <fungi> #topic Actions from last meeting
19:10:03 <fungi> #link http://eavesdrop.openstack.org/meetings/infra/2015/infra.2015-09-29-19.01.html
19:10:13 <fungi> Clint: write script to prepare layout.yaml change for migration
19:10:14 <Clint> #link https://review.openstack.org/#/c/228002/
19:10:49 <Clint> and as sample "output" for a subset of names and using an earlier patchset, there's
19:10:52 <Clint> #link https://review.openstack.org/#/c/229601/
19:10:57 <mordred> jeblair: sorry, that was an indication of my skills at attneding thi smeeting. I will be here on the 17th
19:11:14 <fungi> cool, thanks Clint! (and anteaya and mmmpork who seem to be the primary reviewers so far)
19:11:18 <jeblair> mordred: woot :)
19:11:21 <anteaya> that output used patchset 12 of the script
19:11:32 <jeblair> does that script cover all the necessary files now?
19:11:36 <mmmpork> i've added some unit test coverage so we can check the file names we are changing and the data we'll be writing out
19:11:38 <jeblair> (i mean, as far as we know :)
19:11:43 <Clint> as far as i know
19:11:43 <mmmpork> jeblair: idk does it? ;)
19:11:45 <anteaya> jeblair: patchset 12 looked fine to me
19:11:56 <anteaya> jeblair: as far as I know
19:12:04 <mmmpork> there's a test that i wrote that lists the files we're changing
19:12:10 <jeblair> mmmpork: exactly :)  rephrased: i take it there are no known omissions at this point?
19:12:19 <mmmpork> if someone could take the time to review that and make sure our expectation are covered there, that would be great
19:12:45 <Clint> the only known issue at this time is that some comments will need to be replaced by hand
19:12:58 <anteaya> Clint: in gerrbot/channels.yaml
19:13:02 <Clint> right
19:13:03 <mmmpork> https://review.openstack.org/#/c/228002/27/tools/tests/mass_rename_projects_unit_test.py
19:13:06 <fungi> the sample change looks good on a brief pass. was there a plan to handle the sql update queries?
19:13:09 <anteaya> as noted in the commit message in the script
19:13:23 <Clint> fungi: no, i thought that might be done by the ansible stuff, which i haven't seen
19:13:36 <fungi> jasondotstar: that's what you were hacking on?
19:13:39 <anteaya> fungi: as far as I know the sql queries were not part of this script
19:14:00 <Clint> i was thinking this script would not extend outside the boundaries of the project-config repo
19:14:20 <anteaya> Clint: well so far it doesn't
19:14:29 <Clint> right
19:14:34 <mmmpork> do we have a checklist somewhere of all the pieces that need to be updated?
19:14:42 <anteaya> so many steps on of the workflow are not automated
19:15:00 <Clint> mmmpork: there's https://etherpad.openstack.org/p/project-renames-Septemeber-2015
19:15:11 <fungi> oh! right, i skimmed and misread the git mv commands comment you added
19:15:12 <jeblair> Clint, mmmpork: and http://docs.openstack.org/infra/system-config/gerrit.html#renaming-a-project
19:15:23 <anteaya> fungi: yes I did to at first
19:15:32 <anteaya> fungi: thos commands are for the acl file path renames
19:15:54 <anteaya> which Clint will run by hand before submitted the patch to be merged
19:16:11 <jeblair> if we don't have an ansible thing, we have fungi's "script that outputs the sql" we could use
19:16:15 <fungi> so, anyway, if worse come to worse we have that already scripted (more or less)
19:16:21 <fungi> #link https://review.openstack.org/222726
19:16:28 <anteaya> ast you can see in the sample output
19:16:36 <anteaya> #link script sample output https://review.openstack.org/#/c/229601/
19:16:55 <mmmpork> so i'm seeing a bunch of things in a bunch of different places for this project
19:16:55 <fungi> okay, seems like we're on track then
19:16:56 <anteaya> jeblair: yeah I haven't seen one yet and haven't looked at sample output
19:17:10 <anteaya> fungi: I feel comfortable with where the patch should be
19:17:14 <mmmpork> and it's still not clear how we're going to do a test run and verify before pushing this change
19:17:23 <anteaya> fungi: you okay to create the working etherpad for this?
19:17:59 <fungi> anteaya: yeah, though for sanity it may make sense to not paste the filesystem and database updates into the etherpad directly
19:18:07 <anteaya> agreed
19:18:21 <anteaya> I'm open to however you want to address running those steps
19:18:35 <fungi> #action fungi start maintenance plan etherpad for stackforge retirement
19:18:38 <anteaya> as long as we can have the steps noted for when they are done
19:18:42 <anteaya> thanks
19:19:00 <fungi> we had one other action item from the last meeting...
19:19:07 <fungi> jhesketh: look into why the swift upload indices are still not appearing
19:19:34 <fungi> jhesketh may not be around
19:19:43 <fungi> anybody happen to know the status on this?
19:19:48 <anteaya> fungi: do you have a new cpu fan for your workstation?
19:20:06 * anteaya does not know the status of swift upload indices
19:20:11 <fungi> anteaya: nope, i'll have contingencies in place this time
19:20:16 <anteaya> fungi: wonderful
19:20:28 <mordred> fungi: we've started our descent - sorry, hav eto drop
19:20:30 <Clint> btw, the project-config script takes a different input format from the one in https://review.openstack.org/222726
19:20:34 <anteaya> mordred: safe landing
19:20:48 <clarkb> fungi: its working now
19:20:58 <anteaya> clarkb: yay
19:20:59 <fungi> clarkb: excellent
19:21:11 <clarkb> however we did run into some problems
19:21:12 <fungi> jhesketh: when you see this, thanks for getting it working!
19:21:16 <clarkb> swiftclient is not following semver
19:21:22 <clarkb> so we had to downgrade our swiftclient install
19:21:37 <fungi> ahh, so we hit a backward incompatibility?
19:21:39 <clarkb> because newer version introduced a nonbackward compatible type change
19:21:42 <clarkb> fungi: ya
19:21:58 <fungi> that's unfortunate
19:22:07 <clarkb> we have pinned swiftcleint in os-loganalyze and it should all be fine until we are ready to support the new thing and upgrade though
19:22:12 <clarkb> but that was a really fun evening
19:22:18 <fungi> i can imagine
19:22:21 <anteaya> I remember it
19:22:24 <anteaya> late you were
19:22:36 <fungi> okay, moving on then...
19:22:41 <fungi> #topic Specs approval
19:22:56 <fungi> #info approved "Host a CI systems monitoring dashboard" spec
19:23:06 <fungi> #link http://specs.openstack.org/openstack-infra/infra-specs/specs/deploy-ci-dashboard.html
19:23:13 <fungi> #info approved "JJB 2.0.0 API Changes" spec
19:23:30 <notmyname> clarkb: that is unfortunate and not intended. I'd love follow-up (outside of your meeting is fine)
19:23:30 <fungi> #link http://specs.openstack.org/openstack-infra/infra-specs/specs/jenkins-job-builder_2.0.0-api-changes.html
19:23:37 <clarkb> notmyname: can do
19:23:44 <fungi> #topic Specs approval: StoryBoard Worklists and Boards (SotK)
19:23:51 <fungi> #link https://review.openstack.org/202989
19:24:01 <SotK> This spec has been hanging around without activity for a month and I'd like to get it approved so that we can merge patches to implement it.
19:24:04 <SotK> The work I've done on implementing the spec so far can be seen at http://185.98.149.23/#!/ if people are interested in seeing it.
19:24:21 <jeblair> ooh green
19:25:25 <fungi> any objections to setting a 48-hour deadline to register concern over that spec?
19:25:56 <jeblair> nope, looks like ttx has seen it which was the only thing i was going to offer
19:26:02 <clarkb> none here
19:26:07 <anteaya> no objections
19:26:13 <fungi> #info voting open on "StoryBoard Worklists and Boards" spec until 2015-10-08 19:00 UTC
19:26:17 <clarkb> I am happy for those interested in storyboard to drive their own direction too fwiw
19:26:28 <fungi> same here, glad to see it surviving!
19:26:28 <Zara> great. please let SotK know if you find any bugs in the implementation; he really loves that... 0:)
19:26:34 <fungi> heh
19:26:34 <SotK> thanks people :)
19:26:54 <fungi> #topic Priority Efforts
19:27:02 <fungi> any urgent updates on blockers for the priority efforts listed in our agenda? if no, we've got summit planning coming up and i want to make sure we leave time to discuss
19:27:27 <fungi> going once... twice...
19:27:47 <fungi> #topic Summit planning
19:27:55 <fungi> #link https://etherpad.openstack.org/p/infra-mitaka-summit-planning
19:28:22 <fungi> i see some great ideas on the list so far
19:28:46 <anteaya> remember to add your name ot the list on the etherpad, top right hand corner
19:29:17 <fungi> it looks like so far there's a lot of fishbowl ideas but not many workroom ideas
19:29:29 <anteaya> we like to talk?
19:30:02 <anteaya> if you leave a question or comment on the etherpad please add your name or nick
19:30:11 <Zara> I put mine down as a workroom but I thought it was better suited to a fishbowl, I just didn't want to compete with people for that space since I thought they had a better claim to it.
19:30:37 <fungi> the other thing worth considering is that our 4 workroom slots are in back-to-back pairs
19:30:38 <anteaya> whoever just added the green question to yolanda's proposal
19:30:42 <clarkb> greghaynes: getting noepool image works might be good fishbowl?
19:30:51 <clarkb> greghaynes: and or writing nodepool tests
19:30:58 <anteaya> Zara: looks like you made a good space choice
19:31:02 <jeblair> i don't think zuulv3 is ready for a workroom yet -- however, we have some things i think need to get done before v3 -- greghaynes nodepool dib work and jhesketh's zuul connector work
19:31:15 <jeblair> if those are outstanding, maybe we could attack them there
19:31:21 <anteaya> jeblair: +1
19:31:21 <jeblair> clarkb: good idea!  :)
19:31:21 <fungi> so it's _possible_ we might do an extended workroom session if something benefits from 80 (well 90 if you ifnore the break) minutes instead of the usual 40
19:31:24 <yolanda> how is status of masterless puppet? shall we dedicated some time there?
19:31:39 <clarkb> jeblair: I will add them
19:31:51 <crinkle> yolanda: ++ nibalizer ^
19:31:55 <Zara> anteaya: thanks :)
19:32:00 <greghaynes> Sure, I think the image builder stuff should be done before then but who knows what shows up on reviews
19:32:02 <jeblair> yolanda: yeah, good idea
19:32:21 <clarkb> greghaynes: well maybe we use that time to deploy it across the clouds
19:32:24 <clarkb> greghaynes: and debug when it breaks :)
19:32:35 <greghaynes> Yea, that actually sounds like a good plan A/B
19:32:48 <greghaynes> depending on what state its in
19:33:19 <crinkle> I think infra cloud might be a good workroom session or it could wait till the sprint day
19:33:53 <fungi> as usual, keep in mind that workroom sessions are ideal for mini-sprint type tasks where we identify something that a room full of people can potentially churn out (at least get a great start on if not complete) in 40 (or 90) minutes
19:34:05 <jeblair> crinkle: yeah, depends on if there's something we can accomplish in 40-80 mins with infra cloud... i think of it as more of a half-day thing.
19:34:24 <crinkle> jeblair: i think so too
19:34:26 <anteaya> crinkle: you want to put it on the etherpad somewhere?
19:34:36 <jeblair> crinkle: but if there's a mini-task or plan that needs to be sketched out... that'd work.
19:34:36 <crinkle> anteaya: sure
19:34:41 <fungi> for those who joined us on the irc meetings tracker session, that i think was a mostly perfect example of a good workroom idea
19:35:02 <jeblair> fungi: yeah, we got that 90% done and finished it easily the next week.
19:35:04 <anteaya> crinkle: then it isn't lost, thanks
19:35:31 <fungi> i think it's good to view workroom sessions as "team building" exercises
19:36:17 <fungi> they might be things we could collaborate remotely on, but it's fun and helps with socialization to hack together on a common goal and share that sense of accomplishment in the same room
19:36:30 <jeblair> fungi: and establishing a shared understanding
19:37:50 <fungi> for fishbowl sessions, these tend to be best used for topics which need discussion to arrive at a common consensus or level-set some understanding within the group or cross-project with other stakeholders outside infra, particularly where it might otherwise require a protracted many-weeks-long thread on the ml otherwise
19:38:43 <anteaya> zaro: do you want to keep Gerrit development/upgrade as fishbowl or move to workroom?
19:39:10 <zaro> anteaya: IMO better as fishbowl.
19:39:15 <anteaya> very good
19:39:16 <fungi> we won't necessarily be making final decisions in a fishbowl, but we'll be exchanging positions and getting what we need to be able to have the final follow-up decision discussions on the ml (so that those who can't make it to the summit can still have some input)
19:42:30 <fungi> an important additional detail on the friday sprint time. before lunch we're co-sprinting with the ironic team
19:42:50 <anteaya> and after lunch with qa and release management
19:43:05 <fungi> morning would be a great time for infra cloud since we can potentially collaborate on bifrost/bare metal automation needs
19:43:10 <pleia2> ++
19:43:26 <clarkb> fungi: and possibly onmetal if that is still something magnum wants to try
19:43:35 <clarkb> though never heard back from them so maybe not
19:43:40 <fungi> and afternoon, yes our usual group therapy with qa and rm
19:43:49 <anteaya> can't miss that
19:43:52 <pleia2> hehe
19:44:02 <jeblair> i never thought about release management being acronymed 'rm'.  that's fantastic.
19:44:10 <anteaya> ha ha ha
19:44:11 <jeblair> er, initialed, i guess.
19:44:15 <mordred> fungi: I think it would be useful to be explicit on intent with workrooms ... in Vancouver we had different people with mismatched thoughts, both valid things, but mostly incompatible
19:44:28 <anteaya> that was me
19:44:30 <anteaya> my fault
19:44:45 <mordred> not fault. I just think clarity is good for all
19:44:54 <anteaya> agree clarity is good
19:45:02 <anteaya> but I recall that one and will own it
19:45:12 <fungi> mordred: great point. yes workrooms are where we come prepared to collaborate on some predetermined task, not so much come to learn about something or get presented to
19:45:50 <fungi> so it helps to familiarize yourself with what we're going to work on in advance and be ready to volunteer for subtasks
19:45:50 <pleia2> I think we may also want to consider that we can also split out if we don't feel we need to be there, I kind of thought I *should* but made much better use of my time by splitting off into another smaller group to do other things
19:46:05 <mordred> ++
19:47:00 <fungi> yep, don't just show up to a workroom session because "it's infra." there will be other places to have conversations or collaborate on unrelated work, and there will also be sessions for other teams going on so it can be a great excuse to cross-pollinate
19:48:28 <fungi> anyway, the goal with the planning topic for today's meeting was to prompt one another for additional ideas and get them onto the etherpad. we'll have one more meeting where we can settle on which topics from the list we're going to schedule into what slots
19:48:50 <anteaya> I think the goal for today was successful
19:49:04 <fungi> so if you think of things between now and next tuesday please do add them to https://etherpad.openstack.org/p/infra-mitaka-summit-planning
19:49:13 <zaro> anteaya: i've changed my mind on that 'Gerrit development/upgrade' would be better as workroom, 'scaling repo creation' better as fishbowl.
19:49:40 <anteaya> zaro: very good, would you like to make that change?
19:49:57 <anteaya> and thanks for adding yourself to co-chair scaling, didn't want to speak for you
19:50:13 <fungi> zaro: ooh, like collaborate on gerrit/jgit hacking and testing during a work session?
19:51:21 <zaro> fungi: I was thinking get people started on gerrit/jgit hacking but if someone already knows gerrit then we can collaborate as well
19:51:49 <anteaya> zaro: you have a few respondants to your request for help
19:51:55 <fungi> zaro: it might be a good idea to find out how many of the people who volunteered to help try to fix those will be summiting
19:51:59 <anteaya> and at least 2 said they would be at summit
19:52:05 <fungi> oh, excellent
19:52:07 <anteaya> persia I remember
19:52:15 <anteaya> and one other, I will check the logs post meeting
19:52:20 * fungi notes that it's hard to forget persia
19:52:26 <pleia2> hehe
19:52:32 <anteaya> so memorable
19:52:47 <zaro> iirc, i think signed8bit is only one that is summiting
19:52:54 <anteaya> and persia
19:53:05 <nibalizer> yes masterless puppet should get some attention
19:53:06 <anteaya> and thanks zaro, yes that is the other person
19:53:36 <anteaya> pleia2: found signed8bit
19:53:38 <pleia2> oh yes, how could I forget
19:54:16 <zaro> anteaya: np.
19:54:22 <anteaya> :)
19:54:31 <fungi> okay, i'll transition this to open discussion for the last 5 minutes since mmmpork had some additional questions about next week's maintenance, but feel free to keep plugging summit session ideas too
19:54:32 <zaro> anteaya: those sessions are already in the right spot.
19:54:43 <anteaya> zaro: wonderful
19:54:44 <fungi> #topic Open discussion
19:55:24 <mmmpork> we might want to have a meeting or discussion about the project rename process
19:55:28 <pleia2> I'm speaking at Grace Hopper next week on our CI system, this is a pretty huge deal and I'm going to be very busy at the conference from Tuesday on http://schedule.gracehopper.org/session/open-source-presentations-3/
19:55:49 <pleia2> from there I'm off to Japan to do some traveling pre-summit, so see you there? :)
19:55:50 <AJaeger> great, pleia2 !
19:55:58 <fungi> pleia2: thanks for the heads up, and good luck! (not that you need it)
19:56:12 <SpamapS> speaking of infra-cloud
19:56:15 <fungi> mmmpork: what about the project rename process should we discuss?
19:56:18 <pleia2> fungi: thanks
19:56:28 <jeblair> pleia2: yay!
19:56:34 <SpamapS> just an update.. crinkle and greghaynes pushed a bit and got a mini-cloud up with some hand-massaging of network configs
19:56:39 <mmmpork> 1) what are the pieces that need to be run?
19:56:42 <mmmpork> 2) how will they be run
19:56:50 <mmmpork> 3) are we going to do a test run first?
19:56:52 <SpamapS> the current challenge is to turn that into actual automation and deploy it into the working nodes in HP1
19:57:03 <mmmpork> 4) how will we verify the results before making actual changes to make sure we didn't miss anything?
19:57:15 <anteaya> pleia2: congratulations
19:57:43 <mmmpork> i'm ok with us having a document, an etherpad, or something as long as it's linked on the project wiki and we know who is doing what and when
19:57:49 <anteaya> SpamapS: crinkle greghaynes congratulations
19:58:17 <greghaynes> (it was mostly crinkle)
19:58:20 <pleia2> mmmpork: so project renames are something we do pretty often with the previous stackforge<>openstack churn we used to have
19:58:24 <fungi> mmmpork: so when you say "project rename process" you mean the upcoming maintenance specifically, not just our general project rename process (which we have documented quite thoroughly already)?
19:58:29 <mmmpork> yes
19:58:43 <SpamapS> There should be some patches heading toward system-config with the automation bits.
19:58:46 <mmmpork> since we're going to be doing a bunch of them all at once and having gerrit downtime to do so, correct?
19:59:09 <pleia2> mmmpork: this process will be much the same as the one we've done many times, which I think is why we're pretty casual about this and have our etherpad+docs process
19:59:25 <pleia2> mmmpork: it always requires gerrit downtime
19:59:29 <mmmpork> alright, if you all are comfortable with that then i won't push for it
19:59:33 <crinkle> SpamapS: yes, topic:infra-cloud has relevant patches
19:59:34 <fungi> mmmpork: right, so the documented process is still going to be followed, but we have some additional scripts with this one to pregenerate what we're going to run/merge so that it can be reviewed more easily and further in advance
19:59:59 <fungi> anyway, we're at time
20:00:02 <mmmpork> fungi: do we have that documented anywhere? what scripts are going to be run, where and by who?
20:00:22 <fungi> anyway, we're at time, don't want to hold up the tc
20:00:30 <fungi> mmmpork: we can discuss further in #openstack-infra
20:00:34 <fungi> #endmeeting