19:02:27 <jeblair> #startmeeting infra
19:02:28 <openstack> Meeting started Tue Sep 22 19:02:27 2015 UTC and is due to finish in 60 minutes.  The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:32 <openstack> The meeting name has been set to 'infra'
19:02:37 <jeblair> #link agenda https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:02:41 <jeblair> #link previous meeting http://eavesdrop.openstack.org/meetings/infra/2015/infra.2015-09-15-19.02.html
19:02:52 <jeblair> #topic Announcements
19:02:58 <jhesketh> o/
19:03:12 <mmmpork> o/
19:03:15 <hogepodge> o/
19:03:25 <jeblair> #info fungi is the new PTL
19:03:29 <anteaya> yay
19:03:30 <jeblair> yay fungi!
19:03:32 <mmmpork> whoohoo!
19:03:33 <pleia2> all hail fungi!
19:03:36 <crinkle> \o/
19:03:39 <fungi> you're announcing it ahead of the election officials
19:03:41 <pleia2> and thank you for all your work, jeblair :)
19:03:45 <fungi> but close enough ;)
19:03:52 <anteaya> yes, thank you jeblair
19:03:54 <jhesketh> congrats :-)
19:03:54 <AJaeger> fungi: thanks for leading us - and thanks to jeblair as well!
19:03:56 <nibalizer> fungi: congratulations
19:04:03 <fungi> yes, thanks jeblair! we'll expect you to work on fun things now
19:04:03 <pabelanger> fungi: congrats
19:04:03 <nibalizer> yes thanks to jeblair as well
19:04:05 <jeblair> fungi: right, assuming you don't find a way to late-disqualify yourself :)
19:04:05 <SotK> fungi: congrats
19:04:08 <clarkb> now you have to plan a summit, get on it :P
19:04:12 <pleia2> haha
19:04:28 <Zara> fungi is our new overlord! \o/
19:04:32 <fungi> i just planned the summit. you won't like it though
19:04:39 <pleia2> sake
19:04:42 <fungi> mmm
19:04:43 <jasondotstar> congrats fungi!! \o/
19:04:44 <jeblair> fungi: i bet it's on a beach
19:04:49 <anteaya> fungi: I'll like tokyo
19:05:29 <fungi> in seriousness, i'll take care of boring things like brainstorming our summit sessions soon
19:05:45 <fungi> so be on the lookout for e-mails asking for ideas
19:06:39 <jeblair> ++
19:06:48 <jeblair> and a new meeting chair next week :)
19:07:05 <fungi> yeah, that
19:07:26 <jeblair> but wait, there's more:
19:07:39 <anteaya> jeblair: you are just having too much fun
19:08:21 <jeblair> #info adding nibalizer to infra-core/root
19:08:24 <jeblair> #info adding yolanda to infra-core/root
19:08:37 <anteaya> congratulations
19:08:38 <mmmpork> congrats to the new roots!!!!!!!!!!
19:08:39 <pleia2> congrats nibalizer and yolanda
19:08:48 <nibalizer> :) thanks
19:08:48 <Zara> :) congrats!
19:09:01 <SotK> congrats!
19:09:06 <zaro> cool, new cores to bug!
19:09:08 <fungi> welcome!
19:09:08 <jhesketh> nibalizer, pleia2: congrats :-)
19:09:10 <jeblair> they know our sysadminy puppet stuff (is that the right term?) as well as anyone
19:09:12 <pleia2> your experience downstream will continue to be a massive benefit to us :)
19:09:32 <AJaeger> Great.Welcome, nibalizer and yolanda! Will be good to have more European coverage.
19:09:38 <jeblair> and have experience running a similar system
19:09:42 <nibalizer> jeblair: as good a term as any
19:09:53 <fungi> (in related news, nibalizer moves to europe!)
19:09:59 <anteaya> wooooo
19:10:07 <anteaya> good food there
19:10:10 <fungi> (joking)
19:10:10 <anteaya> and trains
19:10:12 <pabelanger> /me claps
19:10:34 <fungi> but yes, thanks nibalizer and yolanda for agreeing to take on additional responsibilities there
19:10:38 <jeblair> #action nibalizer propose change adding nibalizer to infra-root
19:10:45 <jeblair> #action yolanda propose change adding yolanda to infra-root
19:11:02 * nibalizer immediately breaks something
19:11:11 <anteaya> nibalizer: well done
19:11:12 <pleia2> as it should be
19:11:20 <fungi> if only that were also an action item
19:11:27 <jhesketh> implied action
19:11:29 <jhesketh> or rite of way
19:11:30 <anteaya> ha ha ha
19:11:40 <fungi> when you're root, you're expected to fix whatever you break. fair warning ;)
19:11:46 <jeblair> fungi: ++
19:12:15 <nibalizer> fungi: ++
19:12:33 <jeblair> i'm announced out
19:12:37 <jeblair> #topic Actions from last meeting
19:12:45 <jeblair> #action
19:12:46 <jeblair> jeblair automate some sort of mass contact attempt for stackforge move
19:12:50 <jeblair> #action jeblair automate some sort of mass contact attempt for stackforge move
19:12:55 <jeblair> :( sorry
19:13:04 <pleia2> it's ok, you have time
19:13:14 <jhesketh> no need to apologise
19:13:18 <fungi> heh
19:13:33 <jeblair> #topic Specs approval: Translation check site spec (pleia2)
19:13:41 <jeblair> #link Translation check site spec https://review.openstack.org/#/c/184559/
19:13:58 <pleia2> so this was discussed at the last summit during a translations session
19:14:09 <pleia2> I've worked through several revisions with them on this spec, and I think it's finally in a place to get rolling
19:14:10 <fungi> yep, seemed like a neat idea
19:14:17 <fungi> still does
19:15:23 <jeblair> cool, anyone think it needs more time?
19:15:32 <fungi> pleia2: is the idea to continuously deploy devstack? any ideas on how to deal with the times when devstack is broken?
19:15:59 <clarkb> I am curious why we need to run cirros instances
19:16:01 <pleia2> fungi: likely some kind a daily refresh rather than CD, I think on broken nights during our periodic refresh that day it's just broken
19:16:04 <anteaya> pleia2: what is the assignee's irc nick?
19:16:12 <clarkb> would it be better to use the fake nova backend? I Thought that was the original plan
19:16:13 <fungi> pleia2: wfm
19:16:41 <pleia2> clarkb: that's a good point, I think I missed that as a holdover from a previous spec version where they actually wanted to launch them
19:16:48 <fungi> also, seems like some of us (myself included) should have found time to review it and asked our questions there
19:17:10 <pleia2> we only agreed to noop
19:17:11 <clarkb> yes we probably should have
19:17:21 <pleia2> well, we can review and revisit next week if we want
19:17:23 <clarkb> but better late than never I hope
19:17:25 <fungi> but also those are probably minor details which could be worked out in implementation if nobody objects
19:17:46 <clarkb> sure
19:17:47 <anteaya> I have no objection to not knowing the assignee's irc nick
19:17:51 <clarkb> the general plan is good to me
19:17:54 <anteaya> just makes them easier to recognize
19:18:27 <clarkb> looks like fake is used in some places so its just internal doc inconsistency that can be ironed out
19:18:38 <jeblair> clarkb: where is cirros?
19:18:44 <jeblair> clarkb: yeah, i think we're seeing the same thing
19:18:44 <pleia2> anteaya: DeeJay1, but I usually interact with him in person (at summits) and via email because time zones
19:18:48 <clarkb> jeblair: under Servers
19:18:53 <clarkb> its typoed to cirrus
19:19:11 <jeblair> clarkb: ah.
19:19:21 <fungi> i totally don't expect the spec author to have enough of a crystal ball to figure out in advance how we're going to refresh devstack deployments reliably. it will likely take at least a couple tries to get right
19:19:22 <anteaya> pleia2: ah okay thanks
19:19:29 <clarkb> fungi: agreed
19:19:50 <jeblair> yeah, i think 'fake' outnumbers cirros, so maybe it's just a holdover.  probably we can send it to vote and then clarify in a followup.
19:20:00 <clarkb> jeblair: wfm
19:20:06 * nibalizer nods
19:20:17 <tchaypo> Thumbsup
19:20:22 <jeblair> (if it specifically said cirros everywhere, i'd think it was enough of a misunderstanding to make it worth clarifying in advance)
19:20:39 <jeblair> #info Translation check site spec voting open until 2015-09-24 19:00 UTC
19:20:41 <pleia2> if you look at past revisions, we had a lot of discussion about the fake point
19:20:52 <pleia2> mostly them saying "we need" and me saying "nope"
19:20:53 <pleia2> :)
19:21:08 <jeblair> pleia2: ++
19:21:09 <anteaya> pleia2: nice work
19:21:10 <jeblair> pleia2: and thanks!
19:21:38 <jeblair> #topic Schedule Project Renames
19:21:52 <jeblair> aside from my lack of progress, anything else we need to discuss re stackforge/oct 17?
19:21:58 <fungi> we're still on track for "the big rename" afaik
19:22:02 <anteaya> jeblair: you are working on communication
19:22:15 <anteaya> is anyone working on automating the workflow?
19:22:22 <jeblair> anteaya: ah yes, thanks!
19:22:32 <jeblair> anteaya: i threatened to ask for volunteers for that this week
19:22:33 <fungi> there was one recent thread on the -dev ml about "incubating in stackforge" which i mostly just pointed back to the announcement
19:22:38 <anteaya> jeblair: oh good
19:22:41 <jasondotstar> anteaya: I'm looking at the rename stuff
19:22:49 <anteaya> jasondotstar: any status?
19:22:52 <jasondotstar> no progress on it in the last couple days :-(
19:23:07 <anteaya> well see I've looked at mordred's code before too
19:23:07 <jasondotstar> attempting to make progress on puppetizing zaqar
19:23:11 <fungi> jasondotstar: anything we should be doing to help? blocked on input?
19:23:19 <anteaya> it never gave me an end result
19:23:20 <mordred> oh! timezone fail
19:23:24 <mordred> o/
19:23:29 <anteaya> jasondotstar: no idea how that relates to the conversation
19:23:45 <jasondotstar> it doesn't. just mentioning my bandwidth issues
19:23:47 <jeblair> specifically, i think we need a script that will generate the gerrit change to modify all the necessary files in project config.  that's mostly a read/write yaml config files change, or possibly just 'string substitution in files' change.
19:24:17 <jeblair> jasondotstar: is that on your radar, or are you looking at the ansible component?
19:24:18 <jasondotstar> we've captures some conversations about how go about it on an etherpad
19:24:22 <AJaeger> some of the files we need to touch are sorted alphabetically, so we need to resort them.
19:24:27 <jasondotstar> jeblair: yes, it is on my radar
19:24:34 <jeblair> jasondotstar: cool, have an etherpad link?
19:24:39 <fungi> now that we don't embed a separate github-org parameter in jenkins jobs, a straight up stream edit will likely suffice
19:24:42 <jeblair> AJaeger: ah good point, not simple string substitution.
19:24:55 <jeblair> for some of them at least
19:25:03 <fungi> stream edit followed by normalization script
19:25:09 <jeblair> fungi: ah right, we have that part scripted
19:25:22 <jasondotstar> yep: https://etherpad.openstack.org/p/project-renames-Septemeber-2015
19:25:23 <jeblair> okay, so this shouldn't be too hard
19:25:33 <fungi> for most of those alpha order things we have the scripts already written to do the ordering since they get run in our check jobs at least
19:25:34 <jasondotstar> jeblair: nope
19:25:39 <jasondotstar> jeblair: it shouldn't.
19:26:02 <jeblair> jasondotstar: that looks like the steps we used for the last rename
19:26:03 <jasondotstar> there's another link too, sry
19:26:07 <fungi> oh, also some git mv (acl files changing directories?)
19:26:23 <fungi> so, yes, there are likely several steps to the transformation regardless
19:26:59 * jasondotstar digs in his notes...
19:28:39 <asselin> o/
19:29:38 <jasondotstar> hmmm... mordred and I had a brief discussion here: http://paste.openstack.org/show/sv12yQ7uwhitRVX0INkV/
19:29:50 <fungi> #link http://paste.openstack.org/show/sv12yQ7uwhitRVX0INkV/
19:29:58 <yolanda> o/
19:30:21 <jasondotstar> perhaps we need to gather the input from all sources and execute accordingly.
19:30:34 <jeblair> (that paste is not immediately loading for me)
19:30:56 <anteaya> it the bots file for paste active yet?
19:30:58 <fungi> yeah, it finally loaded for me. looking at paste.o.o to see why it's struggling again
19:31:43 <jasondotstar> fungi: it loaded for me once. now it's bombing.
19:31:47 <anteaya> ah not yet: https://review.openstack.org/#/c/226091/
19:31:56 <jasondotstar> and, it's back.
19:32:26 <jasondotstar> ¯\_(ツ)_/¯
19:32:53 <jeblair> jasondotstar: got it; that seems to be mostly about the ansible stuff, which maps to steps 5-8, 12, and 16 on the september etherpad
19:33:16 <jeblair> jasondotstar: the project-config script would generate the change needed in steps 1 and 14
19:33:31 <fungi> #link https://etherpad.openstack.org/p/project-renames-Septemeber-2015
19:33:33 <jasondotstar> jeblair: correct. I failed to mention that we were talking just about the ansiblizing actions
19:33:44 <jeblair> jasondotstar: (which should be similar to all those changes listed at the top of the etherpad)
19:34:16 <jeblair> jasondotstar: okay, but you're on the project-config change too, right?  that's great if you are, but i don't want to overload you and we can find another victim if you're too pressed for time.
19:34:35 <jasondotstar> let's get an extra set of hands for that part if we can
19:35:27 <jasondotstar> that way the other non-related item *cough* zaqar *cough* I can still continue making headway on
19:36:17 <fungi> i'd say i'll do that part, but i also just recently volunteered for something else with a minimum 6-month commitment so would rather wait and see if there are any other takers
19:36:22 <jeblair> mmmpork: ?
19:36:25 <jeblair> Clint: ?
19:36:42 * jeblair looks for people who raised their hands at the beginning of the meeting :)
19:36:47 <Clint> jeblair: just s/stackforge/openstack/ and sort?
19:36:55 <fungi> Clint: and some git mv
19:36:57 <mmmpork> jeblair: i messaged jasondotstar privately
19:36:59 <Clint> yeah, sure
19:37:17 <fungi> and then others will review and poke holes in the methodology used. lather, rinse, repeat
19:37:46 <jasondotstar> +1
19:37:49 <mmmpork> i don't have a lot of experience with ansible but if there are smaller tasks i can take on that would be helpful then i'm happy to
19:38:12 <fungi> the project config change will be, like zero ansible
19:38:32 <clarkb> just string manipulation (please don't write it in perl)
19:38:35 <clarkb> :P
19:38:47 <clarkb> or I suppose yaml data structures can be treated as such too
19:38:49 <pleia2> hehe
19:39:18 <mmmpork> clarkb: why not :D
19:39:19 <mmmpork> hahaah
19:39:27 <Clint> because he wants haskell and only haskell
19:39:34 <mmmpork> oh right, i can get on board with that
19:39:36 <fungi> the trick is that we have a growing wikified list of repos some of which need renaming and some of which need retiring
19:39:40 <clarkb> well mostly because then next time we need to do this someone else will have to rewrite it
19:39:50 <mmmpork> clarkb: i know, i kid ;D
19:39:54 <clarkb> (please no next time too)
19:40:07 <anteaya> clarkb: ah utopia
19:40:17 <fungi> though i suppose we could also rename the ones we're retiring, i don't know if that matters as much since they're being retired anyway
19:40:38 <anteaya> was that not covered in the resolution?
19:41:37 <anteaya> ah it isn't
19:41:39 <jeblair> okay, it's a close race, but i think Clint wins... we'll put him in charge of the script effort; mmmpork why don't you work with Clint and contribute or take over the effort, whatever works for the two of you :)
19:41:53 <jeblair> #action Clint write script to prepare project-config change for migration
19:41:55 <mmmpork> yes! i will happily serve as minion
19:42:03 * Clint chuckles.
19:42:33 <jeblair> Clint, mmmpork, jasondotstar: thanks!
19:42:35 <anteaya> fungi: just that the stackforge/ name shall henceforth not exist
19:42:49 * mmmpork sharpens her regex knives
19:42:57 <fungi> anteaya: emphasis on the "henceforth" because it's an awesome word
19:43:14 <jeblair> anteaya: yeah, my understanding is retired projects just become read-only in stackforge
19:43:20 <anteaya> fungi: I look for an opportunity to squeeze it in whereever I can
19:43:33 * jasondotstar never gets to use the word henceforth in a sentence. Has a sad.
19:43:40 <anteaya> jeblair: okay then, and you wrote the resolution, so wfm
19:43:54 <jeblair> (otherwise it feels a bit revisionist)
19:44:12 <jeblair> #topic Priority Efforts (Swift Logs)
19:44:19 <jeblair> we have completely failed to review this change
19:44:24 <jeblair> #link https://review.openstack.org/#/c/214207/
19:44:38 <jhesketh> yep, so nothing further from me
19:44:46 <jhesketh> eyes would be appreciated
19:44:52 <jeblair> #action everyone review https://review.openstack.org/#/c/214207/
19:45:02 <anteaya> ha ha ha
19:45:10 <jeblair> #topic Priority Efforts (Migration to Zanata)
19:45:22 <jeblair> #link https://review.openstack.org/#/c/225945/
19:45:37 <jeblair> this is an easy one :)
19:45:41 <pleia2> this depends on a doc change that needs to land, but that's the last piece!
19:45:41 <jhesketh> heh, excellent
19:46:01 <AJaeger> yeah, we're in the cleanup and fix surprises phase ;)
19:46:05 <pleia2> we're still doing fiddly bits with scripts to work on perfection, but no need to hold up the spec
19:46:19 <pleia2> AJaeger: hah, yeah
19:46:32 <jeblair> cool! ++
19:46:36 <anteaya> well done everyone
19:46:39 <fungi> what was the deal with the pot file uploads for the ibm branch in zanata ending up getting imported into gerrit changes? is there a bug we need to handle in our scripts there?
19:46:43 <anteaya> a long time to the finish line
19:46:55 <clarkb> pleia2: ya I don't think the version support needs to go in the specas that was sort of last minute hey wewant this
19:46:56 <pleia2> fungi: fix landed this morning
19:47:00 <AJaeger> fungi: fixed already ;)
19:47:02 <fungi> oh, neat
19:47:05 <pleia2> fungi: unfortunate zanata default for us :\
19:47:13 <AJaeger> fungi: See http://lists.openstack.org/pipermail/openstack-i18n/2015-September/001437.html
19:47:18 * fungi turns his etch-a-sketch over and shakes vigorously
19:47:28 * AJaeger is still not sure what is the proper solution.
19:47:50 <AJaeger> Copying of translations sounds like a nice feature - but it broke the esoteric use case we whad with IBM imports
19:47:56 * pleia2 nods
19:48:17 <clarkb> its a semi fix though
19:48:24 <clarkb> anyone else can push docs to zanata and trigger it
19:49:03 <clarkb> Daisy said she would talk to Zanata about making it a bit more configurable so we can avoid it in these cases
19:49:07 <anteaya> AJaeger: nicely organized email
19:49:17 <jeblair> #link http://lists.openstack.org/pipermail/openstack-i18n/2015-September/001437.html
19:51:13 <jeblair> i guess we're waiting on feedback then
19:51:45 <pleia2> yeah, it's night time for most of our translations friends
19:52:04 <jeblair> ok
19:52:05 <jeblair> #topic Third-party OSes support in devstack-gate (eantyshev)
19:52:07 <pleia2> I'm out of the office for a holiday tomorrow, but others can chime in
19:52:19 <anteaya> was this from last week?
19:52:23 <ianw> i had a look at this review, it's fine
19:52:23 * anteaya can't remember
19:52:39 <fungi> link?
19:52:43 <clarkb> ya what review?
19:52:56 <clarkb> eantyshev2: ^
19:52:59 <jeblair> #link http://lists.openstack.org/pipermail/openstack-dev/2015-September/073380.html
19:53:00 <ianw> but i also think we can make it a bit easier -> https://review.openstack.org/224989
19:53:01 <fungi> (or just the review number even)
19:53:04 <jeblair> #link https://review.openstack.org/#/c/215029/
19:53:05 <eantyshev2> Hi! here is the review: https://review.openstack.org/#/c/215029/
19:53:08 <anteaya> eantyshev2: wants infra to support an os he uses for his third party ci
19:53:16 <anteaya> eantyshev2: here you are
19:53:20 <jeblair> ianw: (you do have a -1 on 029)
19:53:27 <eantyshev2> anteaya, not exactly
19:53:39 <anteaya> eantyshev2: do share then, I didn't think you were here
19:54:08 <eantyshev2> just want possibility for devstack-gate to run on OSes which it cannot recognize
19:54:41 <tchaypo> I’d phrase it as “we want the possibility to explicitly tell devstack-gate which OS it should believe it’s on"
19:54:44 <tchaypo> is that accurate?
19:54:52 <anteaya> eantyshev2: can expand on your motivation for wanting this?
19:55:03 <fungi> we're generally not in favor of cross-platforming just for the sake of it, since if we won't test support for a particular platform regularly it will rapidly bitrot and break
19:55:27 <ianw> i don't think we need to argue over this too much
19:55:40 <anteaya> ianw: I don't think we are arguing
19:55:41 <fungi> by we i mean i, and by extension the opinions i've seen from others
19:55:54 <anteaya> I think most of infra don't know why eantyshev2 wants this
19:55:59 <ianw> see my comments, i think my version covers centos, fedora, and the extra distros
19:56:20 * jhesketh has to depart a couple of minutes early sorry. Bye!
19:56:28 <anteaya> jhesketh: thanks for being here!
19:56:32 <jeblair> fungi: i agree, and devstack-gate is very complicated.  however, it sounds like maybe this can be accomplished without any real special casing or extra complexity....
19:56:43 <fungi> if it's a good generalization that seems fine, but i don't think we can honestly claim to have support for platforms we don't test
19:56:48 <ianw> if we require more extensive branching in the future, we can cross that bridge, but we don't need to optimize for that
19:56:56 <eantyshev2> ianw, you solution would be great for me if it is accepted here
19:57:43 <ianw> ok, so please just some eyes on
19:57:48 <ianw> #link https://review.openstack.org/#/c/224989/
19:58:00 <ianw> it will help out 3rd party users
19:58:07 <fungi> 224989 is, indeed a bunch of comment and replacing a couple lines
19:58:08 <anteaya> how?
19:58:22 <anteaya> are one of you willing to clearly state the problem this is solving?
19:58:52 <ianw> anteaya: 3rd party testing on rhel-derived distros
19:59:03 <Clint> anteaya: it's changing a whitelist of [fedora,centos] to "does this thing have working rpm"
19:59:03 <ianw> cloudos, orcalelinux, etc
19:59:04 <anteaya> which affect whom?
19:59:20 <mordred> it's like moving from imake to autoconf, tbh
19:59:21 <ianw> 3rd parties who are trying to test on rhel derived distros :)
19:59:25 <anteaya> so far the only third party operator affected by this is eantyshev2
19:59:29 <mordred> test the capability, don't trust a declared list of things
19:59:30 <fungi> well, does this think have working rpm with a /etc/*-release file managed in an rpm
19:59:37 <Clint> yes
19:59:44 <fungi> which helps weed out things like debian with the rpm package installed
19:59:53 <Clint> unless you've done something crazy
20:00:03 <clarkb> (like google did)
20:00:07 * fungi will reserve judgement on what crazy is
20:00:10 <jeblair> that's time
20:00:14 <anteaya> thank you
20:00:18 <eantyshev2> anteaya: there are many cases, when third-party CI maintainers cannot use devstack-gate as-is
20:00:23 <jeblair> thanks everyone, sorry to the folks whose topics we didn't get to
20:00:27 <jeblair> #endmeeting