19:01:43 <jeblair> #startmeeting infra
19:01:44 <openstack> Meeting started Tue Jun  9 19:01:43 2015 UTC and is due to finish in 60 minutes.  The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:45 <pleia2> o/
19:01:45 * morganfainberg lets infra take the channel
19:01:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:48 <openstack> The meeting name has been set to 'infra'
19:01:49 <nibalizer> o/
19:01:51 <Clint> o/
19:01:52 <mrmartin> o/
19:01:53 <crinkle> o/
19:01:54 <asselin> o/
19:01:55 <jeblair> #link agenda https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:01:55 <jeblair> #link previous meeting http://eavesdrop.openstack.org/meetings/infra/2015/infra.2015-06-02-19.01.html
19:01:57 <GheRivero> o/
19:01:59 <yolanda> o/
19:02:01 <dtantsur> o/
19:02:06 <taron> o/
19:02:23 <mordred> o/
19:02:27 <jeblair> #topic Specs approval: Infra-cloud (jeblair, SpamapS)
19:02:35 <jeblair> #info infra cloud spec was approved
19:02:36 <jeblair> #link infra cloud spec http://specs.openstack.org/openstack-infra/infra-specs/specs/infra-cloud.html
19:02:46 <jeblair> the action on this now moves to the system documentation which is here:
19:02:50 <jeblair> #link infra cloud documentation https://review.openstack.org/180796
19:03:03 <jeblair> so people interested in how we actually deploy that should review that
19:03:10 <ruagair> o/
19:03:36 <jeblair> #topic Specs approval: Host OpenStack Apps Catalog Service (docaedo, fungi)
19:03:41 <jeblair> #info apps.o.o spec was approved
19:03:41 <jeblair> #link apps.o.o spec http://specs.openstack.org/openstack-infra/infra-specs/specs/apps-site.html
19:03:54 <jeblair> that's two down! :)
19:04:00 <fungi> awesome. guess now i'm on the hook to finish that ;)
19:04:11 <ttx> o/
19:04:37 <pabelanger> o/
19:04:41 <jeblair> fungi: i have subscribed to your repo :)
19:04:47 <jeblair> #topic Specs approval: Shade (mordred)
19:04:48 <fungi> and my newsletter?
19:04:55 <jeblair> #link shade spec https://review.openstack.org/187312
19:05:19 <mordred> approve my spec everyone
19:05:24 <mordred> otherwise I'll be sad
19:05:26 <jeblair> this looks like it has buy-in from folks in this area of interest
19:05:38 <jeblair> anyone think it needs more time or shall we open voting on it?
19:06:14 <jeblair> #info voting on https://review.openstack.org/187312 open until 2015-06-11 19:00 UTC
19:06:21 <jeblair> #topic Specs approval: Puppet apply (mordred)
19:06:26 <jeblair> #link puppet apply spec https://review.openstack.org/165217
19:06:32 <mordred> approve my spec everyone
19:06:33 <mordred> otherwise I'll be sad
19:06:39 <jeblair> next up, a spec from mordred!
19:06:49 <anteaya> mordred: can you just add that to the commit message?
19:07:04 <mordred> anteaya: I do have that ability
19:07:11 <anteaya> you do
19:07:30 <jeblair> this one also seems ready to me; it's something we've talked about, and nearly implemented, for a long time
19:07:32 <mordred> as a note, the ansible puppet module has been merged into upstream ansible
19:07:40 <nibalizer> jeblair: agree
19:07:49 <jeblair> #info voting on https://review.openstack.org/165217 open until 2015-06-11 19:00 UTC
19:07:56 <jeblair> #topic Specs approval: Puppet 4 preparation and testing (mordred)
19:08:01 <mordred> approve my spec everyone
19:08:02 <jeblair> #link puppet4 spec https://review.openstack.org/#/c/175223
19:08:03 <mordred> otherwise I'll be sad
19:08:26 <anteaya> mordred specbot
19:08:44 <mordred> this is the last time I'll have 5 specs up for voting at the same time, I promise
19:08:51 <fungi> yikes. puppet 4 already?
19:08:54 <anteaya> I don't believe you
19:08:57 <dougwig> next time it'll be 10
19:08:57 <mordred> fungi: it's coming
19:09:01 <mordred> dougwig: ++
19:09:01 <nibalizer> fungi: just setting up the testing
19:09:07 <nibalizer> we dont have to pull the trigger
19:09:20 <fungi> nibalizer: more just amazed that puppet 4 already exists
19:09:31 <mordred> fungi: semver solves everything
19:09:49 <nibalizer> your view is probably skewed a bit because we were on 3 for entirely too long
19:09:56 <nibalizer> jeblair: I think this spec is ready
19:10:05 <jeblair> s/were/have been/  :)
19:10:11 <jeblair> (which i guess is the point :)
19:10:14 <mordred> s/3/2/
19:10:15 <jeblair> nibalizer: agree
19:10:15 <nibalizer> s/3/2/
19:10:23 <anteaya> dougwig: that is more like it
19:10:33 <jeblair> #info voting on https://review.openstack.org/175223 open until 2015-06-11 19:00 UTC
19:10:36 <nibalizer> wooo
19:10:42 <jeblair> #topic Specs approval: Maniphest bug tracking (mordred)
19:10:44 <jeblair> #link maniphest spec https://review.openstack.org/188196
19:10:49 <mordred> approve my spec everyone
19:10:51 <mordred> otherwise I'll be sad
19:10:56 <pleia2> mordred is a spec machine
19:11:09 <fungi> also he has a great command of the up arrow in his irc client
19:11:17 <anteaya> ha ha ha
19:11:19 <mordred> fungi: I have an up arrow?
19:11:23 <jeblair> ttx: ^ you might want to take a look at this one
19:12:16 <jeblair> but i think this comes almost directly from the summit session, so i think it's probably ready for voting
19:12:19 <jeblair> anyone disagree ^?
19:12:33 <fungi> seems ready
19:12:53 <mordred> I made one informational change in the last revision in response to yolanda's question
19:13:16 <mordred> which is worth pointing out - which is the that I do not think we want to run both things - so we would be migrating everything in storyboard, not just infra projects
19:13:35 <jeblair> *nod*
19:13:45 <jeblair> there aren't too many of those
19:13:54 <jeblair> #info voting on https://review.openstack.org/188196 open until 2015-06-11 19:00 UTC
19:13:57 <jeblair> #topic Specs approval: Puppet Functional Testing (nibalizer, crinkle)
19:14:04 <jeblair> #link puppet functional testing spec https://review.openstack.org/178887
19:14:04 <crinkle> o/
19:14:38 <jeblair> zaro does not seem to be here
19:15:04 <jeblair> he -1d it with questions, but i think they were asking for more information, not expressing significant disagreement or potential problems
19:15:12 <nibalizer> This is largely a summary of what was discussed at the summit, with cleanups from crinkle
19:15:20 <nibalizer> well more like a rewrite from crinkle
19:15:37 <crinkle> ah i can take a look at zaro's questions
19:16:33 <jeblair> nibalizer: answered them as comments; i don't actually think they need a new revision, so i'm inclined to say let's open voting as-is
19:16:34 <crinkle> looks like nibalizer answered them
19:16:47 <mordred> ++
19:16:49 <nibalizer> jeblair: i agree, but I'm biased :)
19:17:03 <jeblair> #info voting on https://review.openstack.org/178887 open until 2015-06-11 19:00 UTC
19:17:07 <jeblair> #topic Specs approval: Host a code search service (taron, fungi, pleia2)
19:17:08 <nibalizer> woooo
19:17:11 <jeblair> #link code search spec https://review.openstack.org/188574
19:17:19 <fungi> if you don't approve my spec, i won't be sad. i was planning to spend this morning reviewing everyone else's open specs and then reality got in the way (again)
19:17:31 <taron> heh
19:17:50 <fungi> this is the project taron, our outreachy intern, is going to be working on this summer
19:17:55 <jeblair> fungi: but mordred might be sad
19:17:56 <mordred> this may be the first spec we've had in infra which suggests that someone write go
19:18:09 <fungi> a frightening thought indeed
19:18:15 * mordred opens the barn door to show everyone 27 sad goats
19:18:20 <pleia2> hah
19:18:41 * mordred closes the door again satisfied that people know the consequences
19:18:43 <fungi> mordred: fwiw, that go suggestion was courtesy of jeblair ;)
19:18:51 <jeblair> mordred's new programming language is goat
19:19:04 <mordred> jeblair: WHY IS THAT NOT A LANGUAGE?????
19:19:08 * fungi assumed this was just an "at" replacement written in go
19:19:09 <anteaya> it will show up everywhere
19:19:10 <taron> I was about to ask the same thing
19:19:12 <anteaya> eat the flowers
19:19:20 <anteaya> be in the neighbour's yard
19:19:26 <jeblair> #info voting on https://review.openstack.org/188574 open until 2015-06-11 19:00 UTC
19:19:41 <mordred> anteaya: eat the neighbour's yard
19:19:42 <jeblair> that was fun!
19:19:45 <jeblair> #topic Schedule Project Renames
19:19:46 <mordred> jeblair: whee!
19:19:47 <anteaya> mordred: that too
19:20:09 <jeblair> i think we mumbled something about doing this on friday as we were ejected from the room last week
19:20:20 <fungi> we have entirely too many of these
19:20:27 <fungi> but i agree friday would work for me
19:20:27 <jeblair> we have a metric boatload
19:20:32 <anteaya> well this friday worked better for me and fungi than last friday
19:20:32 <mordred> yah. and I still haven't tested the playlist :(
19:20:38 <mordred> playbook
19:20:39 <mordred> whatever
19:20:39 <pleia2> I think the puppet openstack stuff needs to move too, and it's not yet on the list
19:20:47 <crinkle> EmilienM: ^
19:20:48 <mordred> yah. I beleive I saw a patch for that
19:20:48 <anteaya> playbill
19:20:48 <nibalizer> mordred: lets spin up a spotify playlist for these ops
19:20:55 <jeblair> mordred: do you think you might have something for us by then?
19:20:57 <fungi> i wonder where we could get a metric boat for these
19:21:14 <jeblair> mordred: or should we proceed as we have in the past?
19:21:21 <anteaya> fungi: not the states
19:21:24 <jeblair> mordred: and will you be around?
19:21:29 <mordred> jeblair: I mean, let's plan to proceed as we have in the past - but I'l also try to have something for us
19:21:30 <pleia2> I'm out on friday for family medical thing, but you can go on without me
19:21:33 <mordred> jeblair: I will be in berlin
19:21:38 <mordred> jeblair: I do not know if that counts as around
19:21:59 <ttx> jeblair: adding to my review queue
19:22:07 <fungi> mordred: i'm happy to put together yet another cut-n-paste batch for this round if the playbook is not ready for prime time
19:22:27 <anteaya> well this friday looks like just fungi and jeblair (you good for friday?) for roots
19:22:33 <anteaya> and a huge list
19:22:43 <mordred> I mean, I'll be around if we can do it earlier in the day
19:22:44 <anteaya> pleia2: is next friday better for you?
19:22:56 <mordred> if we do it later in the day, I'll be, you know, drunk - but could still be around
19:23:23 <pleia2> anteaya: yeah, I'll be around
19:23:33 <anteaya> pleia2: so the 19th is better for you?
19:23:38 <anteaya> mordred: the 19th?
19:23:58 <anteaya> I'm around on the 19th but not root so kind of useless
19:24:04 <jeblair> we normally do it around 2200 utc
19:24:13 <jeblair> mordred: what time would be best for you this friday?
19:24:24 <fungi> either of the next two fridays are wide open for me. i'll just be here fixing (or breaking) things
19:24:31 <mordred> anteaya: I will be around on the 19th
19:24:36 <jeblair> (i think 2200 utc counts as vaguely "late" in berlin)
19:24:44 <mordred> jeblair: I mean, I don't have a lot on my calendar for friday
19:24:48 <mordred> so I have no idea
19:25:04 <jeblair> i will be sprinting on friday the 19th
19:25:16 <mordred> problem is - the times that would be good for me are times when it's bad to have an outage
19:25:19 <jeblair> (project-team guide virtual sprint)
19:25:20 <anteaya> oh yeah, the sprint
19:25:26 <mordred> ahyes
19:25:47 <anteaya> okay well if it is just jeblair and fungi this friday I'm around to do what I can to help
19:25:48 <jeblair> i mean, we might decide to call it quits by 2200 on the 19th anyway
19:25:55 <ttx> jeblair: I plan to start doing things on the Thursday fwiw
19:26:34 <fungi> i think we've gotten the project renames sufficiently streamlined that we can manage it with just two people in a reasonable amount of time
19:26:39 <jeblair> fungi: yup
19:26:44 <ttx> but yeah, I definitely won't be around anymore at 2200 utc
19:26:50 <jeblair> ttx: good plan :)
19:27:18 <jeblair> let's go ahead and do this friday, the 12th, at 2200 and we'll see what happens with mordred and his playbook
19:27:31 <mordred> sounds like a children's book
19:27:31 <jeblair> (i think we would love for either or both to show up, as they are able)
19:27:44 <anteaya> mordred: like where the wild things are
19:27:53 <jeblair> fungi: sound good ^ ?
19:28:12 <fungi> wfm
19:28:18 <jeblair> #agreed project renames friday june 12 at 2200 utc
19:28:32 <jeblair> i'll send the announcement
19:28:34 <pleia2> I'll try to pop in if my husband is recovering ok, but no promises :)
19:28:42 <anteaya> pleia2: thanks
19:28:48 <jeblair> #action jeblair send announcement for project renames friday june 12 at 2200 utc
19:28:50 <anteaya> pleia2: hope things go well for him
19:28:58 <pleia2> anteaya: thanks
19:29:19 <jeblair> #topic Priority Efforts (Downstream Puppet)
19:29:48 <asselin> hi, I sent an e-mail about the proposed virtual sprint for common-ci
19:30:01 <yolanda> i started work on nodepool.conf either on puppet module, and in nodepool itself
19:30:03 <jeblair> #info Virtual Sprint scheduled: Wednesday July 8 1600 UTC Sprint will run for 48 hours
19:30:11 <nibalizer> woot
19:30:12 <jeblair> #link https://wiki.openstack.org/wiki/VirtualSprints#OpenStack_Common-CI_Solution
19:30:15 <asselin> no objections stated, so we should be good witht he date time agreed in the last meeting
19:30:31 <pleia2> turns out I will be around for that (other engagement has been postponed), anteaya you too?
19:30:31 <nibalizer> beaker-rspec tests are comming
19:30:45 <anteaya> pleia2: yes I expect to be available
19:30:49 <nibalizer> they're almost in place for openstackci and then I will fungi them out to all the other modules
19:30:56 <jeblair> nibalizer: which will land first, the spec or the tests? :)
19:30:59 <anteaya> yes do fungi them out
19:31:05 * fungi has just been mordreding, fwiw
19:31:18 <anteaya> fungi: eating the neighbour's yards?
19:31:24 <jeblair> anteaya: drinking
19:31:30 <anteaya> ha ha ha
19:31:31 <nibalizer> jeblair: dunno
19:31:31 * mordred hands fungi a mostly unused implement
19:31:59 <fungi> well, i meant following in the tradition of scripting mass change batches of mostly trivial/repetitive stuff
19:32:05 <nibalizer> we talked a bit with pabelanger and pleia2, testing will focus on infra's use case i.e. ubuntu but our friends who use centos are welcome to add support and testing to the modules for that
19:32:13 <fungi> but drinking too, yes
19:32:27 <cody-somerville> :]
19:32:43 <jeblair> nibalizer: sounds good
19:32:51 <jeblair> tests help make that kind of support viable
19:33:06 <jeblair> (it has not been in the past, we will just instabreak things)
19:33:13 <pabelanger> nibalizer, jeblair Yup, I can help out where ever possible.
19:33:33 <zaro> o/
19:33:52 <nibalizer> thats all I got
19:33:58 <jeblair> cool, thanks
19:34:00 <nibalizer> excited for the sprint
19:34:05 <jeblair> #topic Open discussion
19:34:08 <yolanda> jeblair, saw you unlocked a pair of my changes, cool
19:34:19 <yolanda> i just did a quick rebase but i need to look carefully
19:34:27 <jeblair> yolanda: yeah, the blocking change merged a long time ago, i just missed those, sorry
19:34:44 <yolanda> no problem
19:35:19 <pabelanger> I wanted to know if creating a spec for grafana was worth while.  Outside the CI dashboard spec that is going on now
19:35:50 <asselin> ci dashboard spec might get abandoned....
19:36:00 <pabelanger> since a few people, nibalizer, timrc are doing stuff downstream with it
19:36:10 <pabelanger> asselin, I didn't know that
19:36:32 <timrc> What would the grafana spec include?
19:36:38 <nibalizer> pabelanger: eh, i think getting a grafana up and having it driven by git might be enough
19:36:55 <timrc> One of the things I really want are more data points.  I think we need a spec for data gathering and analysis in general :)
19:37:04 <jeblair> pabelanger: i think with the current scope of "run grafana, use grafyaml to translate static yaml files to grafana configs" probably doesn't need a spec unless you want to.  if it gets any more complicated than that, we probably should.
19:37:04 <anteaya> pabelanger: look at the logs for monday's third party meeting
19:37:11 <asselin> pabelanger, take a look at the latest comments: https://review.openstack.org/#/c/135170/
19:37:17 <anteaya> pabelanger: it provides some context
19:37:26 <pabelanger> timrc, mostly just importing it into -infra, a server that runs it and allows people to setup graph points
19:38:07 <pabelanger> jeblair, Ya, that is what I was mostly asking.  If a spec was required, then I'd do it.  But if we just wanted to stand up a server and run grafyaml, then that is good too
19:38:11 <asselin> an alternative working solution is being proposed. Perhaps the spec will be to just use this: http://ec2-54-67-102-119.us-west-1.compute.amazonaws.com:5000/?project=openstack%2Fcinder&user=&timeframe=24
19:38:31 <timrc> I'm ambivalent on a spec.  A spec would maybe open the floor for more ideas from other people that maybe haven't listened in on the conversations we've had on #openstack-infra.
19:38:44 <asselin> pabelanger, currently hosted here: https://git.openstack.org/cgit/stackforge/third-party-ci-tools/
19:38:52 <fungi> pabelanger: i think we've been leaning toward specs for any implementation requiring new servers, but stuff running on existing servers without substantial new complexity seems fair game for no spec
19:39:34 <pabelanger> okay, so no spec. I'm cool with that.  I'll focus on the puppet-grafana module this week and ping people for reviews
19:39:47 <pabelanger> while will be timrc and nibalizer :)
19:39:53 <pabelanger> which*
19:40:02 <nibalizer> :P
19:40:05 <timrc> pabelanger, Awesome.  We already have grafana deployed in HP so if you need any assistance there, I'd be happy to help.
19:40:23 <timrc> pabelanger, Also did you solve automating datasources and orgs?
19:40:40 <pabelanger> The only other thing I had was around SteveK's packaging work.  Anybody work local with him, or contact.  I've tried pinging him a few times, but nothing back
19:41:01 <pabelanger> timrc, nothing official yet, that's the last piece for me
19:41:14 <pleia2> pabelanger: he's in .au, so ping in US night are best
19:41:41 <timrc> pabelanger, I'll take this offline... there are some other gotchas I stumbled across when deploying this into HP :)
19:41:48 <pabelanger> pleia2, okay, perhaps a ML post is better.
19:41:50 <pleia2> pabelanger: he also does respond to email, which I resort to sometimes when I don't want to stay late
19:41:59 * pleia2 nods
19:42:03 <pabelanger> was mostly looking for an update from him, to help get the infra packaging going again
19:42:13 <pabelanger> since I have some spare cycles to work on it
19:42:21 <pabelanger> timrc, roger
19:42:30 <pleia2> cool
19:42:52 <pabelanger> That is all from me
19:43:54 <jeblair> anteaya, asselin: whatever comes out of the third-party ci dashboard area, we should have a spec for it; even if it's "run patrick's thing"
19:44:05 <anteaya> jeblair: understood
19:44:14 <asselin> jeblair, ok
19:44:14 <anteaya> asselin: are we able to create that spec yet?
19:44:23 <anteaya> asselin: I can work on it with you if you wish
19:44:35 <asselin> anteaya, ok let's discuss offline
19:44:41 <anteaya> asselin: okay
19:45:26 <jeblair> pabelanger, mordred: is there a packaging spec yet?
19:45:39 <jeblair> ah
19:45:40 <jeblair> https://review.openstack.org/179713
19:45:55 <mordred> yah
19:46:07 <pabelanger> ya
19:46:13 <pabelanger> that is the one I was referring too
19:46:16 <jeblair> ok, so that's where the conversation is
19:46:46 <mordred> I should respond to zigo
19:46:51 <jeblair> anyone have anything els?
19:47:14 <mordred> I think there is a difference between "to bypass distros" and "that need to exist sometimes because of the operational need to have a package that is not currently in the distros"
19:47:25 <mordred> it's a difference of intent
19:47:28 <mordred> not of substance
19:47:35 <jeblair> yeah 'bypass' doesn't really cover that subtlety
19:48:32 <jeblair> okay, we can let the tc get started early!
19:48:36 <jeblair> thanks everyone!
19:48:38 <zaro> mordred: iirc you said you were working on spec for testing gerrit upgrades?
19:50:10 <jeblair> to be continued in infra channel ^
19:50:13 <jeblair> #endmeeting