19:01:16 <jeblair> #startmeeting infra
19:01:16 <openstack> Meeting started Tue Oct  1 19:01:16 2013 UTC and is due to finish in 60 minutes.  The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:19 <openstack> The meeting name has been set to 'infra'
19:01:28 <jeblair> agenda: https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting
19:01:44 <jeblair> last meeting: http://eavesdrop.openstack.org/meetings/infra/2013/infra.2013-09-24-19.00.html
19:01:48 <jeblair> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting
19:01:50 <jeblair> #link http://eavesdrop.openstack.org/meetings/infra/2013/infra.2013-09-24-19.00.html
19:02:09 <jeblair> #topic actions from last meeting
19:02:13 <jeblair> #action jeblair move tarballs.o.o and include 50gb space for heat/trove images
19:02:17 <jeblair> i did not do that
19:02:22 <jeblair> as it turns out, friday was very busy.
19:02:51 <jeblair> i'll try again later when things are a bit calmer.
19:03:53 <jeblair> the other action item we can handle in a different topic
19:04:02 <jeblair> #topic Trove testing (mordred, hub_cap)
19:04:15 <jeblair> mordred: you were going to understand and explain the mysterious caching issue with the heat/trove test plan
19:04:44 <hub_cap> heyo
19:04:48 <jeblair> mordred: what's the latest there? and what is trove testing blocked on?
19:04:52 <mordred> o/
19:04:54 <mordred> sorry I'm late
19:05:16 <mordred> jeblair: I have not achieved my task. I still need to understand and explain the mysterious caching issue
19:05:19 <mordred> lifeless: around?
19:05:34 <hub_cap> jeblair: i have achieved my task of waiting
19:05:46 <pleia2> mordred: he's running the tripleo meeting
19:06:00 <mordred> ah. wow. what a poorly timed meeting overlap
19:06:03 <mordred> :)
19:06:14 <mordred> jeblair: I will raise sorting that on my tdl
19:06:53 <lifeless> mordred: in the tripleo meeting
19:07:13 <fungi> clearly a popular meeting time
19:07:14 <jeblair> mordred: is it true that we can't or should not proceed with anything in https://etherpad.openstack.org/testing-heat-trove-with-dib until you understand this issue?
19:07:18 <lifeless> mordred: it's not mysterious, we want to cache further along than just 'we downloaded stuff'
19:08:56 <mordred> lifeless: the details are a thing we want to dig more in to - because dib is not going to make use of pre-downloaded base images in the way that we would pre-download them right now
19:09:33 <mordred> lifeless: I believe there is a dib task identified to be able to be pointed at a locally downloaded pre-cached base image
19:10:12 <mordred> jeblair: if we proceed without the sorting thing, each build job will download a base image from canonical and redhat directly
19:10:18 <mordred> without sorting the caching thing
19:10:23 <lifeless> depending on what you mean we either already have that
19:10:28 <lifeless> or there is no task identified.
19:10:37 <mordred> you did the work we talked about in Seattle already?
19:11:08 <lifeless> there may be confusion
19:11:17 <mordred> great. we will convene to sort it out
19:11:21 <jeblair> mordred: when?
19:11:26 <mordred> when we can do it with higherbandwidth
19:11:33 <mordred> jeblair: how about right after tripleo and infra stop meeting
19:11:37 <mordred> lifeless: ?
19:12:22 * mordred assumes silence to be assent
19:12:34 <lifeless> mordred: I have the OSRB then
19:12:38 <lifeless> mordred: but today, certainly.
19:12:42 <mordred> ok
19:12:54 <mordred> jeblair: we will sort that out today
19:12:57 <jeblair> #action mordred understand and explain the mysterious caching issue with the heat/trove test plan
19:13:16 <jeblair> hub_cap: any further thoughts?
19:14:16 <jeblair> #topic Tripleo testing (mordred, clarkb, lifeless)
19:14:55 <jeblair> mordred, lifeless: any progress on plan C?
19:15:25 <jeblair> or otherwise anything we should chat about?
19:15:52 <mordred> jeblair: nothing really to chat about - plans are underway to get plan C moving
19:16:00 <lifeless> jeblair: your thoughts on the tripleo mail I sent yesterday would be appreciated
19:16:11 <lifeless> jeblair: from a 'implications to the openstack project' perspective
19:16:28 <mordred> jeblair: also, lifeless sent an email yesterday to openstack-dev outlining a plan around plan c related things
19:16:29 <hub_cap> jeblair: nosir
19:16:51 <lifeless> jeblair: tl;dr we're proposing a group of people running a production cloud deployed tripleo style, per commit, with atc's getting credentials
19:17:04 <lifeless> jeblair: and the use of kanban to manage wip and changes to that environment
19:17:32 <lifeless> jeblair: (the tie-in to plan C is that this is common infrastructure to the proposed cloud-test setup
19:20:43 <fungi> having a non-proprietary kanban would be high up the list of preferences, i think
19:21:09 * fungi is not a huge fan of trello for this, but i guess it's a stopgap
19:22:16 <fungi> perhaps that's something which would eventually meld well with storyboard
19:22:26 <mordred> yah. lifeless and I had a chat about that where I expressed concerns about trello - he said (and says at the bottom of the  email in the footnote) the idea with the kanban is to experiment to see if it's worth pursing in an infra way and with infra
19:22:38 <mordred> before asking infra to provide a thing which may actually not be something that's helpful
19:22:54 <jeblair_> we should be careful with that
19:23:09 <mordred> and yes, I agree -might give good feedback on storyboard features
19:23:13 <mordred> jeblair_: I could not possibly agree more
19:23:39 <jeblair_> we've asked projects to stop using trello and similar services before because tool proliferation is not helpful to a unified project
19:23:43 <jeblair_> but experimentation is important
19:23:52 <jeblair_> we're probably on the same page.  just reiterating.
19:23:58 <mordred> ++
19:24:28 <fungi> slippery slope
19:24:46 <SergeyLukjanov> unified project template w/ all tools like kanbans and etc. is a dream for all new projects
19:24:48 <mordred> I think it's clear that trello is a non-starter long term
19:24:54 <SergeyLukjanov> and not for only new
19:25:07 <lifeless> so, for the record
19:25:35 <lifeless> the existing tools in the openstack suite are a poor fit for visualising wip and operational status
19:25:47 <lifeless> we don't /like/ trello
19:26:03 <lifeless> and will be delighted, if the experiment concludes with 'yes, kanban solves the issues we're trying to solve'
19:26:13 <lifeless> to work closely with infra to get an openstack-suitable kanban in place.
19:26:19 <fungi> no argument from me, i understand it's a pragmatic choice for the moment
19:27:03 <jeblair> so to bring this back on topic; how does this interact with the tripleo test plan?
19:27:06 <jeblair> lifeless, mordred: ?
19:27:25 <lifeless> the tripleo test plan has a big handwave of 'tripleo will provide a cloud'
19:27:26 <mordred> jeblair: the cloud they are planing to spin up is part of the first steps of plan c
19:27:29 <lifeless> this is an enabler for that
19:27:50 <lifeless> we don't need anything from infra at this point, but wanted you to be aware of how we're structuring things
19:29:27 <jeblair> lifeless: makes sense.  i like the general direction of open ops.
19:30:04 <jeblair> anything else on this topic?
19:30:07 <lifeless> jeblair: and *if* you have concerns about e.g. reliability of the test results etc from the open ops setup, we'd rather know sooner than later
19:30:25 <lifeless> jeblair: the other aspect is once we're a bit more mature
19:30:35 <lifeless> we'll have an OpenStack cloud infra can use if they want.
19:30:57 <lifeless> We will let you know when it's reliable enough that you wouldn't be crazy to put stuff in it.
19:31:25 <jeblair> lifeless: that would be great.  we're, uh, happy to help drive load.  :)
19:32:44 <mordred> we are a lean-mean-load-generating-machine
19:33:01 <fungi> more mean than lean
19:33:02 <jeblair> emphasis on mean
19:33:06 <fungi> heh
19:33:14 <jeblair> #topic Savanna migration from stackforge to openstack org
19:33:15 * mordred is getting pudgy
19:33:23 <jeblair> SergeyLukjanov: hi there
19:33:27 <SergeyLukjanov> hi
19:33:44 <SergeyLukjanov> I've prepared https://review.openstack.org/#/c/48491/
19:33:51 <jeblair> #link https://review.openstack.org/#/c/48491/
19:34:05 * ttx breaks for 13 min
19:34:50 <jeblair> so we just need to schedule a downtime for the gerrit renaming
19:35:38 * mordred is in north carolina this weekend at a wedding
19:35:52 <fungi> my event coordinator says i'm free all weekend
19:36:14 <jeblair> i think i should be available sat/sun morning
19:36:22 <mordred> I _may_ be able to help on Saturday, but don't really know specific schedule. I'll certainly help if I'm not off being weddinged
19:36:25 <SergeyLukjanov> it'll be good for us (savanna team) to do it this weekend
19:36:40 <jeblair> we're in the middle of the rc window...
19:36:54 <jeblair> but based on last weekends load, i think we can handle having a bit of weekend downtime
19:37:03 <mordred> yah. most of last weekend was me
19:37:11 <mordred> trying to get wheels working
19:37:43 <anteaya> and versioning
19:38:00 <SergeyLukjanov> could I help with smth from my side?
19:38:27 <fungi> SergeyLukjanov: your change wraps puppet-savanna in with the rest of the work... is that part of the savanna project or part of the openstack-puppet group's work on stackforge?
19:39:00 <SergeyLukjanov> fungi, we're working on puppet manifests for savanna and I hope that we'll publish them soon
19:39:03 <jeblair> so how about saturday 'morning'?  oct 5 1600 utc?
19:39:17 * mordred believes puppet-savanna should stay in stackforge - we don't have any precedence in the project for chef or puppet things being considered core project code
19:39:18 <fungi> jeblair: wfm
19:39:22 <SergeyLukjanov> it's not a part of openstack-puppet group
19:39:54 <SergeyLukjanov> mordred, good point, I'll move it back
19:40:11 <mordred> SergeyLukjanov: thanks! (obviously, you can keep savanna-core having core on it if that makes sense for you guys)
19:40:26 <SergeyLukjanov> jeblair, wfm too
19:40:29 <jeblair> SergeyLukjanov: sounds good.  i think puppet or chef deliverables would be a scope expansion for the tc to consider
19:40:51 <jeblair> SergeyLukjanov: cool, it'll be good to have you around to help make sure everything works after the move
19:40:57 <lifeless> wait, puppet or chef?
19:41:08 <SergeyLukjanov> jeblair, it's just puppet manifests for savanna installation
19:41:26 <lifeless> SergeyLukjanov: I thought savanna used disk-image-builder?
19:41:38 <mordred> yah. but we've deliberately kept those non-openstack so far
19:41:49 <mordred> lifeless: I believe he means to deploy savanna, not for use by savanna
19:41:59 <lifeless> mordred: that would be heat then
19:42:09 <SergeyLukjanov> lifeless, yep
19:42:30 <SergeyLukjanov> we're using dib to build images used by savanna
19:42:31 <fungi> yeah, puppet-savanna seems like something which could also benefit from closer work with the stackforge/puppet-.* devs long term, for added ecosystem consistency
19:42:35 <SergeyLukjanov> and puppet to install savanna
19:42:46 <mordred> fungi: ++
19:42:55 <mordred> SergeyLukjanov: makes sense to me
19:42:59 <SergeyLukjanov> I think it's ok to keep puppet-savanna in stackforge for now
19:43:05 <SergeyLukjanov> bye it's empty now
19:43:09 <SergeyLukjanov> btw*
19:43:09 <mordred> :)
19:43:12 <fungi> heh
19:43:52 <SergeyLukjanov> we already have worked manifest but it depends on some mirantis internal stuff
19:44:01 <jeblair> #action jeblair announce gerrit downtime oct 5 1600 utc for savanna rename
19:44:11 <SergeyLukjanov> I have a question about docs
19:44:19 <jeblair> fungi, mordred: can you think of any other maint we should do during then?
19:44:22 <SergeyLukjanov> is it ok to publish them to docs.o.o?
19:44:24 <mordred> annegentle_ loves docs questions
19:44:42 <annegentle_> I do!!!
19:44:47 <mordred> I believe so - I think we've been publishing incubated tocs to doc.o.o so far yeah?
19:44:49 <fungi> jeblair: none springs to mind. maybe things will come up between now and then we can glom onto it
19:44:53 <jeblair> mordred: i think so
19:45:06 <mordred> jeblair: unless we want to move melange to stackforge, no
19:45:10 <SergeyLukjanov> (I've added it due to the marconi config)
19:45:41 <mordred> (and delete openstack-dev/openstack-qa which is a dead fish)
19:45:42 <annegentle_> SergeyLukjanov: In the past we've published to docs.o.org/incubation but it's kind of a case-by-case
19:45:45 <mordred> but I don't care about either really
19:46:29 <jeblair> annegentle_: for developer docs too?
19:46:43 <fungi> mordred: we can probably do those two additional things without needing to announce them, if we feel like it
19:46:45 <jeblair> annegentle_: (eg, project docs rather than manuals)
19:46:51 <annegentle_> jeblair: nah we haven't had it come up for project docs/ dev docs
19:47:02 <SergeyLukjanov> I mean dev docs
19:47:14 <annegentle_> jeblair: it was for API specs, user info, deployer info, and we've grown SO much since, I say we should probably come up with a set of guidelines
19:47:38 <jeblair> annegentle_: i love guidelines.  ESPECIALLY published guidelines.  :)
19:47:44 <annegentle_> jeblair: I'm not super comfortable with incubated projects getting an openstack.org domain, if I'm honest
19:47:50 <annegentle_> jeblair: it feels like getting to use the brand
19:48:26 <SergeyLukjanov> review.o.o and git.o.o are the same way for using brand)
19:48:44 <jeblair> annegentle_: i know, though they are projects that have been accepted into a program by the tc, which is why we have been putting them in the openstack github org
19:48:56 <fungi> on the other hand it's unfortunate if we don't have any way to publish their documentation during incubation, other than to tell them to use rtfd or something
19:49:01 <annegentle_> jeblair: oh well if that's the case, they're not incubating
19:49:08 <annegentle_> jeblair: they're integrated
19:49:20 <annegentle_> jeblair: sorry need more context :)
19:49:28 <annegentle_> fungi: I'm fine with rtfd
19:49:34 <mordred> annegentle_: nope. ingerated means they're part of the release - incubated means they get to be a thing we as a project are actually working on
19:49:40 <mordred> but... it's possible ...
19:49:54 <mordred> that the infra meeting is the wrong place to dig in to integrated/incubated branding semantics
19:50:04 <annegentle_> mordred: I know that, what's SergeyLukjanov's project that we're talking about?
19:50:07 <mordred> (other than the fact that all of us like talking about things)
19:50:10 <mordred> annegentle_: savanna
19:50:23 <mordred> annegentle_: recently voted in as incubated and we're scheduling the move to the openstack/ git org
19:51:02 <annegentle_> mordred: Incubating -- my outline for docs would be quite conserving of resources
19:51:40 <annegentle_> mordred: wiki and rtfd likely but would entertain other ideas
19:51:44 <mordred> annegentle_: yah. I would not expect incubated projets to be covered by the docs team. you guys are busy enough as it is
19:51:53 <annegentle_> mordred: we don't even cover integrated that well
19:52:04 <jeblair> but that's separate from whether they are permitted to publish their own docs to docs.o.o....
19:52:07 <mordred> but I think the question here is about docs.openstack.org/developer
19:52:16 <mordred> to push the in-tree sphinx docs
19:52:20 <SergeyLukjanov> mordred, yep
19:52:29 <mordred> http://docs.openstack.org/developer/ironic/
19:52:32 <mordred> for instance
19:52:53 <mordred> if that's not ok, we should probably circle back and make a plan
19:53:30 <jeblair> based on past practice, other currently incubated projects, the way that the git repos are organized, and i think the spirit of the incubation process, we should continue to let incubated projects publish to docs.o.o/developer....
19:53:54 <clarkb> ++
19:53:56 <SergeyLukjanov> jeblair, it looks consistent I think
19:54:06 <jeblair> (by spirit of incubation process, i believe the common understanding is that the incubation period is when a project is expected to bring themselves inline with how openstack projects operate)
19:54:08 <mordred> clarkb: you're alive!
19:54:17 <clarkb> barely
19:54:44 <clarkb> lunch happened. is now over
19:55:36 <annegentle_> mordred: I'm thinking /developer/ironic got in by us just saying 'don't publish to rtfd and docs.o.o"?
19:55:41 <annegentle_> mordred: do I remember it wrong?
19:55:59 <annegentle_> jeblair: good point
19:56:46 <annegentle_> and honestly I can't argue long or hard on a hard line for docs.o.org/developer -- the jobs and content aren't maintained by docs team but there are still perceptions about docs
19:57:21 <annegentle_> so it feels like a slippery slope
19:57:48 <mordred> annegentle_: I have almost no memory of anything - and I don't like slippery slopes
19:57:56 <annegentle_> mordred: heh. me too
19:58:10 <fungi> the alternative risk, also a slippery slope, is that we wind up with other places the project publishes documentation not covered by the docs team
19:58:32 <jeblair> i'd hate to think we're making it harder for projects to integrate, right as we're pushing them to be more proative in integrating before they become incubated
19:58:44 <dhellmann> can we move them to developer.openstack.org so they aren't associated with the docs team?
19:58:47 <jeblair> before they become integrated, rather.
19:59:10 <annegentle_> dhellmann: might be useful but we get doc bugs on the wiki so who knows :)
19:59:23 <dhellmann> annegentle_: welcome to the internet? ;-)
19:59:30 <annegentle_> dhellmann: and, I'd kinda like to have that domain for devs building cool stuff on openstack
19:59:38 <annegentle_> dhellmann: not developing openstack itself?
19:59:40 <annegentle_> dhellmann: but yeah
19:59:45 <fungi> well, i think all projects get more than their share of miscategorized bugs, so that's probably not something we'll be able to put a stop to regardles
19:59:47 <fungi> s
19:59:49 <dhellmann> sure, that was just a suggested domain, there could be another
19:59:56 <dhellmann> fungi: +1
19:59:56 <annegentle_> dhellmann: ok sure
20:00:03 <mordred> what about annegentle.openstack.org ?
20:00:04 * mordred ducks
20:00:08 <annegentle_> mordred: ha
20:00:09 <dhellmann> haha
20:00:21 <annegentle_> how about a gated garden like facebook or google+ (facepalm)
20:00:22 <jeblair> on that note
20:00:26 <jeblair> #endmeeting