19:03:02 <jeblair> #startmeeting infra
19:03:03 <openstack> Meeting started Tue Jul  2 19:03:02 2013 UTC.  The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:03:06 <openstack> The meeting name has been set to 'infra'
19:03:12 <jeblair> last meeting:
19:03:14 <jeblair> #link http://eavesdrop.openstack.org/meetings/infra/2013/infra.2013-06-25-19.01.html
19:03:19 <jeblair> agenda:
19:03:22 <jeblair> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:03:45 <jeblair> #topic Rename of the project formerly known as mutnuaq
19:04:05 <jeblair> #link https://wiki.openstack.org/wiki/Network/neutron-renaming
19:04:31 <jeblair> markmcclain started an email thread with a few folks with a proposal for an alternate process
19:04:52 <jeblair> mordred and i batted that around a bit and come up with a revision of that
19:05:12 <jeblair> markmcclain: does the latest revision there look good?  should we add it to the wiki page?
19:05:48 <markmcclain> I've going to more to the page
19:06:30 <markmcclain> it's the plan we kicked around with a little more info and links to the (pending) reviews in the task list
19:06:57 <jeblair> here's what i sent (for folks not on the email thread): https://etherpad.openstack.org/vM4mUupvWl
19:07:31 <jeblair> markmcclain: cool.  should we go ahead and branch quantumclient?
19:08:13 <markmcclain> not quiet yet.. I can ping you when it's ready
19:08:35 <jeblair> markmcclain: ok.  of course we can just branch at any time from whatever sha, so timing isn't critical.
19:08:35 <ttx> yes, moving the latest plan to the page would be a good idea
19:08:57 <jeblair> #action markmcclain update wiki page with latest repo move plan and links to changes
19:08:59 <ttx> been receiving a few questions about it already
19:10:05 <ttx> markmcclain: quantum-core LP team can't be renamed yet because you have a mailing-list on it
19:10:16 <jeblair> yeah, i would have added it earlier, but didn't get a lot of feedback via email, so didn't want to jump the gun on publishing it to the wiki
19:10:16 <clarkb> jeblair: the quantumclient branch is there purely to provide a backward compatible code location?
19:10:19 <ttx> markmcclain: you still using that ?
19:10:35 <markmcclain> ttx: ok.. that shoud be easy to address
19:10:43 <markmcclain> you and I coordinate on it
19:11:07 <jeblair> clarkb: yeah, it's there to receive a future change in step 6 that adds compat shims, etc, and we will manually publish a final quantumclient package from that branch
19:11:32 <jeblair> clarkb: meanwhile, master will become neutronclient
19:12:27 <ttx> markmcclain: I think the only way is to remove it completely
19:12:38 <ttx> markmcclain: LP MLs are hard beasts to kill
19:13:02 <clarkb> ttx: markmcclain we could create a new list on lists.o.o and push everyone that direction
19:13:27 <ttx> clarkb: or just drop the elite list
19:13:42 <clarkb> or that
19:14:01 <markmcclain> I think we can kill the LP list
19:14:28 <ttx> then I'll just remove quantum-core. The group is maintained on gerrit anyway
19:14:50 <jeblair> #action ttx remove quantum-core lp team
19:15:19 <jeblair> anything else about the neutron rename?
19:15:51 <jeblair> #action jeblair propose neutron repo rename changes
19:16:13 <jeblair> (to the infra/config repo)
19:16:38 <jeblair> markmcclain: thanks for stopping by!
19:16:49 <jeblair> #topic Asterisk
19:17:04 <jeblair> i started a ml thread
19:17:27 <fungi> i saw. it's generated useful discussion i think
19:17:27 <markmcclain> jeblair: happy to
19:17:46 <jeblair> my reading is that we should probably run asterisk 11 on centos
19:17:54 <jeblair> did anyone else get something else out of that?
19:17:59 <fungi> that is what i got from it
19:18:12 <clarkb> ++, though pabelanger's puppet will need cleaning to support that
19:18:43 <fungi> since we've already got centos going in for cgit, it won't be the first non-jenkins-slave centos server choice for us
19:18:50 <pleia2> yeah
19:19:02 <jeblair> yep, we are sliding down that slope.  and fast.
19:19:07 <fungi> so seems an entirely reasonable solution to the issue
19:19:23 <dhellmann> which ML is that thread on?
19:19:30 <jeblair> dhellmann: openstack-infra
19:19:38 <jeblair> @lists.openstack.org
19:19:43 <dhellmann> aha, ok
19:19:46 <fungi> the alternative was apparently debian, once 11 is cleaned up enough for them to accept it. ubuntu's packages have apparently slipped out of regular maintenance
19:20:16 <jeblair> (which i find personally distressing)
19:20:20 <fungi> yeah
19:21:13 <jeblair> #link http://lists.openstack.org/pipermail/openstack-infra/2013-July/000115.html
19:21:15 <jeblair> dhellmann: ^
19:21:22 <dhellmann> ty
19:21:31 * dhellmann was told that mailing list wasn't used ;-)
19:21:35 <jeblair> so i'll follow up to that thread
19:21:48 <fungi> dhellmann: you should flog whoever told you that
19:22:08 <fungi> it's just nicely low-volume
19:22:09 <dhellmann> heh
19:22:17 <dhellmann> np, I just hadn't bothered signing up yet
19:23:02 <jeblair> #topic Need of MongoDB >= 2.1 for Ceilometer (jd__, fungi)
19:23:26 <jeblair> fungi: ?
19:23:27 <fungi> jd__ wanted to talk about options for a newer mongodb on ubuntu precise
19:23:32 <jd__> o/
19:23:43 <fungi> apparently the one there is well behind the one on centos 6
19:23:51 <jd__> I'm building patches using MongoDB >= 2.1 for Ceilometer
19:24:00 <jd__> yep, CentOS has 2.2 and Precise 2.0
19:24:09 <fungi> zul suggested ubuntu might be able to carry a raring backport to precise in the cloud archive
19:24:10 <jeblair> fascinating
19:24:10 <clarkb> it sounded like there are vendor packages and zul could potentially add them to cloud archive?
19:24:30 <fungi> and yes, 10gen supposedly also has some debs we could use instead
19:24:34 <jd__> zul could do backport from 2.2 or 2.4 I imagine, which are in raring
19:25:10 <fungi> we just wanted to get a broader consensus on what would be doable/preferable
19:25:15 <jeblair> i think cloud archive sounds like the way to go... part of what we want to uncover by setting the supported testing platforms the way we did is breakage on different os platforms
19:25:23 <clarkb> ++
19:25:38 <fungi> another fallback alternative was to only test mongodb under python 2.6, which would ensure it happens exclusively on centos
19:25:56 <jeblair> so if openstack is going to require (or even optional-require, which i think is the case here), we should try to stick to the base os as much as possible
19:25:56 <fungi> but yes, that misses the different platforms thing
19:26:49 <jd__> so best thing to do is like pinging zul to get things moving into Ubuntu I guess?
19:27:06 <mordred> o/
19:27:16 <jeblair> jd__: yeah, i think that's the best way to go.
19:27:19 <fungi> i think we also need to resurrect the old task/patch to add cloud archive on our precise slaves, yeah?
19:27:25 <clarkb> jd__: sounds like it. Then once the new packages are in the cloud archive we can make sure those packages end up on the slaves
19:27:45 <jd__> sounds like a good plan to me
19:27:50 <jeblair> fungi: yeah, if we didn't merge that.
19:27:56 <fungi> we abandoned the attempt back when we wanted to use quantal, then we decided we didn't want to use quantal
19:28:06 <jeblair> mordred: any thoughts on this subject?
19:28:08 <fungi> pretty sure it was never revisited at that point
19:28:12 <mordred> reading scrollback
19:28:34 <jeblair> mordred: since you o/'d...
19:28:44 <mordred> oh, I was just indicating that I was now online and here
19:28:58 <mordred> but I think we should ping zul about cloud-archive
19:29:10 <jeblair> cool
19:29:21 <jeblair> #topic open discussion
19:29:31 <jeblair> thanks to everyone who came to the bootcamp
19:29:35 <mordred> +1000
19:29:48 <pleia2> it was great :)
19:29:51 <anteaya> thanks for having it
19:29:52 <dprince> thanks mordred for going to all the trouble.
19:29:58 <anteaya> +1
19:30:05 <clarkb> indeed
19:30:29 <fungi> yes, i'm thrilled it went so well
19:31:38 <clarkb> I suppose it is worth mentioning that Thursday is a US holiday so it will be quiet around here for many of us
19:31:49 <jeblair> yes, i'll be afk
19:32:01 <fungi> oh! right, i'll be incommunicado for a good chunk of tomorrow (flying to tampa)
19:32:06 <dhellmann> yeah, I got a lot out of it, so thanks for organizing and hosting us!
19:32:10 <clarkb> me too, Thurday and Friday I will be mostly AFK. But back for Saturday fun
19:32:32 <fungi> yes, i've cleared at least a couple hours saturday starting at 1600z
19:32:43 <fungi> i'll hack from the hotel as needed
19:32:59 <jeblair> maybe we could swap in a new zuul on saturday too
19:33:10 <clarkb> ooh
19:33:12 <fungi> i'm game
19:33:22 <jeblair> perhaps even one that reloads its configuration instantly
19:33:31 <clarkb> that would be so shiny
19:33:38 <fungi> reloads its configuration before you even knew you wanted to update it
19:33:53 <ttx> and finds acceptable new name all by itself
19:34:30 <jeblair> ttx: hehe, i wonder if we could make a gate check for project names... :)
19:34:49 <ttx> make them googleflight and choose the looser.
19:34:53 <ttx> fight*
19:35:05 <fungi> and then we could name that gozer
19:35:16 * fungi ducks
19:35:25 <pleia2> :)
19:35:54 <jeblair> huh.  duckduckgo has a really cool api.
19:37:24 <jeblair> anything else, or shall we call this meeting done?
19:37:50 <clarkb> I don't have anything. Been trying to get through lots of code review so not much new
19:38:03 <pleia2> I don't have any updates
19:38:09 <jeblair> clarkb: yeah, that list got long again
19:38:27 <fungi> yep, lots to review
19:38:48 <fungi> i keep getting nose-down in other stuff and then look up and it's a mile long
19:39:55 <jeblair> thanks everyone!
19:39:57 <jeblair> #endmeeting