19:02:44 <jeblair> #startmeeting infra
19:02:45 <openstack> Meeting started Tue May 28 19:02:44 2013 UTC.  The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:48 <openstack> The meeting name has been set to 'infra'
19:03:06 <jeblair> #topic agenda
19:03:17 <jeblair> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting
19:03:27 <jeblair> #topic testr in project progress
19:03:39 <jeblair> clarkb: how's it goin?
19:04:17 <clarkb> not much new to report since the last meeting
19:04:39 <mordred> poo
19:04:44 <clarkb> I think most of the remaining projects are targetting H-2 for testr'ing and H-1 things are taking a front seat right now
19:04:58 <mordred> I migrated a few more folkses I thought
19:05:09 <mordred> or at least submitted patches
19:05:31 <clarkb> I think patches are floating around but no merges yet
19:05:37 <clarkb> you and jgriffith started on cinder
19:06:00 <mordred> i believe we finished cinder, no? also, I have testtools up and initial testr up for swift
19:06:15 <mordred> (thank you long boring plane flight)
19:06:53 <clarkb> if you did I missed it. This is a good thing :)
19:07:33 <clarkb> #action clarkb get up to speed on recent testr'ing
19:09:04 <jeblair> #topic What can infra do to enable remote participation at the next Design Summit?
19:09:20 <jeblair> reed: what's going on in this area?
19:09:56 <reed> jeblair, the discussion on the mailing list didn't really give me the feeling that this is something uber-important
19:11:32 <jeblair> reed: are you leaning toward getting some phone lines, or doing ad-hoc irc/etherpad chats?
19:11:43 <reed> I have little interest in setting up something that is voice only, usable basically only for the summits and only for a handful of people
19:12:15 <reed> jeblair, not sure about phone lines, but if that's all we need I can ask to add them to the budget
19:14:58 <jeblair> reed: okay
19:15:03 <jeblair> #topic Mailing lists
19:15:08 <jeblair> reed: this one is yours too
19:15:16 <reed> yeah ...
19:15:37 <reed> rockstar has been working with Launchpad adminstrators to get a pickle from the General list
19:15:55 <reed> he got one but it's 'funny looking' so he needs another one, hopefully it will be delivered today
19:16:22 <mordred> occasionally I love the sentences that we speak around here
19:16:33 <reed> once we get the pickle we will be able to test that indeed it contains the full list of subscribers and configurations from LP into lists.openstack.org
19:16:39 <jeblair> it's hard to pickle correctly, and possibly dangerous if you do it wrong
19:17:19 <reed> once that is tested, we will have to decide how to migrate from one list to another
19:17:32 <reed> and it won't be as simple as switching a DNS
19:17:50 <reed> I think we need a clear cutoff date
19:17:54 <jeblair> since we don't control launchpad, i think we'll have to just set a flag day and make the switch
19:17:58 <reed> and communication
19:18:03 <reed> yep
19:18:14 <reed> and the day of the switch we'll need to get the pickle again
19:18:28 <reed> so we'll have to coordinate with LP admins
19:18:51 <reed> we're keeping notes on https://etherpad.openstack.org/mailmain-migration-notes
19:19:17 <jeblair> #link https://etherpad.openstack.org/mailmain-migration-notes
19:19:45 <reed> #info we'll need to set a date for a cutoff and do the switch between Launchpad and lists.o.o
19:20:10 <jeblair> reed: so we'll wait on rockstar to propose a date based on when he's happy with the pickle
19:20:18 <jeblair> ?
19:20:21 <reed> yes
19:20:47 <reed> #info we'll wait on rockstar to propose a date based on when he's done testing the migration between LP and lists.o.o
19:20:54 <jeblair> okay, that all sounds good
19:22:11 <jeblair> what should we do to the LP list on cutover?
19:22:28 <clarkb> the archives will be on lists.o.o at that point? can we just kill it on LP?
19:22:49 <jeblair> yeah, just wondering what "kill" means in this context...
19:23:36 <fungi> we could subscribe the new list to the old one right before the cutover to get anything in flight, and then make membership to the old list require approval for a bit
19:23:37 <reed> we should move the archives too
19:24:13 <reed> fungi, why?
19:24:14 <jeblair> reed: is rockstar working on that?
19:24:32 <jeblair> "
19:24:35 <jeblair> "Deactivating this list will stop it from accepting posted messages. You can reactivate the list later, without having to get administrator approval."
19:24:42 <jeblair> so that's an option in launchpad ^
19:24:48 <reed> jeblair, I'll make sure he does
19:24:52 <fungi> reed: only if we care about messages which are pending delivery to the old list at the time of cutover, i guess
19:24:55 <jeblair> i think we could do that at cutover time
19:25:55 <reed> fungi, I get it now, thanks
19:26:03 <fungi> reed: if messages in people's outbound queues at that moment (keeping in mind that temporary connectivity issues can make that days) are an acceptable loss, then no need
19:26:53 <jeblair> fungi: i think we'd have to create a launchpad user in order to do that
19:27:00 * fungi nods
19:27:09 <jeblair> (whose email addr is the new list addr)
19:27:25 <fungi> it's nontrivial, i agree. the ossg list did that for a while
19:27:38 <fungi> i don't know if it's worth the effort, just putting it out there
19:27:38 <jeblair> i lean toward "acceptable loss"...
19:27:50 <reed> me too, acceptable loss
19:27:52 <jeblair> especially since everyone will need to know about the new list and cutover time anyway
19:28:01 <mordred> acceptable
19:28:05 <fungi> yeah, not worth worrying over in that case
19:28:15 <clarkb> ++
19:28:54 <jeblair> reed: anything else on this topic?
19:28:59 <reed> nope
19:29:15 <jeblair> cool, thanks (and i'm looking forward to the move!)
19:29:21 <reed> me too :)
19:29:24 <jeblair> #topic OpenStack Operations Guide - tooling, licensing, publishing discussion
19:29:42 <jeblair> a few of us chatted with annegentle and folks from oreilly about their atlas system
19:30:28 <jeblair> it sounds like it will probably be used mostly for annegentle, the book authors, and oreilly to collaborate for a limited period during which oreilly will be working on editing the book for publication
19:30:48 <jeblair> and that we're not looking at making it part of a long-term workflow for docs/books at this point
19:31:01 <annegentle> Sounds right jeblair -- if we reach a contract agreement.
19:31:15 <annegentle> Limited use, limited time periods.
19:31:44 <jeblair> so that seems like a great position to be in for an experiment
19:31:51 <annegentle> yay for labs
19:32:04 <mordred> ++
19:32:29 <jeblair> also, as a point of interest, their web editor is built around http://ace.ajax.org/
19:32:54 <jeblair> #link http://ace.ajax.org/
19:33:07 <jeblair> #topic TripleO Testing (TOCI)
19:33:17 <pleia2> so, dprince wrote this to do tripleo testing: https://github.com/toci-dev/toci
19:33:30 <pleia2> which is essentially tripleo's incubator notes.md put into scripts and tweaked a bit to run on its own for testing purposes (cool!)
19:33:51 <pleia2> he currently has it running on a physical box, I've done testing on my own physical boxes last week
19:33:55 <dprince> Not just dprince though. Derek and Lucus chipped in quite a bit too!
19:34:00 <pleia2> hooray :)
19:34:08 <pleia2> so on our side, dprince put together this to get the syntax right on actually adding TOCI to devstack-gate https://review.openstack.org/#/c/29978/
19:34:11 <mordred> yay for collaboration!
19:34:20 <pleia2> however, this ends up being testing "openstack on openstack" on hpcloud, an openstack VM, so I guess that's like... quintuple o
19:34:35 <pleia2> I tested this today, hpcloud VM doesn't have the kvm module, so we can't boot the bootstrap node as-is :(
19:34:47 <pleia2> I even tried anyway to see if it would do something clever, alas, no: http://paste.openstack.org/show/37829/
19:34:50 <clarkb> fwiw that change is ready for merging imo. Just need a good time to batch up the zuul layout changes
19:35:09 <mordred> wow. no kvm module makes me a sad panda
19:35:14 <pleia2> mordred: me too
19:35:19 <dprince> well... if it is only going to fail ATM there is no sense sending it in yet.
19:35:24 <dprince> Would it run on RAX?
19:35:24 <pleia2> dprince: right
19:35:41 <pleia2> I don't know if they're any different in this regrad
19:35:43 <pleia2> regard
19:35:45 <dprince> I mean... we *can* add the KVM module there right?
19:35:54 <pleia2> it's not loadable by default
19:36:05 <pleia2> but I just discovered this about 30 minutes ago, so more investigation is required
19:36:24 * jeblair considers kexecing into a kvm-enabled kernel
19:36:44 <mordred> jeblair is more leet than morganfainberg
19:36:44 <clarkb> would that help? KVM requires cpu things that aren't availabe to VMs iirc
19:36:46 <mordred> gah
19:36:50 <mordred> jeblair is more leet than mordred
19:36:53 <sdague> jeblair: that's not going to work
19:36:54 <dprince> Right. But on next gen RAX I don't think they prevent you from using your own kernel, etc.
19:37:01 <dprince> Just throwing it out there if it helps.
19:37:05 <jeblair> sdague: i'm sure; but it's an amusing thought.  ;)
19:37:08 <sdague> kvm needs access to the processor hardware extensions :)
19:37:12 <clarkb> sdague: yeah
19:37:21 <clarkb> this problem exists with RAX and HPCloud
19:37:22 <dprince> I mean eventually we want bare metal anyway... so got plans for that?
19:37:31 <sdague> which if hp cloud isn't running with nested in the host, then you're done
19:37:36 <pleia2> dprince: well we wanted to do both, starting with virtual
19:37:47 <mordred> do we need kvm? I thought the tripleo stuff would also do qemu?
19:37:47 <pleia2> (we're working out details about who would give us a rack that we can do scary things to)
19:37:51 <sdague> but do you actually need kvm
19:37:54 <mordred> I got a rack offer
19:38:00 <pleia2> mordred: that may be possible, if slow
19:38:06 <jeblair> mordred: do you have a people offer?
19:38:11 <mordred> but we're also working out details of people to deal with it
19:38:13 <mordred> :)
19:38:26 <sdague> pleia2: it would be worth trying it without real kvm to figure out how slow it really is
19:38:36 <pleia2> sdague: yeah, maybe that's my next step
19:38:53 <pleia2> so I'll give it a spin with qemu and keep everyone updated, other suggestions will be welcome :)
19:38:54 <sdague> and not assume it's unworkable until proven so, because my experience is sometimes this stuff surprises you
19:38:57 <jeblair> since we've already lost access to one set of hardware, i'm going to be really cautious about having any openstack gating tests depend on that.
19:39:09 <dprince> Okay. There are a couple ways to go here from my prospective. It would be useful to have this as a feedback loop for upstream tripleO stuff (soonish)
19:39:32 <dprince> So if we think cloud isn't going to work out, with qemu or fancy kvm module loading, or whatever...
19:39:42 <dprince> Then I could 3rd party it up on bare metal.
19:39:52 <dprince> I mean... I *know* how to do that. :)
19:40:04 <jeblair> i agree with sdague we ought to try qemu first
19:40:17 <pleia2> so there was that session we had on baremetal where we talked about what requirements we'd have for baremetal, was that ever written down somewhere? (aside from the etherpad)
19:40:48 <pleia2> like, isolated on network, provide on-site hands, don't ever trust these machines again
19:41:29 <fungi> i don't recall seeing it summarized beyond that etherpad
19:42:50 <clarkb> neither do I
19:43:04 <pleia2> ok, so I'll test w/ qemu and see what we can do on the virtualization side, and also put together some baremetal requirements from that etherpad so we have something to give to people who offer us hardware
19:43:16 <clarkb> ++
19:43:20 <jeblair> pleia2: sounds good
19:43:42 <dprince> pleia2: this may be as simple as passing an alternate --engine to configure-bootstrap-vm.
19:44:01 <pleia2> dprince: yeah, going to test locally and compare speeds, then test on hpcloud
19:44:02 <fungi> if nothing else, seeing how slow it is under nested qemu provides some numbers which allow sizing the bare metal environment
19:44:17 * pleia2 nods
19:44:32 <pleia2> cool, thanks everyone
19:44:57 <jeblair> #topic infra bootcamp
19:45:33 <jeblair> mordred and I have been discussing ways to help new people contribute to openstack-infra
19:46:11 <jeblair> i've started a rework of our documentation to orient it to answer questions like "how do i contribute" and "what are all these tools and what the heck do they do?"
19:46:22 <pleia2> awesome
19:46:58 <mordred> that's going to be super helpful
19:47:09 <fungi> i'm extremely excited
19:47:13 <mordred> I just tried to give an overview of things to a person on friday - it got ... complex ... quickly
19:47:19 <jeblair> mordred has been trying to get companies to dedicate some fte to us...
19:47:30 <mordred> which has actually gotten really good response
19:47:48 <jeblair> so we figured that if we can round up a few potential new contribs
19:48:01 <jeblair> we should try to get them together and have a sort of bootcamp
19:48:09 <clarkb> ++
19:48:20 <jeblair> to help deal with the information overload of becoming a new contrib
19:48:52 <mordred> yes. it will be helpful
19:49:01 <clarkb> are you thinking an inperson hackathon type thing?
19:49:18 <clarkb> or just a this is what we are all doing this week sort of thing?
19:49:27 <mordred> I think both
19:49:30 <pleia2> I've been involved in several onboarding initiatives over in Ubuntu land, so I'm happy to help as I can
19:49:33 <jeblair> we're looking at getting together in NYC june 27-28
19:49:58 * mordred ninja-voted for nyc because he's tired of travel, and also has a show the 26th
19:50:16 <sdague> heh
19:50:20 <jeblair> i'm okay with nyc because it's been a while and i'd like to visit.  :)
19:50:20 * mordred predicts that we'll eat at meatball shop
19:50:38 <sdague> mordred: keep me in the loop on that, because I could probably just hop on a train down for a day regardless
19:50:39 <fungi> i'm okay with nyc because it's not far from me for a change
19:50:48 <mordred> sdague: awesome. we'd love to have you
19:51:19 <dprince> mordred: is this something for a couple of infra guys plus new people... or is this a entire infra team meetup?
19:51:20 <jeblair> yes, and pleia2, we'd love help figuring out how to do this.  :)
19:52:11 <pleia2> (and I can support online or in person - mordred just let me know)
19:52:30 <pleia2> I've done plenty of both
19:54:17 <mordred> dprince: that's a good question. one the one hand, it would be great to have everyone. on the other hand, if the ENTIRE infra team is in a meeting for 2 days, god only knows what will happen to the project :)
19:54:50 <mordred> jeblair: ^^ thoughts?
19:54:59 <jeblair> dprince: i think it's not just for new people -- i mean the focus will be on getting new people up to speed, but i'm anticipating there may be a lot of context and orienting that existing contributors could benefit from
19:55:27 <clarkb> jeblair: ++ especially since as we have grown there has definitely been a lot more partitioning of knowledge
19:55:49 * mordred has yet to grok logstash, for instance
19:55:50 * dprince sounds interesting
19:55:54 <jeblair> so if the topic of 'helping to understand what's going on in openstack-infra and how to contribute' sounds interesting, you should come regardless of how long you've been involved
19:55:55 <clarkb> (which isn't a bad thing, but I think there is a lot that other peopel know and understand that I have very little understanding of)
19:56:22 * olaph can't wait
19:56:23 <jeblair> but i don't think it will be a design-summit/hackathon thing; i think the focus on new contributions is the main thing
19:57:41 <mordred> we should probably make a signup thing or something
19:57:45 <fungi> if some of us show up and get busy fixing things, just plug us into extra projectors and let new/potential contributors see what goes into the sausage
19:57:48 <pleia2> sounds really great \o/
19:57:48 <mordred> so that I can size location and stuff
19:57:56 <jeblair> mordred: yeah that's probably a good idea.
19:57:57 <mordred> fungi: ooh. nice
19:58:05 <pleia2> fungi: yeah, afterall, that's a great way to learn
19:58:18 <fungi> or scare people away, either way...
19:58:27 <pleia2> nah, we do fun things :)
19:58:38 <jeblair> #action mordred make a signup thingy for bootcamp
19:59:02 <zaro> i think basic topics are necessary as well.  if you've never used gerrit & git you'll be behind the 8 ball.
19:59:28 <pleia2> zaro: yeah totally, live Gerrit_Workflow
19:59:36 * fungi agrees... i wonder if upstream university would be a good prereq for people unfamiliar with that stuff?
19:59:57 <jeblair> fungi: oh good idea, maybe we should also suggest some homework before attendance
19:59:59 <fungi> i know they've done some 100% online sessions
20:00:08 <clarkb> or try what the GNOME womens outreach program does and force people to submit a patch beforehand
20:00:18 <jeblair> though we're certainly not above helping people grok gerrit and git.  :)
20:00:32 <jeblair> okay, i think that's time for us... thanks all!
20:00:37 <jeblair> #endmeeting