19:02:16 <jeblair> #startmeeting infra
19:02:17 <openstack> Meeting started Tue Feb 19 19:02:16 2013 UTC.  The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:20 <openstack> The meeting name has been set to 'infra'
19:02:33 <fungi> 'allo!
19:02:36 <jeblair> #link previous meeting: http://eavesdrop.openstack.org/meetings/infra/2013/infra.2013-02-12-19.04.html
19:02:51 <pleia2> o/
19:03:17 <jeblair> #topic wiki upgrade
19:03:20 <jeblair> it happened!
19:03:21 <fungi> we weekend-wiki'd!
19:03:29 <jeblair> i have not heard any complaints
19:03:51 <fungi> there were some concerns expressed in irc about missing table contents
19:04:13 <pleia2> I fixed up a link on our own InfraTeam page today, text links to uploaded images didn't quite work
19:04:14 <jeblair> fungi: do we have links for sample pages with problems?
19:04:15 <fungi> i re-added wikiness to the old-wiki vhost so people could compare and copy
19:04:23 <jeblair> fungi: +1
19:04:46 <jeblair> should we set a sunset for that?  2 weeks?
19:04:50 <fungi> jeblair: we asked for examples but i don't think anyone provided them other than to say "tables"
19:04:58 <fungi> jeblair: sounds good to me
19:05:51 <mordred> o/
19:05:56 <fungi> i'll send a reply to the maintenance announcement mentioning we turned that on and will be turning it off again on some date two weeksish from now
19:05:57 <jeblair> #action fungi disable old-wiki sometime after mar 1
19:06:08 <jeblair> fungi: sounds great
19:06:26 <jeblair> #link https://wiki.openstack.org/wiki/WikiMigration
19:06:37 <fungi> and asking people to follow up with examples of what got missed i guess
19:06:53 <jeblair> i started that page with quick notes on cleaning up common errors
19:07:05 <pleia2> I should probably add this one to that page https://wiki.openstack.org/w/index.php?title=InfraTeam&diff=18149&oldid=16008
19:07:35 <pleia2> the :File: syntax for linked files
19:07:41 <jeblair> pleia2: there was a page that auto-listed broken file links, i guess it didn't include broken _attachment_ links...
19:07:50 * pleia2 nods
19:07:56 <jeblair> pleia2: but maybe there's a similar page with a different name?  might be worth a look
19:08:10 <mordred> oh neat! I don't think I'd need that picture...
19:08:13 <pleia2> yeah, I'll poke around
19:08:24 <fungi> i did work out and fix the broken embedded youtube vids
19:08:47 <fungi> pretty sure i got them all, but added a note to the migration tips page
19:09:09 <fungi> just in case anyone stumbles across more
19:10:06 <jeblair> cool.  any more wiki stuff?
19:10:18 <jeblair> ttx: ping
19:11:32 <jeblair> do we need to discuss bug triage, or is that left over on the agenda from last time?
19:11:55 <fungi> i think that was new, to discuss items which came up during triage
19:12:02 <jeblair> (i'm stalling on the CLA topic because an action item from last meeting was ttx wants to discuss cla)
19:12:06 <jeblair> #topic bug triage
19:12:23 <fungi> in case we needed any input and/or action items coming from any of it
19:12:35 <jeblair> fungi: yes, i think you're right..  mordred updated some bugs i think
19:13:43 <pleia2> I don't think there is anything at the moment
19:13:51 <jeblair> i think that just leaves some questions for pabelanger and the qa folks...
19:14:04 <pleia2> probably a good thing to cycle back to on a regular basis though
19:14:08 <jeblair> so it sounds like things should be _reasonably_ up to date.
19:14:10 <jeblair> pleia2: +1
19:14:23 <fungi> "bugs: we have them. we should fix them"
19:14:35 <jeblair> #topic jenkins slave operating systems
19:14:43 <jeblair> fungi: how's the quantal stuff going?
19:15:14 <fungi> as last week, the static slaves are fine and we have some stackforge guinea-pigging on those with no complaints so far
19:15:24 <mordred> woot
19:15:29 <fungi> jclouds stuff was pending me hearing back from pvo and/or rackspace
19:15:38 <fungi> i've heard nothing, need to pester them again
19:16:00 <jeblair> #action fungi pester rax about jclouds quantal image issues
19:16:05 <fungi> recap on that is, probably busted image metadata for quantal. don't know much beyond that
19:16:16 <fungi> escalated by pvo to their image team
19:16:45 <fungi> that's all i've got on that topic for now
19:16:45 <jeblair> i think i'd like to hold off moving more projects to quantal till we can use jclouds
19:16:52 * fungi agrees
19:17:08 <fungi> i'd like to be able to burst while we transition
19:17:08 <jeblair> #topic IANA OID
19:17:24 <fungi> ooh, did we get one assigned?
19:17:31 <jeblair> so lauren got an email asking if the foundation had registered an OID with IANA
19:17:59 <fungi> this would be primarily for quantum virtual network devices, if memory serves
19:18:04 <jeblair> i am not aware of that...
19:18:10 <jeblair> of that having happened, that is
19:18:21 <clarkb> I haven't heard of it happening
19:18:23 <jeblair> well, i think the iana oid would mostly be used for ldap stuff
19:18:31 <jeblair> this was in the context of keystone development
19:18:56 <jeblair> though ttx mentioned that the idea of getting an OUI for networking had come up
19:19:06 <jeblair> i believe OUI's cost money?  OIDs do not
19:19:16 <fungi> ahh, right, not an ieee oui. my mistake
19:19:41 <jeblair> mordred: do you recall any previous conversations about an IANA OID?
19:20:18 <jeblair> it's not in the list, so.
19:20:24 <mordred> I remember that we had one
19:20:29 <jeblair> oh?
19:20:30 <mordred> I mean, a conversation
19:20:32 <jeblair> oh
19:20:55 <mordred> I think jaypipes might have been involved?
19:21:03 <jeblair> okay, so it sounds like the keystone devs would like one.
19:21:06 <mordred> and/or we might have talked about doing it
19:21:11 <mordred> awesome
19:21:24 <mordred> we should probably track those in some manner :)
19:21:30 <jeblair> probably i should sync up with them, and then register one on behalf of the foundation...?
19:21:33 <jeblair> i'll file a bug
19:21:51 <jeblair> i'm not entirely sure how it would be used...
19:22:00 <fungi> might make sense to have an enterprise oid assigned for custom snmp mibs as well
19:22:10 <jeblair> fungi: yeah, i think it's the same registry
19:22:24 <mordred> can we get a set of them?
19:22:31 <jeblair> generally they are used for private trees within an enterprise
19:22:33 <jeblair> mordred: it's a tree
19:22:37 <mordred> awesome
19:22:41 <jeblair> mordred: so you stick whatever you want under it
19:22:43 <fungi> yeah, carve it up however we want
19:23:12 <jeblair> what i'm not sure is whether it's appropriate to start publishing mibs, or ldap object classes, etc, as part of our products that actually use those...
19:24:39 <jeblair> if so, we may also need to do some bookeeping on our side too
19:24:52 <jeblair> that is, take responsibility for registering values underneath our OID
19:25:11 <jeblair> i mean, that could just start out as a wiki page
19:25:22 <fungi> we'll definitely want someone keeping that from turning into a free-for-all mess anyway
19:25:27 <clarkb> ++
19:26:06 <jeblair> #action jeblair chat with keystone devs about OID PEN, possibly get PEN
19:26:07 <fungi> and yeah, if it's on the wiki, maybe that someone is everyone
19:26:30 <jeblair> #topic askbot
19:27:06 <jeblair> it looks like we're just going to outsource the running of the askbot server to the askbot folks
19:27:20 <jeblair> so i'm going to spin up some servers for them and hand them off
19:27:37 <pleia2> jeblair: great, can you update https://bugs.launchpad.net/openstack-ci/+bug/1082784 ?
19:27:39 <uvirtbot> Launchpad bug 1082784 in openstack-ci "Add ask.openstack.org" [High,Triaged]
19:28:02 <jeblair> i think that's simplest for everyone, and since they're on contract, hopefully they'll just take care of it
19:28:32 <jeblair> i'd like it to be in our public infrastructure, but we didn't seem to be overrun with new volunteers begging to sysadmin the service.
19:28:59 <fungi> and according to the discussion yesterday, the way to escalate issues with the ask server is to e-mail the developer directly?
19:29:07 <jeblair> fungi: yep
19:29:08 <clarkb> that was my understadning
19:29:31 <fungi> i'm eager to see how that works out
19:30:01 <jeblair> yeah.  well, it's not a critical piece of developer infrastructure.  :)
19:30:53 <fungi> point
19:31:10 <jeblair> okay, we better start talking about the cla now
19:31:13 <jeblair> #topic CLA
19:31:47 <fungi> as discussed, i sent a more eye-catching announcement to the dev ml a week ago and also hyped it on the project/release meeting last week
19:32:01 <fungi> i just e-mailed lsell about it too, at jeblair's urging
19:32:07 <jeblair> fungi: reed also mentioned it in the community newsletter
19:32:30 <fungi> yes, saw that. intended to thank him when i see him next
19:32:45 <jeblair> fungi: i got an email from jbryce this morning relaying a request from some lawyers that we add a sentence:
19:32:49 <jeblair> "In return, the Project Manager shall not use Your Contributions in a way that is contrary to the public benefit or inconsistent with its nonprofit status and bylaws in effect at the time of the Contribution."
19:33:04 <jeblair> that's apparently in the apache cla (it says foundation instead of project manager)
19:33:12 <fungi> oh, fun. if he could be explicit about where to put it
19:33:15 <jeblair> and they wanted to restore that to our cla
19:33:22 <fungi> i'll be happy to put a review through asap
19:33:38 <jeblair> fungi: same place as the apache cla, one sec
19:33:39 <fungi> mimic where it lives on apache's then?
19:33:41 <fungi> yeah
19:33:46 <fungi> i can do that, no sweat
19:33:47 <jeblair> #link http://www.apache.org/licenses/icla.txt
19:34:02 <fungi> also the main change for this weekend is rebased and up for review
19:34:05 <fungi> #link https://review.openstack.org/14099
19:34:28 <fungi> please give it a once over, but it's mimicking what's been on review-dev for months
19:34:46 <jeblair> fungi: i think you should also probably send a notice to the ml about that change too.
19:35:05 <fungi> the dev ml or the infra ml?
19:35:16 <jeblair> fungi: since part of this is to give people time to review the new cla too.
19:35:39 <fungi> jeblair: i linked the new cla from last week's "important" announcement to the dev ml
19:36:02 <fungi> the cla itself is not in that change since the file is already installed on the gerrit servers
19:36:27 <jeblair> fungi: oh sorry, let me rephrase...
19:36:54 <jeblair> fungi: after the new sentence is added to the cla file on the gerrit servers, i think you should send a notice to that effect to the -dev mailing list
19:37:02 <fungi> oh, absolutely
19:37:04 <jeblair> to bring to their attention that it has been slightly revised since thet last time
19:37:29 <fungi> #action fungi send follow-up announcement and mention last-minute cla amendment
19:37:35 <jeblair> (poor choice of words on my part earlier, by change i meant "change to the cla text" not "change under review in gerrit")
19:37:56 <jeblair> we got changes coming out of our ears
19:38:53 <jeblair> ttx: reping
19:39:14 <fungi> other than the above, we're still on track for this weekend obviously
19:39:41 <fungi> and will likely need all hands on deck come monday, to triage devs who don't read the ml and ignore error messages from git
19:39:51 <jeblair> +1
19:40:10 <jeblair> mordred: i hope you're not on a plane monday
19:40:19 <pleia2> I'll be out of town fri-sun (speaking at SCaLE), but I'll be back monday
19:40:45 <fungi> or, if i anger the gods on sunday, to help with whatever breakage i inadvertently get us into
19:40:45 <jeblair> pleia2: cool, i think reed is going to scale
19:41:14 <pleia2> jeblair: yeah
19:41:30 <clarkb> I will be around
19:41:45 <clarkb> fungi: you should have an irc bot that responds with infos :)
19:42:01 <fungi> clarkb: i intend to change the /topic in -infra and -dev at least
19:42:09 <jeblair> fungi: oh, just to fill in the rest of the context, apparently that line was omitted from the original cla because openstack llc wasn't a non-profit.
19:42:33 <fungi> ...and the openstack foundation is. got it
19:42:43 <jeblair> (or will be rsn)
19:42:49 <fungi> soon come
19:42:51 <anteaya> teach me what to say, and I can help Monday
19:43:00 <fungi> anteaya: you bet!
19:43:26 <jeblair> #topic open discussion
19:43:40 <jeblair> things on my plate include:
19:43:50 <jeblair> reviewing zaro's patches
19:44:01 <jeblair> grenade testing
19:44:26 <jeblair> something about tempest cli testing i think.. maybe there's a patch to turn it on and we just need to approve it?
19:44:33 <jeblair> i have such a review backlog :(
19:44:37 <fungi> so what's the decision on quantal slaves vs cloud archive?
19:44:54 <fungi> also, we'd like to do another git-review release tag very soon if possible
19:44:56 <jeblair> i _think_ the consensus is that cloud archive doesn't apply...
19:45:07 <pleia2> yeah
19:45:16 <fungi> anteaya: sorry about the cloud archive patch, but it was a great learning experience!
19:45:30 <jeblair> anteaya: yeah, sorry that didn't end up as merged code, but it was still really useful
19:45:34 <anteaya> fungi, it is, I don't take any decision personally
19:45:44 <jeblair> anteaya: we can still close the bug.  ;)
19:45:55 <anteaya> jeblair, okey dokey
19:45:56 <fungi> anteaya: i've abandoned almost as many patches as i've had merged, i suspect ;)
19:46:07 <jeblair> anteaya: any runners-up you might like to work on?
19:46:12 <anteaya> fungi, glad I am starting of on a good foot then, :D
19:46:36 <anteaya> annegentle, and ladquin and I are about to ambush fungi when meeting is over
19:46:48 <anteaya> there are a lot of doc/ci bugs languishing
19:46:49 <fungi> oh, also i've got a proposed new release for the puppet-dashboard puppet module to deal with an updated dependency. needs review and release
19:47:00 <anteaya> that if we have a tutorial on it, ladquin and I can address
19:47:02 <jeblair> anteaya: awesome!
19:47:22 <annegentle> woo
19:47:23 <pleia2> fungi: ah yes, I need to get my puppet dashbord test env running, testing that is on my list
19:47:35 <fungi> anteaya: i'm always glad to teach. the more people who know how to fix stuff, the less the rest of us need to fix ;)
19:47:47 <anteaya> fungi, figured you would feel that way
19:47:54 <ladquin> cool
19:48:04 <anteaya> we are waiting to pounce in -infra at the end of the meeting
19:48:06 <pleia2> reading the backlog from the weekend was helpful for me too, so thanks fungi :)
19:48:12 <jeblair> spending a week documenting jjb was one of the best time investments i've made on this project.  :)
19:48:17 <fungi> always time well spent
19:49:11 <fungi> mordred: if you and saper want to hash out interrelationships between your git-review patch and his, i'll see about retesting and merging them
19:50:05 <fungi> otherwise git-review is in decent shape and most of the pending patches are dealt with now. and i'm trying to find time to implement the shell mock tests we discussed
19:50:18 <clarkb> I am still not able to run nova absolute-limits with the jenkins creds
19:50:26 <clarkb> I am probably missing some obscure flag to novaclient
19:51:00 <fungi> or else it's an hpcloudism preventing you from doing that
19:51:17 <fungi> did you try against rackspace too?
19:51:18 <clarkb> no it works with my personal account
19:51:22 <fungi> ahh
19:51:27 <clarkb> so in theory it is possible
19:51:32 <fungi> freaky
19:51:49 <clarkb> the jenkins account is also wonky. the web gui doesn't work with it
19:51:52 <clarkb> among other things
19:52:12 <fungi> seems like we need them to take a hard look at that account in general
19:52:20 <fungi> i assume it was an early adopter
19:52:37 <clarkb> mordred: do you have any insight on that?
19:53:06 <ttx> jeblair: pong
19:53:20 <jeblair> ttx: anything you want to say about the cla?
19:53:37 <ttx> nope, no reamrk
19:53:40 * fungi say "cla good"
19:53:40 <ttx> remark
19:53:44 <ttx> cla good
19:53:46 <jeblair> cool.
19:53:58 <fungi> s/good/necessary evil/
19:54:12 <jeblair> s/necessary even/unecessary evil/
19:54:18 <fungi> arguably, yes
19:54:29 <fungi> necessary according to some lawyers
19:54:43 <jeblair> but fortunately, we don't have to argue that here and now.  :)
19:55:36 <fungi> ttx: did you have other infra items to bring up? 4 minutes left!
19:55:40 <jeblair> #action mordred yell at hpcloud to fix the openstackjenkins account
19:57:04 <jeblair> #endmeeting