19:04:40 <jeblair> #startmeeting infra
19:04:41 <openstack> Meeting started Tue Jan 15 19:04:40 2013 UTC.  The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:04:44 <openstack> The meeting name has been set to 'infra'
19:05:12 <jeblair> in accordance with the first item from last meeting, i'm calling this meeting infra.
19:05:25 <clarkb> ++
19:05:25 * fungi cheers
19:05:33 <jeblair> #action jeblair make sure wiki/calendar are updated
19:05:51 <jeblair> #topic CLA
19:05:54 <ttx> o/
19:06:17 <jeblair> ttx: oh, hi! while you're here... we want to call this the infra meeting, can you update the calendar entry?
19:06:44 <fungi> we've got the new cla text wrapped up i think (just needs approval/merge):
19:06:49 <fungi> #link https://review.openstack.org/19335
19:06:57 <jeblair> fungi: that's safe to do now?
19:07:11 <ttx> doing it now
19:07:15 <jeblair> ttx: (i believe i can update the wiki page)
19:07:15 <clarkb> did we get a response to fungi's question in the change ocmments?
19:07:21 * ttx is parralelizing with an audio meeting
19:07:21 <fungi> yes, it doesn't get linked anywhere until we start using gerrit clas
19:07:32 <clarkb> something about referring to text below a point in the CLA document?
19:07:34 <jeblair> clarkb: yes, latest change reflects that
19:07:35 <fungi> clarkb: yep, jonathan got back to us on that
19:07:39 <jeblair> clarkb: it's an inline block now
19:07:56 <ttx> I'm happy to share agenda-updating privileges. [caution: trap in previous sentence]
19:08:37 <ttx> infra team meeting it is
19:09:00 <fungi> we also need reviews on the cla implementation change itself...
19:09:07 <fungi> #link https://review.openstack.org/14099
19:09:35 <fungi> this is basically shifting the review-dev only bits over to apply to review.o.o as well
19:10:15 <clarkb> should we remove the WIP tag from that change?
19:10:19 <fungi> it's still set to wip, but i can un-wip it if that helps. still don't want it to merge until we schedule
19:10:35 <clarkb> in that case maybe its best to leave it as WIP
19:10:44 <clarkb> so that nothing happens unintentionally
19:10:50 <fungi> yeah, that's why i opted to advertise it in the meeting instead
19:11:21 <clarkb> ++
19:11:40 <jeblair> fungi: cool, what about doc updates and scheduling?
19:12:28 <jeblair> fungi: you had an etherpad somethere with the whole plan, right?
19:12:47 <fungi> i need to finish up a few bits of the documentation updates and submit a change to turn off user sync (all three should go in at the same time)
19:12:55 <fungi> sorry, fell off the office wireless for a moment
19:13:08 <fungi> #link https://etherpad.openstack.org/cla-maintenance-2012
19:13:17 <fungi> (slightly in need of a rename now)
19:13:36 <fungi> but i think the outstanding pieces are trivial enough we can pick adate
19:13:41 <fungi> er, a date
19:14:12 <jeblair> fungi: the communication with todd can go ahead and happen, right?
19:14:18 <jeblair> about the appsec?
19:14:39 <fungi> jeblair: yes, i'll sync up with him. he'll want to change that around the same time we merge the cut-over changes
19:15:19 <jeblair> fungi: oh, why not now?
19:15:45 <fungi> jeblair: well, the cla implementation on review-dev will start working when he invalidates its appsec key
19:16:03 <fungi> sorry, stop working
19:16:14 <fungi> maybe we want to repoint that to a dummy cgi first?
19:16:26 <fungi> i can do that after lunch pretty easily
19:17:19 <fungi> basically a one-line change to the gerrit config and a four-line (or so) cgi
19:17:19 <jeblair> fungi: yeah, let's do that and then go aheand and coordinate with todd
19:17:35 <jeblair> fungi: and then when todd&co have a staging server, we can point review-dev at that
19:17:46 <fungi> yep, sounds good
19:17:48 <clarkb> ++
19:18:18 <ttx> jeblair: I'll have to drop in a few. We should really move that meeting at some other time some other day :)
19:18:34 <ttx> anything you needed from me ?
19:18:40 <jeblair> fungi: the announcement looks generally good, though i feel like http://ci.openstack.org/gerrit.html#group-management should probably be a wiki page...
19:19:07 <fungi> jeblair: works for me. i can do that easily enough
19:19:15 <jeblair> ttx: i don't think so; i think the other big thing is the wiki migration
19:19:33 <ttx> I haven't worked on the main page yet. I plan to do that tomorrow.
19:19:42 <fungi> i'd like to make sure whatever scheduling we do for the cla cut-over doesn't intersect with the wiki final migration
19:19:55 <fungi> since there are wiki bits involved
19:20:20 <jeblair> what about sunday feb 17th?
19:20:29 <jeblair> for the cla change
19:20:34 * fungi looks at a calendar
19:20:46 <jeblair> i think that's the first time i'm available after LCA
19:20:49 <fungi> sure, works for me
19:20:58 <ttx> jeblair: that's the weekend just before g3
19:21:08 <fungi> ooh, right
19:21:12 <ttx> a.k.a. money time
19:21:14 <jeblair> sun feb 24th?
19:21:27 <clarkb> that should work for m
19:21:29 <clarkb> *me
19:21:32 <fungi> i can do the 24th
19:21:35 <ttx> Sure, i'll be on ski slopes at that point :)
19:21:41 <mordred> ++
19:21:42 <fungi> ha!
19:21:55 <mordred> that's the academy awards, just fyi
19:21:57 <jeblair> yeah, i'll just have to ski on saturday.  :)
19:22:08 <clarkb> ttx: you should tell us when all of your ski days are so that we can plan to break things then
19:22:14 <annegentle_itsme> I keep meaning to send an email to the mailing list about the wiki migration, shall I do so with a new date?
19:23:13 <jeblair> mordred: annegentle_itsme we had a few things we wanted to get sorted before scheduling the date...
19:23:19 <annegentle_itsme> jeblair: ah ok
19:23:30 <ttx> how are we doing with the openstack theme ?
19:23:32 <annegentle_itsme> jeblair: I think communicating that would be good
19:23:37 <clarkb> olaph: ^
19:23:38 <jeblair> #topic wiki
19:23:47 <annegentle_itsme> jeblair: that is, what's still in the works and part of the plan
19:23:56 <jeblair> http://eavesdrop.openstack.org/meetings/ci/2013/ci.2013-01-08-19.03.html
19:24:04 <olaph> http://openstack-wiki-instance.pmtpa.wmflabs/wiki/Main_Page
19:24:10 <ttx> We had a number of blocking issues -- get the main page ok (should be ready by tomorrow) and a base theme
19:24:16 <jeblair> annegentle_itsme: the three big things are under item 6 there
19:24:17 <olaph> oh, no, wait
19:24:31 <ttx> any other issue we needed to solve before cutoff?
19:24:34 <jeblair> Ryan_Lane: ping
19:24:41 <jeblair> ttx: the third was the redirects
19:24:47 <Ryan_Lane> didn't get to it just yet :(
19:24:49 <annegentle_itsme> jeblair: got it
19:24:53 <ttx> oh right, serving everything under /
19:25:20 <jeblair> so it sounds like we should give ourselves another week and see if those three things are resolved, and try to schedule a date hten
19:25:37 <jeblair> olaph: how is your skin coming?
19:25:37 <ttx> sounds good. My part should be covered by then
19:25:39 <annegentle_itsme> jeblair: sounds very reasonable
19:25:50 <jeblair> #action ttx make nice front page
19:25:56 <jeblair> #action Ryan_Lane handle redirects
19:25:58 <Ryan_Lane> day job is currently killing me. I should hopefully get time soonish.
19:26:21 <ttx> Ryan_Lane: couldn't you edit the wiki page of your job and fix it ?
19:26:25 <jeblair> Ryan_Lane: much appreciated.
19:26:30 <jeblair> ttx: you should be able to do thta
19:26:32 <Ryan_Lane> :D
19:26:36 <olaph> I was just trying to show it - guess it's still behind mediawiki's bastion
19:26:45 <ttx> I thought EVERYTHING was wikidriven at wikimedia :P
19:26:58 <olaph> will paste.o.o handle a screenshot?
19:26:58 <Ryan_Lane> it is for the most part ;)
19:27:07 <jeblair> olaph: no, but you could put it on imgur
19:27:10 <clarkb> olaph: no, but imgur will
19:27:11 <Ryan_Lane> olaph: does that link I sent not work?
19:27:17 <Ryan_Lane> http://openstack-wiki-instance.pmtpa.wmflabs/wiki/Main_Page
19:27:24 <Ryan_Lane> oh
19:27:25 <Ryan_Lane> crap
19:27:29 <Ryan_Lane> of course it won't
19:27:43 <ttx> unless you registered some pretty neat toplevel lately
19:27:49 <Ryan_Lane> let me give it a public IP
19:28:01 <Ryan_Lane> hm. actually. let me just fix its redirects
19:28:18 <Ryan_Lane> http://openstack-wiki-instance.instance-proxy.wmflabs.org/wiki/Main_Page
19:28:55 <jeblair> Ryan_Lane: css is still at the wmflabs toplevel
19:29:08 <fungi> i like it! very minimalist
19:29:09 <jeblair> Ryan_Lane: (rather, load.php)
19:29:25 <ttx> fungi: looks like your website :P
19:29:30 <fungi> heh
19:29:40 * fungi likes console-based web browsers
19:30:29 <Ryan_Lane> ok, hit it now
19:30:33 <Ryan_Lane> force-refresh, too
19:31:03 <Ryan_Lane> I know it's working this time, I hit it from a browser that doesn't have a socks proxy configured :)
19:31:37 <jeblair> cool, so things i see real quick:
19:31:49 <jeblair> we might want to use the vertial version of the logo so it's not as crowded
19:32:00 <jeblair> footer needs styling
19:32:01 <ttx> links are lighter than regular text, feels funny
19:32:14 <jeblair> and the links should either be red or blue; probably red.
19:32:16 <Ryan_Lane> I mentioned to olaph that links shouldn't be red
19:32:23 <jeblair> hehe
19:32:34 <jeblair> so most of the openstack sites have red links
19:32:38 <Ryan_Lane> red links mean something in mediawiki
19:32:49 <Ryan_Lane> they mean "this is a link to a page that doesn't yet exist"
19:32:56 <jeblair> on some of the CI systems that are just pages full of links, it makes your eyes bleed, so we changed them to blue
19:33:00 <Ryan_Lane> blue links are links that exist
19:33:05 <olaph> http://imgur.com/0DaRW
19:33:28 <jeblair> so i think we could use mediawiki standard blue/red, but just use the openstack blue and red links
19:33:29 <Ryan_Lane> olaph: heh. I got it working without the screencaps :)
19:33:54 <ttx> Sounds like a better logo: http://upload.wikimedia.org/wikipedia/en/thumb/4/4c/OpenStack.png/170px-OpenStack.png
19:34:09 <ttx> more vertical, square
19:34:11 <jeblair> ttx: yeah, that's the one
19:34:20 <jeblair> there should be one with a transparent bg
19:34:42 <olaph> will we need all the navigation/toolbox links?
19:34:53 <jeblair> ttx: http://www.openstack.org/assets/openstack-logo/openstack-cloud-software-vertical-small.png
19:35:13 <jeblair> olaph: ^ the official version of that (and it does have a transparent bg, i just didn't know how to read that in FF)
19:35:36 <ttx> also maybe ruse the same font for something as the one in openstack.org titles
19:35:39 <ttx> reuse
19:35:40 <jeblair> olaph: yeah, and i think they can probably be openstack-blue too.
19:36:02 <jeblair> ttx: that's a google-hosted woff font, so it'll take a bit more work...
19:36:02 <olaph> roger that
19:36:17 <ttx> ah ok, we can tweak that later
19:36:17 <jeblair> olaph, Ryan_Lane: is it easy to add in a woff font?
19:36:24 <Ryan_Lane> woff?
19:36:33 <fungi> maybe long-term the tab bar across the tops of articles could be redone like the menu bar on the other ostack sites too
19:36:36 <jeblair> Ryan_Lane: css font-face
19:36:48 <jeblair> Ryan_Lane: it's probably just some more css
19:36:54 <Ryan_Lane> should be. can also use web fonts if the font doesn't exist in the browser
19:37:08 <jeblair> Ryan_Lane: yeah, that's what this is
19:37:40 <jeblair> ttx: I've been thinking we should actually host that ourselves; it'll be faster.  but of course, we should get the website in our infra first.  then that change will be easier to make.  :)
19:37:49 <ttx> I think if we fix the logo and the color of the links we are good to go... then we can make the top menu more openstack like and some fonts more openstack like in v2
19:37:58 <jeblair> ttx: +1
19:38:06 <fungi> sounds great
19:38:12 <clarkb> works for me
19:38:14 <ttx> (v2 can happen before cut-off, but won't block migration if ot doesn't)
19:38:17 <jeblair> #action olaph to finish openstack skin
19:38:25 <jeblair> olaph: you good?
19:38:28 <ttx> (v1 of openstack skin
19:38:29 <ttx> )
19:38:32 <olaph> jeblair: yup
19:38:42 <jeblair> groovy
19:38:45 * ttx disappears
19:38:49 <jeblair> #topic rechecks
19:38:58 <ttx> ooh, sounds interesting
19:39:03 * ttx stays
19:39:18 <jeblair> #link http://status.openstack.org/rechecks/
19:39:33 <jeblair> quick recap: that page updates when you leave a comment like "recheck bug ####"
19:40:07 <jeblair> we merged a change to zuul to allow configuration of the message left in gerrit, so that when changes fail, we can link right to the wiki page
19:40:16 <jeblair> #link http://wiki.openstack.org/GerritJenkinsGithub#Test_Failures
19:40:21 <jeblair> ^ has updated documentation
19:40:21 <uvirtbot> jeblair: Error: "has" is not a valid command.
19:40:27 <jeblair> grumble.
19:41:14 <jeblair> so the last thing is for me to write an announcement about that syntax; send it to the -dev list, and in a week, change the regex to require the new syntax
19:41:43 <jeblair> i haven't written that yet, but i hope to do that RSN.
19:42:35 <jeblair> any questions?
19:43:06 <clarkb> sounds good to me
19:43:50 <jeblair> #topic status page
19:44:03 <jeblair> reviewday is now a project in gerrit
19:44:34 <jeblair> but other than that, i don't think we've made progress on running it on static.o.o.  shouldn't be too hard though.
19:45:04 <jeblair> if anyone's eager for a smallish puppet project, that would be a good one.
19:45:27 <jeblair> that's bug 1082785
19:45:29 <uvirtbot> Launchpad bug 1082785 in openstack-ci "Import reviewday into OpenStack infrastructure" [High,Triaged] https://launchpad.net/bugs/1082785
19:45:54 <jeblair> #link https://bugs.launchpad.net/openstack-ci/+bug/1082785
19:45:55 <uvirtbot> Launchpad bug 1082785 in openstack-ci "Import reviewday into OpenStack infrastructure" [High,Triaged]
19:46:50 <pleia2> I'll take a look at it
19:47:15 <jeblair> pleia2: awesome!  go ahead and grab that bug if you like then.
19:47:23 <ttx> pleia2: heh, welcome :)
19:47:45 <pleia2> thanks :)
19:48:15 <jeblair> cool, any other topics?
19:48:20 <jeblair> #topic open discussion
19:48:22 <fungi> dprince might want to say something about rhel-based jenkins slaves?
19:48:43 <clarkb> and in a related conversation our cloud providers now have quantal images
19:48:52 <fungi> righteous
19:48:58 <jeblair> yeah, i need to verify that branch can spin up oneiric/precise slaves still
19:49:09 <jeblair> i sat down to do that last week and rackspace stopped working.
19:49:27 <jeblair> i'll try to do that this afternoon
19:49:31 <dprince> fungi: I'm anxious to have the RHEL jenkins stuff merged!
19:49:38 <jeblair> though the branch needs one update to get the ldap change
19:50:03 <jeblair> sorry, this one:
19:50:03 <jeblair> Add libsasl2-dev package to jenkins slaves.
19:50:26 <dprince> jeblair: you need me to add that?
19:50:30 <jeblair> dprince: that would be great
19:50:44 <dprince> jeblair: will do.
19:50:47 <ttx> I'd suggest to change the meeting time but i can't find a good time. I'm out of california-compatible time slots
19:51:06 <fungi> dprince: on rhel it'll be cyrus-sasl-devel
19:51:09 <jeblair> https://review.openstack.org/#/c/19716/ is also in the pipeline, but maybe we can procrastinate that until after the rhel changes land
19:51:31 <clarkb> I think we can procrastinate since dprince got in the queue first iirc
19:51:37 <jeblair> ttx: :( you're around for the next meeting, right?
19:51:44 <jeblair> ttx: i guess this is dinner time?
19:51:56 <ttx> yes, it's eating half my dinner
19:52:01 <ttx> in winter time
19:52:15 <ttx> in summer time it just createes a LOOOONG meetings tunnel
19:52:59 <ttx> 1700 UTC is when I usually care for the kids, so not so great either
19:53:34 <clarkb> for quantal we will need to make sure puppet doesn't break to badly on it when running the slave manifests
19:53:50 <fungi> any earlier than 1700 and the usa west-coasters will hate you
19:53:53 <clarkb> and I some people have had trouble with quantal and devstack which may need sorting
19:54:10 <ttx> fungi: yeah, if I had a good alternatives I would insist, but I haven't
19:54:57 <jeblair> clarkb: yeah, i think that's going to be a moderate sized project we'll need to start soon.
19:55:21 <clarkb> jeblair: yeah it won't be something that gets done in an afternoon
19:55:44 <jeblair> clarkb: we can start by adding some quantal slaves, and manually testing unit test jobs on them
19:55:54 <jeblair> clarkb: previously, we've moved one project at a time to the new slave
19:56:14 <jeblair> clarkb: and then maybe when that's done, or in parallel, tackle devstack
19:56:30 <clarkb> jeblair: sounds good
19:57:14 <jeblair> anything else?
19:57:24 <fungi> nothing from me
19:58:03 <jeblair> thanks everyone!
19:58:05 <jeblair> #endmeeting