16:02:33 <alexpilotti> #startmeeting hyper-v
16:02:34 <openstack> Meeting started Tue Sep 10 16:02:33 2013 UTC and is due to finish in 60 minutes.  The chair is alexpilotti. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:37 <openstack> The meeting name has been set to 'hyper_v'
16:02:45 <alexpilotti> Hi guys
16:03:01 <alexpilotti> who's around today?
16:03:11 <hanrahat> hanrahat's here
16:03:21 <alexpilotti> hi Tom!
16:03:39 <iben> Iben's here...
16:03:49 <alexpilotti> let's wait a couple of minutes to see if anybody joins
16:04:04 <iben> streaming live from the SDDC Symposium in Santa Clara, CA
16:04:24 <alexpilotti> iben: hi there!
16:04:31 <ociuhandu> hi all
16:05:21 <alexpilotti> ok let's start
16:05:28 <alexpilotti> #topic H3
16:06:09 <alexpilotti> Things went fairly well in the end, as most of the blueprints got accepted and merged
16:07:06 <alexpilotti> Since it's a big amount of features, we need to test as much as possible in the next few weeks
16:07:23 <alexpilotti> Havana will be cut in roughly one month
16:07:50 <alexpilotti> another good news is that Hyper-V 2012 R2 has been released yesterday
16:08:11 <alexpilotti> for MSDN subscribers only for now, but it's already RTM
16:08:23 <hanrahat> alexpilotti: I've updated https://wiki.openstack.org/wiki/Hyper-V#Code to reflect h3 but we also need to think about documentation soon.
16:09:06 <alexpilotti> hanrahat: great job, thanks
16:09:14 <iben> cool
16:09:52 <alexpilotti> the amount of Hyper-V features is becoming fairly large, so it's definitely important to do that
16:10:06 <alexpilotti> #action update Hyper-V docs for Havana
16:10:40 <alexpilotti> let's get now into detail about some of the blueprints that need special attention
16:11:02 <alexpilotti> #topic Ceilometer
16:11:07 <alexpilotti> #link https://blueprints.launchpad.net/ceilometer/+spec/hyper-v-agent
16:12:09 <alexpilotti> The inspector merged and we're in the process of adding the ceilometer agent in our installer to make it easily available in most OpenStack Hyper-V installations
16:12:28 <alexpilotti> It's based on the Hyper-V metrics API, introduced in 2012
16:13:10 <alexpilotti> CPU and network metrics are available with 2012, while disk metrics require 2012 R2
16:13:54 <alexpilotti> this needs to be pointed out in the upcoming documentation
16:14:48 <alexpilotti> to avoid useless waste of resources, the metrics are not enabled in nova and neutron by default
16:15:41 <alexpilotti> enable_instance_metrics_collection must be set to true
16:15:53 <alexpilotti> in the config options
16:16:21 <alexpilotti> the installer will do it automatically of course, but it needs to be pointed out in case of manual installation
16:17:03 <alexpilotti> #topic WMI V2
16:17:44 <alexpilotti> all Hyper-V related OpenStack projects are now using WMI V2 on Windows >= 2012
16:18:31 <alexpilotti> so 2012 R2 compute nodes are perfectly feasible
16:18:55 <alexpilotti> we're thinking about back porting this code to grizzly (outside of the tree of course)
16:19:14 <alexpilotti> #topic VHDX
16:19:18 <alexpilotti> #link https://blueprints.launchpad.net/nova/+spec/hyper-v-vhdx
16:20:11 <alexpilotti> As already widely discussed, VHDX allows us to improve performance in local storage and to resize differencing (CoW) disks
16:20:39 <alexpilotti> there's one consideration related to the format
16:21:01 <alexpilotti> AFAIK there are no open source converters that manage VHDX
16:21:31 <alexpilotti> when users want to convert images (e.g. QCow2) the usually employ qemu-img convert
16:21:45 <alexpilotti> which currently supports VHD, but not VHDX
16:22:44 <alexpilotti> to avoid having most people using the old format, it might be wise to contribute the VHDX conversion bits to qemu-img
16:23:36 <alexpilotti> currently, users need to convert QCow2 -> VHD and then VHD -> VHDX
16:23:49 <alexpilotti> (the latter on Windows, e.g. by using Powershell)
16:24:23 <alexpilotti> #topic Cinder
16:24:28 <alexpilotti> #link https://blueprints.launchpad.net/cinder/+spec/windows-storage-driver-extended
16:24:34 <alexpilotti> pnavarro: ping
16:25:21 <alexpilotti> pnavarro took care as usual of the Cinder bits
16:25:47 <alexpilotti> he's not joining us today, so we'll postpone details about this for next time
16:26:13 <alexpilotti> #topic Ephemeral storage
16:26:16 <alexpilotti> #link https://blueprints.launchpad.net/nova/+spec/hyper-v-ephemeral-storage
16:26:41 <alexpilotti> Not much to say on this topic, beside the fact that now we have it as well :-)
16:26:51 <alexpilotti> it supports of course VHD and VHDX
16:27:17 <alexpilotti> with the former used in case the platform is < 2012
16:27:42 <alexpilotti> #topic Dynamic memory
16:27:45 <alexpilotti> #link https://blueprints.launchpad.net/nova/+spec/hyper-v-dynamic-memory
16:28:03 <alexpilotti> And finally, memory ballooning has been included as well
16:28:36 <alexpilotti> a simple property has been used to set the default percentage on the compute node
16:28:56 <alexpilotti> we might think about extending this with an image property in the future
16:29:29 <alexpilotti> #topic general discussion
16:30:09 <alexpilotti> In the next week we'll test all the bits and make sure that everything works as expected
16:30:43 <alexpilotti> especially on 2012 R2
16:31:01 <alexpilotti> If anybody has anything to add this is a good moment :-)
16:31:29 <hanrahat> alexpilotti: let's talk offline about how I can help with the documentation
16:31:43 <alexpilotti> hanrahat: sure!
16:32:08 <alexpilotti> Ok, that's all folks for today!
16:32:14 <alexpilotti> #endmeeting