20:01:18 <e0ne> #startmeeting horizon
20:01:19 <openstack> Meeting started Wed Apr  4 20:01:18 2018 UTC and is due to finish in 60 minutes.  The chair is e0ne. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:22 <openstack> The meeting name has been set to 'horizon'
20:01:40 <rdopiera> o/
20:01:43 <e0ne> hi
20:02:35 <e0ne> #link https://wiki.openstack.org/wiki/Meetings/Horizon#Agenda_for_Next_Meeting
20:03:42 <e0ne> #topic Notices
20:03:47 <e0ne> I hope we'll have more people here once meeting time will be changed
20:04:01 <rdopiera> who knows
20:04:09 <e0ne> current poll results are available here https://doodle.com/poll/ei5gstt73d8v3a35
20:05:12 <e0ne> rdopiera: I really hope in it
20:05:56 <david-lyle> o/
20:06:01 <e0ne> I think that we'll have our meetings at 15:00 UTC on the same day.
20:06:17 <e0ne> let's wait one week more and make a final decision on the next meeting
20:07:04 <rdopiera> perhaps we should also post on the mailing list about the poll
20:07:38 <e0ne> rdopiera: do you mean to send one more reminder?
20:07:47 <rdopiera> yes
20:07:52 <e0ne> ok
20:08:23 <e0ne> #action e0ne to send one more remidner about the meeting time poll
20:09:20 <e0ne> #topic Rocky priorities
20:09:47 <e0ne> thanks everybody for reviews and patches
20:10:41 <e0ne> https://launchpad.net/horizon/+milestone/rocky-1 - looks good for me. I'll change milestone for  merged bugfixes if needed. will check it later in rocky-1
20:11:12 <e0ne> that's all from my side accodting to notices/announcements
20:11:28 <e0ne> #topic Improve Horizon testing
20:12:01 <e0ne> rdopiera, david-lyle: I summarized my last efforts and PTG discussion in the proposed blueprint
20:12:13 <e0ne> #link https://blueprints.launchpad.net/horizon/+spec/improve-horizon-testing
20:12:52 <e0ne> I've got some blockers to get selenium-headless job fixed
20:13:15 <e0ne> e.g. nose test runner doesn't show real results - it hides stderr output
20:13:30 <e0ne> so there is no way to see if some tests failed
20:14:18 <e0ne> using  django.test.tag with node doesn't work too:(
20:14:36 <e0ne> that's why I'm going to remove nose from plugins first and than from the horizon
20:14:54 <e0ne> rdopiera, david-lyle: it would be great to have any feedback from you on this
20:16:11 <rdopiera> what are the blockers?
20:16:12 * david-lyle looking
20:16:39 <rdopiera> or do you mean that runner is a blocker?
20:16:52 <rdopiera> I'm all for getting rid of nose
20:17:17 <david-lyle> e0ne, the selenium tests are being skipped
20:17:25 <david-lyle> that's why there's no output, no?
20:17:46 <david-lyle> http://logs.openstack.org/68/490868/20/check/horizon-selenium-headless/17f0416/job-output.txt.gz#_2018-04-04_13_07_40_953529
20:18:04 <david-lyle> I mean that's a failure, but it's an installation failure
20:18:28 <e0ne> david-lyle: job configuration in only a part of fixe
20:18:32 <e0ne> *fixes
20:19:09 <e0ne> david-lyle: here is my WIP patch for it
20:19:11 <e0ne> #link  https://review.openstack.org/558467
20:19:35 <e0ne> it requires to change tests code too
20:20:13 <david-lyle> same issue http://logs.openstack.org/67/558467/10/check/horizon-selenium-headless/470066c/job-output.txt.gz#_2018-04-04_16_45_56_991997
20:20:37 <david-lyle> I wasn't referring to them being non-voting, but the fact that the selenium setup itself fails
20:20:41 <e0ne> rdopiera, david-lyle: nose hides a real issue why tests are skipped
20:20:56 <david-lyle> this will likely require project-config changes
20:22:40 <e0ne> #link http://logs.openstack.org/96/544296/11/check/horizon-selenium-headless/02aac18/job-output.txt.gz#_2018-04-02_07_38_02_481177
20:22:40 <e0ne> david-lyle: yes. I fixed issue with Xvfb package in my patch.
20:22:40 <david-lyle> e0ne, ok, just jumped to output
20:22:41 <e0ne> david-lyle: I need to configure geckodriver or mayve firefox on gates to run tests
20:23:04 <david-lyle> ok
20:23:48 <e0ne> my idea is pretty simle
20:25:01 <e0ne> 1) get rid of nose to get tests output more detailed and failures more precictable (e.g. I saw false-positive results in our gates because of https://github.com/nose-devs/nose/issues/984)
20:25:16 <e0ne> 2) fix selenium-headless job
20:25:51 <e0ne> 3) try to test horizon with plugins on our gates using selenium-headless-<pliugin> job
20:26:10 <e0ne> there are more details on the blueprint
20:26:29 <e0ne> I just want to confirm that team is OK with it
20:26:49 <david-lyle> e0ne, maybe make the plugin tests a periodic job?
20:26:56 <david-lyle> the overhead will be significant
20:27:05 <e0ne> probably, I have to send a mail to openstack-dev@ too since it's a cross-project activity
20:27:07 <david-lyle> but periodic might miss the point
20:27:46 <e0ne> david-lyle: IMO, we can do it per each change request. it should be not slower than our tempest job
20:28:08 <david-lyle> but there will be 20 or so extra jobs
20:28:19 <e0ne> yes, and that's the issue
20:28:19 <david-lyle> that's significant overhead on zuul
20:28:25 <e0ne> +1
20:28:58 <e0ne> honestly, I don't know what is the the best solution. that's why I bring this topic here
20:29:20 <e0ne> I'll discuss cross project testing with ironic team next week
20:29:31 <e0ne> they're interesting with such kind of testing
20:30:15 <rdopiera> are we really that much constrained in resources?
20:30:31 <rdopiera> wasn't hardware supposed to be cheaper than developers?
20:30:54 <e0ne> rdopiera: we've got full devstack + tempest for login test only, so I don't know...
20:31:10 <rdopiera> I still didn't have time to look into that
20:31:21 <rdopiera> still stuck in the translations for testing
20:31:59 <e0ne> :(
20:32:21 <rdopiera> I will get to it
20:32:58 <e0ne> rdopiera: thanks
20:34:04 <e0ne> david-lyle: if we care about zuul resources, we can ask infra team about it
20:35:05 <david-lyle> I think that's a good idea
20:35:11 <david-lyle> once we get there
20:35:47 <e0ne> ok, we'll do it when some tests will be ready
20:38:54 <e0ne> do we have anything else to discuss or let's end our meeting?
20:40:49 <e0ne> thanks everyone. see you next week!
20:41:08 <e0ne> #endmeeting