20:01:04 <r1chardj0n3s> #startmeeting horizon
20:01:05 <openstack> Meeting started Wed Oct  5 20:01:04 2016 UTC and is due to finish in 60 minutes.  The chair is r1chardj0n3s. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:08 <openstack> The meeting name has been set to 'horizon'
20:01:17 <david-lyle> o/
20:01:19 <r1chardj0n3s> Hello all
20:01:20 <tsufiev> o/
20:02:09 <david-lyle> stop shoving
20:02:14 <r1chardj0n3s> Well, I'd like to thank Dave and Timur for coming :-)
20:02:34 <r1chardj0n3s> #topic Notices
20:02:37 <rdopiera> hi
20:02:48 <qwebirc41501> hello
20:02:55 <r1chardj0n3s> #link https://etherpad.openstack.org/p/horizon-ocata-summit now has a schedule
20:03:00 <tsufiev> :)))
20:03:40 <r1chardj0n3s> I've grouped things into sessions that seem to make sense. Feedback is welcome, of course. And ordering can change, though I'd like to keep it stable within reasonable time before the summit.
20:04:13 <r1chardj0n3s> Hmm, I should note the times of each of the sessions on that pad too.
20:05:04 <r1chardj0n3s> #action r1chardj0n3s to add time, location and session-specific etherpad links to the summit overview etherpad page
20:05:13 <r1chardj0n3s> (let's see if I got that right ;-)
20:06:27 <r1chardj0n3s> ok... next thing I have is Project Teams Gathering
20:06:29 <r1chardj0n3s> #link http://www.openstack.org/ptg is intended to replace mid-cycles - are we going to participate?
20:06:59 <r1chardj0n3s> I need to know whether Horizon folks are happy to do that thing rather than have an independent mid-cycle
20:07:24 <david-lyle> I think we should try it
20:07:41 <tsufiev> seems like a proper thing to do
20:08:24 <rdopiera> can we skip the summits then?
20:08:36 <david-lyle> rdopiera, for most, that's the idea
20:08:40 * tsufiev thinking is if Atlanta a 'cost-effective transportation hub'
20:09:31 <david-lyle> rdopiera, this summit is still design related, but starting with Boston, it will not have the design component
20:10:11 <rdopiera> david-lyle: I know that's the plan, but I'm a bit afraid that we will start going to both
20:10:18 <david-lyle> so devs should go if they want to talk to users/customers/other devs who have come to talk to users/customers
20:10:29 <david-lyle> rdopiera, we already go to both
20:10:35 <r1chardj0n3s> I concur with y'all - let's see how the PTG goes. I'll feed that back to the Foundation.
20:10:54 <rdopiera> david-lyle: I thought ptg is a new thing
20:11:23 <david-lyle> but this is an attempt to reduce the need for most to go to both
20:12:05 <rdopiera> makes sense
20:12:15 <r1chardj0n3s> Yeah, it'll be interesting to see how it goes.
20:13:12 <r1chardj0n3s> They're reducing our face-to-face time for planning and discussion to once per cycle. We'll have to come up with alternative methods of planning to fill that void, and I'm not sure what that'll look like.
20:14:11 <r1chardj0n3s> OK, so the only other thing I have is to mention that RC3 is out and we’re looking to get 10.0.0 released this week from it.
20:14:12 <tsufiev> r1chardj0n3s, how is that different from what was before? IIRC, midcycle meetups were not organized by foundation...
20:14:40 <david-lyle> 10.0.1 right?
20:15:15 <r1chardj0n3s> david-lyle: no, 10.0.0 unless I'm horribly confused... 10.0.0 hasn't been released
20:15:36 <r1chardj0n3s> the patch for newton final is https://review.openstack.org/#/c/380478/
20:15:40 <david-lyle> tsufiev, the midcycle weren't official, but a large number projects were using them
20:16:07 <r1chardj0n3s> tsufiev: yes, we'll have to see how many projects end up having a "planning" meetup independently
20:16:18 <david-lyle> r1chardj0n3s, I'm jumping the gun
20:16:18 <tsufiev> david-lyle, I mean, the foundation isn't going to forbid us to hold midcycles, are they :)?
20:16:40 <robcresswell> tsufiev: More that nobody will get approval to travel 6 times a year :)
20:16:51 <robcresswell> (also hi, sorry for lateness)
20:16:51 <david-lyle> tsufiev, no, there are a few reasons for the reorg
20:17:21 <david-lyle> allowing key devs to actually use the summit to interface with people other than devs
20:17:32 <david-lyle> reduce the overall travel burden on most devs
20:17:51 <robcresswell> We can also use the forum for mid-cycle style meetups. Thats even in the Forum description.
20:17:52 <david-lyle> better align releases and downstream consumers around summits
20:17:54 <r1chardj0n3s> the mid-cycle timing we used to have lines up with when the summit will run, so that's going to be difficult for some to manage
20:18:01 <robcresswell> As key people will all be there anyway.
20:19:01 <robcresswell> Just read scrollback, I'm a +1 for PTG too.
20:19:08 <r1chardj0n3s> thanks robcresswell
20:19:55 <tsufiev> well, the future is going to come despite all our concerns, I think...
20:20:26 <david-lyle> tsufiev, what are the concerns?
20:20:26 <r1chardj0n3s> I look forward to mid-cycling with y'all in Boston :-)
20:21:08 <tsufiev> david-lyle, that there might be not enough time for our interaction - as r1chardj0n3s mentioned
20:22:01 <r1chardj0n3s> we've still not been told the exact format of the summit-located mid-cycles (I recall some folks indicating that they would be held "away" from the summit to reduce cost)
20:22:14 <robcresswell> Yeah, we can chat at the summit anyway. Its not banned, just wont be dedicated rooms for it. But the cores/ptls will hopefully be around, which is what the midcycles most consist of anyway.
20:22:16 <r1chardj0n3s> we'll just have to see
20:22:24 <david-lyle> I think PTG will the primary meeting for devs
20:22:32 <robcresswell> david-lyle: yup
20:24:10 <r1chardj0n3s> so the last thing I wanted to talk about was the low attendance at these meetings
20:24:25 <ediardo> o/
20:24:47 <rdopiera> I have to admit that I often forget about them :(
20:24:48 <tsufiev> ediardo, that was a proper timing ;) ^^
20:24:53 <r1chardj0n3s> I'm going to send out a reminder email to the dev list
20:24:58 <r1chardj0n3s> #action r1chardj0n3s to email openstack-dev reminding folks about the weekly IRC meeting
20:25:15 <r1chardj0n3s> we'll see if that has any impact
20:26:09 <robcresswell> r1chardj0n3s: You could try a courtesy reminder type thing like searchlight and others do
20:26:09 <ediardo> rdopiera ;)
20:26:22 <r1chardj0n3s> I think the timing of the meeting will mean that the large number of contributors we have in China won't be making it along (it's very much in the AM there)
20:26:40 <tsufiev> r1chardj0n3s, maybe the main reason is that people don't know what to expect from these meetings? I mean, if before people were coming to a meeting to push their feature, now they generally don't do it (maybe that just didn't work for them and they stopped trying)
20:26:44 <rdopiera> I wonder if we could make the bot announce the meeting on the #openstack-horizon channel
20:26:51 <rdopiera> when it's starting
20:26:59 * david-lyle recalls an APAC friendly time that was even less attended
20:26:59 <robcresswell> Something like this, to remind people: https://etherpad.openstack.org/p/search-team-meeting-agenda( about line 6)
20:27:00 <r1chardj0n3s> robcresswell: I'm not familiar with the searchlight timing thing?
20:27:15 <robcresswell> ugh, misplaced '(' might break that link
20:27:18 <r1chardj0n3s> tsufiev: that's a good point
20:27:31 <david-lyle> r1chardj0n3s, same as TC meeting start
20:27:49 <david-lyle> just a list of nics copied into room
20:27:52 <r1chardj0n3s> david-lyle: yep, the APAC meeting time was a dud indeed
20:27:56 <ediardo> Let's do an iOS app that reminds us wehave a meeting to attend
20:28:02 <david-lyle> searchlight does in their team room too
20:28:04 <ediardo> connected to keystone
20:28:10 <tsufiev> o_O
20:28:11 <robcresswell> tsufiev: Right, the old blueprint system and asking for approval in meetings seems to have died
20:28:26 <ediardo> k jk
20:28:33 <robcresswell> one sec just moving, internet might fall over
20:29:01 <david-lyle> TIL robcresswell routes the entire internet
20:29:11 <r1chardj0n3s> robcresswell: ok, I'll see about finding out how that meeting reminder thing works
20:29:16 <ediardo> lol
20:30:03 <tsufiev> then, dropping the integrated/incubated statuses (and a requirement to have a Horizon dashboard in a Horizon repo to be an integrated project) has certainly contributed to the downfall of interest to Horizon meetings
20:30:09 * tsufiev thinks about Sahara
20:30:20 <r1chardj0n3s> (though to be honest, I have a calendar on my desktop and the meeting is in it and I get reminders, it's not difficult...)
20:30:42 <david-lyle> tsufiev, I think there larger influences on that decreased interest
20:31:31 <robcresswell> david-lyle: Looks like the internet survived without me
20:32:02 <r1chardj0n3s> http://www.thewebsiteofdoom.com/new/wp-content/uploads/2012/12/internet.jpg
20:32:43 <tsufiev> david-lyle, like the containers thing :)?
20:33:40 <david-lyle> tsufiev, I'm happy to have a larger discussion, but not sure out meeting time is the best place to cover openstack macrotrends
20:34:19 <tsufiev> sure, not going to continue with off-topic discussion right now
20:34:42 <david-lyle> I guess the point is, smaller meetings may become the norm
20:34:54 <robcresswell> We generally just use the meeting for announcements now
20:35:07 <robcresswell> Previously it was for bug/bp discussion
20:35:45 <robcresswell> I think if we used bp approval then it might get more attention, but thats somewhat ignored now. People just throw up features and ping for reviews :)
20:36:32 <david-lyle> the volume into the funnel has fallen
20:36:50 <david-lyle> we've solved it
20:37:53 <r1chardj0n3s> we're also in the end-of-cycle dead spot at the moment where we're kind of on pause getting the release out and before the summit when priorities are agreed to
20:38:10 <r1chardj0n3s> so these few weeks are a bit weird anyway
20:38:34 <robcresswell> Yeah its normally quiet while people prep Ocata features and demos
20:39:11 <r1chardj0n3s> so they can surprise us with theirthrowing up features and pinging for reviews, yes :-)
20:39:22 * tsufiev grabs the microphone and promotes the Profiler commits :D
20:39:53 <r1chardj0n3s> tsufiev: yes! um, I had questions about that, which I forgot (because vacation)
20:40:12 <r1chardj0n3s> tsufiev: I'm a little hazy on the actual setup of the profiler - do I need to be running a MongoDB or something somewhere to make it work?
20:40:30 <tsufiev> unfortunately, yes
20:40:48 <tsufiev> otherwise you'll have to face the Ceilometer poor performance
20:41:26 <r1chardj0n3s> it might be helpful to have some (hopefully simple) setup instructions for devs to follow to get that right
20:41:32 <tsufiev> osprofiler team might fix the ceilometer drivers in some distant future... but I won't bet a large sum on that
20:41:52 <robcresswell> We need to axe that panel
20:41:56 <robcresswell> Should've done it last cycle
20:42:03 <tsufiev> https://review.openstack.org/#/q/status:open+project:openstack/horizon+branch:master+topic:bp/openstack-profiler-at-developer-dashboard
20:42:19 <robcresswell> (the ceilometer panel I mean)
20:42:19 <tsufiev> instructions are in the second patch, https://review.openstack.org/#/c/303514/
20:42:34 <tsufiev> r1chardj0n3s, ^^
20:43:10 <r1chardj0n3s> OK, so the issue then becomes how to test the first patch
20:43:11 <tsufiev> we even made some preparations for profiling API calls made from Angular pages
20:44:19 <tsufiev> r1chardj0n3s, I may merge them if that makes things easier
20:44:31 <tsufiev> 1st + 2nd
20:45:20 <tsufiev> always a tradeoff between the ease of reviewing vs. providing a fully demoable feature
20:46:08 * tsufiev puts back the microphone
20:46:32 <r1chardj0n3s> absolutely, but I think it makes sense to be able to exercise the code before merging it, and we can't sensibly exercise the code in the 1st patch I think
20:46:55 <tsufiev> yep, that's true
20:47:02 <robcresswell> On the summit etherpad, are we starting with priorities?
20:47:37 <r1chardj0n3s> robcresswell: that's the ordering at the moment, but it doesn't really make sense so that session will probably be the fourth.
20:47:50 <r1chardj0n3s> Well, the priorities bit
20:47:54 <robcresswell> cool
20:48:10 <robcresswell> Wait who +1'd rotten fruit
20:48:23 <david-lyle> ;)
20:48:31 <robcresswell> I should've known...
20:48:38 <david-lyle> you should have
20:48:51 <r1chardj0n3s> ok, I think this meeting may have run its course. thanks all for coming!
20:49:06 <robcresswell> oh
20:49:10 <robcresswell> o/
20:49:13 <r1chardj0n3s> #endmeeting