12:01:02 <david-lyle> #startmeeting Horizon
12:01:03 <openstack> Meeting started Wed Sep 30 12:01:02 2015 UTC and is due to finish in 60 minutes.  The chair is david-lyle. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:01:07 <openstack> The meeting name has been set to 'horizon'
12:01:38 <david-lyle> who's around ?
12:01:42 <r1chardj0n3s> o/
12:01:45 <fnordahl> o/
12:01:46 <masco_> 0/
12:01:47 <mrunge> o/
12:01:55 <kzaitsev_mb> \0
12:02:07 <robcresswell> o/
12:03:15 <david-lyle> Let's get rolling
12:03:42 <david-lyle> So we have an RC-1 for Liberty
12:03:57 <david-lyle> we will need an RC-2 to roll in the translations
12:05:03 <david-lyle> bug wise I'm not seeing anything that would require an RC-2 otherwise. There is a django_openstack_auth issue that will require a release there once fixed
12:05:05 <r1chardj0n3s> when's RC-2 due?
12:05:23 <david-lyle> r1chardj0n3s: good question
12:05:57 <david-lyle> week of Oct 5-9 looks like
12:06:03 <fnordahl> I have a few bugs and corrensponding fixes that I would like to see in for subnetpools to work.
12:06:27 <tsufiev> o/
12:06:35 <fnordahl> https://review.openstack.org/#/c/222904/
12:06:35 <doug-fish> fnordahl: can you share links?
12:06:38 <david-lyle> as a reminder of process,
12:06:39 <fnordahl> https://review.openstack.org/#/c/227167/
12:06:40 <doug-fish> :-)
12:07:14 <robcresswell> Don't know if it helps but I made #link https://bugs.launchpad.net/horizon/+bugs?field.tag=liberty-rc-potential to categorise any bugs
12:07:46 <david-lyle> liberty is now on stable/liberty, so all changes need to merge to master first then be backported to stable/liberty
12:08:21 <david-lyle> but at this point we really only want to merge high priority issues
12:08:29 <robcresswell> Ah okay
12:08:29 <david-lyle> to stable/liberty
12:08:42 <r1chardj0n3s> david-lyle: it looks like we have a consensus on that fix for the MySQL vs. DOA deathmatch?
12:08:57 <david-lyle> robcresswell: https://bugs.launchpad.net/horizon/+bugs?field.tag=liberty-rc2-potential
12:09:18 <robcresswell> ah poop
12:09:23 <robcresswell> will redo those
12:09:26 <r1chardj0n3s> but that fix will require a global-requirements update...
12:09:38 <david-lyle> r1chardj0n3s: I think setting the field length to 64 by default
12:09:48 <david-lyle> but that won't fix the migration issue
12:10:17 <david-lyle> r1chardj0n3s: we can release and as long as upper constraints is set appropriately, people will pick it up
12:10:25 <david-lyle> and we can update g-r in Mitaka
12:10:30 <r1chardj0n3s> ok
12:10:42 <r1chardj0n3s> (I'm not familiar with the migration issue, but this isn't the time to clue in my cluelessness ;)
12:11:03 <david-lyle> exception for straight to stable/liberty patches are the translations
12:11:27 <david-lyle> r1chardj0n3s: it's in the bug comments https://bugs.launchpad.net/horizon/+bug/1499856
12:11:27 <openstack> Launchpad bug 1499856 in django-openstack-auth "latest doa breaks with new db layout" [Critical,In progress] - Assigned to Eric Peterson (ericpeterson-l)
12:12:06 <r1chardj0n3s> david-lyle: ok, thanks
12:12:21 <david-lyle> no plan for that part yet
12:12:53 <david-lyle> other general reminders
12:13:15 <david-lyle> #link https://etherpad.openstack.org/p/horizon-mitaka-summit
12:13:21 <david-lyle> for topic ideas
12:13:53 <david-lyle> #link http://odsreg.openstack.org/
12:14:05 <david-lyle> for cross-project (>2) session topics
12:15:34 <david-lyle> fnordahl: https://bugs.launchpad.net/horizon/+bug/1498926
12:15:34 <openstack> Launchpad bug 1498926 in OpenStack Dashboard (Horizon) "Unable to create subnet from IPv6 subnetpool" [Undecided,In progress] - Assigned to Frode Nordahl (fnordahl)
12:15:46 <david-lyle> unable to create subnets without?
12:16:04 <david-lyle> err subnetpool
12:16:23 * david-lyle still processing
12:16:24 <fnordahl> david-lyle: Without this patch it will be imposible to create subnet from a IPv6 subnetpool
12:16:43 <david-lyle> which was the whole point of your bp, no?
12:17:00 <fnordahl> david-lyle: Entirely my fault for introducing crappy JS in the intiial patch so this is attepmpt to do it right.
12:17:18 <fnordahl> david-lyle: largely yes. Neutron will come with support for IPv6 Prefix Delegation
12:17:26 <fnordahl> Horizon needs this to work with that.
12:17:48 <fnordahl> (and addreass scopes and other nice network-p0rn)
12:18:22 <david-lyle> ok, marked high, if the change makes master, will consider for RC-2
12:18:26 * tsufiev makes a note how he should call neutron :)
12:18:33 <fnordahl> david-lyle: great, thx!
12:18:57 <david-lyle> #topic The Bug Report
12:19:01 <david-lyle> robcresswell: o/
12:19:05 <robcresswell> hey
12:19:26 * robcresswell finds link
12:19:36 <robcresswell> #link https://wiki.openstack.org/wiki/Horizon/WeeklyBugReport
12:19:46 <robcresswell> I wanted to try focusing reviews a little better on key issues
12:20:07 <robcresswell> We're mega productive at RC time, partly because pressure, but also partly because we have a very set list of items to look at, I feel.
12:20:41 <robcresswell> This is an attempt to break that down into a weekly event. So we try to ensure resolution of a small number of bugs or bps.
12:21:13 <robcresswell> Rather than ignoring critical bugs or long standing coded bps until end of cycle.
12:21:45 <Anticimex> is the famous stale session timeout related bug among those listed? i can't really tell
12:21:53 <robcresswell> I'm happy to review and keep producing weekly reports like this, if its deemed valuable.
12:22:11 <tsufiev> Anticimex, it should have been already fixed
12:22:28 <robcresswell> Anticimex: I thought the timeout bug was fixed, just the migration issue left, which is at the top of the list.
12:22:31 <mrunge> tsufiev, it's not. https://bugs.launchpad.net/horizon/+bug/1499856
12:22:31 <openstack> Launchpad bug 1499856 in django-openstack-auth "latest doa breaks with new db layout" [Critical,In progress] - Assigned to Eric Peterson (ericpeterson-l)
12:22:50 <doug-fish> robcresswell: how does this help us more than just going to https://launchpad.net/horizon/+milestone/liberty-rc1 and looking at priorized bugs?
12:22:58 <Anticimex> robcresswell: ack, we're testing now. so i guess i'll figure it out
12:23:02 <Anticimex> robcresswell: ack re: migration
12:23:19 <david-lyle> well to be fair, the timeout bug is fixed and replaced with a newer shinier bug
12:23:19 <robcresswell> doug-fish: Bugs are rarely categorised to each milestone until they are merged.
12:23:22 <tsufiev> mrunge, that's a bit different issue, though from the same family...
12:23:52 <mrunge> yes, agree. that's a different thing.
12:23:55 <doug-fish> robcresswell: but they could be - isn't that the same activity as created the report?
12:24:29 <tsufiev> doug-fish, I think the point here is that meetings are held every week, while there are only one milestone in half a year
12:24:41 <tsufiev> s/one/three/
12:24:57 <robcresswell> doug-fish: Arguably. It's targeting a *lot* of bugs, which may or may not have code, vs. "Here's 5 bugs with patches, please review this week"
12:25:26 <david-lyle> The main problem from my point of view is that we have gotten way behind on the bug triage and classification in Horizon
12:25:43 <robcresswell> Yeah
12:25:44 <david-lyle> ideally we could use lauchpad to track, if things are up to date
12:26:01 <david-lyle> so there are a few option...
12:26:27 <mrunge> we == OpenStack community used to have a few issues with launchpad we tried to solve with Storyboard
12:26:39 <david-lyle> 1) have a report to work around the larger issue and still provide value
12:27:08 <david-lyle> 2) get our house in order using some bug days
12:27:19 <robcresswell> It's not like the two are mutually exclusive. I can spend a few minutes each week producing a short report while we clean up LP, and then we can use that if its preferable.
12:27:36 <david-lyle> 3) get our house in order and have a report/list to prioritize the highest priority issues of the day
12:27:49 <mrunge> #vote 3
12:28:23 <doug-fish> david-lyle: does "get our house in order" mean to get bugs traiged and up to date?
12:28:23 <robcresswell> The wiki is just a neater option of shouting out the high priorities each meeting, which several other projects do.
12:28:30 <david-lyle> doug-fish: yes
12:28:41 <r1chardj0n3s> I'm all for that
12:28:45 <doug-fish> yes, that sounds sensible
12:28:59 <r1chardj0n3s> focused bug days can help with that
12:29:18 <david-lyle> robcresswell: I have no issue with the wiki, I think it has value, but the fact that we have >50 untriaged bugs (guessing at the number) is scary
12:29:43 <robcresswell> Cool
12:29:55 <tsufiev> +1 for wiki
12:30:11 <tsufiev> I'm not sure if bug days work
12:30:14 <r1chardj0n3s> the wiki is a cool idea too
12:30:15 <david-lyle> once we have gone through the pain to catch up, as long as people pay attention the maintenance cost will be must less
12:30:37 <david-lyle> tsufiev: ?
12:31:12 <robcresswell> Sure. For now then, I'll update this each week and we can call it out briefly in the weekly meeting.
12:31:17 <david-lyle> people come try to focus on, discuss and triage bugs, what's not to work?
12:31:20 <tsufiev> david-lyle, I mean asking people to just fix bugs on, say Wednesday, - this looks dubious to me
12:31:33 <david-lyle> no fixing needed on the bug day
12:31:39 <r1chardj0n3s> tsufiev: nothing stopping you also working on bugs on other days
12:31:52 <tsufiev> ah, okay, so I got this concept wrong
12:32:08 <david-lyle> a lot of it is just confirming or asking for more information
12:32:11 <r1chardj0n3s> tsufiev: but sometimes people need a nudge to think about dealing with or even triaging bugs, and having a day to do so can help
12:32:30 <tsufiev> then no objections from my side
12:32:33 <david-lyle> or noting that this bug is two years old, and has been fixed for 18 months
12:32:41 <robcresswell> lol
12:32:47 <doug-fish> let's hope for many of those!
12:33:11 <robcresswell> doug-fish: They're a royal PITA, having to track down ancient commits.
12:33:40 <Anticimex> the timeout issue is merged to master, but we ran stable/kilo and i miss it there
12:33:42 <r1chardj0n3s> needs some experience with the project, is all
12:33:46 <doug-fish> I was thinking about just asserting that it's fixed and seeing if the original bug owner complained
12:33:55 <doug-fish> that's much easier
12:33:59 <doug-fish> :-)
12:34:02 <r1chardj0n3s> doug-fish: solid plan!
12:34:08 <david-lyle> do people have a day preference
12:34:18 <ducttape_> it seems appropriate to at least try to reproduce, if easy / possible ;)
12:34:26 <r1chardj0n3s> doug-fish: in all seriousness, I have poked at bugs asking people to confirm it's still an issue after failing to reproduce the problem
12:34:32 <david-lyle> would be nice to have one before the summit, will help in prioritization
12:34:43 <robcresswell> doug-fish: Heh, true, I tend to like linking proof if possible, which starts to up the time investment quite quickly, and perhaps it was only "90% fixed"
12:34:46 <doug-fish> r1chardj0n3s: agreed. that's completely reasonable
12:35:15 <doug-fish> robcresswell: IMO you are overacheiving! if it works, just say its fixed
12:35:18 <david-lyle> ducttape_: yes, that's part of the confirmation testing in my mind
12:35:32 <robcresswell> doug-fish: Yessir :)
12:35:35 <david-lyle> doug-fish: at times there are nuances
12:35:42 <david-lyle> but for the most part yes
12:36:21 <david-lyle> monday and fridays are out due to date lines
12:36:25 <r1chardj0n3s> david-lyle: I reckon just pick your least-favourite day next week and declare that the first bug-bash day :)
12:36:32 <doug-fish> do we have an outline of what is expected to happen during bug traige
12:36:33 <david-lyle> so tues, wed or thurs?
12:36:51 <tsufiev> Tuesday
12:37:11 <doug-fish> Wed is best for me
12:37:14 <robcresswell> Tuesday suits me.
12:37:25 <david-lyle> doug-fish: I think there is a general wiki page for openstack somewhere
12:37:32 <doug-fish> https://wiki.openstack.org/wiki/BugTriage
12:37:46 <david-lyle> looky there
12:37:52 <doug-fish> :-)
12:38:14 <david-lyle> I was just G'ingTFY
12:38:55 <r1chardj0n3s> the bug basj also needs an etherpad for folks to note bugs they're looking at, and what the outcome of their investigation is (and whether someone with more specific knowledge should take a look)
12:39:12 <david-lyle> r1chardj0n3s: good point
12:39:26 <david-lyle> and use the horizon room for discussion
12:40:18 <fnordahl> I would love to join in on bug bashing. wed or thurs is better than tue for me
12:40:27 <fnordahl> depending on time (and zone)
12:41:03 <tsufiev> actually, any day would suffice
12:41:45 * tsufiev meant himself
12:41:50 <david-lyle> let's make it Wed then
12:41:54 <david-lyle> robcresswell: ok with you?
12:41:55 <mrunge> since Wed is already full of horizon meetings....
12:42:04 <robcresswell> So, Confirming is checking the validity of the bug, and Triaging is checking the content of the bug and confirming it?
12:42:14 <robcresswell> david-lyle: Yeah, I just have most of my meetings wednesdays.
12:42:22 <robcresswell> Plus 2 hours of horizon meetings.
12:42:35 <robcresswell> Days are too short.
12:43:03 <doug-fish> robcresswell: I think the wiki has a pretty good outline
12:43:16 <doug-fish> of bug maintenance that should be done
12:43:20 <doug-fish> no fair skipping to the end!
12:43:38 <david-lyle> I do use the term triage more generally, to be fair
12:44:07 <david-lyle> I think in the wiki, triage is so far as understanding the fix and documenting it, IIRC
12:44:34 <david-lyle> I'm looking more for step one, admitting you have a problem :P
12:44:56 <doug-fish> :-)
12:44:56 <david-lyle> and then indicating how severe it is
12:45:21 <robcresswell> So focus on confirming and setting status
12:45:34 <robcresswell> and setting importance*
12:45:37 <tsufiev> david-lyle, if someone clearly uinderstands the bug and fix, why he won't fix it :)?
12:45:51 <robcresswell> tsufiev: Code takes time :)
12:46:02 <david-lyle> tsufiev: a couple of reasons
12:46:28 <david-lyle> code does take time, and we're looking at 300 bugs
12:47:04 <david-lyle> 2) it's nice to leave low hanging fruit for people new to the community to provide simpler things to work on
12:47:31 <tsufiev> sounds reasonable. Still for most tricky bugs Triaging sometimes may take up to 50-70% of time spend on coding the fix
12:47:43 <fnordahl> +1 recruitment is very important. we won't stay as agile and lean as we are now forever.
12:48:04 <david-lyle> sometimes people don't want to follow a patch through the process either
12:48:41 <david-lyle> ducttape_ often post a fix in launchpad but not on gerrit
12:48:42 <r1chardj0n3s> tsufiev: the doa thing is a good example of knowing exactly what the problem was, but the fix being tricky (or very expensive)
12:48:44 <david-lyle> for that reason
12:49:16 <david-lyle> ok, I will send out an email for a Web bug day for Horizon
12:49:22 <david-lyle> *Wed
12:49:44 <david-lyle> #action david-lyle email about Horizon bug day on Wed
12:50:08 <fnordahl> david-lyle: e-mail to the general mailing-list or do you have a private one stashed?
12:50:11 <r1chardj0n3s> so now I have to choose whether I do the bug day on my Wednesday or wait until Thursday which will be at the end of your bug day :)
12:50:19 <fnordahl> s/general/dev
12:50:49 <david-lyle> r1chardj0n3s: preference?
12:51:06 <david-lyle> I'll email a time range in UTC
12:51:17 <r1chardj0n3s> actually, waiting until my Thursday means I do the bug day after I attend the Horizon meeting (which is 6am my time Thursday)
12:51:25 <r1chardj0n3s> so that could actually be good, help me be more focused
12:52:01 <r1chardj0n3s> How about you just declare it "Wednesday" and see how that rolls, rather than dictate a time range?
12:52:29 <david-lyle> I can do that too, just hoping someone else in a TZ close to you might participate too
12:52:34 <r1chardj0n3s> helll, I'll probably have a Wednesday And Thursday Bug Day, just to one-up everyone ;)
12:52:41 <tsufiev> local TZ Wednesday is a chance for a bug day to last longer than 24 hours :)
12:52:51 <r1chardj0n3s> tsufiev: yep :)
12:53:02 <david-lyle> ok, will remain vague and shifty
12:53:07 <fnordahl> hehe
12:53:09 <r1chardj0n3s> heh
12:53:13 <david-lyle> #topic Open Discussion
12:53:34 <r1chardj0n3s> so who knew that people ran Horizon over an actual database?
12:53:39 <r1chardj0n3s> that was a surprise for me
12:53:41 <robcresswell> hahaha
12:53:44 <doug-fish> \o
12:53:45 <r1chardj0n3s> I wonder whether we should test for that :)
12:53:56 * david-lyle hangs head
12:54:01 <r1chardj0n3s> \o/
12:54:15 <doug-fish> r1chardj0n3s: along those lines - I was surprised that people upgrade Horizon in place and hope to keep sessions alive
12:54:19 <mrunge> r1chardj0n3s, I do. from time to time
12:54:31 <mrunge> doug-fish, +1
12:54:31 <r1chardj0n3s> I've just had most of a week's vacation, so I'm fulla happy :)
12:54:42 <r1chardj0n3s> doug-fish: that's just plain odd, yeah
12:54:43 <robcresswell> I knew about the db part, but dougs point about keeping sessions surprised me too.
12:55:01 <r1chardj0n3s> indeed, thinking about "migrating" horizon's database just makes me think "why"...
12:56:07 <david-lyle> that part is new to me too
12:56:23 <david-lyle> I suppose if you're augmenting the model???
12:56:54 <david-lyle> or have monitoring accounts with really long token life spans
12:56:58 <r1chardj0n3s> the session model? that is the only thing being actually stored in the db, yeah?
12:57:44 <robcresswell> It might be easier to just ask eric what wizardry he has created
12:57:45 <david-lyle> r1chardj0n3s: not entirely sure
12:57:58 <robcresswell> Since it seems he may be the only person on Earth doing this
12:58:07 <r1chardj0n3s> yeah
12:58:09 <doug-fish> Didn't Lin find the same issue?
12:58:14 <r1chardj0n3s> (on the first part, no idea about the second)
12:58:32 <david-lyle> he's just closer to master than the rest
12:58:43 <david-lyle> other's will find it I'm sure
12:59:03 <robcresswell> Likely just my isolation from deployers speaking.
12:59:14 * robcresswell hides in the IRC channel all day
12:59:24 <doug-fish> I recall Eric demo-ed his ability to quickly spin up new Horizons at the mid-cycle
12:59:42 <doug-fish> I guess if those all have the same config, pointing to the same session storage this will happen
13:00:23 <david-lyle> time's up. Take a look at the wiki page robcresswell posted
13:00:32 <david-lyle> Thanks everyone and have a great week.
13:00:35 <david-lyle> #endmeeting