12:01:08 <david-lyle> #startmeeting Horizon
12:01:09 <openstack> Meeting started Wed Aug  5 12:01:08 2015 UTC and is due to finish in 60 minutes.  The chair is david-lyle. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:01:12 <openstack> The meeting name has been set to 'horizon'
12:01:35 <david-lyle> anyone here to talk Horizon?
12:01:50 <tsufiev> mostly to listen )
12:02:07 <r1chardj0n3s> Hi
12:02:17 <mrunge> hey o/
12:02:42 <r1chardj0n3s> I was going to talk about the domain stuff but I picked your brain about it earlier :-)
12:03:05 <robcresswell> o/
12:04:31 <david-lyle> General items first and then chaos
12:04:40 <david-lyle> as no one added agenda items
12:04:53 <david-lyle> L-2 was tagged last week
12:05:10 <david-lyle> https://launchpad.net/horizon/liberty/liberty-2
12:06:01 <david-lyle> our pace on blueprints is down from Kilo, not sure the reason why
12:06:25 <r1chardj0n3s> so much refactoring
12:06:35 <david-lyle> maybe thicker blueprints
12:06:44 <r1chardj0n3s> I think we've finally finished the eslint twiddling tho, so there's that
12:06:45 <david-lyle> and refactoring
12:06:53 <robcresswell> \o/
12:07:09 <r1chardj0n3s> just a few of those still to be merged, but I believe the substantive work is all done
12:07:18 <robcresswell> Now we can have some content? :p
12:07:20 <r1chardj0n3s> (if robcresswell was looking for something to review... ;)
12:07:26 <robcresswell> On it.
12:07:33 <r1chardj0n3s> haha, I'm sure we can find some more files to rename first!
12:07:42 <david-lyle> I have a feeling L-3 is going to be frenzied
12:07:54 * tsufiev votes for topology stuff
12:08:06 <r1chardj0n3s> because I'm an idiot, I'm focusing on getting our damned selenium suite fixed :/
12:08:49 <david-lyle> tsufiev: curvature is getting some final tweaks before merging, I think we're close though
12:09:28 <david-lyle> #topic Review Liberty Priorities
12:09:43 <david-lyle> #link https://etherpad.openstack.org/p/YVR-horizon-liberty-priorities
12:10:28 <david-lyle> so a lot of the tech debt items are far along
12:11:46 <david-lyle> for plugins, work continues. I have a patch up to make horizon load content only via enabled files
12:12:03 <david-lyle> the mixed model made testing difficult
12:12:19 <robcresswell> I saw that. Interesting patch.
12:12:19 <david-lyle> lhcheng is working on moving trove
12:13:08 <david-lyle> and plugin docs is still a WIP on my end
12:13:51 <david-lyle> session cleanup has a patch proposed that needs review
12:14:01 <masco> have any link for plugin docs?
12:14:14 <david-lyle> and the eslint work is close to completion, finally
12:14:31 <david-lyle> masco: only local copy will push soon for more eyes
12:14:48 <masco> david-lyle, ok no problem.
12:15:08 <david-lyle> Django 1.8 support is turning into an onion
12:15:16 <mrunge> yes
12:15:21 <doug-fish> stinky?
12:15:28 <david-lyle> and lhcheng is peeling away layers
12:15:41 <david-lyle> building on work started by mrunge
12:16:12 <david-lyle> we need to land that in time to roll g-r to include 1.8
12:16:15 <tsufiev> hope it doesn't make him cry )
12:16:38 <david-lyle> so we can't let that one go to the very end as g-r freezes about 2 weeks before L-3
12:16:44 <mrunge> david-lyle, it's one of my highest prios right now
12:16:52 <david-lyle> excellent
12:17:23 <david-lyle> I will also give a plug for trove and sahara reviews
12:17:42 <david-lyle> #link https://etherpad.openstack.org/p/sahara-reviews-in-horizon
12:18:09 <david-lyle> #link https://etherpad.openstack.org/p/trove-reviews-in-horizon
12:18:49 <david-lyle> for both trove and sahara, I consider +1s from the service team and 1 +2 sufficient to approve
12:19:18 <david-lyle> so horizon cores, if there are positive reviews from the team and looks good to you, go ahead and approve
12:19:42 <mrunge> got you
12:19:47 <robcresswell> Got it
12:19:49 <david-lyle> they have a lot of work there that's struggling to get into Horizon
12:20:15 <david-lyle> eventually that will be part of the documentation :)
12:20:37 <david-lyle> Last general update
12:20:50 <david-lyle> Domain scoped tokens in the sessions are very close
12:21:17 <david-lyle> one last bit of logic encapsulation and the d-o-a patch will be ready
12:21:30 <mrunge> great!!
12:21:33 <david-lyle> and then there's a fairly good sized Horizon patch to consider
12:21:39 <masco> superb
12:23:08 <david-lyle> there has been active ongoing discussion which you can track here:
12:23:14 <david-lyle> #llink https://etherpad.openstack.org/p/domains_planning
12:23:20 <david-lyle> #link https://etherpad.openstack.org/p/domains_planning
12:23:25 <david-lyle> less l this time
12:23:47 <david-lyle> that's the priorities wrap up
12:23:56 <david-lyle> I think we're actually pretty close on most
12:24:19 <david-lyle> oh and I will be releasing a new release for d-o-a in kilo soon
12:24:42 <david-lyle> and d-o-a for liberty as soon as domain support goes in
12:25:05 <david-lyle> would like to have 1.8 support in that release as well, but I'll need to monitor the timing
12:25:14 <david-lyle> #topic Open Discussion
12:25:42 <tsufiev> david-lyle, what do you think about the chances to backport WEBROOT fix into Kilo?
12:26:02 <mrunge> tsufiev, do you have a link?
12:26:10 <tsufiev> mrunge,  I've started it here: https://review.openstack.org/#/c/209108/
12:26:24 <tsufiev> still WIP, I hope to make a final version in few days
12:26:32 <david-lyle> I'm worried with all the moving files it won't be clean, but I haven't looked at your patch yet
12:26:44 <mrunge> tsufiev, it fixes broken behavior.
12:26:58 <mrunge> but as david mentioned, lot's of files moving around
12:27:02 <tsufiev> mrunge, okay, I take it as chances are good enough )
12:27:31 <david-lyle> that files moved just makes it more difficult, but I think it makes sense to backport
12:27:40 <mrunge> yes, same here
12:27:59 <mrunge> launch instance is broken in kilo, when not using / as webroot
12:28:17 <david-lyle> oh I have a patch to devstack to move it by default
12:28:19 <mrunge> glance metadata is broken in kilo, too
12:28:28 * david-lyle shamelessly self-promoting
12:28:40 <mrunge> link? or it didn't happen... :D
12:28:46 <tsufiev> mrunge,  yeah, we encountered all these issues in our distro Horizon
12:28:58 <david-lyle> #link https://review.openstack.org/#/c/206263/
12:29:22 <david-lyle> things keep moving under me and I need to fix up the offline compression
12:29:26 <mrunge> tsufiev, I believe you. that's the reason we're still with old launch instance
12:29:49 <david-lyle> once I have that working again I think it will be ready
12:30:03 <mrunge> great, thank you david-lyle
12:30:27 <david-lyle> but that will help us prevent future breakages
12:30:38 <mrunge> yes!
12:30:41 <david-lyle> or at least get quicker feedback
12:30:51 <mrunge> and maybe we should change location from time to time?
12:30:58 <david-lyle> it also fixes the fact that keystone now stomps on our users page URL
12:31:21 <mrunge> I mean, move from /dashboard to /horizon to / to ....
12:31:22 <david-lyle> hurgleburgler has a patch to make that easier
12:31:55 <david-lyle> #link https://review.openstack.org/#/c/206592/
12:32:09 <tsufiev> david-lyle, btw, I suspect that the problem with OFFLINE_COMPRESS on devstack may be caused by CUSTOM_THEME_PATH, so Diana's patch may fix it
12:32:16 <david-lyle> I've been fighting other first so I need to review it
12:32:38 <david-lyle> tsufiev: it was working before the patch to the themes changed
12:33:33 <david-lyle> but yes it should help a great deal
12:34:13 <david-lyle> oh yeah, forgot to mention, robcresswell excised the router dashboard from the horizon tree
12:34:31 <david-lyle> and moved it to its own repo
12:34:51 <david-lyle> seems like that should've been a blueprint
12:38:57 <david-lyle> anyone have anything else?
12:39:25 <robcresswell> david-lyle: It was a blueprint
12:39:39 <robcresswell> david-lyle: Just a partial one; still want to remove the rest of the Cisco code
12:39:42 <mrunge> uhm, do we need a more regular blueprint review process?
12:40:07 <david-lyle> mrunge: most likely :)
12:40:19 <mrunge> I mean, reviewing blueprints is a question coming up from contributors
12:40:55 <mrunge> current status is a bit undefined, leaving ALL blueprints in a semi-accepted state
12:41:50 <robcresswell> So that's one thing I've actually spent very little time on since being core, admittedly. Mainly done bug cleanup and reviews.
12:42:00 <robcresswell> How much discussion/ group acceptance does a blueprint need?
12:42:33 <robcresswell> Can a core approve it? Or do they all need to be brought up on mailer/ meeting, which is what I tend to advise people who ask.
12:43:04 <david-lyle> so for Kilo I tried to get more reviews from across the horizon team and horizon drivers, that was short lived
12:43:16 <david-lyle> robcresswell: any core can approve a BP
12:43:36 <mrunge> back in the old days(R), you proposed a blueprint, and submitted code for it. once code was approved, bp was approved
12:43:37 <david-lyle> some need more discussion than others, but that's a judgement call
12:44:34 <mrunge> there is a whiteboard field in blueprints. just write down your thoughts on that bp
12:44:55 <robcresswell> At the moment, aside from the bigger BPs, most seem to be left and just used as tracking for bigger features.
12:45:12 <robcresswell> Yeah, will put some more time into BP review
12:45:45 <david-lyle> a couple of things from my point of view
12:46:05 <david-lyle> I don't like a heavy handed process around adding new feature support
12:46:21 <david-lyle> I do think architectural changes make sense to review in BP
12:46:48 <david-lyle> but we don't have a stable API to maintain, and that makes our life easier, I think
12:47:14 <david-lyle> and if you don't have code for your proposal, it's not worth a whole lot yet
12:47:54 <david-lyle> but I understand that with other services without approval, you shouldn't even start, so that makes it confusing
12:48:02 <masco> so we have to start work on the BP before it get approve?
12:48:24 <david-lyle> masco: no, but we have 400+ bps
12:48:40 <david-lyle> many of those are approved and never moved anywhere
12:48:47 <robcresswell> Sounds reasonable, I'll keep those points in mind
12:48:58 <david-lyle> so getting the bp approved doesn't move us very far without the code
12:49:16 <masco> ok got it
12:49:31 <david-lyle> the other option is we could schedule something to regularly review bps
12:49:39 <david-lyle> and try to stay on top of it
12:49:49 <masco> makes sense
12:50:15 <david-lyle> but I really dislike having a huge bundle of inactive approved bps
12:50:29 <masco> if it is in top it will get attention
12:50:51 <mrunge> we could try to clean up old blueprints
12:51:01 <mrunge> I think, there are still many duplicates
12:51:10 <david-lyle> masco some times it just takes a ping to say, "no, I'm actually serious about this one"
12:51:10 <masco> by doing some activity the submitter can bring in to top
12:51:48 <david-lyle> mrunge: I cleaned some up
12:51:56 <david-lyle> not near enough
12:52:03 <robcresswell> I'd be up for that, scheduling something to run through them
12:52:11 <david-lyle> problem is I start going through them and think, we really should do this
12:52:17 <david-lyle> :)
12:52:43 <masco> you have think that before approve ;)
12:52:54 <mrunge> same here david-lyle , still there are too many. and most of them are really good
12:53:00 <david-lyle> well some are from 2013
12:53:06 <david-lyle> and we still haven't done them
12:53:15 <david-lyle> but we should
12:53:45 * david-lyle mumbles about linting and bit twiddling
12:54:54 <david-lyle> limited sample, but who's in favor of regularly reviewing in a meeting setting
12:55:13 <r1chardj0n3s> sounds good to me. timezone permitting ;)
12:55:15 <david-lyle> #startvote review bps in regular meeting ? yes, no
12:55:16 <openstack> Begin voting on: review bps in regular meeting ? Valid vote options are yes, no.
12:55:17 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
12:55:24 <r1chardj0n3s> #vote yes
12:55:25 <mrunge> #vote yes
12:55:31 <robcresswell> #vote yes
12:55:32 <tsufiev> #vote yes
12:55:34 <masco> #vote yes
12:55:56 <david-lyle> #vote yes
12:56:00 <mrunge> :D
12:56:05 <david-lyle> #endvote
12:56:06 <openstack> Voted on "review bps in regular meeting ?" Results are
12:56:07 <openstack> yes (6): robcresswell, mrunge, masco, r1chardj0n3s, david-lyle, tsufiev
12:56:12 <david-lyle> so no then
12:56:15 <david-lyle> :P
12:56:22 <r1chardj0n3s> (having the regular meetings really helped some kilo stuff along, I see no reason why it couldn't also help other things along)
12:56:43 <david-lyle> ok, I will schedule a time
12:56:50 <mrunge> awesome
12:56:58 <david-lyle> do we want alternating TZs I suppose?
12:57:14 <david-lyle> really the only way any more
12:57:40 <r1chardj0n3s> mmm
12:57:46 <mrunge> alternate like our weekly meeting, but the other way around?
12:58:06 <mrunge> like: today, 20:00 UTC a bp meeting?
12:58:14 <david-lyle> sure, we could that
12:58:24 <mrunge> just a thought
12:58:47 <mrunge> not sure it is the brightest idea ever, since sliced bread
12:58:54 * robcresswell foresees confusion
12:59:14 * mrunge too, but you just need to remember: horizon meeting
12:59:17 <robcresswell> review meeting in alternating tzs then
12:59:20 <doug-fish> I like it
12:59:35 <mrunge> either bp review or weekly meeting
12:59:47 <david-lyle> let's start next week, so I have time to send an email and get people informed
13:00:33 <masco> and we have to come with a list of BPs to review on that day either via wiki link or eitherpad
13:00:33 <mrunge> cool
13:00:43 <david-lyle> I will send said email
13:00:53 <david-lyle> and we're out of time
13:01:00 * r1chardj0n3s heads off to bed
13:01:02 <r1chardj0n3s> o/ all
13:01:12 <david-lyle> #action schedule/email about bp review meeting
13:01:16 <mrunge> good night r1chardj0n3s
13:01:17 <david-lyle> #undo
13:01:18 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0xa50c810>
13:01:34 <david-lyle> #action david-lyle schedule/email about bp review meeting
13:01:43 <david-lyle> Thanks everyone
13:01:49 <david-lyle> #endmeeting