20:01:30 <lhcheng> #startmeeting Horizon
20:01:31 <openstack> Meeting started Wed Apr 22 20:01:30 2015 UTC and is due to finish in 60 minutes.  The chair is lhcheng. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:35 <openstack> The meeting name has been set to 'horizon'
20:01:41 <rhagarty> hello
20:01:45 <lhcheng> hello everyone
20:01:52 <gary-smith_> hi
20:02:00 <mrunge> hello
20:02:07 <TravT> o/
20:02:09 <cbader> hi
20:02:46 <mattfarina> howdy
20:02:58 <jgravel> hello
20:03:14 <david-lyle> o/
20:03:41 <lhcheng> will for a minute for people to trickle in
20:03:42 <lhcheng> #chair david-lyle
20:03:43 <openstack> Current chairs: david-lyle lhcheng
20:04:32 <david-lyle> ok, Let's get rolling now that tqtran_afk is gone :P
20:04:51 <tqtran_afk> lol sorry have a dentist app
20:04:56 <TravT> haha
20:04:57 <tqtran_afk> cindy has agreed to take over
20:04:59 <david-lyle> no worries
20:05:08 <david-lyle> enjoy
20:05:40 <lhcheng> #topic General
20:06:02 <david-lyle> So we have opened RC-2 mostly for translation and a few opportunistic bug fixes
20:06:06 <lhcheng> #link https://launchpad.net/horizon/+milestone/kilo-rc2
20:06:57 <adurbin_> I'm not sure if this is the correct time to ask, is the window open to submit/request a fish-bowl talk for the vancouver summit?
20:07:09 <lhcheng> I see there are 5 bugs that are tagged as rc-potential: https://bugs.launchpad.net/horizon/+bugs?field.tag=kilo-rc-potential
20:07:15 <david-lyle> adurbin_, we'll cover that in a minute
20:07:58 <david-lyle> doug-fish, o/
20:08:06 <adurbin_> david-lyle: ok, thanks
20:08:18 <lhcheng> are those bug still to be determined if we want to include them for rc2?
20:08:18 <doug-fish> david-lyle: did we win?
20:08:49 <david-lyle> lhcheng, doug-fish, doug-fish has a couple of bugs that are string changes on that list
20:09:07 <david-lyle> the csv one certainly didn't make it to translators and I -2'd it
20:09:18 <david-lyle> wasn't sure about the admin state one
20:09:39 <david-lyle> since it's a previously translated string, I wasn't sure
20:09:51 <david-lyle> wondeing if the mapping is there in the .po file
20:10:05 * david-lyle also wondering
20:10:16 <doug-fish> oh yes -  I don't think there is any new translation for the Admin State fix
20:10:21 <lhcheng> not sure, worst case if will just default to english
20:10:32 <david-lyle> which it already does
20:10:35 <doug-fish> it's pointing to the existing translations
20:10:35 <lhcheng> doesn't break anything
20:10:40 <david-lyle> so we can probably approve that
20:11:12 <lhcheng> sounds good to me
20:11:46 <david-lyle> ok I +2'd it, I'll let ttx, approve it
20:12:29 <lhcheng> okay, targetted the bug for Kilo too.
20:12:35 <david-lyle> thanks
20:14:49 <david-lyle> ok, everything should be set now for RC-2
20:14:58 <david-lyle> translations should be ready tomorrow
20:15:04 <david-lyle> then we'll wrap Kilo
20:15:08 <david-lyle> \o/
20:15:23 <TravT> \o/
20:15:43 <david-lyle> it does look like we'll get another requirements bump
20:15:55 <david-lyle> glanceclient apparently not ideal
20:16:03 <lhcheng> so the other 3 bugs tagged for rc-potential, we won't be adding them to RC-2?
20:16:18 <david-lyle> they don't have patches merged on master do they?
20:16:46 <lhcheng> no, 2 still in progress, 1 haven't started
20:17:01 <gary-smith_> https://review.openstack.org/#/c/128133/ is just waiting for core reviews
20:17:01 <david-lyle> mrunge, I couldn't reproduce this one
20:17:08 <david-lyle> have you reverified?
20:17:18 <mrunge> david-lyle, sorry?
20:17:33 <david-lyle> you filed a bug regarding nova-net
20:17:43 <mrunge> sorry, I didn't had a minute to look at that
20:17:56 <david-lyle> ok, let me know if you can reproduce
20:18:04 <mrunge> so, I guess it's either not a bug, or we'll hear from users
20:18:20 <david-lyle> I'm hoping for the former
20:18:27 <mrunge> yes, me too
20:18:27 <mattfarina> david-lyle can we get https://review.openstack.org/#/c/128133/ into rc2 if it's ready?
20:18:55 <mrunge> david-lyle, thank you for looking into that
20:19:19 <david-lyle> mrunge if you can repro, we need to fix
20:19:23 <david-lyle> for kilo
20:19:28 <mrunge> sure
20:19:34 <david-lyle> anyone else testing with nova-net
20:19:42 <david-lyle> lhcheng?
20:19:42 <lhcheng> mrunge: that bug is from using the existing launch instance?
20:19:46 <david-lyle> yes
20:19:50 <mrunge> lhcheng, yes
20:19:57 <david-lyle> wonder if it was glanceclient related
20:19:58 <lhcheng> I'll try it out after the meeting
20:19:59 <mrunge> current lauch instance
20:20:14 <david-lyle> I'll try again tomorrow
20:20:15 <mrunge> new launch instance renders just a white screen
20:20:27 <mrunge> I didn't file a but for that
20:20:34 <david-lyle> really?
20:20:38 <lhcheng> it's experimental :P
20:20:47 <mrunge> no bug to see
20:20:48 <david-lyle> we're settling on a shade of white
20:20:58 <mrunge> that was rc1
20:21:09 <TravT> mrunge: would like to know more about that.
20:21:28 <mrunge> let's move that to #openstack-horizon please
20:21:35 <TravT> sounds good
20:21:43 <david-lyle> mattfarina, I've meant to look into that.
20:22:05 <mattfarina> david-lyle it's a regression that would be nice to have fixed. otherwise some of us will need to carry that change
20:22:17 <gary-smith_> mattfarina: +1
20:22:57 <david-lyle> does it effect only editing the local_settings.py to add the dashboard, or the plugin mechanism via local/enabled as well?
20:23:12 <david-lyle> s/does it effect/is it seen/
20:23:27 <gary-smith_> I see it when usnig local/enabled
20:23:29 <jwy> david-lyle: it's to fix a bug in the plugin mechanism
20:23:41 <david-lyle> ok, I'll review today
20:23:54 <jwy> thanks
20:24:15 <david-lyle> lhcheng, that's your backyard, can you take a look too?
20:24:21 <jwy> i've seen people asking about that bug in the horizon channel a few times
20:24:34 <david-lyle> we're building interest :)
20:24:42 <jwy> been affecting a number of folks
20:24:59 <david-lyle> we should try to get that in
20:25:22 <gary-smith_> fyi, The instructions for installing manila-ui require manually applying 128133 (https://github.com/hp-storage/manila-ui/blob/master/README.rst)
20:25:26 <lhcheng> david-lyle: yeah, been reviewing that initially. got distracted with other stuff
20:25:36 <lhcheng> I'll look at it later
20:25:40 <david-lyle> but does it rebreak the issue that caused a patch creating the regression
20:25:41 <david-lyle> ?
20:25:56 <david-lyle> will review and see
20:25:59 <david-lyle> moving on
20:26:08 <jwy> no, the intial issue is also addressed by the patch
20:26:18 <jwy> er, original issue
20:26:24 <david-lyle> jwy, ok, thanks, that flew under my radar a bit
20:26:50 <david-lyle> we have a day or so to get it landed
20:27:01 <david-lyle> depending on when translations lannd
20:27:43 <david-lyle> I'm still working on the specs repo
20:27:56 <david-lyle> hope to have more progress reported soon, been traveling
20:28:57 <david-lyle> Moving on to the agenda which I'm prepending a topic onto
20:29:03 <david-lyle> #topic summit planning
20:29:45 <david-lyle> topic proposal etherpad up #link https://etherpad.openstack.org/p/horizon-liberty-summit
20:29:59 <david-lyle> please propose your ideas there in the next week
20:30:11 <david-lyle> and then we'll start picking topics
20:30:32 <david-lyle> remember we have 3 fishbowl sessions, 8 working sessions and all day Friday
20:30:39 <TravT> Do you know the days and times for the session allocation?
20:30:43 <david-lyle> so propose working session topics there too
20:30:54 <david-lyle> TravT yes
20:30:55 <david-lyle> :P
20:31:11 <david-lyle> #link https://docs.google.com/spreadsheets/d/1VsFdRYGbX5eCde81XDV7TrPBfEC7cgtOFikruYmqbPY/edit#gid=569963128
20:31:16 <david-lyle> from the ML
20:31:40 <TravT> thanks, added that link to the etherpad
20:31:41 <david-lyle> recent change in Horizon schedule to free up Thursday afternoon Horizon talk time
20:31:57 <david-lyle> mrunge, when is you talk?
20:32:01 <david-lyle> *your
20:32:04 <mrunge> monday
20:32:10 <david-lyle> no conflicts then
20:32:11 <david-lyle> good
20:32:44 <mrunge> david-lyle, I don't see, why we have two talks with nearly the same topic
20:32:55 <david-lyle> we'll start sorting topics next week and try to begin placing them
20:33:08 <david-lyle> mrunge, shrug
20:33:16 <david-lyle> latter will focus much more angular side
20:33:28 <david-lyle> I don't think they'll overlap too much
20:33:45 <david-lyle> unless you're talking angular in Horizon
20:33:49 <mrunge> yeah, makes sense. I will skip that completely
20:33:58 <mrunge> and will point folks to your talk
20:34:07 <david-lyle> perfect
20:34:22 <david-lyle> any questions on the summit?
20:35:37 <mrunge> will we have a contributor meetup?
20:35:39 <TravT> So, Thursday afternoon is like extra contributor meetup?
20:36:14 <doug-fish> mrunge: you mean like, meet informally over a drink before the summit starts?
20:36:21 <mrunge> yes!
20:36:25 <TravT> +1
20:36:27 <doug-fish> +1!
20:36:59 <doug-fish> My flight arrives kind of early on Sunday, so I'd be up for that.
20:37:16 <mrunge> I'll be in late on Sunday, count me in
20:37:23 <clu_> +1
20:37:31 <mrunge> doug-fish, glad you'll manage to come
20:37:55 <doug-fish> well let's hope I don't break anything between now and then.  :-)
20:38:00 <david-lyle> so session types, non-program f2f pre-summit, fishbowl, working (40 minute smaller group), contributor meetup (all day Friday)
20:38:03 <doug-fish> I'm looking forward to it.
20:38:47 <david-lyle> somebody pick a venue for the pre-summit
20:39:26 <david-lyle> TravT, I'm not entirely sure your question
20:39:48 <TravT> david-lyle: above you said something about freeing up time Thursday for Horizon talks.
20:39:56 <TravT> Did you mean the conference presentations?
20:40:00 <david-lyle> TravT, you're presenting
20:40:21 <david-lyle> 5 people are that would be a sizeable chunk
20:40:22 <TravT> lol - yeah, i just wasn't quite sure
20:40:31 <david-lyle> it overlapped with a working session
20:40:34 <TravT> ok.
20:40:50 <david-lyle> if you hadn't looked before, I probably couldn't have said anything :P
20:41:13 <TravT> lol... no I hadn't looked at the design summit schedule before.
20:41:14 * david-lyle has no idea what tense I'm typing in
20:41:24 <david-lyle> all I think
20:41:34 <david-lyle> equal opportunity tense
20:41:49 <david-lyle> ok, there was another topic on the agenda
20:42:11 <david-lyle> #topic Jshint undef and unused clean up for legacy code, should we do it? (tqtran)
20:42:39 <david-lyle> clu_, did tqtran_afk pass this off to you?
20:42:52 <clu_> david-lyle: yes
20:43:05 <clu_> he ran off before i could say no :)
20:43:10 <david-lyle> haha
20:43:16 <david-lyle> ok, unconfuse me
20:43:22 <david-lyle> what is the question
20:44:04 <clu_> he wants to know see if everyone is ok with adding to 2 flags
20:44:11 <lhcheng> I think tqtran_afk want to add the undef and unusued variable in jshint
20:44:19 <clu_> to check for unused variables and such
20:44:21 <clu_> yep
20:44:25 <lhcheng> but it fails on a lot of the old javascript code
20:44:40 <david-lyle> oh, so go hack up all the legacy code?
20:44:48 <david-lyle> (boom)
20:44:52 <asahlin> * turn on flags but ingore legacy javascript
20:45:02 <lhcheng> yup
20:45:12 <asahlin> I think that was tqtran's proposal.
20:45:17 <david-lyle> wait turn on and ignore
20:45:18 <david-lyle> ?
20:45:22 <david-lyle> won't that be noisy
20:45:33 <david-lyle> or not checking the legacy code?
20:45:37 <mattfarina> we still work on the legacy code... jshint should still be run on that
20:45:43 <lhcheng> exclude the legacy code from the check
20:45:52 <david-lyle> just for those two flags?
20:46:02 <lhcheng> hmm not sure if that is possible
20:46:11 <asahlin> I think it was ignore entirely
20:46:11 <david-lyle> I would doubt it
20:46:24 <mattfarina> how hard would a patch to clean up the problems be before we add the flags?
20:46:25 <david-lyle> hmm, there's a fair amount of active JS code there
20:46:27 <mattfarina> there isn't that much JS
20:46:40 * mattfarina thinks the amount of JS is relative
20:46:55 <david-lyle> uncle leo?
20:47:10 <lhcheng> I think there are hundreds, not complicated by tedious
20:47:15 <lhcheng> *but
20:47:16 <doug-fish> I like the idea of bringing the legacy js inline with what jshint recommends
20:47:16 <asahlin> I think he turned it on and hit ~ 400
20:47:29 <TravT> 400 errors?
20:47:32 <mrunge> cool
20:47:36 <asahlin> yeah
20:47:45 <david-lyle> I those flags would point out relatively benign fixes, like unused
20:47:54 <doug-fish> let's make tqtran_afk fix it!
20:47:59 <mrunge> +1
20:48:01 <TravT> +1
20:48:02 <david-lyle> +1000
20:48:03 <asahlin> +1
20:48:03 <mattfarina> +1
20:48:04 <doug-fish> +1
20:48:07 <doug-fish> lol
20:48:10 <david-lyle> his idea, he can do it
20:48:13 <mrunge> word!
20:48:18 <david-lyle> sold
20:48:27 <doug-fish> now is a good time for that kind of refactor too (early in the release)
20:48:28 <TravT> I see now why he turned over to clu_ and went to the dentist
20:48:29 <mrunge> congrats tqtran_afk
20:48:41 <david-lyle> #action tqtran_afk fixes legacy JS
20:48:46 <lhcheng> too bad it backfired
20:48:48 <lhcheng> lol
20:48:48 <asahlin> lol
20:48:56 <doug-fish> zodm
20:48:58 <doug-fish> oops
20:48:59 <mattfarina> i like that action. it's so well defined!
20:49:13 <david-lyle> I think I scoped it correctly
20:49:17 <TravT> lol
20:49:18 <doug-fish> Isn't that what he intended?  Permission/agreement on that approach
20:49:40 <david-lyle> let's do it early
20:49:46 <lhcheng> I think he is looking more for forgiveness
20:49:58 <david-lyle> we need a saner L-3 than k-3
20:50:01 <TravT> all joking aside, i think it is a good idea.
20:50:28 <doug-fish> I assume tqtran_afk will let us know if he wants to break it up and get help
20:50:40 <lhcheng> my only worry is possibility of regression
20:50:51 <TravT> all the more reason to do it early
20:50:57 <mattfarina> so, while he's doing this he should add to the tests?
20:51:08 <david-lyle> lhcheng, unused should be fairly harmless unless they're globals
20:51:12 <david-lyle> :/
20:51:30 <asahlin> tqtran has a patch up to add thse 2 paths to .jshintignore
20:51:30 <asahlin> 
20:51:31 <lhcheng> david-lyle: true
20:51:33 <asahlin> horizon/static/horizon/tests/
20:51:41 <asahlin> horizon/static/horizon/js/*.js
20:51:44 <doug-fish> has anyone been able to spend time on our integration tests?
20:51:48 <doug-fish> I miss them.
20:51:58 <david-lyle> doug-fish, I haven't got back to them
20:52:07 <doug-fish> I haven't either.
20:52:09 <david-lyle> #topic open discussion
20:52:16 <david-lyle> just a little late
20:52:35 <david-lyle> I want to discuss at the summit a more robust approach
20:52:59 <david-lyle> might be a dream, but we break a lot on integration tests, but not by them catching issues
20:53:18 <david-lyle> only selenium or another dependency hamstringing us
20:53:43 <TravT> I sent out a message to the ML a bit ago.
20:53:44 <david-lyle> which make the integration tests ignored
20:53:55 <TravT> on the angular work.  please take a look
20:54:06 <doug-fish> TravT: have a link?
20:54:15 <TravT> hmm... let me see.
20:54:45 <TravT> #link: http://www.mail-archive.com/openstack-dev@lists.openstack.org/msg51188.html
20:55:54 <clu_> TravT: +1
20:56:14 <david-lyle> I have to run
20:56:24 <david-lyle> lhcheng, can you shut this down in 5 minutes
20:56:25 <david-lyle> ?
20:56:30 <lhcheng> sure
20:56:31 <david-lyle> thanks!
20:56:38 <TravT> david-lyle: you should also consider eating better.
20:57:24 <TravT> :P
20:59:32 <lhcheng> doug-fish: do you have an idea on the changes need for integration test to work?
20:59:50 <doug-fish> no. Haven't studied it yet to know what's happening
21:00:13 <doug-fish> I'm hopeful I can spend some time on it next week.  But I hoped that last week as well.  :-(
21:00:27 <lhcheng> okay, I'll try to help out when I get the time.
21:00:36 <lhcheng> alright, time's up
21:00:39 <lhcheng> thanks everyone
21:00:43 <doug-fish> thanks!
21:00:52 <lhcheng> #endmeeting