20:03:13 <david-lyle> #startmeeting Horizon
20:03:14 <openstack> Meeting started Wed Feb 25 20:03:13 2015 UTC and is due to finish in 60 minutes.  The chair is david-lyle. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:03:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:03:18 <openstack> The meeting name has been set to 'horizon'
20:03:32 <david-lyle> got caught looking at something else
20:03:37 <david-lyle> hello everyone
20:03:51 <doug-fish> :-)  hi
20:05:01 <david-lyle> ok, organized again
20:05:17 <david-lyle> So, starting off with some important dates
20:05:38 <david-lyle> FPF (Feature Proposal Freeze) for openstack is March 9
20:05:42 <tqtran> hola!
20:05:43 <david-lyle> that means...
20:06:04 <david-lyle> Feature code needs to be submitted for initial review by that date
20:06:44 <david-lyle> There can be iterations on patch sets beyond that, but completely new code for features beyond that date will require a FFE
20:06:58 <david-lyle> err FPFE
20:07:08 <david-lyle> an exceptions
20:07:12 <david-lyle> singular
20:07:24 <doug-fish> so ... is there any standard for how good the initial review patch needs to be?
20:07:28 <doug-fish> :-D
20:07:38 <david-lyle> Better than you're wnating
20:07:42 <doug-fish> lol
20:07:56 <david-lyle> reasonably complete before reviews
20:08:08 <david-lyle> but intended to be mergable
20:08:27 <doug-fish> yeah, that's what I'd expect
20:08:42 <david-lyle> so if two confused cores +A'd it we wouldn't hate ourselves in the morning
20:09:13 <david-lyle> after march 9, the next important date is March 19
20:09:19 <david-lyle> That is the end of Kilo-3
20:09:35 <david-lyle> all code should be merged by that point if it's going to make Kilo
20:10:15 <david-lyle> if it does not, and it's very close and worth the risk, it may be eligible for a FFE (Feature Freeze Exception)
20:10:35 <david-lyle> where we land the code for RC-1
20:10:45 <david-lyle> (release candidate - 1)
20:11:02 <david-lyle> the exception process for that is via openstack-dev
20:11:38 <david-lyle> any questions on that?
20:12:20 <mrunge> when is string freeze?
20:12:34 <david-lyle> mrunge: good question
20:12:59 <david-lyle> #action david-lyle to contact amotoki and daisy re: string freeze
20:13:08 <mrunge> it used to be 2 weeks after milestone 3 (or so)
20:13:31 <david-lyle> mrunge: I think that sounds right but I'd like daisy's input
20:13:37 <mrunge> this time, roughly rc1
20:13:45 <david-lyle> it's usually a bit of a negotiation
20:13:52 <robcresswell> https://wiki.openstack.org/wiki/Kilo_Release_Schedule any help?
20:14:14 <mrunge> robcresswell, too easy
20:14:19 <mrunge> March 19th
20:14:21 <mrunge> :D
20:14:23 <david-lyle> robcresswell: we usually carry a little over
20:14:35 <david-lyle> due to the nature of the project being all text
20:14:59 <david-lyle> I'll report back at next meeting
20:15:21 <mrunge> thank you david-lyle
20:15:34 <david-lyle> Let's look at the current status https://launchpad.net/horizon/+milestone/kilo-3
20:15:55 <david-lyle> I think not great is my summary
20:16:13 <david-lyle> some of that is that things that missed 1 and 2 have continued to slide to here
20:16:24 <david-lyle> I dropped a few from the release target all together
20:16:44 <david-lyle> but lots of high priority items are still not completed
20:16:58 <david-lyle> *most high priority
20:17:48 <david-lyle> I think this is to be expected with a major direction shift and I don't feel terrible about it
20:18:22 <david-lyle> Angular development has consumed a lot of resources and other items have just stalled
20:19:29 <david-lyle> Are there items people know they are not planning on for Kilo?
20:19:51 <TravT> i'll look at the glance v2 one again, but it'll probably slide out
20:19:53 <rdopiera> david-lyle: I think I will have to drop the entrypoints blueprint
20:20:03 <rdopiera> david-lyle: I won't have time to finish it on time
20:20:19 <david-lyle> rdopiera: sure, thanks
20:20:22 <david-lyle> dropped
20:21:08 <david-lyle> I additionally have some items from Sahara that they are trying to land to clean up what was there in Juno, https://etherpad.openstack.org/p/sahara-reviews-in-horizon
20:21:31 <david-lyle> the Guided items are covered by a blueprint, the others are bug fixes
20:21:32 <lhcheng> david-lyle: how about items we want to add for Kilo? :)
20:21:51 * david-lyle glares at lhcheng
20:21:55 <david-lyle> :)
20:21:57 <david-lyle> like what
20:21:57 <david-lyle> ?
20:22:08 <lhcheng> david-lyle: talked to the metacloud folks, and they might have some bandwidth to add the horizon theming
20:22:25 <mrunge> django-1.8 support?
20:22:26 <lhcheng> david-lyle: they got permission from Dianna to contribute it
20:22:42 <david-lyle> lhcheng: I'll deal with that if it comes
20:22:50 <mrunge> django-1.6 won't receive any security updates, once django-1.8 is out
20:22:56 <david-lyle> I'm open to it as operators want it
20:23:05 <mrunge> and we currently don't even support django-1.7
20:23:11 <lhcheng> mrunge: allowing the user to change the theme used by horizon
20:23:15 <david-lyle> mrunge: we didn't even look at that did we
20:23:29 <mrunge> david-lyle, I did a bit
20:23:37 <lhcheng> mrunge: there was a quick demo in the paris summit
20:23:38 <mrunge> filed at least one bug
20:23:48 <mrunge> lhcheng, about what?
20:23:57 <mrunge> theme support?
20:24:06 <lhcheng> mrunge: yes
20:24:12 <david-lyle> mrunge: we may be able to tackle those bugs after k-3
20:24:20 <mattfarina> lhcheng the user to change the theme or to have white labled themes?
20:24:20 <lhcheng> mrunge: sorry the django1.8 is different topic. nevermind me
20:24:51 <mrunge> no, no, lhcheng . that's what operators actually want
20:24:54 <david-lyle> heck, we still have django 1.4 support for some reason
20:25:12 <mrunge> django-1.4 is lts until this april
20:25:17 <lhcheng> mattfarina: user will have an option to pick from multiple theme and  change it on the browser (probably from user preference)
20:26:01 <mrunge> david-lyle, debian uses django-1.7. tests are failing currently. but it seems to work
20:26:18 <david-lyle> ok, that shouldn't be terrible to patch up
20:26:30 <mrunge> david-lyle, on issue is https://bugs.launchpad.net/bugs/1425001
20:26:32 <openstack> Launchpad bug 1425001 in OpenStack Dashboard (Horizon) "remove try except from tests" [Medium,New] - Assigned to Yash Bathia (ybathia)
20:26:47 <mrunge> I counted 2 bugs for django-1.7 supprot.
20:27:05 <mrunge> nothing really to worry.
20:27:25 <david-lyle> mrunge: we should be able to tackle 2
20:27:45 <david-lyle> DOA is already 1.7 compatible
20:27:51 <david-lyle> as of Juno
20:27:53 <mrunge> yepp
20:28:05 <david-lyle> mrunge: can you add a cp
20:28:07 <david-lyle> bp
20:28:11 <mrunge> and there seems to be an unrelated issue in infra
20:28:19 <mrunge> david-lyle, yes. will do
20:28:19 <david-lyle> trivial content
20:28:23 <david-lyle> not long form
20:28:30 <mrunge> good
20:28:32 <mrunge> :D
20:28:32 <david-lyle> thanks!
20:28:42 <mrunge> yw!
20:28:55 <david-lyle> The other item missing completely is Ironic support
20:29:07 <david-lyle> Not sure that's going to be addressed
20:29:12 <david-lyle> as there is no owner
20:29:15 <mrunge> there is an api patch
20:29:26 <mrunge> (for ironic)
20:29:33 <david-lyle> ok, that's a start
20:29:45 <mrunge> it's not merged yet
20:29:50 <david-lyle> there's a bp, but I think it stalled
20:29:56 <david-lyle> that might be part of that
20:30:15 * david-lyle sees more housekeeping in my future
20:30:23 <lhcheng> david-lyle: I think there was a pending discussion there for ironic. if the panel should go into tuskar-io
20:30:24 <mrunge> we should discuss at some point, if we want to support ironic in horizon
20:30:29 <lhcheng> *tuskar-ui
20:30:39 <mrunge> yepp, lhcheng
20:30:41 <david-lyle> lhcheng: I don't think so
20:30:47 <david-lyle> re: answer
20:31:00 <david-lyle> tuskar-ui has non-integrated dependencies
20:31:17 <david-lyle> we could put it there, but no one would be able to use it
20:31:36 <david-lyle> ironic has user space usefulness
20:31:52 <david-lyle> we should move on
20:32:26 <mrunge> david-lyle, maybe worth a session in Vancouver?
20:32:34 <lhcheng> david-lyle: tuskar-ui already have some ironic panels, perhaps they can move it from there to horizon
20:32:49 <david-lyle> lhcheng: but the leverage tuskarclient as well
20:32:52 <david-lyle> IIRC
20:33:20 <lhcheng> david-lyle: it uses ironicclient
20:33:22 <david-lyle> The simplest thing I could see is allowing a use to launch an instance on baremetal
20:33:31 <lhcheng> david-lyle: we can discuss it later
20:33:33 <david-lyle> that won't happen in tuskar-ui
20:33:36 <david-lyle> lhcheng: sure
20:34:30 <david-lyle> One last thing before the agneda
20:34:38 <david-lyle> *you know what I meant
20:34:42 <rdopiera> lhcheng: our views are all very specific to the task of running openstack on openstack
20:35:59 <david-lyle> jpich has moved on from Horizon for the time being. I just wanted to officially recognize what a great part of our community she has been for the last ~3 years. Thanks jpich and happy adventures!
20:36:27 <david-lyle> the agenda for today can be found at https://wiki.openstack.org/wiki/Meetings/Horizon
20:36:35 <mrunge> +1 david-lyle
20:37:02 <david-lyle> #topic Use of discoverd in Tuskar-UI [rdopiera]
20:37:45 <rdopiera> ok, so the gist of it is
20:38:13 <rdopiera> we are relying on ironic-discoverd in tuskar-ui to do discovery of hardware nodes
20:38:48 <rdopiera> the thing is, it's not officially part of OpenStack
20:39:10 <rdopiera> so I wanted to check if you see any problems with including it in the dependencies
20:39:27 <rdopiera> in particular, we need the python client for it
20:40:04 <david-lyle> and that part is not part of the stackforge repo?
20:40:45 <rdopiera> I think it is, it's in the "ironic-discoverd" python module
20:40:59 <david-lyle> rdopiera: looking now, I see the client
20:41:03 <rdopiera> I proposed a patch to add it do global-requirements.txt here https://review.openstack.org/#/c/158210/
20:41:51 <rdopiera> if it can't be included, we will make it optional
20:41:56 <david-lyle> rdopiera: my thoughts are that tuskar-ui is likely not graduating soon (especially as that concept is going away), and tripleO in general is in the same boat
20:42:03 <rdopiera> but that will make the code a little more complex, with conditional imports
20:42:22 <david-lyle> I think for now using it makes sense to me
20:42:46 <david-lyle> either if it's adopted as part of the global requirements or if it's a conditional
20:42:59 <rdopiera> ok, thank you
20:43:28 <david-lyle> anyone have a concern with that?
20:44:09 <david-lyle> ok, raise you hand if you know what tuskar-ui is
20:44:13 <david-lyle> :)
20:44:14 <lhcheng> I'm fine with it
20:44:42 <david-lyle> #topic Review Blueprint: https://blueprints.launchpad.net/horizon/+spec/k2k-federation (doug-fish)
20:44:54 <doug-fish> ok great
20:44:56 <doug-fish> I've submitted the above blueprint for keystone to keystone federation
20:45:24 <doug-fish> So the basic idea is that K2K federation allows a user to log in through one keystone, and then use the unscoped token to get a saml assertion which can be presented as credentials to other, federated keystones, so the user doesn't have to log in separately.
20:45:41 <doug-fish> My plan to allow Horizon to interact with a k2k federated environment is to hide it from the end user
20:46:00 <doug-fish> d_o_a will need to be updated to manage the collection of tokens needed for each keystone, present a combined list of regions, and swap out the tokens (if needed) when the users switches regions.
20:46:13 <doug-fish> how hard could it be?
20:46:23 <david-lyle> doug-fish: I think the idea is fine
20:46:38 <david-lyle> I need to push a new session store default to devstack
20:46:46 <david-lyle> we have a few things blocking on that now
20:47:12 <david-lyle> I'll clean up that effort
20:47:19 <doug-fish> my main concern with k2k federation that I see there is other major work happening in d_o_a for domain tokens
20:47:29 <doug-fish> I think both are large scale changes.
20:47:44 <david-lyle> doug-fish: there will be a lot of contention around all the keystone changes
20:48:03 <david-lyle> between SSO, K2K, domain scoped tokens, HMT
20:48:13 <doug-fish> HMT?
20:48:16 <david-lyle> they've really overrun our ability to keep up
20:48:25 <david-lyle> Hierarchical Multi-tenancy
20:48:29 <doug-fish> ah
20:48:34 <david-lyle> some things will miss Kilo
20:48:41 <david-lyle> just a fact
20:49:06 <david-lyle> but the domain tokens are still in flux, and may have been a wasted effort
20:49:24 <woodm1979> wasted effort?  /sad panda
20:49:46 <doug-fish> FWIW I'm not sure K2K support is quite complete in Keystone
20:49:46 <david-lyle> woodm1979: it's a moving target even though we waited 4 releases
20:49:51 <lhcheng> doug-fish: isn't the implementation of this will be similar to using an external Idp for federation.  for k2k, keystone can acts as an Idp, wondering what is the difference on interaction between k2k and with external Idp?
20:50:06 <doug-fish> lhcheng: that was my first thought too
20:50:07 <tqtran> if you dont mind me hijacking your time for a bit, i'd like to also mention that the websso work is nearing completion, just need more eyes on it. the keystone side has already merged
20:50:08 <doug-fish> and there is similarly
20:50:18 <woodm1979> :-)  I understand.  I'm sto;; a sad [amda
20:50:24 <woodm1979> wow.  sad panda
20:50:25 <doug-fish> but the consumption of the similar APIs happens at a different time
20:50:39 <doug-fish> websso = how to get auth to the first keystone
20:50:46 <doug-fish> k2k federation = access other keystones later
20:52:04 <doug-fish> so of domain tokens might be out does that mean that k2k could be in?
20:52:11 <david-lyle> doug-fish: I'd say the best thing to do is get the patch ready and if it doesn't make k-3 then l-whatever-they-are-going-to-be
20:52:31 <david-lyle> doug-fish: if the patch is ready
20:52:35 <doug-fish> david-lyle: sounds good!
20:52:45 <lhcheng> david-lyle: for HMT, we probably don't need to land it in Kilo. The nested quota driver in Nova is not going in Kilo, I don't find HMT that useful without that.
20:52:49 <david-lyle> there's certainly a possibility
20:53:12 <david-lyle> no HMT was the first feature to get the boot
20:53:29 <lhcheng> david-lyle: ah ok, makes sense
20:53:34 <david-lyle> I personally think it's too early even for the keystone part
20:53:54 <david-lyle> I'd like to see it stabilize so we're not chasing our tails
20:54:07 <david-lyle> see: domain scoped tokens
20:54:10 <david-lyle> :)
20:54:18 <david-lyle> ok
20:54:36 <david-lyle> #topic Review Blueprint: https://blueprints.launchpad.net/horizon/+spec/sahara-event-log (NikitaKonovalov)
20:55:47 <david-lyle> that seems uncontroversial and a WIP patch is up, I'm ok if with it if it can get review cycles
20:56:06 <david-lyle> which is the big question for all of these
20:56:54 <david-lyle> ok
20:57:06 <david-lyle> #topic Open Discussion
20:57:12 <david-lyle> 3 minute free for all
20:57:13 <david-lyle> go
20:57:18 <TravT> two weeks ago I brought this up and want to circle back.
20:57:18 <TravT> Reference: http://eavesdrop.openstack.org/meetings/horizon/2015/horizon.2015-02-11-20.01.log.html
20:57:18 <TravT> Go to time: 20:52:02
20:57:20 <TravT> several people indicated interest and wanted to mention it again
20:57:22 <TravT> r1chardj0n3s has indicated that he can't make it due to pycon activities
20:57:24 <TravT> so a few other options would be to do it a few days before the summit at HP's office in Seattle (few hours South of Vancouver)
20:57:26 <TravT> Also, could try a virtual summit, but thus far we have not found a great video conferencing tool that supports enough people around the world on all OS platforms
20:58:08 <r1chardj0n3s> yeah, aprily/may are pretty hectic with pycon and summit
20:58:41 <david-lyle> ooh, that reminds me I requested 3 fishbowl and 8 work sessions and a full day on Friday
20:59:07 <TravT> yeah, i thought that having all the extra sessions may make the week before the summit less worthwhile
20:59:19 <TravT> anyway, if you are interested, add your name to that etherpad
20:59:26 <david-lyle> for the summit, so less fishbowl time and more work session time
20:59:31 <TravT> and we can try to coordinate
20:59:39 <david-lyle> may obviate some of the need
20:59:43 <david-lyle> sure
21:00:16 <david-lyle> There have been several sprint/review sessions around the angular work and many patches have landed
21:00:48 <david-lyle> we're still a ways from launch instance, but I think we can see it from here, where we couldn't before
21:01:21 <TravT> been great work
21:01:21 <tqtran> TravT: which etherpad?
21:01:23 <TravT> https://etherpad.openstack.org/p/horizon-liberty-presummit-meetup
21:01:56 <david-lyle> ok time's up. Thanks everyone have a great week!
21:02:00 <david-lyle> #endmeeting