22:02:27 <gabrielhurley> #startmeeting horizon
22:02:28 <openstack> Meeting started Tue May  7 22:02:27 2013 UTC.  The chair is gabrielhurley. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:02:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:02:32 <openstack> The meeting name has been set to 'horizon'
22:02:38 <gabrielhurley> #topic overview
22:02:49 <gabrielhurley> Hello all
22:02:52 <gabrielhurley> things are oving right along
22:02:55 <lcheng> hello
22:02:57 <david-lyle> Hello
22:02:58 <bradjones> hey
22:03:00 <jpich> hey
22:03:42 <gabrielhurley> Basically, the overview looks like this: the Havana plan looks solid and stable, we're halfway through H1 and look to be on target, and that makes me happy as long as we keep it up.
22:04:01 <gabrielhurley> everything else I've got is about blueprints
22:04:11 <gabrielhurley> #topic blueprits and bugs
22:04:22 <gabrielhurley> I'm gonna ignore the typo in that topic... ::sigh::
22:04:46 <gabrielhurley> There are reviews up for both of the "essential" blueprints:
22:05:05 <gabrielhurley> D3: https://review.openstack.org/#/c/28362/
22:05:22 <gabrielhurley> and enabling keystone v3: https://review.openstack.org/#/c/27989/
22:05:46 <gabrielhurley> I intend to review the D3 one thoroughly in the next day or two
22:06:03 <gabrielhurley> the Keystone one is from me and has some +1's but it needs core reviewer eyes on it asap
22:06:15 <gabrielhurley> it's blocking work on several other blueprints
22:06:19 <gabrielhurley> so it's the highest priority
22:06:49 <gabrielhurley> as far as the actual blueprint for it (https://blueprints.launchpad.net/horizon/+spec/api-capability-detection) I'm going to split it into two pieces
22:07:14 <gabrielhurley> one will be "enabling API version switching" which is what that review actually does
22:07:34 <gabrielhurley> and the other will be for the larger question of version/capability detection via the APIs
22:07:50 <gabrielhurley> I'm gonna do that because the latter has turned out to be a long-term process for the whole OpenStack community
22:08:06 <gabrielhurley> you can see the current state of the proposal here: https://gist.github.com/gabrielhurley/5499434
22:08:17 <gabrielhurley> I'm gonna continue to carry that through the whole H cycle
22:08:55 <gabrielhurley> So, to come back around, let's get reviews done on those two since they're the "essential" blueprints for the entire Havana cycle
22:09:30 <gabrielhurley> that'll open up the ability to progress on https://blueprints.launchpad.net/horizon/+spec/admin-domain-crud https://blueprints.launchpad.net/horizon/+spec/admin-role-crud https://blueprints.launchpad.net/horizon/+spec/login-domain-support and https://blueprints.launchpad.net/horizon/+spec/admin-group-crud
22:09:46 <gabrielhurley> (basically all the Keystone v3 stuff for H1)
22:09:55 <david-lyle> the other blocker for those is https://review.openstack.org/#/c/21942/
22:10:01 <david-lyle> python-keystoneclient support
22:10:12 <gabrielhurley> good to know
22:10:30 <gabrielhurley> I'll keep an eye on that one too
22:10:46 <david-lyle> lin's been making good progress using that patch
22:10:51 <gabrielhurley> so I see :-)
22:10:58 <gabrielhurley> let's run through the other H1 blueprints real quick
22:11:12 <lcheng> Found some bugs on it already, added some comments  on the review.
22:11:15 <gabrielhurley> working down the list, I still need to follow up on the Heat UI
22:11:22 <gabrielhurley> so that's on me
22:12:08 <gabrielhurley> cody-somerville: you reassigned https://blueprints.launchpad.net/horizon/+spec/dry-templates to Tatiana Mazur... happen to have an IRC handle there?
22:12:18 <gabrielhurley> if not I can email to make sure of what's happening there
22:13:32 <gabrielhurley> Not a big deal. I'll follow up there too.
22:14:02 <gabrielhurley> david-lyle: You've got https://blueprints.launchpad.net/horizon/+spec/centralized-color-palette assigned to you. I assume you've been focused more on other areas like Keystone that're more preseeing. Any particular update to share?
22:14:17 <gabrielhurley> s/preseeing/pressing
22:14:36 <david-lyle> I started pulling out the pieces, but haven't gotten back to it yet.  Shouldn't take too long to wrap up
22:15:02 <gabrielhurley> that's about what I figured. thanks.
22:15:19 <gabrielhurley> It's also one that can slip if needed, but it's early in the cycle to think about that.
22:15:49 <lcheng> https://blueprints.launchpad.net/horizon/+spec/login-domain-support - will be probably be ready for review in a day or two.
22:15:54 <gabrielhurley> awesome
22:16:09 <gabrielhurley> it doesn't look like amotoki is around, so I won't linger on https://blueprints.launchpad.net/horizon/+spec/quantum-security-group
22:16:26 <gabrielhurley> if anyone wants to say something about Quantum Security Groups feel free though
22:17:15 <gabrielhurley> Per-project flavors... https://blueprints.launchpad.net/horizon/+spec/define-flavor-for-project
22:17:37 <gabrielhurley> the review expired. I'll contact the author and see about getting it updated. If not we should re-assign it and wrap it up.
22:18:41 <gabrielhurley> lastly, password change(https://blueprints.launchpad.net/horizon/+spec/change-user-passwords )  has a review which was recently updated: https://review.openstack.org/#/c/23901/
22:18:47 <gabrielhurley> that needs review too
22:19:35 <gabrielhurley> bradjones: you asked for https://blueprints.launchpad.net/horizon/+spec/network-quotas to be assigned to you
22:19:48 <gabrielhurley> I went ahead and did that... thoughts on what milestone it should be in? (currently it's H3)
22:19:59 <gabrielhurley> also, you'll obviously want to work closely with the Quantum team on that
22:20:30 <bradjones> yeah I can begin working on it straight away so i'll take a look at how the API is looking at get back to you
22:20:38 <gabrielhurley> awesome. just let me know.
22:20:59 <bradjones> will do
22:21:08 <gabrielhurley> quick notes on bugs:
22:21:23 <david-lyle> I've also got the prelimary step of https://blueprints.launchpad.net/horizon/+spec/multiple-service-endpoints about ready for review, it's just a selector to pick the region the services are being managed for.  Any feedback in the blueprint on the picker placement would be great.  http://imgur.com/gIh8MFh
22:21:33 <gabrielhurley> some interesting bugs crept into to the keystone API recently which got reported 4 or 5 times in differing forms
22:22:15 <gabrielhurley> david-lyle: perhaps that'd be a good thing to reach out to the new OpenStack UX group for...
22:22:54 <david-lyle> gabrielhurley: was unaware of the group, I will do that.  Thanks
22:22:55 <gabrielhurley> lemme find a link
22:23:01 <gabrielhurley> it's surprisingly hard to google for
22:23:50 <gabrielhurley> https://plus.google.com/u/0/communities/100954512393463248122
22:24:04 <gabrielhurley> #action get that group more visiblity/discoverability
22:24:17 <gabrielhurley> it's just getting started
22:24:28 <gabrielhurley> so I'm interested to test the waters on having them weigh in on real UX questions
22:24:51 <gabrielhurley> anyhow, interesting keystone bugs... mostly not our fault... will get resolutions in the future
22:24:58 <gabrielhurley> #topic open discussion
22:25:05 <gabrielhurley> everyone's being mighty quiet today...
22:25:09 <gabrielhurley> here's your chance!
22:25:19 <jpich> Question about backporting translations
22:26:24 <jpich> I've hit this strange error in the unit tests after backporting -> http://paste.openstack.org/show/36915/ It looks like a mix of locales is being used in the error message. Curious to hear if anyone is familiar with this?
22:27:12 <gabrielhurley> I can help a  bit
22:27:31 <gabrielhurley> that's what happens when there's a unicode character in an exception string that is naively printed by a tool like (in this case) nose
22:27:48 <gabrielhurley> it can't print the real exception because it tries to convert the exception to an ascii string (stupid nose) and fails
22:28:11 <gabrielhurley> fixing that is a lot harder because you have to figure out what the failure is
22:28:33 <jpich> Wouldn't the tests still be run in English though?
22:28:41 <cody-somerville> gabrielhurley: Hey. Sent you e-mail about that.
22:28:50 <cody-somerville> gabrielhurley: She e-mailed me and asked to be assigned that bp.
22:28:56 <gabrielhurley> the tests have unicode characters in the test data
22:29:22 <gabrielhurley> I suggest tracing up the stack to somewhere in code under your control and wrapping that in a new try/except block and printing the error yourself so you can see what's happening
22:29:35 <jpich> I pasted the error below the test output in that paste
22:30:03 <gabrielhurley> cody-somerville: yeah, I saw the email, just wanted to follow up to on timeline/expectations
22:30:19 <gabrielhurley> jpich: oh... hmmmm
22:30:25 <gabrielhurley> that is odd
22:30:42 <gabrielhurley> okay, I'm not sure offhand
22:30:45 <jpich> The only change is the po/mo files
22:30:50 <jpich> Fair enough! I'll dig further
22:31:01 <gabrielhurley> yeah, now I'm curious
22:31:12 <jpich> Not looking good for getting it into the next stable release this way though
22:31:49 <jpich> Cheers
22:31:56 <gabrielhurley> yeah, they're pushing to get that out ASAP
22:32:04 <gabrielhurley> if it goes into the next one so be it
22:32:13 <gabrielhurley> better to figure out what's wrong
22:32:21 <jpich> Yep
22:35:09 <gabrielhurley> anybody else?
22:35:17 <vkmc> Is there something new regarding Keystone's trust API integration with Horizon?
22:35:44 <gabrielhurley> define "something new"
22:35:55 <gabrielhurley> like, management of trusts?
22:36:00 <gabrielhurley> or something else?
22:36:31 <lcheng> Trust api has been pulled out of keystone before Grizzly release.  Not sure what is the current state.
22:36:32 <vkmc> Like if there is planned blueprint for it
22:36:50 <gabrielhurley> yeah, that API is in flux currently, so we hadn't targeted anything for it
22:37:01 <gabrielhurley> actually I don't think there's even an untargeted BP
22:37:07 <gabrielhurley> hopefully that'll become clearer in H
22:37:18 <gabrielhurley> I think having an open BP to track it would be good
22:37:36 <gabrielhurley> we might want to land something later on (H3?)
22:37:42 <gabrielhurley> it all depends on Keystone
22:38:23 <vkmc> I see... I lost the track of it and wasn't sure which was the current state
22:39:30 <vkmc> I'll keep an eye on Keystone then and see how is it managed
22:39:33 <gabrielhurley> yeah. it's been messy
22:39:35 <gabrielhurley> sounds good
22:39:37 <gabrielhurley> good question though
22:39:42 <jpich> Is there something else in Keystone v3 that could help with implementing tenant deletion differently?
22:39:51 <gabrielhurley> not presentl
22:39:54 <gabrielhurley> y
22:40:18 <gabrielhurley> there's informal talk around improving cross-project event-driven behavior though
22:40:33 <gabrielhurley> it's actually being driven by changes in Nova
22:40:35 <vkmc> Thanks jpich, I didn't consider other choices heh
22:40:53 <gabrielhurley> we'll see where it goes over the next milestone or two
22:41:00 <jpich> Interesting, ok
22:41:38 <jpich> vkmc: Always be in flux ;)
22:41:49 <vkmc> Great :)
22:41:56 <gabrielhurley> hehe
22:42:04 <vkmc> jpich, Oh I try hehe
22:43:28 <gabrielhurley> okay
22:43:36 <gabrielhurley> I'm gonna call it here
22:43:41 <gabrielhurley> have a great week folks!
22:43:44 <gabrielhurley> review, review, review!
22:43:53 <gabrielhurley> and thank you all as usual.
22:43:55 <gabrielhurley> #endmeeting