22:01:46 <gabrielhurley> #startmeeting horizon
22:01:47 <openstack> Meeting started Tue Mar 12 22:01:46 2013 UTC.  The chair is gabrielhurley. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:01:50 <openstack> The meeting name has been set to 'horizon'
22:01:54 <gabrielhurley> #topic General
22:02:00 <gabrielhurley> hello folks!
22:02:05 <jpich> hey
22:02:05 <mrunge> o/
22:02:06 <gabrielhurley> another week has come around oh so quickly
22:02:10 <vkmc> hey o/
22:02:21 <lcheng> hello
22:02:26 <david-lyle> hi
22:02:41 <gabrielhurley> things are progressing well. lots of reviews up for quantum stuff. that's good. nothing critical or unmanageable.
22:03:11 <gabrielhurley> don't have much off the top of my head, so let's just go to bug discussion
22:03:15 <gabrielhurley> #topic bugs and blueprints
22:03:48 <lcheng> I'd like to get some feedback on this: https://bugs.launchpad.net/horizon/+bug/1144820
22:03:49 <uvirtbot`> Launchpad bug 1144820 in horizon "Fade out success message automatically" [Undecided,In progress]
22:04:23 <lcheng> Curious about people's thought on auto-fading alert messages..
22:04:52 <mrunge> lcheng, I have seen people arguing in both directions: yes, we want, nooo, no way
22:04:58 <gabrielhurley> Though the fully configurable option is the most complex, it seems the most flexible
22:05:11 <gabrielhurley> I wouldn't add this for Grizzly, but it'd be great for Havana
22:05:23 <mrunge> I'd favor the configurable option as well
22:05:30 <gabrielhurley> personally i *am* in favor of auto-fading them after some amount of time
22:05:35 <mrunge> gives you some time to fix the issues
22:05:39 * mrunge too
22:06:03 <gabrielhurley> I targeted the bug to H1
22:06:10 <mrunge> but one of our qa guys say: I want to read each error/warning...
22:06:12 <gabrielhurley> and I'll add a comment in favor of the cofigurable version
22:06:27 <lcheng> I guess we can go with this type of configuration:
22:06:28 <lcheng> HORIZON_CONFIG = {
22:06:28 <lcheng> ..
22:06:28 <lcheng> 'auto_fade_message': {
22:06:28 <lcheng> 'delay': 3000,
22:06:28 <lcheng> 'fade_duration': 1500,
22:06:29 <lcheng> 'alerts' : ['success', 'info']
22:06:29 <mrunge> gabrielhurley, I think jpich did that already
22:06:31 <lcheng> },
22:06:33 <lcheng> ..
22:06:35 <lcheng> }
22:06:45 <gabrielhurley> mrunge: it wasn't set just now... ::shrug::
22:07:05 <mrunge> ah no, I meant comment on the config option
22:07:08 <gabrielhurley> oh
22:07:11 <gabrielhurley> yeah
22:07:45 <gabrielhurley> cool. the one bug I wanna ask about is https://bugs.launchpad.net/bugs/1153477
22:07:46 <lcheng> cool,  I'll implement it that way.
22:07:47 <uvirtbot`> Launchpad bug 1153477 in horizon "editing security group rules ends up with ValueError when Quantum secgroup is enabled" [High,Confirmed]
22:07:58 <gabrielhurley> is amotoki or anyone else from quantum able to provide an update on that?
22:08:05 <jpich> cheers, lcheng
22:08:12 <gabrielhurley> I'm hoping it's as simple as just checking the ID type as we do in some other places...
22:08:22 <gabrielhurley> but I'd like confirmation of that
22:09:00 <mrunge> I must admit, I haven't seen that error yet
22:09:03 <david-lyle> I'm trying to reproduce it
22:09:16 <mrunge> but it's worth to fix it anyways
22:09:22 <gabrielhurley> not sure if it's dependent on quantumclient version or something of the like
22:09:44 <gabrielhurley> just got quantumclient updated to the latest 2.2.0 today so that might help some things
22:10:11 <gabrielhurley> all in all the bug list is looking pretty reasonable
22:10:22 <mrunge> what about https://bugs.launchpad.net/horizon/+bug/1011171 ? can we just close that?
22:10:25 <uvirtbot`> Launchpad bug 1011171 in horizon "Instances & Volumes tab is being opened inside itself recursively " [High,Incomplete]
22:10:31 <mrunge> and the other incomplete ones?
22:10:44 <mrunge> ... just to reduce the list
22:10:58 <gabrielhurley> mrunge: incomplete bugs are garbage-collected after some amount of time in launchpad
22:11:00 <jpich> Normally incomplete bugs expire after 60 days, not sure what's up with that one
22:11:06 <kspear> yeah, there are some very old ones still around
22:11:11 <gabrielhurley> why is that still open
22:11:13 <gabrielhurley> weird
22:11:24 <gabrielhurley> okay, yeah, any that old should be closed
22:11:26 <kspear> i closed at least one last week that had been around for > 6 months
22:11:29 <gabrielhurley> they escaped launchpad's janitor somehow
22:11:48 <mrunge> I could live with manual closing
22:11:49 <gabrielhurley> yes, please close them if they're that old for sure
22:11:56 <kspear> also remove the importance if it has been set previous
22:11:58 <mrunge> if we decide to close them after 6 months
22:12:11 <gabrielhurley> #action close out incomplete bugs that have escaped launchpad's janitor
22:12:39 <gabrielhurley> for those of you that didn't hear it in the Project Status meeting right before this, we'll be cutting RC1 a week from today, so bug fixes should go in this week.
22:13:02 <gabrielhurley> I'll make sure to get my couple in by Saturday at the latest (I'm traveling this week so my time is questionable)
22:13:34 <gabrielhurley> (if anybody's in seattle and wants to grab a beer with the Nebula folks, shoot me an email)
22:14:24 <vkmc> Thanks for the reminder :) I wasn't sure about RC1 deadline
22:14:26 <gabrielhurley> any other Grizzly bugs people want to talk about? otherwise I'm gonna open it up for general bug/blueprint/whatever discussion.
22:14:37 <vkmc> Hey guys, I would like your suggestions about this if you have a second. Listing the resources associated to a tenant is needed to perform the clean up when deleting it.
22:14:42 <vkmc> Most APIs don't have that feature and, after discussing this with devs involved in each service, the only way to do that is making a cURL call. I updated the whiteboard with some notes about this. How should I proceed in this case?
22:15:01 <gabrielhurley> what do you mean not supported?
22:15:12 <vkmc> Whiteboard here https://blueprints.launchpad.net/horizon/+spec/tenant-deletion
22:15:34 <vkmc> I mean that is not possible to filter resources by tenant id
22:15:54 <gabrielhurley> oh, got it. not all the APIs have that type of filter. some do, but many still don't.
22:16:05 <gabrielhurley> we'd have to list everything and filter on our end
22:16:22 <vkmc> Admin users can list, e.g. instances, from their own tenant... but cannot do the same to other tenants
22:16:29 <gabrielhurley> yeah
22:16:51 <gabrielhurley> I'm curious if we could use/abuse some keystone feature to make that work
22:17:03 <gabrielhurley> either the token create method or the new "trusts" stuff
22:17:03 <vkmc> We would need a super-admin heh
22:17:26 <gabrielhurley> basically to use the admin API to get a token that would allow us to request things as if we were that user.
22:17:31 <gabrielhurley> that's trusts-like
22:17:59 <vkmc> Hm.. it sound a bit insecure
22:18:23 <gabrielhurley> If you're up for it, I'd talk to the keystone folks (ayoung, dolphm, heckj) and see if there's a way this would work in the v3 API.
22:18:32 <gabrielhurley> I suspect there might be
22:18:37 <gabrielhurley> which would be really cool
22:18:59 <vkmc> I'm totally on it, so please add me to CC if you contact them
22:19:03 <lcheng> The trust api supports delegation and impersonation.. I suppose we can use impersonation for that.
22:19:12 <gabrielhurley> that's what I was thinking
22:19:17 <gabrielhurley> worth finding out
22:19:44 <gabrielhurley> it'd be a cool "hey look! we're doing something new and shiny with the v3 API in Havana" feature.
22:19:58 <vkmc> chmouel mentioned something about the 'reseller admin' role... if that is possible in Cinder, maybe it's possible in other services
22:20:12 <vkmc> Yeah sounds great :)
22:20:15 <gabrielhurley> cool
22:20:23 <gabrielhurley> other topics?
22:21:12 <jpich> We might want/have to go through the dance of adjusting the meeting time in a couple of weeks after DST hits Europe
22:21:45 <jpich> ...just throwing it out there :-)
22:21:58 <jpich> It's not as bad for me as it'll be for the continental folks
22:22:08 <gabrielhurley> yeah, it's screwy and tough
22:23:15 <dolphm> gabrielhurley: lcheng: ++
22:23:25 <gabrielhurley> cool
22:24:22 <gabrielhurley> okay
22:24:26 <gabrielhurley> let's call it a wrap
22:24:28 <gabrielhurley> good stuff everyone!
22:24:32 <gabrielhurley> next week is the RC
22:24:36 <gabrielhurley> have a good week!
22:24:38 <gabrielhurley> #endmeeting