16:03:16 <raildo> #startmeeting hierarchical-multitenancy
16:03:16 <openstack> Meeting started Fri Jul 24 16:03:16 2015 UTC and is due to finish in 60 minutes.  The chair is raildo. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:20 <openstack> The meeting name has been set to 'hierarchical_multitenancy'
16:03:58 <raildo> I think that we have few points to talk today
16:04:02 <vilobhmm> sure
16:04:04 <vilobhmm> lets start
16:04:05 <sajeesh> ok
16:04:07 <raildo> so... let's go :)
16:04:18 <raildo> #topic Review Actions
16:05:12 * raildo searching the review topics
16:05:16 <raildo> :P
16:05:20 <vilobhmm> i think everything here https://blueprints.launchpad.net/nova/+spec/nested-quota-driver-api
16:05:22 <sajeesh> :-)
16:05:29 <vilobhmm> for Nova
16:05:46 <vilobhmm> Cinder : https://review.openstack.org/#/c/205369/ - Nested Quota Driver Implementation
16:05:57 <vilobhmm> Nova : everything here https://blueprints.launchpad.net/nova/+spec/nested-quota-driver-api
16:06:03 <vilobhmm> needs to be reviewed
16:06:22 <vilobhmm> does everyone agree ?
16:06:32 <raildo> sure, we need start to ask for core reviews in both services
16:06:34 <ericksonsantos> I saw you already have a review, vilobhmm, that's nice
16:06:37 <sajeesh> yes
16:06:54 <ericksonsantos> I'll review this patch soon.
16:07:07 <sajeesh> raildo, I have uploaded the latest patch
16:07:08 <vilobhmm> thanks ericksonsantos
16:07:20 <raildo> sajeesh: great
16:07:26 <sajeesh> thanks erickson...kindly review the code
16:08:17 <raildo> #action ALL ask for code review to core team in both services
16:08:39 <sajeesh> in the latest patch , I have kept the authentication method same like that in DbQuotaDriver
16:09:25 <raildo> sajeesh: can you send me the link for this patch?
16:09:38 <ericksonsantos> vilobhmm, I'm planing to split your patch in at least 2 patches: 1. make the keystone calls and the tests for it; 2. the quota calculation
16:10:00 <ericksonsantos> vilobhmm, so it will be easier for the reviewers and for us. What do you think?
16:10:11 <sajeesh> vilobh they are already in two patches
16:10:31 <sajeesh> raildo , I will send it
16:10:32 <raildo> about the keystone calls, I think that we have to use the current context.py https://github.com/openstack/cinder/blob/master/cinder/context.py
16:10:39 <raildo> and the same for nova
16:10:55 <raildo> imho this is the correct place to make the keystone calls
16:11:04 <sajeesh> vilobh, in the latest patches I have split the code
16:11:08 <raildo> to implement*
16:11:15 <ericksonsantos> raildo, nice
16:11:17 <raildo> and we can use this calls in the driver
16:11:22 <vilobhmm> ericksonsantos : i think the changes are minimal in current patch as well
16:11:23 <ericksonsantos> raildo, I'll take a look at it
16:11:29 <raildo> but not implementing "get_parent" in quota.py
16:11:29 <vilobhmm> as i have mininmized duplication of code
16:11:44 <raildo> ericksonsantos: nice
16:11:54 <sajeesh> you mean make keystone calls in context.py
16:11:54 <ericksonsantos> vilobhmm, but it's lacking tests
16:12:02 <vilobhmm> agree
16:12:09 <vilobhmm> and thats why i have requested you to help there
16:12:11 <vilobhmm> with tests
16:12:18 <raildo> sajeesh: yes
16:12:26 <vilobhmm> raildo, sajeesh, ericksonsantos : i have a plan…since the "creation of allocated table patch[https://review.openstack.org/#/c/185704/] and setting default values to subproject[https://review.openstack.org/#/c/194406/]" has been merged in cinder ….from nova side we can try merging respective patches in nova and help colloboratively in helping nova with the reviews…..For the nested quota driver implementation if we all
16:12:32 <ericksonsantos> vilobhmm, in the first patch we can just test the keystone calls, and in the next we can test the quota calculation
16:12:54 <sajeesh> raildo , I will change it to context.py
16:12:55 <ericksonsantos> vilobhmm, ++
16:13:04 <ericksonsantos> sure we can
16:13:14 <sajeesh> vilobh ++
16:13:28 <vilobhmm> raildo, sajeesh, ericksonsantos : trying to do eveything in a smaller group will lead us nowhere IMHO
16:13:34 <raildo> vilobhmm: I agree, that why yesterday I made a rebase in this patches and fix some tests
16:14:09 <sajeesh> vilobh ++
16:14:44 <ericksonsantos> vilobhmm, if we made a big change it will be difficult for us to test and for the reviewers.
16:14:54 <raildo> #action  sajeesh, raildo in Nova side, try merge the initial patches related to allocated column and setting default values to subprojects
16:15:00 <vilobhmm> ericksonsantos : agree
16:15:16 <vilobhmm> even i can help in above action item
16:15:22 <vilobhmm> and with reviwing nova side code
16:15:33 <raildo> #link https://review.openstack.org/#/c/151327/29
16:15:37 <ericksonsantos> me too
16:15:41 <vilobhmm> since its a huge change…we can colllectively help sajeesh to move defaults values for  sub-project and allocated column and you all can help me with getting the nested quota driver for cinder in...
16:15:43 <raildo> #link https://review.openstack.org/#/c/151677/
16:15:59 <sajeesh> ++1
16:16:02 <vilobhmm> lets just focus on these 3 tasks
16:16:10 <raildo> sounds good to me
16:16:29 <vilobhmm> and even if we have all 3 in by next week we would have achieved almost 60%
16:16:41 <vilobhmm> and pushing nova quota driver code would be easy
16:16:48 <vilobhmm> awesome
16:16:55 <sajeesh> deadline is July-30
16:16:55 <vilobhmm> looks like we all r on same page
16:17:02 <sajeesh> yes
16:17:30 <vilobhmm> sure https://wiki.openstack.org/wiki/Liberty_Release_Schedule
16:17:36 <vilobhmm> sajeesh : ^^
16:17:42 <sajeesh> thanks
16:17:51 <raildo> sajeesh: I think that we probably will need FF for it :(
16:18:00 <ericksonsantos> I think our main challenge in order to be quota driver merged is the interaction between services (cinder/nova) and keystone
16:18:12 <sajeesh> whether we get it ? we are not in priority list
16:18:51 <raildo> I think if we finish the implementation until July-30
16:19:03 <raildo> and with tests, we have a good argument to ask for it
16:19:07 <sajeesh> that is possible
16:19:17 <vilobhmm> raildo : true
16:19:43 <sajeesh> I normally work during the weekend.. I will try to do some extra work if possible
16:19:51 <vilobhmm> ericksonsantos : I agree but can you clearly state what are the problems you are facing
16:20:29 <raildo> great, let's go work hard, and keep the focus, I believe that we can do this :)
16:20:34 <ericksonsantos> cinder does not make calls to keystone right now, and we need them in order to get project hierarchy information
16:20:40 <vilobhmm> raildo : yes we can :)
16:20:41 <sajeesh> sure we will do it :-)
16:20:41 <ericksonsantos> so, I think it's a delicate change,
16:20:53 * raildo obama feelings
16:20:59 <vilobhmm> :P
16:21:02 <vilobhmm> ok
16:21:09 <ericksonsantos> raildo, lol
16:21:14 <sajeesh> :-)
16:21:21 <raildo> anything more to discuss?
16:21:29 <vilobhmm> ericksonsantos : it would be same as interacting with other services….so we shoudl be good
16:21:47 <vilobhmm> as you described yesterday in the email thread
16:21:56 <vilobhmm> i think that approach should be fine
16:22:03 <vilobhmm> nothing more from my side
16:22:07 <vilobhmm> raildo : ^^
16:22:14 <vilobhmm> so we have 3 action items
16:22:25 <vilobhmm> 1. Push for sajeesh patch
16:22:45 <vilobhmm> for subproject default and allocated column get them merged by next week
16:22:56 <sajeesh> ok
16:23:01 <vilobhmm> 2. Cinder nested quota driver implementation…work on getting it merged
16:23:55 <vilobhmm> 3. If sajeesh's patch get stuck with reviews as his timezone is different i can move his patch ahead….since melanie is also from yahoo i can talk with her in person and help to speed up the reviews
16:24:16 <raildo> sajeesh: sounds good for you?
16:24:17 <sajeesh> vilobh thanks
16:24:22 <ericksonsantos> vilobhmm, nice to know you can talk to melwitt in person :)
16:24:26 <sajeesh> ++1
16:25:04 <raildo> sajeesh: one more thing, please abandon the other patches asap :)
16:25:17 <ericksonsantos> raildo, ++
16:25:18 <sajeesh> raildo, I have abandoned
16:25:19 <raildo> ops, you already have done
16:25:21 <vilobhmm> ericksonsantos : we sit next to each other
16:25:25 <raildo> sorry
16:25:35 <sajeesh> its ok :-)
16:25:44 <ericksonsantos> vilobhmm, awesome o/
16:26:21 <ericksonsantos> I think that's it
16:26:27 <raildo> ok, so let's go work!
16:26:28 <vilobhmm> yes
16:26:38 <vilobhmm> nothing from my side
16:26:43 <raildo> have a good weekend :)
16:26:55 <sajeesh> raildo, one more thing
16:26:56 <raildo> #endmeeting hierarchical-multitenancy