16:22:55 <vishy> #startmeeting Hierarchical Multitenancy
16:22:55 <openstack> Meeting started Fri Jun 13 16:22:55 2014 UTC and is due to finish in 60 minutes.  The chair is vishy. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:22:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:22:58 <openstack> The meeting name has been set to 'hierarchical_multitenancy'
16:23:15 <Sajeesh_> Hi Vishy
16:23:51 <vishy> I’m still working on my nova-network related code so I haven’t been able to work on multitenancy at all
16:24:02 <vishy> have you guys made any progress?
16:24:22 <schwicke> hi
16:25:36 <Sajeesh_> Regarding quota implementation on nested projects,I have opened a blue print and working on the desin
16:26:03 <schwicke> needs some coordination with Raildo I think
16:26:52 <Sajeesh_> yes
16:27:17 <schwicke> we've been starting from the domain quota code written by Vinod.
16:28:00 <raildo> I talked to morgan and it was decided that we would implement inherited roles that had been discussed earlier with you. Inherited roles will be a flag (as is done today at Keystone), remaing the implementation of list inherited roles.
16:29:07 <Sajeesh_> ok
16:29:52 <schwicke> raildo: do you have any code running already that Sajeesh could interface with ?
16:30:28 <raildo> Regarding the implementation of hierarchical project, I believe that can be used which has been implemented by Telles for the POC. https://github.com/tellesnobrega/keystone_hierarchical_projects
16:31:05 <raildo> I helped him in this implementation
16:31:21 <Sajeesh_> I will use it
16:32:15 <raildo> schwicke: I believe that this version is more clear what was implemented. https://github.com/tellesnobrega/keystone/commit/c0232d0d4f5117a09a75f5cbb7c3d063fd56a8dd
16:32:28 <schwicke> ok
16:32:46 <raildo> #link branch https://github.com/tellesnobrega/keystone/tree/hierarchical_projects
16:33:20 <Sajeesh_> ok
16:33:54 <raildo> Sajeesh_: Please disregard my last commit, because the implementation of inherited roles is incorrect.
16:34:08 <Sajeesh_> ok
16:36:12 <schwicke> I think there is one more thing which needs clarification
16:36:26 <schwicke> for the domain quota we needed to use keystone API V3
16:36:31 <vishy> has anyone been working with morgan on getting the nested projects working in keystone?
16:36:56 <morganfainberg> vishy, i have not had anyone reach out to me, was on my list to come find someone today
16:38:29 <raildo> morganfainberg: I believe that I can help with the implementation.
16:38:56 <morganfainberg> raildo, ok lets work on getting a spec in the keystone-specs repo up then
16:39:11 <raildo> morganfainberg: ok
16:39:25 <morganfainberg> raildo, thats going to be the big blocker for getting the work accepted here in Juno. 2nd we need to get the code in by J2 (Keystone's cut off for new features)
16:40:35 <raildo> morganfainberg: I was reading about the keystone-specs, I'll try to do that this week.
16:40:55 <morganfainberg> raildo, great, let me know if you need help.
16:40:57 <morganfainberg> raildo, 100% on board to get this stuff moving.
16:42:07 <raildo> morganfainberg: Thank you. Any questions I seek you in #openstack-keystone
16:42:30 <morganfainberg> raildo, ++
16:42:44 <morganfainberg> raildo, i also am in #openstack-nova and -dev (depending on the topic hit me up anywhere)
16:43:23 <raildo> morganfainberg: ok, tks
16:43:41 <schwicke> from our side Sajeesh will continue to work on the quota part for Nova. So keep in touch with you guys
16:44:42 <Sajeesh_> Yes,I am extending the code written for domain quota for nested projects
16:45:39 <raildo> morganfainberg: one doubt, I must create the keystone-specs on nested projects and not only inherited roles. correct?
16:46:01 <morganfainberg> raildo, most of the work for inherited roles already exists (domain -> projects under domain)
16:46:14 <morganfainberg> raildo, we will just extend that functionality
16:46:16 <schwicke> vishy: at some point there was the request to have a blue print for the migration of Nova using keystone api V3 everywhere. Is this a prerequisit for getting the stuff released, or is this a nice-to-have only ?
16:46:18 <raildo> Sajeesh_: Do you have some code ready? I'm curious to see this part.
16:46:25 <morganfainberg> raildo, OS-INHERIT is the extension that handles that concept
16:47:01 <Sajeesh_> raildo:Not now...I have started  the design part
16:47:09 <raildo> morganfainberg: All right, I'll refer to that extension
16:49:00 <raildo> Sajeesh_: I implemented this blueprint https://blueprints.launchpad.net/nova/+spec/domain-quota-driver, if you need, I believe I can help in something
16:49:25 <Sajeesh_> Ok..thanks
16:51:03 <Sajeesh_> raildo: I may need some clarification on the roles..I will send you a detailed mail
16:51:45 <raildo> Sajeesh_: Great, You already have my email?
16:52:06 <Sajeesh_> raildo:yes I am having
16:52:15 <raildo> Sajeesh_: ok
16:53:23 <vishy> does one of you want to take over organizing this meeting?
16:53:39 <vishy> I’m worried i’m slowing things down because I can’t really put my full attention on this right now
16:54:29 <schwicke> I think I could do that. Would need some instructions on how to do that maybe :)
16:54:49 <schwicke> unless anybody else wants to jump on this
16:57:27 <raildo> #action create the keystone-specs about nested projects
16:57:55 <raildo> schwicke: I believe I can help in any way possible
16:58:16 <schwicke> raildo: great !
17:02:35 <schwicke> vishy: do you want one of us to take over as of next week Friday ?
17:03:07 <vishy> schwicke: that would be awesome
17:03:25 <vishy> #action schwicke to take over leading the meetings
17:03:35 <schwicke> ok
17:03:43 <raildo> +1
17:03:53 <vishy> ok great
17:03:56 <vishy> thanks guys
17:04:00 <vishy> #endmeeting