16:18:10 <vishy> #startmeeting Hierarchical Multitenancy
16:18:11 <openstack> Meeting started Fri May 23 16:18:10 2014 UTC and is due to finish in 60 minutes.  The chair is vishy. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:18:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:18:14 <openstack> The meeting name has been set to 'hierarchical_multitenancy'
16:18:33 <vishy> #topic next steps
16:18:49 <vishy> so I’m wondering if we can modify the nova prototype
16:19:14 <vishy> and just have a dummy call to keystoneclient
16:19:31 <vishy> i.e. fakekeystoneclient.get_hierarchy(project_id)
16:19:43 <morganfainberg> vishy, that wouldn't be a bad approach for now.
16:19:46 <vishy> which returns parents, children
16:19:53 <raildo1> sounds good to me
16:20:10 <Sajeesh> that is good
16:20:17 <vishy> where each one is a tuple of (id, name)
16:20:20 <raildo1> I have to change the implementation of inherited roles in keystone
16:20:46 <vishy> morganfainberg: could you use raildo1’s help with that one?
16:21:05 <vishy> so I wouldn’t mind doing the nova prototype
16:21:14 <vishy> we also need a list matcher in policy
16:21:30 <vishy> instead of a prefix matcher
16:21:43 <morganfainberg> vishy, yeah i could use help there as I'm really impacted over the next week or 2
16:22:19 <vishy> #action raildo1 to help morganfainberg on role inheritance
16:22:37 <vishy> can you give raildo1 some tips as the best way to implement it?
16:22:57 <vishy> unfortunately i won’t have time to prototype stuff for a week or two
16:23:07 <vishy> doing too much nova-network hacking at the moment
16:23:17 <morganfainberg> yeah i'll work with raildo1 to get some general guidelines
16:23:23 <vishy> so if anyone else wants to tackle that part in the meantime i don’t mind
16:23:27 <morganfainberg> we can work from there.
16:24:11 <raildo1> I'm glad to help in this projects.
16:24:11 <vishy> Sajeesh: summit decision was domain related stuff does not belong in the projects
16:24:12 <morganfainberg> once i have some more spare time i'll be working more directly on the real implementation within keystone i think as well. so however we start it here for POC purposes will help direct that work
16:24:19 <raildo1> project*
16:24:37 <Sajeesh> vishy:ok
16:24:50 <vishy> so it will have to be nested project quotas
16:25:17 <vishy> so basically it will look like checking the quota for all of the parent projects
16:25:21 <vishy> jaypipes: ping
16:25:37 <Sajeesh> ok
16:25:54 <vishy> jaypipes: was talking about optimizing the quota code during this cycle to do multiple reservations in one request
16:26:19 <vishy> we probably will need to do multiple projects in one request as well to get any kind of reasonable perf out of this
16:26:58 <morganfainberg> vishy, hm. yeah.
16:33:30 <Sajeesh> vishy:I am glad to work in this poject....in which area should I work?
16:36:23 <SumitNaiksatam> .away
16:48:40 <jaypipes> vishy: on phone... wil be with you in a bit
16:51:43 <morganfainberg> vishy, jaypipes, need to run i'll read back logs here/nova channel/etc when i'm back.
16:53:28 <vishy> Sajeesh: sorry had to relocate
16:53:52 <vishy> Sajeesh: want to try redoing the nova poc with the new call?
16:54:09 <vishy> that i mentioned above?
16:54:27 <vishy> #endmeeting