14:00:23 <ricolin> #startmeeting heat
14:00:24 <openstack> Meeting started Wed Mar 20 14:00:23 2019 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:28 <openstack> The meeting name has been set to 'heat'
14:00:40 <ricolin> ramishra, zaneb pas-ha meeting time:)
14:00:42 <ricolin> #topic roll call
14:01:06 <ramishra> hi
14:01:43 <ricolin> o/
14:03:27 <ricolin> let's wait for zaneb a while:)
14:03:29 <ramishra> ricolin: Is anyone else joining? Am on 2 meetings/calls at the same time;)
14:03:36 <zaneb> o/
14:03:55 <ricolin> there he is:)
14:04:40 <ricolin> ramishra, I guess we can get started, feel free to jump across meetings if you needs
14:04:52 <ricolin> #topic adding items to agenda
14:04:58 <zaneb> fwiw I'd be fine with moving this meeting 1hr earlier if that worked better for y'all
14:04:58 <ricolin> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282019-03-20_1400_UTC.29
14:05:17 <ricolin> zaneb, that will be better IMO
14:05:35 <ricolin> ramishra, will that be better for your schedule?
14:05:42 <zaneb> (daylight savings has started here)
14:06:03 <ramishra> ricolin: yep, that would be better for me
14:06:50 * ricolin never understand why moving your time around :p
14:07:07 <zaneb> me neither ;)
14:07:14 <zaneb> Europe is going to stop
14:07:23 <ricolin> #action ricolin will change the meeting time one hour earlier
14:07:28 <zaneb> I hope the US will too but probably not this year
14:07:40 <ricolin> #topic Converting legacy Zuul jobs
14:07:58 <zaneb> so I guess this is a bit less urgent now
14:08:13 <zaneb> because they updated the legacy jobs to Bionic anyway
14:08:19 <zaneb> (and it worked! yay)
14:08:36 <ricolin> zaneb, no project breaks?
14:08:40 <zaneb> but in the long term our pain would be reduced by migrating to new jobs
14:08:55 <zaneb> ricolin: well, our project didn't break :)
14:09:22 <zaneb> so anyway, we might consider this as something we should get done in Train
14:10:03 <ricolin> zaneb, indeed, not on the top in my mind but we should make it in list
14:10:13 <zaneb> I don't think we're actually doing anything too out-there, so I don't know that it would be hard but I know very little about the zuul jobs
14:10:46 <ramishra> yeah may be we target that for next cycle. I had started it sometime back https://review.openstack.org/#/c/521236/ but never managed to spend time on it
14:11:18 <ramishra> the fact that you can't test it locally makes it really painful
14:11:36 <zaneb> yeeep
14:11:54 <ricolin> ramishra, I have try to migrate gate tests too, and I sure your pain:)
14:12:59 <ricolin> #action add  Converting legacy Zuul jobs to Train target
14:13:28 <ricolin> zaneb, move to next?
14:13:38 <zaneb> yup
14:13:42 <ricolin> #topic Cycle highlights
14:13:57 <zaneb> ricolin: have you already worked on this?
14:14:44 <ricolin> zaneb, not yet actually, but I try to list actions we done, inprogress, or hanging for this cycle here https://etherpad.openstack.org/p/2018-Denver-PTG-Heat
14:14:54 <ricolin> see the very end of the etherpad
14:15:16 <zaneb> we actually have some highlights this time, so we should make sure that we get them submitted on time :)
14:15:20 <zaneb> cool
14:15:48 <zaneb> should we start a separate etherpad to just collect cycle highlights?
14:16:07 <ricolin> zaneb, that will be a nice idea indeed
14:16:15 <zaneb> #link https://etherpad.openstack.org/p/heat-stein-highlights
14:16:41 <ricolin> lol
14:16:48 <zaneb> ok, they're due this week
14:17:29 <zaneb> I will add some stuff today, and let's try to review tomorrow and get them submitted before the end of the week
14:18:36 <zaneb> next :)
14:18:41 <ricolin> you mean submitted to openstack/releases?
14:18:58 <zaneb> yeah. I'll leave that part to you :)
14:19:36 <ricolin> #action all provide feedback to cycle hightlight in https://etherpad.openstack.org/p/heat-stein-highlights
14:20:00 <ricolin> #action ricolin summit hightlight before the end of this week
14:20:50 <ricolin> I think we need to discuss about cycle review too,
14:21:58 <ricolin> We do have some hanging targets
14:22:40 <ricolin> ramishra, zaneb would any of those task suitable for Train target?
14:23:35 <zaneb> did we not do the upgrade-checker? I thought we had
14:24:17 <ramishra> I thot that was just doing nothing:)
14:24:35 <ramishra> it's just a placeholder
14:24:39 <zaneb> yeah, but we have to have some code there to do nothing ;)
14:24:57 <zaneb> oslo will provide us with all of the code
14:25:04 <zaneb> we just need to hook it in
14:25:19 <ramishra> OK
14:26:53 <ricolin> zaneb, okay
14:27:22 <ricolin> zaneb, let's keep tracking on oslo side than
14:27:54 * ricolin move upgrade-checkers to inprogress
14:28:34 <zaneb> https://storyboard.openstack.org/#!/story/2003657 shows Heat as merged
14:29:16 <zaneb> https://review.openstack.org/611802
14:29:24 <zaneb> ricolin: you approved it :)
14:30:25 <ricolin> zaneb, yes, just though it needs more further works
14:30:51 <zaneb> no, that's all we need to do
14:31:57 <openstackgerrit> Merged openstack/heat master: Update master for stable/stein  https://review.openstack.org/644866
14:32:11 <ricolin> nice
14:32:46 * ricolin move it to achieved:)
14:32:48 * pas-ha goes to re-instate his calendar
14:32:52 <pas-ha> o/
14:33:39 <ricolin> pas-ha, notice that we will move to Wednesday 1300 UTC since next week
14:33:50 <ricolin> one hour earlier
14:33:54 <pas-ha> ok, thanks
14:34:02 <ricolin> pas-ha, and it's good to have you back:)
14:34:11 <zaneb> \o/
14:35:08 <ricolin> We should land Swift template support for cli earlier, but I guess we can do it right at Train started
14:36:18 <ricolin> We got some features under review, like add tags to octavia pool member, and make keystone endpoint type configable for server
14:36:58 <zaneb> that second one is arguably a bug
14:37:36 <zaneb> RC1 is this week, so at this point any features that have not merged have missed the boat
14:37:57 <ricolin> Heat RC1 just landed
14:37:59 <zaneb> there are I think a number of bug fixes floating around that would be nice to get in though
14:38:07 <zaneb> oh
14:38:20 <ricolin> #link https://review.openstack.org/#/q/topic:release-heat+(status:open+OR+status:merged)
14:38:20 <zaneb> well features have *definitely* missed the boat then :D
14:38:28 <ricolin> haha
14:39:08 <ricolin> I'm fine with consider that as a bug, since I really hope they can make it to earlier versions
14:39:28 <zaneb> yes, I expect we'll want to backport it regardless of when it lands
14:39:29 <ricolin> But I need to know how you guys think about it
14:39:42 <ramishra> +1
14:40:05 <ricolin> ramishra, thanks
14:40:13 <zaneb> I have a couple of concerns that are already mentioned on the patch
14:40:39 <zaneb> 1) is putting the full endpoint path (with version) in the config file the Right Thing
14:40:59 <zaneb> 2) it's not abstracted into a function that tells us what it's trying to do
14:42:50 <zaneb> ramishra: does your +2 mean that (1) is the Right Thing? I wasn't quite sure how to interpret your earlier comment
14:43:10 <ricolin> also I keep trying to make sure the queue status will be consist when we try to get status from heat-engine
14:43:29 <ramishra> zaneb: function part can be refactored later I guess, on full endpoint path, I guess we support only v3 and it's ok
14:43:35 <ricolin> another nit: will be nice to have a release note:)
14:43:57 <ramishra> ricolin: do we need releasenotes for all bugs:)
14:44:31 <ricolin> ramishra, not a blocker for sure, but will be nice to have when we touching config:)
14:45:05 <zaneb> ricolin: +1
14:46:02 <zaneb> ramishra: if we only support v3 would it be better to add the version in code so that the config option is consistent with auth_uri?
14:46:28 <pas-ha> can you drop a link to that ''make keystone endpoint type configable for server" thing?
14:46:35 <zaneb> https://review.openstack.org/#/c/642812/
14:47:34 <ricolin> #action cores please keep review keystone endpoint patch and we will allow https://review.openstack.org/#/c/642812/ to backport to previous version
14:48:18 <ramishra> zaneb: possibly, or we can do a lookup from keystone https://github.com/openstack/heat/blob/master/heat/common/endpoint_utils.py#L24
14:48:43 <ramishra> I mean discovery whatever it's called
14:50:16 <pas-ha> yes, the 'client' (os-collect-config) should be able to handle version discovery itself IMO
14:50:43 <zaneb> I'll add some comments on the review
14:51:01 <ramishra> zaneb: I mean we can change to support endpoint url without version(both) later too, so I +2ed it
14:51:12 <ricolin> pas-ha, it might be hard for inner server though
14:51:42 * ricolin need to close some tabs in chrome before it crush...
14:51:45 <zaneb> ramishra: I'd rather not ever move the goalposts on what the config option should contain
14:51:47 <pas-ha> anyway whatever ends up inside the instance must use 'public' endpoints, as it's generally not possible to access internal net from inside tenant net
14:53:00 <ricolin> pas-ha, that's true
14:53:15 <openstackgerrit> jacky06 proposed openstack/python-heatclient master: Update hacking version  https://review.openstack.org/641370
14:53:17 <ramishra> zaneb: I mean it's not a blocker as we have to make both work (with/without), but feel free to -1 it
14:54:02 <zaneb> I wouldn't -1 but I might only +1 :)
14:54:21 <ricolin> pas-ha, it might also works if we just force it all to be public endpoint
14:54:55 <ricolin> I guess we can all move to gerrit for this topic
14:54:58 <ricolin> let's move on
14:55:02 <openstackgerrit> jacky06 proposed openstack/python-heatclient master: Update hacking version  https://review.openstack.org/641370
14:55:08 <ricolin> #topic Heat Release
14:55:46 <ricolin> as you know we release heat rc1 for stein
14:56:05 <zaneb> ramishra: actually I guess we can't do discovery, because Heat itself probably can't reach the public endpoint
14:56:29 <ricolin> I'm also target some release for other repo and for stable branch
14:56:33 <ricolin> #link https://review.openstack.org/#/q/topic:release-heat+(status:open+OR+status:merged)
14:57:05 <ricolin> zaneb, your job as stable branch reviewer has come :)
14:57:09 <ricolin> zaneb, https://review.openstack.org/#/q/status:open+project:openstack/heat+branch:stable/stein
14:57:24 <zaneb> #link https://review.openstack.org/#/q/(project:openstack/heat+OR+project:openstack/heat-agents+OR+project:openstack/heat-cfntools+OR+project:openstack/python-heatclient+)+branch:%22%5Estable/.*%22+status:open
14:57:34 <ramishra> zaneb: ok, then having the version in the uri sounds like the only viable option?
14:57:36 <zaneb> looks like I have been slacking
14:58:32 <zaneb> ramishra: unless there's a way to discover the public keystone endpoint from the internal endpoint (in which case, why are we adding a config option?), I assume so yeah
14:59:23 <ramishra> zaneb: I'll look at it tomorrow, we can discuss that in the review itself, lets move on now, ricolin sorry to drag this
14:59:59 <ramishra> we have only 1 min left
15:00:09 <ricolin> ramishra, NP, that's good discussion and should keep it going in review
15:00:35 <ricolin> well, that make me need to jump to the last topic
15:00:40 <ricolin> #topic Technical Vision Reflection
15:01:25 <ricolin> I'm working on writing a daft version of reflection, but I definitely need you all to do it together
15:01:30 <ramishra> ricolin: sorry I need to go now, I'll catch up later
15:01:40 <zaneb> ramishra: thanks! \o
15:01:43 <ricolin> ramishra, thx for join
15:02:19 <zaneb> ricolin: I can help with that if I ever find the time
15:02:36 <zaneb> I need to review all of the other projects vision reflections as well :/
15:02:47 <ricolin> Anyway, let's not go to deep for the rest of meeting time, just like you guys know about this action
15:03:12 <zaneb> ricolin: where are we going to work on it? in a review? or etherpad?
15:03:47 <ricolin> #action ricolin will put out a draft version for vision reflection, cores please help on review
15:04:07 <ricolin> zaneb, let me put out a draft version and we can all update that patch anytime
15:04:12 <zaneb> ok
15:04:38 <ricolin> just resummit that patch with your update will be fine
15:05:02 <zaneb> cool
15:05:44 <ricolin> Okay, time's over, and I don't want to take too much of all your time, so let's try to keep those actions after meeting
15:06:30 <ricolin> zaneb, ramishra pas-ha feel free to tag `heat-train-target` to any story you think we have to do it in next cycle
15:06:37 <ricolin> #endmeeting