08:01:10 <ricolin> #startmeeting heat
08:01:11 <openstack> Meeting started Wed Dec 19 08:01:10 2018 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:01:14 <openstack> The meeting name has been set to 'heat'
08:01:16 <ricolin> #topic roll call
08:01:20 <zaneb> o/
08:01:32 <ricolin> o/
08:01:41 <ricolin> rabi seems not around:)
08:03:02 <ricolin> zaneb, btw I update the temp file patch for multi cloud earlier
08:03:27 <zaneb> oh, I guess I have to review that series now then
08:06:09 <ricolin> zaneb, that will be kind of you!
08:06:11 <ricolin> #topic Cirros image is AWOL in the gate
08:06:35 <zaneb> the master gate is broken
08:06:41 <zaneb> Rabi has been working on it
08:06:50 <ricolin> so the gate is failing in that patch for now
08:06:52 <zaneb> #link https://review.openstack.org/625912
08:07:05 <zaneb> yeah, strange stuff is happening
08:07:30 <zaneb> I don't understand why the new devstack is not downloading images
08:08:17 <ricolin> there must be some discussion that we're not aware about
08:08:44 <zaneb> we're not going to solve it in this meeting, but it needs to get solved so I thought it was worth flagging on the agenda
08:09:46 <ricolin> zaneb, I will try to dive in and find what's wrong, and I think Rabi will keep doing so too
08:10:14 <zaneb> cool. I put a suggestion in there but I don't know if it's crazy or not :)
08:10:24 * zaneb is not a devstack user
08:10:57 <ricolin> devstack is getting easier to use now
08:11:24 <ricolin> at least you can use systemctl to control services
08:11:39 <ricolin> #topic We need to use upper-constaints in heat-agents to unblock stable branches
08:12:06 <openstackgerrit> Rabi Mishra proposed openstack/heat master: Bump minimal_image_ref  https://review.openstack.org/625912
08:12:21 <zaneb> the stable branch gates for heat-agents are all blocked because we don't use upper-constraints
08:12:40 <zaneb> we need reviews on the patches to unblock them
08:12:47 <zaneb> #link https://review.openstack.org/#/q/Ib2ef3b3d0d0733842abad97898114c3dbdab3b7a
08:13:00 <zaneb> shouldn't take more than 3 minutes
08:13:55 <zaneb> all the major revisions of paunch have caused us no end of trouble, but once those merge we should finally have proper dependency management for heat-agents
08:14:10 <zaneb> which leads nicely into our next topic...
08:14:38 <ricolin> approved in master
08:15:19 <zaneb> ricolin: thanks. I will approve the stable ones with your +1
08:15:39 <zaneb> once that merges
08:15:49 <ricolin> talk about stable branch
08:16:03 <ricolin> is there chances we can land these https://review.openstack.org/#/c/617593/
08:16:32 <ricolin> the missing of region in os-collect config for pike and ocata
08:17:15 <ricolin> zaneb, do you happen to be the core of os-collect-config?:)
08:17:36 <zaneb> we already closed stable/pike for heat-agents, so I don't know that we should merge anything to ocata/pike
08:17:49 <zaneb> I am not stable-core on that
08:18:01 <zaneb> so it's TripleO people that would have to merge it
08:18:44 <ricolin> It's weird to fix it, and also weird to just leave it
08:19:03 <ricolin> s/and/but/
08:20:11 <ricolin> #topic It's time to remove the deprecated copy of heat-agents from heat-templates
08:20:40 <zaneb> ricolin: thanks for updating the patch
08:21:01 <ricolin> I should done that for long time:(
08:21:04 <zaneb> #link https://review.openstack.org/584777
08:21:34 <zaneb> I +2d it already, so unless somebody objects very soon I'm gonna approve it
08:21:42 <ricolin> zaneb, cool
08:21:50 <openstackgerrit> Merged openstack/heat-agents master: Use upper-constraints in tox tests  https://review.openstack.org/623363
08:21:56 * zaneb is sick of having to -2 patches to those agents
08:22:21 <zaneb> that ^ was quick
08:22:35 <ricolin> I'm also concern about the python versions too
08:22:57 <ricolin> are we going to keep update the python language version for heat-templates?
08:23:21 <zaneb> is there any python code left in that repo after this?
08:23:30 <ricolin> zaneb, well, welcome back to Asia time zone
08:23:52 <zaneb> lol
08:24:35 <zaneb> I have been pushing patches at times when I would have guessed for sure there'd be nothing running in the gate, and it has still taken ages
08:25:03 <ricolin> ./setup.py
08:25:03 <ricolin> ./tests/software_config/test_hook_cfn_init.py
08:25:03 <ricolin> ./tests/software_config/common.py
08:25:03 <ricolin> ./tests/software_config/test_heat_config.py
08:25:03 <ricolin> ./tests/software_config/test_hook_json_file.py
08:25:03 <ricolin> ./tests/software_config/test_hook_apply_config.py
08:25:05 <ricolin> ./tests/software_config/test_hook_kubelet.py
08:25:07 <ricolin> ./tests/software_config/test_heat_config_notify.py
08:25:09 <ricolin> ./tests/software_config/test_hook_salt.py
08:25:11 <ricolin> ./tests/software_config/test_heat_config_docker_compose.py
08:25:13 <ricolin> ./tests/software_config/heat_config_notify.py
08:25:15 <ricolin> ./tests/software_config/test_hook_script.py
08:25:17 <ricolin> ./tests/software_config/test_hook_puppet.py
08:25:19 <ricolin> ./tests/software_config/hook-fake.py
08:25:21 <ricolin> ./tests/software_config/hook_kubelet.py
08:25:23 <ricolin> ./tests/software_config/config-tool-fake.py
08:25:25 <ricolin> ./tests/software_config/test_hook_atomic.py
08:25:27 <ricolin> ./tests/software_config/test_hook_chef.py
08:25:31 <ricolin> ./tests/software_config/test_heat_config_kubelet.py
08:25:33 <ricolin> ./tests/software_config/test_hook_docker_compose.py
08:25:35 <ricolin> ./tests/software_config/test_hook_ansible.py
08:25:37 <ricolin> ./tests/software_config/__init__.py
08:25:39 <ricolin> ./tests/software_config/test_hook_docker_cmd.py
08:25:41 <ricolin> ./tests/software_config/test_hook_hiera.py
08:25:43 <ricolin> ./tests/__init__.py
08:25:45 <ricolin> ./doc/source/conf.py
08:25:47 <ricolin> sorry, I should use paste
08:25:49 <ricolin> Anyway, these are all python files left
08:25:51 <ricolin> in heat-templates
08:25:55 <therve> Those are the tests for agents
08:26:39 <zaneb> yeah, those should be deleted along with the agents
08:27:48 <ricolin> I guess I should remove them all in same patch
08:28:14 <zaneb> ricolin: I promise to re-review it promptly :)
08:28:55 <ricolin> thanks
08:29:30 <ricolin> #topic WTF is the name of the service(s) project in RDO???
08:29:49 <zaneb> #link https://review.openstack.org/625239
08:30:02 <ricolin> I don't know:(
08:30:05 <zaneb> so it's either "service" or "services"
08:30:15 <zaneb> it has flipped back and forth like 4 times now
08:30:34 <zaneb> it would be great to know the answer?
08:31:04 <zaneb> but failing that we should at least say we have no idea and if one doesn't work for you try the other
08:31:08 <ricolin> #link http://git.openstack.org/cgit/openstack/glance/tree/doc/source/install/install-rdo.rst
08:31:18 <ricolin> maybe this will help you
08:32:01 <ricolin> I see most of other project use `service`
08:32:08 <ricolin> why we're services?
08:32:26 <zaneb> because somebody said it was 'services'
08:32:41 <ricolin> #link http://git.openstack.org/cgit/openstack/cinder/tree/doc/source/install/cinder-controller-install-rdo.rst
08:32:45 <ricolin> cinder ^^^
08:33:16 <zaneb> #link https://review.openstack.org/531116
08:33:24 <zaneb> ricolin: you and I reviewed it ^ ;)
08:33:46 <ricolin> lol
08:34:06 <zaneb> there were 2 +1s but maybe they were just trying to pad their stats
08:34:32 <ricolin> let's secretly move it back:)
08:34:42 <zaneb> the thing is, RDO definitely does (or did) use a different name for that project than the official install guide
08:34:57 <zaneb> therve: do you remember the details?
08:35:31 <ricolin> therve, good morning:)
08:35:33 <therve> Not precisely. I think it's some puppet BS at the origin
08:35:57 <zaneb> I'd vote for change it back but add a note saying if that doesn't work then try 'services'
08:36:37 <therve> puppet uses services, so tripleo uses services, so rdo uses services?
08:36:42 <therve> Or something like that
08:37:04 <zaneb> therve: or the other way around? :D
08:37:11 <therve> Exactly
08:37:12 <ricolin> so rdo use puppet?
08:37:37 * ricolin never play with rdo installation
08:37:54 <zaneb> #action zaneb to propose a new patchset
08:39:09 <ricolin> #topic Tap-as-a-Service patches are ready for merging IMHO
08:39:26 <ricolin> #link https://review.openstack.org/589238
08:39:26 <ricolin> #link https://review.openstack.org/625210
08:39:50 <zaneb> I believe I reviewed all of the pending new resource type patches this week
08:40:30 <zaneb> L2Gateway and Blazar need some minor tweaks
08:40:40 <ricolin> Vitrage one?
08:40:53 <zaneb> but I believe the Tap-as-a-Service is ready to merge with one more reviewer
08:41:03 <zaneb> ricolin: I did not review Vitrage
08:42:05 <ricolin> zaneb, I can review it right after meeting
08:42:14 <zaneb> ricolin: is Vitrage ready for Stein?
08:42:30 <zaneb> I thought you mentioned at the last meeting that they were WIP still
08:42:44 <zaneb> also they weren't in my queue
08:42:48 <ricolin> zaneb, No, if you mean the resource type, but she needs more feedback for sure
08:43:08 <ricolin> And yes it's WIP
08:43:45 <zaneb> ok, added it to my queue
08:43:47 <ricolin> but not going to go anyway, if we provide no feedback
08:44:05 <ricolin> zaneb, thanks:)
08:44:05 <zaneb> but my top priority for now is stuff that is merge-able in Stein
08:44:23 <ricolin> zaneb, agreed
08:44:39 <therve> zaneb: The glance image stuff maybe?
08:45:17 <ricolin> therve, glance V2 support?
08:45:27 <therve> ricolin: web-download support
08:45:36 <ricolin> therve, yes
08:45:42 <therve> https://review.openstack.org/617915
08:45:49 <zaneb> therve: is the 'WIP' in the headline still accurate?
08:46:00 <therve> zaneb: Somewhat
08:46:29 <therve> Probably need a story, and also if we care about graceful failure
08:47:15 <zaneb> we don't have a mechanism in general for hiding resources based on optional features, do we
08:47:21 <ricolin> therve, maybe we should just change Image  to use webdownload?
08:47:55 <zaneb> which is something openstack in general is somewhat weak in: https://review.openstack.org/#/c/621516/
08:47:55 <therve> zaneb: We do, but not that the level that glances exposes it
08:48:05 <therve> We do for service stuff like load balancing
08:48:25 <zaneb> right, yeah we can hide it if there's no service endpoint in the catalog
08:48:44 <zaneb> but within a service, we can't do that kind of introspection
08:49:12 <therve> Well there is service extension too
08:49:35 <zaneb> oh, ok, it's fancier than I thought
08:50:16 <zaneb> but this is less of an extension and more of a configuration option?
08:50:36 <zaneb> is it tied to policy at all, or just an option?
08:50:46 <therve> I think it's just an option
08:51:00 <therve> It probably could be exposed as an extension but I don't believe that's the case
08:54:05 <zaneb> therve: I'd be inclined to go with 'meh, just ship it' then
08:54:12 <therve> OK :)
08:54:39 <therve> It can definitely be fixed easily after
08:54:54 <zaneb> users want it, and if it doesn't work they'll get an error _fairly_ early
08:55:18 <zaneb> therve: I'm still not convinced we need to change the type name though
08:55:52 <zaneb> the new resource can still delete images created by the old one, right? what else is there to do to maintain compatibility?
08:56:10 <therve> The properties are not the exact same
08:56:20 <zaneb> ah, ok
08:57:04 <zaneb> I hate naming resources with verbs is all
08:57:19 <ricolin> IIRC, it's an option, and we need to give declare to say we only support web download if we like to mark substitute_class for Image?
08:57:53 <zaneb> ah, you put the substitute_class thing in, that's cool
08:58:39 <therve> We can replace the existing, but I'm not going to test the behavior :)
08:59:24 <zaneb> it should work
09:00:13 <therve> Yep I don't mind. Rabi suggested the new name in the first place
09:00:21 <ricolin> maybe we can bump to v2 in following patch:)
09:00:23 <zaneb> actually, I think the properties have to be compatible, so I'll check that
09:00:46 <zaneb> what about OS::Glance::WebImage?
09:01:03 <ricolin> zaneb, yes, it have to be cover all the old properties IIRC
09:01:25 <therve> We can keep the props and ignore the irrelevant ones
09:01:41 <ricolin> therve, +1
09:02:19 <zaneb> I didn't actually know the props were different until just now
09:02:38 <therve> is_public, extra_properties are out
09:02:56 <therve> os_version and visibility are in
09:05:34 <ricolin> Okay let's review that patch as following actions
09:05:49 <ricolin> Also tap as a service too
09:05:55 <ricolin> #topic Open discussion
09:05:59 <zaneb> therve: so I think you just need to add translation rules for those to make it compatible
09:06:12 <therve> "just" :D
09:06:18 <zaneb> SMOP
09:07:07 <ricolin> If you're using translate rule that means you have to also define them in new resource type too
09:07:10 <zaneb> http://www.catb.org/jargon/html/S/SMOP.html <- reference
09:07:20 <ricolin> that's not ideal IMO
09:07:44 <zaneb> ugh, do you
09:08:13 <zaneb> maybe just skip the substitute class thing then
09:08:41 <zaneb> GlanceV1 has been dead for long enough that there's probably not many users affected
09:10:03 <ricolin> maybe:)
09:10:45 <ricolin> Anything else for topic?:)
09:11:26 <zaneb> if we have to add the old properties with translations then there's no point doing the new class. I thought the translations ran first, but if not I don't think it's worth the effort
09:11:51 * zaneb has nothing else
09:12:14 <zaneb> this felt productive though!
09:12:29 <zaneb> let's do it again. but not next week because it's christmas
09:12:44 <ricolin> zaneb, we need to trace more to be productive
09:13:03 <ricolin> zaneb, agree, let's skip the next one
09:13:33 <zaneb> ricolin: yeah, we do need to make sure we follow up
09:13:40 <zaneb> but at least we talked about stuff
09:13:58 <ricolin> zaneb, yep!
09:13:59 <zaneb> it's very quiet out here in +13 TZ
09:15:09 <ricolin> most of the people are sleeping while you're awake:)
09:15:21 <ricolin> #endmeeting