14:00:35 <ricolin> #startmeeting heat
14:00:37 <openstack> Meeting started Wed Mar 21 14:00:35 2018 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:40 <openstack> The meeting name has been set to 'heat'
14:00:44 <ricolin> #topic roll call
14:02:09 <ramishra> hi
14:02:16 <ricolin> o/
14:02:21 <zaneb> o/
14:02:47 <kazsh> o/
14:03:06 <ricolin> #topic adding items to agenda
14:03:07 <ricolin> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282018-03-21_1400_UTC.29
14:04:28 <ricolin> #topic Vancouver Summit
14:05:16 <ricolin> If any one got any topic for Furum, now is brain stroming
14:05:18 <ricolin> #link
14:05:18 <ricolin> https://wiki.openstack.org/wiki/Forum/Vancouver2018
14:05:41 <ricolin> if got any heat specific topic
14:05:45 <ricolin> #link https://etherpad.openstack.org/p/YVR-forum-heat-brainstorming
14:06:12 <ricolin> Who will be there for Vancouver summit?
14:06:29 <ramishra> Negative :)
14:06:41 <ricolin> kazsh?
14:06:44 <zaneb> I plan to skip this one
14:06:46 <kazsh> hopefully I will be there :)
14:06:57 <kazsh> I didn't talk with my boss yet but
14:07:06 <kazsh> I have a reason why I will be there :)
14:07:23 <kazsh> looks the forum session is good place to get feedbacks for the dashboard
14:07:46 <ricolin> kazsh, if I put you up for project update, is that a good reason?:)
14:08:00 <kazsh> ahh yea, yes :)
14:08:11 <kazsh> good I have two reasons :)
14:08:45 <ricolin> cool, I will take care of it
14:09:04 <kazsh> ricolin: thanks mate
14:10:15 <ricolin> #topic Open discussion
14:10:43 <ricolin> we've reapply for rolling upgrade tag
14:10:57 <ricolin> and it looks good
14:10:59 <ricolin> #link https://review.openstack.org/#/c/503145/
14:12:12 <ricolin> also the one for clarify testing
14:12:13 <ricolin> https://review.openstack.org/#/c/550571/
14:12:31 <ricolin> I wonder what's our next step for that?
14:12:51 <ricolin> separate a new tempest test repo for interop test?
14:12:55 <zaneb> we'll have to split the repo again
14:13:12 <ricolin> zaneb, and what needs to be in it
14:13:24 <ricolin> those tests for interop
14:13:32 <zaneb> once it's approved we can talk to the interop folks and see if they want the repo under their governance or ours
14:13:45 <zaneb> ricolin: yes, just the tests that were approved by the board
14:14:03 <ramishra> zaneb: Split or copy api tests to a new repo for interop testing?
14:14:44 <ricolin> zaneb, and do you think we should test those tests in heat or just copy it out
14:15:53 <zaneb> start with a copy and then we can decide later about removing them from heat-tempest-plugin or not
14:16:05 <ricolin> I think we can copy and maybe make a non-voting job for it?
14:16:08 <zaneb> once we're sure all the gating is correct
14:16:18 <ramishra> Good to keep them in one repo only. but then we need to test them at the gate, so have to fix the gate testing.
14:16:26 <ramishra> yep
14:16:36 <ricolin> okay
14:17:18 <ramishra> ricolin: can we merge https://review.openstack.org/#/c/550708/?
14:18:25 <ricolin> zaneb, I'm fine with put new tempest plugin under our governance if those just tests from heat, but I guess that's interop team's call
14:19:10 <ricolin> ramishra, done
14:19:28 <zaneb> ricolin: I personally think that when there are a bunch of these it will make sense to have them in one place, but I'm fine with it being under our governance too
14:20:20 <ricolin> zaneb, you mean like maybe a single interop test repo for all tests from projects?
14:21:09 <zaneb> ricolin: no, I mean having all of the different projects' interop test repos under refstack governance
14:22:32 <ricolin> zaneb, got it
14:23:06 <ricolin> Anything to discuss today?
14:23:13 <ramishra> zaneb: Is the interop/refstack team interested in doing that? I would assume we keep it with us unless they ask for it;)
14:24:00 <zaneb> ramishra: we have discussed it with them. the resolution is written in such a way as to let them decide
14:24:06 <ricolin> ramishra, they actually wish not, that's why they asking tempest team to do it
14:24:35 <zaneb> ricolin: that's not accurate afaik
14:25:21 <zaneb> the original idea proposed after the TC session was for the QA team to take it, and so originally I was pursuing that
14:25:50 <ramishra> I'm confused by the some of the mails from the tempest team on the topic. Anyway, we should be fine with anything that they decide;)
14:26:05 <zaneb> but the QA team didn't want it. RefStack were open to the idea of taking it, so the new resolution says that they can have it if they want it, otherwise we'll keep it
14:26:28 <ramishra> zaneb: ack
14:26:30 <ricolin> ramishra, I think the resolution is the final answer for any discussion in that ML
14:26:49 <zaneb> ramishra: the various members of the QA team were not all on the same page, which is why it was confusing
14:27:21 <ricolin> #action separate tempest repo for interop tests once https://review.openstack.org/#/c/550571/ landed
14:27:53 <ricolin> #action confirm with refstack team about the governance
14:28:09 <ricolin> zaneb, is these sounds right?
14:28:10 <ricolin> ^^^
14:28:46 <zaneb> ++
14:29:13 <ricolin> cool, I will confirm with them
14:30:10 <ricolin> I guess a lot of stuff for PTG is still WIP, so no much to discuss about:)
14:30:29 <ricolin> maybe start trace after few weeks
14:30:38 <ricolin> Anything else?
14:31:54 <ricolin> I guess that's all for today, thanks zaneb ramishra kazsh
14:31:59 <ricolin> #endmeeting