20:00:15 <skraynev_> #startmeeting heat
20:00:16 <openstack> Meeting started Wed Jan 27 20:00:15 2016 UTC and is due to finish in 60 minutes.  The chair is skraynev_. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:20 <openstack> The meeting name has been set to 'heat'
20:00:23 <prazumovsky> Hi
20:00:30 <skraynev_> #topic rollcall
20:00:31 <jdob> o/
20:00:32 <Drago> o/
20:01:12 <skraynev_> shardy, stevebaker, zaneb
20:01:33 <jdob> ... slackers :)
20:01:50 <zaneb> sorry, will only have 5% attention on this today
20:01:51 <skraynev_> lol ;)
20:01:58 <jdob> actually, i shouldn't start out talking trash, I need to beg for core reviewers on one of my patches
20:02:24 <skraynev_> zaneb: np. We have a short agenda, just want to make sure, that somebody else here ;)
20:02:41 <zaneb> jdob: just be grateful you're not doing what I've been doing all day ;)
20:03:04 <jdob> i have no idea what you've been doing, but I can say with 100% certainty that i am glad it's you and not me
20:03:11 <randallburt> o/
20:03:40 <cwolferh> o/
20:03:40 <skraynev_> jdob: let's continue it in Open discussion, please
20:03:54 * jdob quiets down
20:03:55 <skraynev_> #topic Adding items to agenda
20:04:10 <skraynev_> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282016-01-27_2000_UTC.29
20:04:22 <skraynev_> as I told it's really short :)
20:04:50 <skraynev_> so let's do it quick and got to Open discussion
20:05:08 <skraynev_> if nobody don;t mind of course ;)
20:05:21 <jreeves> oops..I forgot to add mine to the agenda
20:05:36 <skraynev_> jreeves: do it ;)
20:05:43 <skraynev_> #topic Remove useless job for heatclient and find alternative
20:06:24 <skraynev_> we have a bug https://bugs.launchpad.net/python-heatclient/+bug/1532867
20:06:26 <openstack> Launchpad bug 1532867 in python-heatclient "gate-tempest-dsvm-neutron-src-python-heatclient is useless" [Medium,Triaged] - Assigned to Sergey Kraynev (skraynev)
20:06:43 <skraynev_> This job does not make sense for us gate-tempest-dsvm-neutron-src-python-heatclient
20:06:59 <skraynev_> because it does not execute any Heat related tests
20:07:02 <randallburt> kill it with fire
20:07:28 <skraynev_> Yes, https://review.openstack.org/#/c/272411/
20:07:30 <jreeves> agenda updated
20:07:34 <skraynev_> it's already here ^
20:07:39 <skraynev_> so
20:07:50 <skraynev_> do we need some alternative for it?
20:08:34 <skraynev_> some tempest job or we may improve our own functional tests for heatclient and it will be enough ?
20:08:40 <randallburt> skraynev:  what was it "supposed" to do?
20:09:05 <jdob> is it worth investing in replacing whatever it's supposed to do against heat client or potentially rewrite for OSC?
20:09:20 <randallburt> skraynev:  and has our current gate not given us enough confidence?
20:09:53 <randallburt> jdob:  was just about to say, I agree it doesn't make much sense unless we start writing functional tests for the OSC stuff
20:10:24 <skraynev_> randallburt: as I see, it tries to execute tempest.api tests
20:10:35 <skraynev_> f.e. tempest.api.orchestration.stacks.test_neutron_resources.NeutronResourcesTestJSON
20:11:23 <skraynev_> TBH, I have not checked, what exactly this test does
20:11:26 <randallburt> skraynev_:  but tempest uses its own client so it is in fact pointless
20:12:39 <randallburt> anyway, fwiw, I would say we just remove it since its not doing anything for us and write functional jobs that run the osc plugins against devstack
20:12:49 <skraynev_> randallburt: agree, but it might have some useful test cases. Probably the best solution - check what tests it had and add something similar to our internal functional tests (if it be really valuable for us)
20:12:50 <jdob> +1
20:13:04 <randallburt> and not try and write new tests for the existing client
20:13:28 <skraynev_> randallburt: good point. I forgot about it.
20:14:11 <skraynev_> #action don't wtite new functional tests for old client methods. Do it for osc plugin
20:14:23 <skraynev_> next one
20:14:34 <skraynev_> #topic Update spec to add new resource type
20:14:45 <skraynev_> #link https://review.openstack.org/#/c/272173/
20:14:56 <skraynev_> looks like I did what I could :)
20:14:59 <jreeves> simple thing left. just needs anothe +2
20:15:01 <skraynev_> for this spec
20:15:05 <jreeves> another
20:15:11 <jreeves> yeah, thanks skraynev
20:15:22 <jreeves> hoping to get this in so I can get to coding
20:15:38 <skraynev_> jreeves: you need two +2
20:15:48 <jreeves> yeah....'another' :)
20:15:48 <skraynev_> because it's a specs repository
20:16:13 <skraynev_> jreeves: two != second
20:16:26 <jreeves> ah
20:16:27 <skraynev_> totally it should be equal 3 -  +2
20:16:35 <skraynev_> before it be approved
20:17:05 <skraynev_> we use this approach, because it allows for more people take a look on spec
20:17:20 <randallburt> IMO this sounds like a good candidate for the spec-lite
20:17:29 <randallburt> not that you should redo anything
20:17:43 <skraynev_> randallburt: first bird ? :)
20:18:10 <skraynev_> first candidate == first bird :)
20:18:15 <randallburt> lol
20:18:16 <randallburt> sure
20:18:22 <randallburt> but I +2 anyway :D
20:18:48 <skraynev_> jreeves: try to ping tiantian or shardy or therve tomorrow
20:18:56 <jreeves> ok
20:19:07 <skraynev_> jreeves: or you can choose hard way and ask zaneb ;)
20:19:23 <skraynev_> #topic Open Discussion
20:19:26 <randallburt> skraynev_:  but going forward, I think new resources def fall in the spec-lite bucket
20:19:35 <randallburt> lol
20:19:38 <zaneb> -2
20:19:41 <zaneb> what is the spec?
20:19:53 <skraynev_> zaneb: https://review.openstack.org/#/c/272173/
20:19:54 <randallburt> new netron qos resources
20:19:59 <jreeves> ok....I'll do that moving forward. I think I asked in the #heat channel last week about that, but got no response...so this was a simple add
20:21:01 <skraynev_> jdob: what patch did you want to ask to review?
20:21:07 <jdob> https://review.openstack.org/#/c/239967/
20:21:17 <jdob> already had a +2 from shardy, but the RPC versoin moved again
20:21:35 <skraynev_> jdob: oh. it's about multienviroments ?
20:21:43 <jdob> and i have another change that will also move the RPC version so i'd like to get this one landed before I'm chasing two patches
20:22:24 <jdob> ya, i still need to figure out why CI is failing on the impl behind multi-env, but it doesnt seem to happen all the time
20:22:32 <skraynev_> jdob: I remember about it. it was in my today's plans, but I stopped before this one :) I promise to review it tomorrow (if you will not find someone else)
20:22:47 <jdob> mostly just hoping to get it in before the RPC versoin moves again
20:22:50 <jdob> awesome, thanks! :)
20:23:14 <pratikmallya> damned rpc version
20:23:38 <randallburt> jdob:  where do these files get resolved or are they already assumed to be the file contents at this point?
20:23:57 <jdob> they are in the files dict by the time they reach the server
20:23:59 <skraynev_> jdob: early thanks. I will do it only tomorrow ;)
20:24:22 <randallburt> jdob:  k, thanks for saving me digging
20:24:30 <jdob> :)
20:24:32 <randallburt> jdob:  I'll also try and take a look later this afternoon
20:24:37 <jdob> very much appreciate it
20:24:41 <skraynev_> pratikmallya: we just need to stop commit changes in rpc :)
20:25:17 <skraynev_> do we have anything else for discussion?
20:25:22 <randallburt> skraynev_:  you joke but should we really bump rpc version for *every* change or just when releases are cut
20:25:37 <skraynev_> Oh. I forgot. We released 0.9.0 version for heatclient
20:25:40 <prazumovsky> hm... Another one
20:25:42 <randallburt> skraynev_:  probably an old can of worms really
20:26:24 <skraynev_> randallburt: as I remember therve found some useful link in documentation
20:26:36 <prazumovsky> Short notice: we have netgateway resource with property list of devices id, but have no gateway device resource
20:26:55 <skraynev_> where rules about updating rpc version were clearly described
20:27:39 <prazumovsky> think, this is should be implemented, cause it's little odd have resource which have links on other resource, which is not in heat
20:27:41 <skraynev_> randallburt: I need to dig in log history and then find it, if you want ?
20:28:16 <prazumovsky> end notice:)
20:28:18 <skraynev_> prazumovsky: not really, but it will be good to have this resource in heat :)
20:28:20 <randallburt> skraynev_:  I have no patches that affect rpc, so nbd if we keep on like we are. I'll complain when I have to rebase a 1000 times :)
20:29:03 <skraynev_> prazumovsky: btw, as was mentioned above - use for this lite spec - as launchpad bug
20:29:28 <prazumovsky> yeah, i thought about that
20:29:39 <skraynev_> prazumovsky: As I remember ramishra posted patch with guidelines about it on review
20:29:42 <prazumovsky> will be good practice:)
20:30:42 <prazumovsky> skraynev_: ok
20:30:45 <skraynev_> randallburt: I understand it, but if you have changes in some common file - it's expected result
20:31:22 <skraynev_> randallburt: we may add link on original doc to our developer guides. I think it will be useful
20:31:32 <jreeves> http://osdir.com/ml/openstack-dev/2016-01/msg01323.html
20:32:08 <jdob> ya, i only really stumbled on it when i got a comment on my review about needing to bump it
20:32:17 <randallburt> skraynev_:  sure
20:32:44 <skraynev_> #action skraynev ask therve to post link on guide with description of rpc version changes or do it himself
20:32:56 <skraynev_> ok. that's all from my side
20:34:22 <skraynev_> So all other questions -> #heat
20:34:29 <skraynev_> thank you all ;)
20:34:48 <jdob> \o
20:34:57 <skraynev_> #endmeeting