20:00:47 <skraynev_> #startmeeting heat
20:00:47 <openstack> Meeting started Wed Jan 13 20:00:47 2016 UTC and is due to finish in 60 minutes.  The chair is skraynev_. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:51 <openstack> The meeting name has been set to 'heat'
20:01:01 <skraynev_> #topic rollcall
20:01:08 <jdob> o/
20:01:21 <stevebaker> hi!
20:01:37 <skraynev_> shardy
20:01:41 <skraynev_> pas-ha
20:01:46 <markvan> howdy
20:01:47 <zaneb> o/
20:01:49 <ochuprykov> hi
20:02:33 <shprotby> hello
20:02:40 <skraynev_> more we need more people (sinister laugh)
20:02:51 <skraynev_> :)
20:03:13 <skraynev_> #topic Adding items to agenda
20:03:19 <shprotby> test my nickname.
20:03:23 <shprotby> Hm...
20:03:31 <skraynev_> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282016-01-13_2000_UTC.29
20:04:45 <skraynev_> so two big sections - upcoming releases/milestones and convergence
20:06:24 <skraynev_> #topic Review priorities
20:06:51 <skraynev_> I think, that we may skip it and focus on bugs and BPs targeted on m2
20:06:54 <skraynev_> so
20:07:24 <skraynev_> I will mention it later ;)
20:07:28 <skraynev_> #topic release for stable/liberty
20:07:36 <stevebaker> I have a series of heatclient backports which need reviews so that 0.8.1 can be released https://review.openstack.org/#/q/status:open+project:openstack/python-heatclient+branch:stable/liberty+topic:bug/1532326
20:08:10 <skraynev_> stevebaker: do we need merge them before heatclient release, I suppose ?
20:08:25 <stevebaker> skraynev_: yep, its on a stable/liberty branch
20:09:56 <skraynev_> stevebaker: hm. I am not sure, that we will make new tag for stable/liberty for python heatclient, but I will try to review (I already  have reviewed couple of them)
20:10:13 <skraynev_> so about stable/liberty and heat.
20:10:25 <skraynev_> ttx sent a mail about it.
20:10:55 <skraynev_> and we may do new extra tag for stable/liberty branch in heat
20:11:40 <stevebaker> can we do a stable/liberty release whenever we feel the need to?
20:11:41 <skraynev_> #link https://review.openstack.org/#/q/project:openstack/heat+branch:stable/liberty+status:open
20:11:54 <skraynev_> stevebaker: we should it in this way :)
20:12:19 <skraynev_> ttx: just notify, that it looks like we have enough commits in stable/liberty alredy
20:12:22 <skraynev_> *already
20:12:26 <stevebaker> hell yes
20:13:47 <skraynev_> I think we may try to merge this list ^ of commits during this week
20:13:55 <skraynev_> and make a release on the next one.
20:14:03 <skraynev_> stevebaker: what do you think?
20:14:32 <zaneb> stevebaker: are we backporting convergence stuff to stable?
20:14:34 <skraynev_> we need to involve shardy and zaneb in this process
20:14:34 <stevebaker> sounds good, those which haven't merged this week can be evaluated for being punted to next release
20:14:35 <zaneb> and if so, why?
20:14:51 <stevebaker> zaneb: not so much anymore
20:15:11 <skraynev_> zaneb: I see couple commits related with convergence
20:15:21 <zaneb> ok, I see at least two and likely more in that list
20:15:32 <skraynev_> maybe they were introduced early
20:16:01 <skraynev_> zaneb: imo we may merge them without big risk
20:16:27 <zaneb> I guess, but there's no point waiting on them either
20:16:39 <skraynev_> zaneb: agree
20:17:12 <stevebaker> maybe just abandon them, lets reduce our cognitive load
20:17:29 <zaneb> skraynev_: btw the rule for stable branches is that the author or backporter can count as a +2 if they are core
20:17:38 <skraynev_> #action shardy, stevebaker, zaneb, skraynev prepare stable/liberty branch for new release to next week (merge remaining patches)
20:17:43 <stevebaker> unless they affect the stablity of the liberty ci
20:17:47 <zaneb> skraynev_: so you may only need 1 other person to approve
20:18:19 <zaneb> I think some of the ones in that list with +2 could have been approved already under that rule
20:18:21 <skraynev_> zaneb: I have not know about such exception :)
20:18:33 <skraynev_> zaneb: your truth ;)
20:18:48 <zaneb> skraynev_: I heard it from one of the stable branch folks
20:18:55 <stevebaker> tis true
20:19:12 <skraynev_> zaneb: stevebaker: nice
20:19:27 <skraynev_> then it will be easier
20:20:04 <skraynev_> #action skraynev upload patch to release repo for new stable/liberty release on the next week
20:20:19 <skraynev_> go to the next one
20:20:24 <skraynev_> #topic new release for python-heatclient
20:21:03 <skraynev_> stevebaker: I remember, that we wanted to do it in Jan
20:21:10 <skraynev_> so we are here
20:21:41 <stevebaker> yep, that is what the backports are for https://review.openstack.org/#/q/status:open+project:openstack/python-heatclient+branch:stable/liberty+topic:bug/1532326
20:22:18 <stevebaker> since we're in the middle of developing the openstack commands I propose that we do a python-heatclient-1.0.0 when they are useful enough
20:22:34 <markvan> yup, for mitaka, good progress on openstack client  https://review.openstack.org/#/q/status:open+project:openstack/python-heatclient+branch:master+topic:bp/heat-support-python-openstackclient
20:22:44 <stevebaker> until then we can do 0.8.x bug fix releases on the stable/liberty branch
20:22:53 <skraynev_> stevebaker: hm.. we probably talk about two different things. I meant new release for master
20:23:13 <skraynev_> because we have some stuff, which are not available via pip installation
20:23:33 <skraynev_> and as result is not available in default devstack
20:23:46 <stevebaker> skraynev_: which changes are you looking for>
20:23:48 <stevebaker> ?
20:23:51 <jdob> stevebaker, is the openstack client  ultimately going to sit in heatclient side by side with the old stuff?
20:23:58 <jdob> er, openstack client commands
20:24:10 <skraynev_> stevebaker: honestly - changes related with new API for outputs
20:24:38 <stevebaker> jdob: yes, heatclient commands will eventually be deprecated, and openstack commands will live in heatclient
20:24:46 <jdob> cool
20:24:52 <skraynev_> stevebaker: I agree to propose 0.8.x for stable/liberty after merging backports mentioned by you
20:26:04 <skraynev_> stevebaker: as I understand openstack commands are not merged yet, so we may do a pre-version with all fixes, but without openstack commands. what do you think about it?
20:26:32 <stevebaker> skraynev_: how about a patch which doesn't register the osc plugins, so we can do a 0.9.0
20:26:53 <skraynev_> #action merge backports patches in stable/liberty for python-heatclient and then propose new 0.8.x release for stable branch
20:27:05 <skraynev_> stevebaker: +2
20:27:23 <stevebaker> it would just comment out setup.cfg openstack.cli.extension
20:27:35 <skraynev_> and then focus on review osc and release 1.0.0 with all these commands
20:27:59 <stevebaker> sounds fine to me
20:28:26 <stevebaker> are there any pending reviews which need to be in a 0.9.0?
20:28:27 <skraynev_> stevebaker: would you like to do it or I need to assist with it ?
20:28:59 <zaneb> https://review.openstack.org/#/c/266653/1/heatclient/openstack/common/apiclient/base.py makes my eyes bleed
20:30:25 <skraynev_> zaneb: oh. it's patch from super series, which try to fix everywhere ;)
20:30:43 <stevebaker> skraynev_: do you want to handle 0.9.0 and I
20:30:49 <stevebaker> 'll do 0.8.1?
20:31:34 <skraynev_> stevebaker: as you want. I agree with any solution, where I do just a half part of the work :))
20:31:42 <stevebaker> heh
20:31:46 <skraynev_> :)
20:32:00 <skraynev_> so. yes. I can take 0.9.0
20:32:16 <skraynev_> and help with merging patches for 0.8.x
20:33:49 <skraynev_> #action prepare and do 0.9.0 release for python-heatclient with stub in setup.cfg for osc commands
20:34:01 <skraynev_> stevebaker: correct ^ ?
20:34:27 <skraynev_> #topic Mitaka-2 release date
20:34:37 <stevebaker> +1
20:34:51 <skraynev_> stevebaker: ok
20:34:57 <skraynev_> the most important topic
20:35:13 <skraynev_> on the next week should be released m-2
20:35:24 <skraynev_> #link http://docs.openstack.org/releases/schedules/mitaka.html
20:35:46 <skraynev_> #link https://launchpad.net/heat/+milestone/mitaka-2
20:36:20 <skraynev_> we have 5 BPs, probably 2 of them will be merged
20:36:31 <skraynev_> other have more patches for review
20:36:56 <skraynev_> #link welcome to review this one https://blueprints.launchpad.net/heat/+spec/add-neutron-address-scope
20:37:09 <skraynev_> there is one patch need to be merged
20:37:31 <skraynev_> Senlin is blocked by one patch with WIP...
20:38:11 <skraynev_> jdob: and I remember about your patches. for https://blueprints.launchpad.net/heat/+spec/multi-environments
20:38:32 <jdob> i was gonna pester people about those :)
20:38:42 <jdob> right now failing CI from the ceilometer fix, but should hopefully pass soon
20:38:46 <jdob> since that fix got merged
20:39:11 <skraynev_> jdob. sure
20:40:34 <jasond> here's another for m-2 https://review.openstack.org/#/c/256872/
20:40:36 <skraynev_> about bugs.... welcome to fix them. looks like we need to make some bug fixing day ;)
20:41:46 <skraynev_> jasond: updated. doh. a lot of patches need to review.
20:42:28 <skraynev_> #topic Enabling convergence by default
20:43:02 <skraynev_> zaneb, stevebaker: ananta raised this question on the previous meeting
20:43:24 <zaneb> is it ready?
20:43:48 <skraynev_> AFAIK, we still have some skipped functional tests for convergence
20:44:22 <skraynev_> except this job is green about month
20:44:39 <skraynev_> so we need to make decision about it
20:45:07 <jdob> would it make sense to hold off until after m2 to be safe?
20:45:16 <jdob> "safer", I suppose
20:45:56 <skraynev_> jdob: you stole my words ;)
20:46:12 <skraynev_> ananta suggested to do it before m-2
20:46:15 <zaneb> I'd like to see us not skip any tests
20:46:17 <stevebaker> I'm still yet to get a tripleo overcloud to deploy with convergence
20:46:24 <jdob> :)
20:46:42 <zaneb> but I'd also like to see us flip it soon, so that if there's screaming we will hear it before the Mitaka release
20:46:47 <skraynev_> however I prefer to do it after m-2
20:46:51 <stevebaker> I tried it mid-december and it didn't work, but I'll try again soon
20:47:13 <stevebaker> ... and this time raise bugs ;)
20:47:13 <skraynev_> stevebaker: could you check it after m-2 ?
20:47:49 <skraynev_> and I will prepare announce about our plans
20:48:18 <skraynev_> zaneb: and in this ^ mail mention a important patches
20:48:27 <skraynev_> for enabling skipped tests
20:49:15 <skraynev_> #action sent mail about making convergence by default after m-2
20:49:27 <skraynev_> #topic Open Discussion
20:50:11 <skraynev_> something else for discussion?
20:50:28 <markvan> hi, just a plug for the lbaasv2 work https://review.openstack.org/#/q/status:open+project:openstack/heat+branch:master+topic:bp/lbaasv2-suport
20:50:39 <markvan> is that something that could make the review priority list?
20:51:02 <markvan> it's very close now, thx for all the previous review efforts
20:53:02 <skraynev_> I don't want to be a rough, but looks like we will not do it before m-2. Could you ping more core-reviewers from the next week
20:53:27 <skraynev_> I believe we will take a look on it
20:53:43 <markvan> yup, was not expecting it for m-2, just want to keep it a float
20:53:44 <skraynev_> and will merge if you say, that it's ready ;)
20:53:53 <skraynev_> markvan: sure
20:54:05 <markvan> thx
20:55:02 <skraynev_> good. we can finish now ;)
20:55:12 <skraynev_> thank you all, guys :)
20:55:13 <jdob> \o
20:55:16 <stevebaker> \o
20:55:16 <skraynev_> #endmeeting