20:00:03 <asalkeld> #startmeeting heat
20:00:05 <openstack> Meeting started Wed Dec 17 20:00:03 2014 UTC and is due to finish in 60 minutes.  The chair is asalkeld. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:08 <openstack> The meeting name has been set to 'heat'
20:00:25 <asalkeld> #topic rollcall
20:00:48 <stevebaker> sort-of here (at the hospital)
20:00:48 <skraynev_> o/
20:00:58 <jpeeler> hi
20:00:59 <ryansb> \o
20:01:10 <asalkeld> hope all is well stevebaker
20:01:11 <russellb> stevebaker: eep, hope everything is ok
20:01:21 <skraynev_> stevebaker: O. did something bad happen?!
20:01:23 <stevebaker> asalkeld: son is having a day of tests
20:01:35 <stevebaker> mostly borin
20:01:36 <asalkeld> ok cool
20:01:37 <stevebaker> \g
20:01:50 <skraynev_> whuh :)
20:02:08 <asalkeld> #link agenda in the normal place: https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282014-12-18_2000_UTC.29
20:02:26 <asalkeld> #topic Review action items from last meeting
20:03:08 <asalkeld> #link http://eavesdrop.openstack.org/meetings/heat/2014/heat.2014-12-10-12.00.html
20:03:12 <asalkeld> ok that action is done
20:03:26 <asalkeld> skraynev and i chatted to therve
20:03:46 <asalkeld> #topic Adding items to the agenda
20:03:58 <asalkeld> anything new
20:04:43 <asalkeld> ok, moving on
20:04:58 <asalkeld> #topic kilo-1
20:05:05 <asalkeld> #link https://launchpad.net/heat/+milestone/kilo-1
20:05:25 <asalkeld> 3 in progress bugs
20:05:41 <asalkeld> #link https://bugs.launchpad.net/bugs/1401929
20:05:44 <uvirtbot> Launchpad bug 1401929 in heat "Overzealous validation of images in empty ResourceGroups" [High,In progress]
20:06:23 <asalkeld> mmm, not sure that's going to get in
20:07:14 <asalkeld> well we can wait for shardy to write some tests
20:07:44 <asalkeld> #link https://bugs.launchpad.net/bugs/1396917
20:07:47 <uvirtbot> Launchpad bug 1396917 in heat "set stack to ADOPT_FAILED if disable stack adopt " [Medium,In progress]
20:08:21 <pas-ha> o/
20:08:27 <asalkeld> hi pas-ha
20:08:38 <asalkeld> we are going through the k1 bugs
20:08:45 <pas-ha> ok
20:08:57 <asalkeld> stevebaker, how is your bug going
20:09:12 <asalkeld> #link https://bugs.launchpad.net/heat/+bug/1402472
20:09:12 <skraynev_> pas-ha: you did not miss something very important ;)
20:09:13 <uvirtbot> Launchpad bug 1402472 in heat "heat standalone mode should work with keystone v3" [Medium,In progress]
20:09:24 <pas-ha> ok, cool
20:09:32 <stevebaker> asalkeld: I'll be able to work on the extra unit test next
20:10:02 <asalkeld> ok
20:10:27 <asalkeld> shardy's one might have to go
20:10:34 <asalkeld> the others look ok
20:10:52 <asalkeld> that's all for k1
20:11:06 <skraynev_> \o/
20:11:07 <asalkeld> #topic Planing the midcycle meetup online - bring your ideas!
20:11:31 <asalkeld> so we need to start making some concrete plans for the online meetup
20:11:50 <asalkeld> anyone got some ideas on how to do this?
20:12:35 <asalkeld> ok, everyone seems to be super quiet today
20:12:53 <stevebaker> we'll need to choose a time zone to sync to
20:13:04 <jpeeler> do we have a date and a list of participants?
20:13:19 <asalkeld> jpeeler, no
20:13:45 <jpeeler> need that to coordinate choosing the time zone
20:13:56 <asalkeld> #link https://etherpad.openstack.org/p/kilo-heat-midcycle-meetup
20:14:10 <asalkeld> bit old
20:14:10 <skraynev_> also I remmber, that we had idea to make some local groups (to minimaze counts of people on call)
20:14:32 <asalkeld> yeah, could do
20:15:07 <asalkeld> a partly crazy idea is to have this as a one or two hour a day thing
20:15:26 <asalkeld> to workaround the TZs
20:15:33 <stevebaker> I assume there will be a big convergence theme
20:15:45 <asalkeld> yeah
20:15:59 <asalkeld> ok so we need to figure out:
20:16:01 <asalkeld> date
20:16:13 <asalkeld> topics? or is that dynamic
20:16:19 <asalkeld> software
20:16:34 <asalkeld> (skype/g+/whatever)
20:16:48 <asalkeld> format
20:16:50 <skraynev_> participants
20:17:02 <asalkeld> yip
20:17:20 <asalkeld> I'll write up an email and we try figure those out
20:17:28 <asalkeld> (to the ml)
20:17:32 <skraynev_> +1
20:17:58 <asalkeld> #action asalkeld to write up an email to the ml re: meetup
20:18:04 <ryansb> probably scope it down to just TZ/software/date
20:18:05 <pas-ha> skype would be really voice only, some people a highly motivated against g+.. still need to try that new built-in webrtc from mozilla
20:18:07 <ryansb> topics can wait
20:18:29 <asalkeld> ryansb, sure
20:19:02 <asalkeld> #topic open discussion
20:19:38 <asalkeld> if people want a short meeting, i'd be happy to end early
20:19:46 <pas-ha> I have some Q
20:19:51 <asalkeld> sure
20:20:16 <pas-ha> can someone help me figure out what we consider as critical exceptions from neutronclient?
20:20:32 <pas-ha> https://review.openstack.org/#/c/142448/
20:20:57 <pas-ha> for now I just considerd OverQuota, but there are 7 more
20:21:07 <pas-ha> all disguised as Conflict
20:21:55 <asalkeld> conflict seems ok
20:22:05 <asalkeld> (as in use Conflict)
20:22:31 <pas-ha> well, simple Conflict if you create a rule that is there - np
20:23:06 <pas-ha> but if you tried to create a rule and it is not there due to "conflict" with quota - that's a reason for failure
20:23:21 <asalkeld> they all look like show stoppers
20:23:34 <pas-ha> I mean IpAddressGenerationFailureClient also look like a failure to me
20:23:39 <skraynev_> also I have short update about our grenade job: after rebasing and updating some code I met a issues with devstack Heat installation (https://review.openstack.org/#/c/142045/) so hope it's last, what blocks grenade gates now :)
20:24:35 <asalkeld> nice skraynev
20:24:37 <pas-ha> ok, we can discuss further in the patch, and anyway there would be a place to add them all later
20:25:35 <asalkeld> pas-ha, you don't want to just change to "Conflict"?
20:26:10 <pas-ha> you mean to fail on all conflicts?
20:26:19 <asalkeld> yeah
20:26:57 <pas-ha> as I said, pure type(ex) is Conflict is raised when one tries to create a "duplicate" rule in a secgroup - nbd in that case
20:27:23 <pas-ha> but the class hierarchy in those neutronclient exceptions is quite strange to my taste
20:27:26 <asalkeld> ok, i see what you mean
20:27:40 <asalkeld> i'll review the patch after some coffee
20:27:52 <stevebaker> don't get me started on neutronclient exceptions ;)
20:28:01 <pas-ha> we should ignore Client but not ignore its children, at least some of them
20:28:42 <pas-ha> stevebaker, now I get you :)
20:29:05 <asalkeld> i am not sure how overquota can be a conflict
20:29:39 <asalkeld> ok well it seems like topics are running out
20:29:46 <pas-ha> also, another question while digging in some old bugs -
20:29:52 <asalkeld> ok
20:30:12 <pas-ha> do we ever want to enable stack/resources names with non-latin chars?
20:30:49 <asalkeld> not sure
20:30:58 <stevebaker> I thought there was already changes to support that for resource names, not sure how far it got
20:31:19 <pas-ha> I am personally a bit against it as that would somehow depend on how the db backend is configured, e.g. ust in mysql tables
20:31:33 <pas-ha> s/ust/utf
20:31:54 <asalkeld> pas-ha, we require utf atm
20:32:18 <pas-ha> aha, ok
20:32:35 <pas-ha> need to tink more then :)
20:32:44 <pas-ha> s/tink/think/
20:32:56 * pas-ha getting sloppy with kb
20:33:22 <pas-ha> ok, I'm out of Qs for now :)
20:33:53 <asalkeld> pas-ha, https://github.com/openstack/oslo.db/blob/master/oslo/db/sqlalchemy/migration.py#L92-L111
20:34:22 <asalkeld> ok, i'll end early
20:34:26 <spzala> asalkeld: hi, just an update, heat-translator project repo renaming is complete - https://github.com/openstack/heat-translator is the new one
20:34:40 <asalkeld> spzala, nice
20:35:04 <spzala> asalkeld: :-) yes, thanks
20:35:25 <asalkeld> anything more spzala?
20:35:36 <asalkeld> else we will end early
20:35:37 <spzala> asalkeld: nope
20:35:44 <asalkeld> #endmeeting