12:00:08 <shardy> #startmeeting heat
12:00:09 <openstack> Meeting started Wed Nov 26 12:00:08 2014 UTC and is due to finish in 60 minutes.  The chair is shardy. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:12 <openstack> The meeting name has been set to 'heat'
12:00:18 <shardy> #topic rollcall
12:00:21 <asalkeld> o/
12:00:25 <shardy> Hi all, who's around?
12:00:55 <skraynev> hi guys
12:01:05 * cmyster nods
12:01:15 <inc0> \o\ /o/
12:01:53 <asalkeld> might be a short meeting :-O
12:01:59 <skraynev> I suppose, that pas-ha should be here too..
12:01:59 <shardy> Heh, yeah
12:02:09 <shardy> #topic Review actions from last meeting
12:02:13 <shardy> #link http://eavesdrop.openstack.org/meetings/heat/2014/heat.2014-11-19-20.00.html
12:02:27 * shardy asalkeld to send out an announcement about the bug cleanup day
12:02:33 <asalkeld> done
12:02:45 <asalkeld> and the other email too
12:02:49 <shardy> #info asalkeld sent out an announcement about the bug cleanup day
12:02:49 <skraynev> 2 December :)
12:03:11 <shardy> #info asalkeld announced remote mid-cycle plan
12:03:28 <asalkeld> we should start thinking about how to actually do that
12:03:39 <shardy> Yeah, I think that's it from last week?
12:03:47 <shardy> #topic Adding items to the agenda
12:03:52 <shardy> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282014-11-26_1200_UTC.29
12:03:59 <shardy> Anyone have anything to add?
12:04:20 <shardy> I added a quick recap of the liason-all-the-things status
12:04:30 <asalkeld> add an item about approaching k1
12:04:44 <shardy> asalkeld: Ok, good point
12:04:57 <asalkeld> k1 is 2014-12-18
12:04:57 <shardy> #infp Additional topic: discuss approaching k1 milestone
12:05:06 <shardy> #info Additional topic: discuss approaching k1 milestone
12:05:15 <shardy> Shall we do that first?
12:05:15 <ananta> In the end I would also like to discuss about convergence PoC if possible
12:05:32 <asalkeld> shardy, sure
12:05:40 <skraynev> shardy: +1
12:05:48 <asalkeld> ananta, we will have heaps of time
12:06:05 <ananta> asalkeld: ok, sounds great
12:06:15 <shardy> #info Add topic discuss about convergence PoC
12:06:22 <shardy> Ok lets do K1 first
12:06:29 <shardy> #topic K1 milestone
12:06:38 <asalkeld> https://launchpad.net/heat/+milestone/kilo-1
12:06:55 <asalkeld> this is just a reminder that k1 is approaching
12:07:00 <shardy> #link https://launchpad.net/heat/+milestone/kilo-1
12:07:11 <asalkeld> so don't plan on squeezing big things in
12:07:17 <shardy> How's the bug backlog looking?
12:07:20 * shardy looks
12:07:35 <asalkeld> good I think
12:07:57 <shardy> Yeah, all the High stuff is in-progress or committed :)
12:08:00 <asalkeld> we should review those bugs/blueprints above others
12:08:15 <asalkeld> that's all really
12:08:22 <asalkeld> just a heads up
12:08:24 <skraynev> only one bug without owner
12:08:41 <shardy> I really need to revisit the decouple-nested patches
12:08:55 <shardy> All the easy ones have merged now, so I need to tackle the remaining test nightmare
12:08:56 <asalkeld> zane set that
12:09:04 <shardy> Will try to get that sorted next week
12:09:12 * shardy has been saying that for a few weeks...
12:09:15 <skraynev> ok
12:09:58 <shardy> Everything else looks good I think modulo some review iterations :)
12:10:06 <asalkeld> yip
12:10:14 <shardy> Ok, shall we move on?
12:10:19 <asalkeld> yip, move on
12:10:38 <skraynev> go
12:10:44 <shardy> #topic Cross Project Liasons revisited
12:10:55 <shardy> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons
12:11:04 <shardy> So the only gap is the VMT liason
12:11:19 <shardy> Despite saying it was pointless last week, I can do that if nobody else wantst to
12:11:20 <asalkeld> and randall has a question mark
12:11:30 <shardy> Yeah, did anyone check if he's happy to do that?
12:11:40 <shardy> I can take an action to if not
12:12:00 <asalkeld> that's a good action to email him
12:12:14 <asalkeld> i can do that
12:12:18 <shardy> #action shardy to check with randallburt re Docs liason
12:12:26 <shardy> #action asalkeld to check with randallburt re Docs liason
12:12:26 <asalkeld> or you:-)
12:12:31 <asalkeld> doh
12:12:31 <shardy> Either works ;)
12:12:31 <skraynev> that is all?
12:12:59 <asalkeld> skraynev, all others have names now
12:13:07 <shardy> yup, I think we have all others covered
12:13:31 <skraynev> ok
12:14:27 <shardy> Ok, I guess we can move on - asalkeld, shall I undo that last action before changing topic?
12:14:50 <asalkeld> i have just emailed him
12:14:52 <asalkeld> so you can
12:15:01 <shardy> #undo
12:15:02 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x1b164d0>
12:15:15 <shardy> Ok, thanks
12:15:27 * shardy can't type in more than one window at once ;D
12:16:01 <shardy> #topic Convergence PoC status
12:16:14 <asalkeld> ananta,
12:16:24 <ananta> we have the poc at
12:16:32 <ananta> https://github.com/anantpatil/heat-convergence-poc
12:16:43 <shardy> #link https://github.com/anantpatil/heat-convergence-poc
12:16:50 <ananta> I would like to see some feedback so that we can take it forward
12:17:02 <shardy> ananta: So you've been collaborating with zaneb and inc0 re the test framework?
12:17:14 <inc0> we haven't really decided on approach...
12:17:29 <ananta> our poc started much before zaneb's
12:17:40 <ananta> so we have changes on top of the heat engine
12:17:43 <shardy> inc0: What I'm getting at is, are we collaborating effectively, or all working on separate PoC efforts
12:17:55 <padiyar> It would be great if we can feedback on the poc which built on top of heat code itself
12:18:07 <shardy> I get the impression it's the latter, so it would be good to start working out how we change that :)
12:18:27 <asalkeld> agree
12:18:31 <shardy> ananta, padiyar: OK, well thanks for the update
12:18:39 <shardy> let's revisit this next week when Zane is around
12:19:07 <asalkeld> the main thing here is to talk to each other about the ideas
12:19:26 <asalkeld> but padiyar ananta , i'll look at the poc
12:19:34 <ananta> asalkeld: sure
12:19:43 <asalkeld> i have been looking at inc0 and zane's efforts
12:20:00 <padiyar> we are putting lot of effort on this so that we can make some decision.. it would really help to get some feedback and work on it if it required changes
12:20:12 <asalkeld> sure
12:20:15 <ananta> as long as we can convey the ideas it would be great ...
12:21:01 <ananta> I also seek feedback on the persist-graph BP
12:21:39 <ananta> https://review.openstack.org/#/c/123749/
12:22:08 <ananta> our PoC is based on that and I gues that is the case with zaneb's poc
12:22:15 <shardy> padiyar, ananta: Do you have any thoughts on how we can improve the collaboration between folks interested in defining this design?
12:22:42 <padiyar> Do we need a separate meeting to discuss only convergence poc? proabably a hagnout session?
12:22:55 <ananta> shardy: yes
12:23:04 <inc0> we have these... just after heat meetings
12:23:27 <asalkeld> padiyar, i'd really like you guys and zane and inc0 in a hangout working together discussing pros/cons
12:23:48 <asalkeld> trying to zero in on a solution
12:23:53 <padiyar> sure we will do that
12:24:00 <ananta> shardy, asalkeld: we do think of collaborating, now that the poc has taken a concrete shape
12:24:06 <inc0> next week just after heat meetings ananta?
12:24:11 <inc0> its ok with you?
12:24:27 <ananta> inc0: cant tell right now
12:24:33 <ananta> will communicate later
12:24:46 <shardy> #action Convergence folks to organise call/hangout to define direction re various PoC efforts
12:25:02 <shardy> Ok, I'll leave you guys to discuss timing with Zane next week
12:25:10 <asalkeld> guys one thing (inc and ananta) don't cling too hard to *your* design
12:25:10 <padiyar> lets get a sync up on this over email
12:25:12 <shardy> Anything else before we wrap up?
12:25:23 <inc0> sure, just my humble request, lets try to organise it in some managable time for Euro;)
12:25:32 <asalkeld> try focus on finding the best solution, not *my* solution
12:26:07 <padiyar> yes :) for sure
12:26:41 <asalkeld> that's all from me
12:26:50 <shardy> Ok then, thanks all!
12:26:58 <padiyar> thank you
12:27:01 <shardy> #endmeeting