00:00:25 <stevebaker> #startmeeting heat
00:00:26 <openstack> Meeting started Thu Apr  3 00:00:25 2014 UTC and is due to finish in 60 minutes.  The chair is stevebaker. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:00:30 <openstack> The meeting name has been set to 'heat'
00:00:37 <stevebaker> #topic rollcall
00:00:39 <wirehead_> o/
00:00:43 <cyli> o/
00:00:48 <spzala> Hi
00:00:49 <greghaynes> O/
00:00:51 * Michalik waves
00:00:54 <bgorski> o?
00:01:04 <zaneb> greetings
00:01:22 <dingxiao> hi
00:02:00 <stevebaker> no actions last week
00:02:17 <stevebaker> #topic Adding items to the agenda
00:02:35 <stevebaker> anything to add for anyone?
00:02:41 <stevebaker> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282014-4-02_0000_UTC.29
00:04:00 <stevebaker> #topic rc2 potential bugs
00:04:16 <stevebaker> RC1 is out, great job everybody!
00:04:53 <stevebaker> we've been tagging bugs to decide whether to open an rc2 window https://bugs.launchpad.net/heat/+bugs?field.tag=icehouse-rc-potential
00:05:06 <radix> o/
00:05:19 <lindsayk> o/
00:05:29 <zaneb> has anyone tested stack abandon with nested stacks?
00:05:29 <stevebaker> there needs to be one fix critical enough to justify an rc2, then other fixes can also be included on its coat-tails
00:05:57 <stevebaker> possibly https://bugs.launchpad.net/heat/+bug/1299349 alone is enough to justify an rc2
00:06:20 <mattoliverau> o/
00:06:51 <stevebaker> if you are working on a bug which you really think needs to be in rc2 then you can tag it icehouse-rc-potential
00:07:17 <stevebaker> and if you're prioritising what to review, check out the in progress bugs in https://bugs.launchpad.net/heat/+bugs?field.tag=icehouse-rc-potential
00:07:51 <stevebaker> #topic python-heatclient release prep
00:08:01 <stevebaker> I'd like to do a release real soon now
00:08:33 <stevebaker> there are a small collection of reviews which could make it into the release if they are reviewed soon
00:08:36 <stevebaker> https://review.openstack.org/#/q/status:open+project:openstack/python-heatclient,n,z
00:08:52 <stevebaker> possibly I could release as soon as https://review.openstack.org/#/c/83487/ is in
00:10:01 <stevebaker> #topic heat.conf.sample generation
00:10:06 <stevebaker> is totally busted
00:10:11 * stevebaker looks for the bug
00:10:12 <zaneb> this should be a fun one :D
00:10:27 <stevebaker> bug #1288586
00:10:52 <stevebaker> https://bugs.launchpad.net/heat/+bug/1288586
00:11:23 <stevebaker> anyone know what dhellmann means by the new entry point hook in comment https://bugs.launchpad.net/heat/+bug/1288586/comments/5 ?
00:11:26 <zaneb> dhellmann suggested a complex workaround involving treating Heat like a library, but I couldn't get it to work
00:11:35 <zaneb> stevebaker: yes
00:12:01 <stevebaker> (btw, check_updtodate.sh is disabled until we fix this)
00:12:06 <zaneb> but then I realised that the gate wasn't actually broken yet, and I could fix it by just committing the diff it asked for
00:12:26 <zaneb> but it is properly broken now by the looks of it
00:13:13 <stevebaker> didn't sdake propose a fix which also wrote out options in a deterministic order?
00:14:12 <zaneb> stevebaker: order isn't really the problem, I didn't think?
00:14:31 <zaneb> the latest oslo code certainly does it in deterministic order
00:14:37 <stevebaker> its not the problem, its a different problem
00:14:45 <stevebaker> oh, ok
00:14:46 <mattoliverau> Looks like there was a patch submitted to oslo to allow options in multiple groups, but it has been abandoned.
00:15:02 <stevebaker> https://review.openstack.org/#/c/78535/
00:15:17 <zaneb> btw my attempt at implementing dhellmann's workaround looked like http://paste.fedoraproject.org/91147/13964840
00:15:43 <zaneb> mattoliverau: I've proposed a more up-to-date patch since then
00:16:10 <zaneb> mattoliverau: but the problem is that there is no one patch that is right for both Nova and us
00:16:30 <mattoliverau> zaneb: lol, I should poke mikal to take a look then.
00:16:35 <zaneb> so something else has to change before we can properly fix it
00:16:55 <zaneb> (I submitted patches for that too, but nobody really liked them, including me)
00:17:27 <stevebaker> zaneb: do you want to own pushing this forward?
00:17:37 <stevebaker> maybe want is the wrong word
00:18:14 <zaneb> definitely the wrong word
00:18:20 <wirehead_> The captain needs a volunteer for the suicide mission.  He picked you.
00:18:36 <stevebaker> zaneb: do you feel an inescapable obligation to pushing this forward? ;)
00:18:40 <zaneb> tbh I feel a bit stuck
00:18:49 <zaneb> I proposed a patch and Oslo guys rejected it
00:18:57 <zaneb> and haven't suggested anything better
00:19:29 <zaneb> but I can poke them again
00:19:30 <stevebaker> zaneb: maybe an openstack-dev post is the next step, so nova and oslo folk can weigh in
00:19:50 <zaneb> ok, that's not a bad idea
00:20:29 <stevebaker> #action zaneb to post to openstack-dev to find an actionable solution to config generation
00:20:48 <stevebaker> Thats all I have
00:20:56 <stevebaker> #topic Open discussion
00:21:19 <wirehead_> So, I dragged Michalik here today.
00:21:24 <Michalik> Hi!
00:21:33 <Michalik> Greetings from SFO
00:21:44 <zaneb> o/
00:21:48 <stevebaker> Michalik: hi
00:21:51 <mattoliverau> zaneb: I don't know much more about the issue, or have experience with oslo, but if i can help in anyway, even if it's just and ear then let me know :)
00:23:30 * radix is slurping soup atm...
00:23:37 <zaneb> mattoliverau: keep an eye on the ML I guess :)
00:25:06 <stevebaker> oh, we appear to be close to python3 unit tests passing on python-heatclient. That was the other reason reviews would be helpful. We may be close to making python33 job voting!
00:25:15 <wirehead_> Whoa.
00:27:14 <stevebaker> oh, and feature freeze is over, so in theory juno features can land now
00:27:20 <wirehead_> Okay.
00:27:39 <zaneb> I hope you've all got your Juno features ready to land ;)
00:27:53 <stevebaker> I'm still fixing the icehouse ones!
00:28:11 <wirehead_> Well, I'm working on getting some people who have no Icehouse responsibilities working on Juno features.
00:28:13 <wirehead_> :)
00:28:21 <stevebaker> nice
00:28:30 <Liang> hehe, I can start pushing those lazy translation patches again ;)
00:28:39 <stevebaker> Liang: ++
00:28:56 <Liang> https://github.com/openstack/heat-templates/tree/master/jeos
00:29:19 <Liang> anyone used those templates recently?
00:29:41 <stevebaker> they need to die in a fire
00:29:46 <Liang> the U12.10-amd64-cfntools.tdl one does not seem to work for me - cloudinit isn't installed properly
00:30:04 <Liang> stevebaker, hehe
00:30:09 <zaneb> radix: is work on autoscaling for Juno ramping up now?
00:30:17 <stevebaker> Liang: have you considered building your images with diskimage-builder?
00:31:18 <Liang> stevebaker, I am making a choice between using diskimage-builder or Oz now
00:31:36 <Liang> stevebaker, which one do you recommend?
00:31:54 <stevebaker> Liang: I use dib exclusively
00:31:55 <Liang> by Oz, I mean the old heat way
00:32:21 <wirehead_> zaneb: I had cyli and radix working on some prototyping spike work of late for autoscale.
00:32:34 <stevebaker> Liang: it is actively tested, and help is always available in #tripleo
00:33:00 <Michalik> zaneb - We're also finding better ways to interact with our upstream systems that will feed into native autoscale.
00:33:03 <Liang> stevebaker, I see. Thanks.
00:33:37 <zaneb> wirehead_: cool. I would love to see some progress on it in Juno, and I have discovered the trick to that is to start right now
00:34:29 <wirehead_> zaneb: agreed.  We've got a session proposal for the Juno conference and we'll be there at the summit.
00:35:15 <stevebaker> should we finish up the meeting?
00:35:26 <zaneb> wirehead_: that's great, but by "start right now" I mean you want to be halfway done by the time of summit. that's your best chance at getting it ready in time for the release
00:35:43 <zaneb> big features take a long time to land
00:36:36 <zaneb> stevebaker: by all means :)
00:36:42 <stevebaker> #endmeeting