00:09:15 <stevebaker> #startmeeting heat
00:09:17 <openstack> Meeting started Thu Feb 20 00:09:15 2014 UTC and is due to finish in 60 minutes.  The chair is stevebaker. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:09:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:09:20 <openstack> The meeting name has been set to 'heat'
00:09:26 <stevebaker> #topic **sigh**
00:09:36 <sdake> updating wikis is srs biz
00:10:02 <zaneb> not sure why we had to move, given that they are the ones who didn't reserve the channel?
00:10:06 <zaneb> oh well
00:10:09 <stevebaker> #topic rollcall
00:10:16 <randallburt> o/
00:10:18 <sdake> \o/
00:10:20 <zaneb> I'm here
00:10:22 <tango> o/
00:11:10 <stevebaker> hey, small meeting
00:11:16 <randallburt> these usually are.
00:11:18 <sdake> zaneb I have the same feeling :)
00:11:33 <stevebaker> where is china?
00:11:39 <kebray> I'm here, but have to leave in 5.
00:11:43 <stevebaker> #topic Review last meeting's actions
00:12:04 <stevebaker> there were none
00:12:17 <stevebaker> #topic Adding items to the agenda
00:12:23 <stevebaker> #link https://wiki.openstack.org/wiki/Meetings/HeatAgenda#Agenda_.282014-2-20.29
00:13:20 <stevebaker> #topic Blueprints which will miss the FPF
00:14:06 <stevebaker> shardy is working on a native waitcondition which I'm OK with having a feature proposal extension for
00:14:08 <sdake> https://blueprints.launchpad.net/heat/+spec/systemd-integration merged today
00:14:26 <sdake> not sure why it wasn't kicked to implemented
00:14:30 <stevebaker> sdake: is that all that is required?
00:14:38 <sdake> yup
00:14:41 <stevebaker> sweet
00:15:03 <stevebaker> I'm not sure where this is at https://blueprints.launchpad.net/heat/+spec/parameter-nested-schema
00:15:12 <zaneb> function-plugins has reviews up
00:15:31 <stevebaker> I think therve was going to evaluate whether it was done indirectly already
00:15:54 <sdake> stevebaker to make the FPF, does blueprint need tobe in "Needs Code REview" or is "Good progerss" sufficient
00:16:01 <stevebaker> #action therve to update https://blueprints.launchpad.net/heat/+spec/parameter-nested-schema
00:16:26 <randallburt> stevebaker:  I don't think its done via therve's recent changes. Maybe the unification of properties and parameter schema?
00:16:55 <stevebaker> sdake: good question. I'd be happy with some definitions of Good Progress
00:17:37 <sdake> stevebaker my definition of Good Progress means code is available for review, it may not pass the gate, and it may have some bugs, but for the most part it is functional
00:17:38 <zaneb> sdake: I don't think it's a question of the blueprint status, but more of whether you have patches up
00:17:51 <stevebaker> sdake: sounds sufficient to me
00:17:57 <zaneb> sdake: I think that should count
00:18:14 <randallburt> agreed
00:18:38 <stevebaker> It looks like a main part of https://blueprints.launchpad.net/heat/+spec/i18n-messages has just been reverted, but I'm sure it shouldn't be kicked yet
00:18:42 <sdake> https://blueprints.launchpad.net/heat/+spec/db-sync-models-with-migrations has no patches up
00:19:15 <sdake> https://blueprints.launchpad.net/heat/+spec/retry-failed-update has no patches up
00:19:51 <sdake> https://blueprints.launchpad.net/heat/+spec/hot-software-config has no patches up
00:20:02 <stevebaker> it jolly well does
00:20:08 <randallburt> there are def patches up for software config
00:20:10 <sdake> launchpad lies then :(
00:20:21 <stevebaker> maybe I've been slack with my commit messages
00:20:32 <stevebaker> https://blueprints.launchpad.net/heat/+spec/cancel-update-stack looks like Good Progress
00:20:56 <zaneb> sdake: there's like 30 patches listed for that?
00:21:29 <stevebaker> I think I'll kick https://blueprints.launchpad.net/heat/+spec/db-sync-models-with-migrations from icehouse
00:22:08 <sdake> zaneb I was expecting gerrit reviews to show up in launchpad, guess that isn't always the case
00:22:14 <sdake> I haven't actually looked at the review queue this week :(
00:22:34 <zaneb> sdake: they're right there in the whiteboard
00:23:01 <stevebaker> I'll kick https://blueprints.launchpad.net/heat/+spec/retry-failed-update for now
00:23:03 <sdake> zaneb your right, my mistake
00:25:10 <stevebaker> anything else? there seems to be something in review for all the Good Progress ones
00:25:33 <sdake> https://blueprints.launchpad.net/heat/+spec/as-intermediate-resources needs a priority
00:25:47 <stevebaker> sdake: refresh ;)
00:26:11 <stevebaker> #topic Heat presentation votes
00:27:15 <stevebaker> Voting for Atlanta general presentations is now open, so if you have a proposal then post your links here so we know about them
00:27:20 <stevebaker> #link https://www.openstack.org/vote-atlanta/Presentation/application-software-configuration-using-heat
00:27:24 <stevebaker> vote for meeeee!
00:27:30 <zaneb> #link https://www.openstack.org/vote-atlanta/Presentation/introduction-to-openstack-orchestration
00:27:36 <zaneb> vote for us too!
00:27:43 <stevebaker> vote for zaaaaaane!
00:27:49 <zaneb> (me and shardy - mostly shardy)
00:28:32 <randallburt> https://www.openstack.org/vote-atlanta/Presentation/orchestration-for-public-cloud-the-experience-of-running-heat-at-rackspace
00:28:45 <stevebaker> you can search for presentations at the top
00:29:07 <zaneb> randallburt: ooh, nice one
00:29:16 <randallburt> vote mostly for kebray. I'm just there to correct the technical mishaps.
00:29:20 <randallburt> ;)
00:29:42 <randallburt> and to look pretty, of cource
00:29:58 <stevebaker> naturally
00:30:13 <stevebaker> vote for keeeeeith!
00:30:26 <zaneb> might be time to break out my brute-force screen-scraper to get a list of presentations
00:30:33 <stevebaker> #topic Open Discussion
00:30:35 <stevebaker> zaneb: +1
00:30:57 <stevebaker> we have a lot to review
00:31:51 <sdake> we have alot of core reviewers not in this meeting - might make sense to shoot them an email and remind them of the impending deadlines around reviewing the "Needs Review" blueprints :)
00:32:19 <zaneb> it's cool that there are people I have never heard of offering tutorials on Heat
00:32:31 <sdake> zaneb got a link?
00:32:41 <zaneb> https://www.openstack.org/vote-atlanta/Presentation/hands-on-heat-tutorial
00:32:44 <stevebaker> March 6 for feature freeze
00:32:51 <stevebaker> heature freeze
00:32:58 <zaneb> (_weird_ but I guess cool)
00:33:46 <stevebaker> cool SUSE is using heat?
00:35:00 <stevebaker> we may as well finish early unless there is anything else
00:35:33 <zaneb> +2 for finish early
00:35:41 <sdake> ya late here need to unplug :)
00:35:43 <randallburt> stevebaker:  we sorted wrt security alerts n such
00:35:46 <randallburt> ?
00:36:06 <randallburt> sorry trying to type before we ended
00:36:12 <stevebaker> randallburt: Was I right in that Jason volunteered for that?
00:36:21 <randallburt> stevebaker:  yup
00:36:39 <stevebaker> so the security team is shardy, zaneb, jasond and stevebaker
00:36:55 <stevebaker> ah, that is a thing to discuss
00:37:40 <stevebaker> we'll probably add heat-cfntools to the list of projects that belong to the security process. sdake do you recall and auditing as part of the fedora packaging process?
00:38:08 <stevebaker> recall *any* auditing
00:39:48 <stevebaker> also we need to decide if heat-templates is added to the security process. It currently has quite some issues https://bugs.launchpad.net/heat-templates/+bug/1267635
00:41:14 <randallburt> stevebaker:  I wouldn't worry about adding the templates until there's some gating around them.
00:41:34 <stevebaker> randallburt: I wouldn't either, except that Red Hat packages it
00:41:55 <stevebaker> randallburt: and it may be the most obvious home for the software-config hooks
00:43:06 <randallburt> stevebaker:  in the templates repo? ok, but then the gating should be done before we add it to the security process is all I'm saying
00:43:29 <randallburt> and it seems really odd that that repo is packaged
00:43:36 <stevebaker> randallburt: yes, you're right about gating
00:44:09 <zaneb> sdake: why _is_ that repo packaged?
00:46:56 <randallburt> stevebaker:  btw, when to we get to start submitting topics for the developers summit? Any ideas?
00:47:13 <stevebaker> randallburt: I don't think that is open yet
00:47:30 <randallburt> not that I've seen either
00:47:57 <stevebaker> oki, lets finish up
00:48:00 <stevebaker> #endmeeting