20:00:06 <sdake_z> #startmeeting heat
20:00:06 <openstack> Meeting started Wed Jan 16 20:00:06 2013 UTC.  The chair is sdake_z. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:10 <openstack> The meeting name has been set to 'heat'
20:00:23 <sdake_z> #topic rolecall
20:00:27 <sdake_z> sdake here
20:00:30 <stevebaker> \o/
20:00:32 <shardy> shardy here
20:00:33 <jpeeler> jpeeler here
20:00:34 <asalkeld> here
20:01:13 <shadower> here
20:01:18 <sdake_z> zane around?
20:01:39 <stevebaker> he is not online
20:01:43 <sdake_z> #topic action review
20:01:57 <sdake_z> ya i see must be on extended pto ;)
20:02:13 * sdake_z git review pluggable-clients (everyone) (stevebaker, 20:23:22)
20:02:20 <sdake_z> as i recall that patch went in
20:02:35 <stevebaker> it sure did
20:02:42 <sdake_z> #info patch merged
20:02:55 * sdake_z Write blueprints for any current and potential future feature development (everyone) (stevebaker, 20:30:15)
20:03:01 <sdake_z> i noticed a few more blueprints
20:03:13 <shardy> added some for updatestack improvements
20:03:21 <sdake_z> if you have more, please submit and we can take them up in h
20:03:44 * sdake_z Start moving towards the PTL process (sdake) (stevebaker, 20:35:22)
20:04:02 <sdake_z> so started down this path, i'll have more in the meeting
20:04:22 <sdake_z> #info see meeting topic governance
20:04:50 <sdake_z> #topic blueprint review for g3
20:05:20 <stevebaker> #link https://launchpad.net/heat/+milestone/grizzly-3
20:05:34 <sdake_z> last meeting I believe we agreed to hold off on new blueprint implementations and focus new features to h1
20:05:47 <sdake_z> but we have some blueprints for g3, would like to review
20:06:04 <sdake_z> https://launchpad.net/heat/+milestone/grizzly-3
20:06:14 <sdake_z> overview page ^
20:06:21 <sdake_z> first one up is
20:06:25 <sdake_z> add a static resource roup
20:06:32 <sdake_z> https://blueprints.launchpad.net/heat/+spec/static-inst-group
20:06:59 <sdake_z> angus, definition is in "new"
20:07:04 <asalkeld> sorry
20:07:11 <sdake_z> no problems, should we move to approved?
20:07:14 <asalkeld> yea we need it
20:07:18 <asalkeld> yip
20:07:34 <sdake_z> #info add a static instance group defn moved to approved
20:07:43 <sdake_z> rest of the fields look right
20:07:50 <asalkeld> Moniker resource could be delayed
20:07:55 <sdake_z> Moniker Resource
20:08:05 <sdake_z> https://blueprints.launchpad.net/heat/+spec/moniker-resource
20:08:05 <asalkeld> not sure on the status of the client
20:08:23 <sdake_z> should I bounce out of g3 then?
20:08:30 <asalkeld> yea
20:08:31 <sdake_z> we have 5 more weeks to sort thorugh it
20:08:50 <sdake_z> ok i'll bounce it
20:09:06 <sdake_z> #action moniker resource delayed because of client issues - targeting to h
20:09:12 <sdake_z> #undo
20:09:13 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x1e36850>
20:09:30 <sdake_z> action sdake to bounce moniker resource - delayed because of client issues - targeting towards h
20:09:37 <sdake_z> raw template db
20:09:44 <sdake_z> https://blueprints.launchpad.net/heat/+spec/raw-template-db
20:10:29 <sdake_z> defn is pending approval
20:10:32 <sdake_z> any problems with approving?
20:10:40 <asalkeld> if someone has time to impl.
20:10:43 <stevebaker> That would be good to do within grizzly since it is changing the db structure
20:10:53 <sdake_z> agree
20:11:00 <sdake_z> stevebaker you have  time?
20:11:07 <stevebaker> i think so
20:11:32 <sdake_z> vpc resources:
20:11:44 <sdake_z> #link https://blueprints.launchpad.net/heat/+spec/vpc-resources
20:12:00 <stevebaker> #link https://etherpad.openstack.org/grizzly-heat-quantum
20:12:17 <stevebaker> I was going to pick this up again in this cycle
20:12:35 <sdake_z> one thing i dont like about the blueprint is the link is to a changing medium
20:12:38 <asalkeld> stevebaker, need you for presentation
20:12:53 <sdake_z> can we pull the etherpad into the blueprint?
20:13:10 <asalkeld> normally you link to a wiki pages
20:13:14 <stevebaker> the original plan was that others would help with the effort - this would be good since I've made some huge assumptions on the vpn<->quantum mapping that need validation
20:13:41 <sdake_z> defn is new - should this move to approved?
20:14:10 <stevebaker> yep
20:14:10 <asalkeld> seems big
20:14:22 <sdake_z> does seem big - what is current state of the impl?
20:14:33 <stevebaker> maybe it should be a parent blueprint with another blueprint for each resource
20:14:44 <asalkeld> good idea
20:14:46 <shardy> sounds like a good idea
20:14:49 <sdake_z> yup agreed
20:14:51 <stevebaker> there is a start, 2 resources so far?
20:15:18 <sdake_z> we can review this again next week after you have split out the blueprints and then approve at that time
20:15:32 <sdake_z> #action sdake to review in next weekly meeting vpc resources for moving to defn->approved
20:15:42 <stevebaker> ok, and we can just do as many as there is time for in the cycle
20:15:48 <sdake_z> yup
20:16:00 <shardy> sdake_z: I'd like to add autoscale-update-stack and instance-update-stack to g3, provided I have time to do them
20:16:11 <shardy> they have been requested by several users
20:16:13 <sdake_z> jpeeler your up with complete init functionality complete init functionality
20:16:29 <sdake_z> ok i'll add them to agenda to discuss next
20:16:42 <asalkeld> choose requested feature first IMO
20:16:45 <sdake_z> #link https://blueprints.launchpad.net/heat/+spec/aws-cloudformation-init
20:16:57 <jpeeler> i started it, but shifted over to working on something else
20:17:10 <jpeeler> "Heat EBS implementation should support Cinder" which is also targetted for g3
20:17:19 <sdake_z> ok
20:17:24 <sdake_z> well will this make g3 then?
20:17:55 <jpeeler> i think so, it's not that much work
20:18:06 <sdake_z> ok moving defn to approved
20:18:25 <sdake_z> #info init moved to approved
20:18:44 <sdake_z> shardy can you link each blueprint
20:18:50 <sdake_z> one at a time ;)
20:19:00 <shardy> #link https://blueprints.launchpad.net/heat/+spec/autoscale-update-stack
20:19:22 <shardy> #link https://blueprints.launchpad.net/heat/+spec/instance-update-stack
20:19:38 <sdake_z> updatestack for autoscaling:
20:19:42 <asalkeld> first one should be easy
20:19:44 <sdake_z> looks good, anyone object?
20:19:46 <shardy> autoscale should be pretty easy
20:19:51 <sdake_z> if not, i'll target towards our series goal
20:20:12 <shardy> instance may be partial, the main feature required is to update metadata for cfn-hup, which again should be pretty easy
20:20:41 <sdake_z> #info autoscaling update group accepted as blueprint
20:20:41 <asalkeld> that would be a good feature
20:20:52 <shardy> sdake_z: I'll assign to me as I've started looking at both
20:21:05 <sdake_z> sounds good
20:21:17 <sdake_z> #info approved instance updatestack blueprint
20:22:27 <sdake_z> ok thats the blueprints
20:22:37 <sdake_z> #topic bug squashing
20:22:58 <sdake_z> we have 40 bugs atm
20:23:25 <sdake_z> i propose we each assign ourselves 3 bugs 1 high prio 2 medium and work on getting them solved on a weekly basis
20:23:56 <sdake_z> any objections?
20:24:06 <stevebaker> sounds good
20:24:09 <shardy> +1
20:24:13 <stevebaker> looks like some of them should be blueprints
20:24:25 <stevebaker> https://bugs.launchpad.net/heat/+bug/1083501
20:24:26 <shadower> I don't know how much time I'll be able to put into Heat these days but I'll try to help
20:24:26 <uvirtbot> Launchpad bug 1083501 in heat "Heat packaging for ubuntu" [High,Triaged]
20:24:30 <sdake_z> for g3, lets keep them as bugs, in future lets keep blueprints in mind
20:24:48 <sdake_z> ok shadower understood
20:25:33 <shardy> stevebaker: actually I have some (which I raised) which should also be blueprints, e.g:
20:25:37 <shardy> https://bugs.launchpad.net/heat/+bug/1072952
20:25:38 <uvirtbot> Launchpad bug 1072952 in heat "Implement Rollback feature of AWS API" [Medium,Triaged]
20:25:57 <sdake_z> #topic governance
20:26:16 <stevebaker> shardy: yeah, thats a huge one ;)
20:26:24 <sdake_z> i've done a bit of hunting and found this link: #link http://wiki.openstack.org/Governance/TCElectionsFall2012
20:27:07 <sdake_z> if you read through that, the key points are 2 weeks of election cycle, 1 week for open candidacy and one week for election period
20:27:13 <sdake_z> also, ther eare election officials
20:27:25 <sdake_z> Monty Taylor has agreed to serve as our election official
20:27:34 <asalkeld> cool
20:27:43 <stevebaker> shall we ask ceilometer what they did? I bet it didn't take that long
20:27:43 <sdake_z> The dates are : Jan 14th-25th open candidacy for heat ptl
20:27:49 <sdake_z> jan 26-feb1 heat ptl election
20:28:08 <sdake_z> part of what we will be evaluated on is how well we can learn openstack processes ;)
20:28:15 <sdake_z> the voting site is here:
20:28:21 <sdake_z> #link http://www.cs.cornell.edu/w8/~andru/civs/
20:28:28 <stevebaker> true
20:28:52 <sdake_z> so if we can operate launchpad and the voting site, we are golden ;)
20:29:09 <sdake_z> any other questions about that?
20:29:18 <asalkeld> lets do it
20:29:22 <sdake_z> sounds good
20:29:26 <stevebaker> ye
20:29:26 <sdake_z> #topic packaging
20:29:42 <sdake_z> did you add this stevebaker?
20:29:51 <stevebaker> So g-2 packages were blocked on removing the extras dependency
20:30:17 <stevebaker> the question is, do we create a grizzly branch and backport that change and build packages from that?
20:30:27 <shardy> stevebaker: are the nightly builds running now?
20:30:27 <stevebaker> or do we just create packages from master?
20:30:35 <sdake_z> master imo
20:30:40 <stevebaker> yep http://repos.fedorapeople.org/repos/heat/heat-trunk/
20:31:05 <shardy> stevebaker: cool, will try them out :)
20:31:09 <sdake_z> #info packages to be created from master
20:31:22 <sdake_z> speaking of packaging we have one bug for an ubuntu ppa
20:31:37 <sdake_z> mind taking that on stevebaker since your getting involved in ubuntu/deb upstreams?
20:31:55 <stevebaker> My heat-rpms is diverging a bit, so I'll be asking for a branch merge when g-2 is ready https://github.com/steveb/heat-rpms
20:32:17 <stevebaker> yep, I'm getting my head around debian/ubuntu as well
20:32:39 <sdake_z> #action stevebaker to take on ubuntu PPA of heat
20:32:47 <sdake_z> #topic cfntools integration
20:33:06 <stevebaker> This is also related to packaging
20:33:15 <stevebaker> here is what I think we should do
20:33:44 <stevebaker> 1. encourage users to spin their own images which includes packaged heat-cfntools, as well as anything else they need
20:34:11 <stevebaker> 2. use cloud-init to check for cfn-*, and install from pypi if not there
20:34:42 <asalkeld> I like 2
20:34:43 <sdake_z> 2 sounds interesting
20:34:47 <shardy> +1
20:34:48 <sdake_z> need to keep 1 i think
20:35:10 <sdake_z> ok lets do that - stevebaker taking that on?
20:35:18 <stevebaker> 3. always install to /usr/bin, and include a script which sets up symlinks to /opt/aws/bin. cloud-init runs this script if necessary <- this is because packages (and pypi) never should install in /opt
20:35:31 <sdake_z> #info adding cloud-init support for cfntools
20:35:49 <asalkeld> stevebaker, what ever - the setup.py can do that
20:36:08 <asalkeld> install to /opt/aws or link to it
20:36:19 <stevebaker> but packages can't, not if we want the package to be in official repos
20:36:40 <sdake_z> asalkeld i think sbaker is talking about option 3
20:36:42 <stevebaker> debian already said no ;)
20:36:55 <sdake_z> ya packaging in opt is a  hot topic ;)
20:36:57 <asalkeld> well then the cloud-init script could do that
20:37:09 <asalkeld> (make the links)
20:37:10 <sdake_z> ya we can upload a handler for that
20:37:39 <sdake_z> ok all set then?
20:37:55 <stevebaker> yep
20:38:01 <sdake_z> #topic open discussion
20:38:24 <sdake_z> sending out agenda before meeting - not sure this has been happening
20:38:39 * asalkeld super lazy
20:38:41 <sdake_z> i'll take that on, but need folks to add their agenda items on Tuesday before 2000 UTC
20:39:06 <sdake_z> and then I'll mail out notes at conclusion of meeting
20:39:29 <sdake_z> thats all I have for open discussion anyone else?
20:39:35 <SpamapS> hm
20:39:37 <stevebaker> any issues running heat on f18 so far?
20:39:38 <SpamapS> sorry I came late
20:39:48 <asalkeld> hi SpamapS
20:39:58 <asalkeld> we are in open discussion
20:40:00 <SpamapS> are we drafting/filing blueprints for discussion at the summit now?
20:40:00 <sdake_z> still time in the meeting slot
20:40:17 <asalkeld> yip, you got time
20:40:20 <shadower> stevebaker, I had trouble getting devstack to work today, will get it and Heat sorted tomorrow
20:40:24 <sdake_z> the basic idea is we will draft now, and discuss at summit
20:40:27 <shardy> SpamapS: we added the updatestack autoscaling and instance metadata blueprints, which we discussed recently, for g-3
20:40:29 <sdake_z> and assign to h1/h2/h3
20:40:35 <SpamapS> shardy: woot
20:40:55 <SpamapS> I'd also like to file one on performance
20:40:57 <sdake_z> if there is something that makes heat broken without it, bring it up and we can see about fitting it in
20:41:03 <sdake_z> but we have a pretty tight schedule
20:41:13 <sdake_z> feb21 is our deadline for our 8 bps and 40 bugs
20:41:17 <SpamapS> specifically on measuring it during CI so we can improve it.
20:42:00 <SpamapS> sdake_z: is there a need for general bug fixing? Like, should I just go pop a few off the stack of medium priority bugs?
20:42:11 <sdake_z> that would be great!
20:42:22 <sdake_z> we have a ton of bugs and devs pretty thin on time
20:42:26 <SpamapS> mmk I'll look at doing that when next I'm blocked.. which happens a lot ;)
20:42:44 <SpamapS> thats all I had
20:43:01 <sdake_z> #info spamaps to pick a few bugs up in spare cycles
20:43:09 <sdake_z> anything else for open discussion?
20:43:37 <sdake_z> ok well thanks folks
20:43:38 <sdake_z> #endmeeting