19:59:32 <asalkeld> #startmeeting heat
19:59:33 <openstack> Meeting started Wed Nov 28 19:59:32 2012 UTC.  The chair is asalkeld. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:59:36 <openstack> The meeting name has been set to 'heat'
19:59:54 <asalkeld> #chair shardy zaneb
19:59:55 <openstack> Current chairs: asalkeld shardy zaneb
20:00:00 <stevebake> http://wiki.openstack.org/Meetings/HeatAgenda
20:00:04 <asalkeld> #chair shardy zaneb asalkeld stevebake
20:00:05 <openstack> Current chairs: asalkeld shardy stevebake zaneb
20:00:29 <asalkeld> well done shardy on agenda
20:00:38 <shardy> guys, I need to head out in about 40mins so may need to leave early
20:00:46 <stevebake> ok
20:00:55 <asalkeld> well lets be quick
20:01:05 <asalkeld> roll call?
20:01:07 <zaneb> +1 on being quick ;)
20:01:21 <shardy> here
20:01:26 <asalkeld> here
20:01:26 <zaneb> o/
20:01:27 <stevebake> o/
20:01:27 <jpeeler> here
20:01:38 <asalkeld> #topic packaging
20:01:57 <asalkeld> so we need pypi ?
20:02:10 <shardy> Yeah, so there was a request from one of the HP guys for pypi
20:02:21 <asalkeld> do we put the package on the openstack pypi
20:02:22 <shardy> I don't know if we need it, but it was requested
20:02:36 <zaneb> are other openstack projects in pypi?
20:02:49 <asalkeld> honestly not sure
20:02:54 <shardy> not sure either
20:02:55 <zaneb> my recollection is that to the extent they are, which is not great, it is a total pita
20:03:04 <jpeeler> some of the clients are
20:03:14 <zaneb> I think a really outdated version of swift is
20:03:16 <asalkeld> ya, for tests
20:03:19 <stevebake> it would be good for project visibility, and maybe our ubuntu instructions could use it until there is a PPA
20:03:21 <shardy> key issue seems to be ease of use on ubuntu rather than pypi specifically
20:03:32 <zaneb> jpeeler: good point, and that makes sense
20:03:33 <shardy> for several users (all our users?)
20:03:49 <asalkeld> well maybe talk to the guys asking
20:03:59 <asalkeld> and really find out what to do
20:04:04 <zaneb> ubuntu ppa > pypi imo
20:04:07 <stevebake> python-heatclient should be in pypi anyway, since its a lib
20:04:14 <asalkeld> yip
20:04:24 <zaneb> yes, client definitely in pypi
20:04:38 <asalkeld> #action put heatclient in pypi
20:04:53 <shardy> so as a first step, I'll get the getting started and tools/openstack working properly on ubuntu, that should satisfy most of the initial issues
20:04:54 <asalkeld> is there a bug/bp for the packaging?
20:05:11 <shardy> yep, linked in the agenda ;)
20:05:14 <asalkeld> cool well done shardy
20:05:22 <asalkeld> doh
20:05:31 <asalkeld> well lets move on
20:05:43 <asalkeld> #topic State of ubuntu host/guest support
20:06:11 <shardy> so two issues - ease of install, and ubuntu guest functionality
20:06:22 <shardy> I'll tackle the first as mentioned above
20:06:34 <asalkeld> so we addressed packaging (ya)
20:06:46 <asalkeld> what about the guests
20:06:57 <shardy> jpeeler: did you look at the cloud-init path issue?
20:07:16 <jpeeler> a while back, not recently
20:07:33 <jpeeler> changes between different versions of cloud-init is the problem
20:07:49 <asalkeld> can we just increase the Importance on ubuntu bugs
20:08:11 <jpeeler> i started looking for a way to query for the version, but that was only recently added. that's where i stopped
20:08:20 <shardy> Ok, so we need to figure that out, and update the ubuntu tdls to install a recent version of boto (need a bug for the latter)
20:09:00 <shardy> what about integration testing - that currently only targets Fedora
20:09:17 <asalkeld> #action make a bug to  update the ubuntu tdls to install a recent version of boto
20:09:35 <asalkeld> shardy, sounds like  a good idea
20:09:45 <asalkeld> to have a mix of guests
20:09:54 <shardy> we have the all-clear to request some help from the CI team, but not sure what exactly we need atm
20:10:15 <asalkeld> ok
20:10:33 <asalkeld> to get the functional tests running?
20:10:43 <asalkeld> mmm
20:11:01 <stevebake> should we also talk to Derek Higgins to see if there are some lab resources we could use?
20:11:25 <shardy> So if I get the ubuntu getting started markup sorted, what would it take to plumb that in with the existing automated tests zaneb?
20:11:57 <asalkeld> (the ones we are not running)
20:12:11 <asalkeld> we do really need to run those
20:12:12 <zaneb> shouldn't be too bad, but would have to get the existing ones running again first
20:12:34 <asalkeld> #action start running the integration tests
20:12:34 <shardy> need better visibility of the results, so it's noticed when we break them
20:12:40 <zaneb> need to copy over the ubuntu ISO and build a jeos for it
20:13:06 <zaneb> shardy: problem is we never got them all working on the server
20:13:18 <zaneb> (and now the server is broke too)
20:13:24 <shardy> doh
20:13:47 <asalkeld> ok all in all - not good
20:13:58 <zaneb> auth to beaker is not working, I'll have to file a ticket to get it sorted
20:14:14 <zaneb> but I really do feel that we would be better off migrating to tempest
20:14:20 <asalkeld> this is becomming a resource sucker
20:14:54 <asalkeld> we need to have a plan for this
20:15:04 <shardy> Any ideas how we can get better value out of the existing tests without committing lots of resources?
20:15:05 <zaneb> I have spent at least 3 months of this year on it already, it was always a giant resource sucker
20:15:14 <shardy> how do other projects handle this?
20:15:24 <zaneb> shardy: yes, tempest ;)
20:15:34 <shardy> ok, lets do that then ;)
20:15:46 <asalkeld> is that more work?
20:15:46 <stevebake> Dan Prince is Mr Tempest, we should ask him
20:15:55 <asalkeld> yip
20:15:55 <zaneb> that way we don't need to do any infrastructure stuff
20:16:04 <asalkeld> well that is good
20:16:28 <zaneb> big issue that I see is that we somehow need a guest image to launch
20:16:29 <asalkeld> anyone interested in finding out about it
20:16:40 <asalkeld> yip
20:16:57 <stevebake> to the tests have to build a new image every run?
20:17:15 <shardy> Could they not just download a pre-built jeos?
20:17:18 <asalkeld> well they could download the example images
20:17:23 <zaneb> stevebake: no, although it has to be up to date if we keep changing the cfn-tools
20:17:42 <shardy> zaneb: automate rebuilding the pre-built images
20:17:55 <shardy> sdake already wrote a script for that IIRC
20:17:58 <asalkeld> or get cfn tools packages
20:18:10 <shardy> Yep, cfntools packages sounds better to me
20:18:14 <asalkeld> or get cfn tools packaged (how is that goind)
20:18:25 <shardy> then we can have ostools which use the rest api
20:18:25 <zaneb> +1
20:18:49 <asalkeld> yip
20:18:52 <jpeeler> yeah i was going to package cfntools
20:18:55 <zaneb> *or* use the AWS cfn tools, which are presumably already packaged ;)
20:19:08 <jpeeler> can we do that ^^^
20:19:11 <asalkeld> zaneb, we have an extension for ha
20:19:18 <jpeeler> ok so no
20:19:25 <asalkeld> to restart services
20:19:40 <zaneb> asalkeld: can we inject it through cloud-init?
20:19:50 <asalkeld> yes
20:20:00 <zaneb> let's do that
20:20:02 <asalkeld> we could have cloud-init do that update
20:20:04 <Sl0w_> wouldn't that let us use other jeos images off amazon?
20:20:21 <asalkeld> no
20:20:36 <asalkeld> we would need the cloud-init config
20:20:51 <zaneb> do AWS images not have cloud-init?
20:21:12 <asalkeld> yes, they do but not that default config
20:21:23 <Sl0w> I don't know enough about how the native aws cfn images work
20:21:23 <asalkeld> to install our cfn-init
20:21:51 <asalkeld> I think we should move on
20:21:55 <zaneb> that's what I'm suggesting, use Amazon's cfn-init
20:22:15 <zaneb> yeah, moving on
20:22:33 <asalkeld> some unresolved issues there
20:22:45 <asalkeld> #topic RHEL/CentOS support?
20:23:02 <shardy> so do we see that as important?
20:23:05 <asalkeld> is this for guest/host
20:23:18 <shardy> clearly nobody is going to deploy Fedora in a production environment
20:23:19 <asalkeld> looks like host
20:23:30 <shardy> I was thinking host
20:23:40 <shardy> but TDLs for RHEL would be good too
20:23:44 <asalkeld> shardy, I think we need to focus on upstream work
20:23:52 <asalkeld> less disto
20:24:06 <asalkeld> else we will never get any work done
20:24:15 <shardy> Ok, the problem is our users are demanding distro-specific instructions...
20:24:20 <Sl0w> I would think rhel support will come at some point, maybe not now?
20:24:20 <asalkeld> but yes to testing many guests
20:24:33 <stevebake> is there a public date for RHEL7?
20:24:38 <zaneb> stevebake: no
20:24:41 <shardy> ok, cool, lets drop that item for now then
20:24:49 <asalkeld> shardy, mainly ubuntu right now
20:24:58 <Sl0w> I guess the issue is if you need packages in rhel it's better to start sooner rather than later
20:25:02 <zaneb> stevebake: "second half of 2013" is what I found on google
20:25:05 <shardy> yeah, I'm trying to get some users who're not on ubuntu ;)
20:25:11 <Sl0w> because it can take a long time
20:25:28 <asalkeld> #topic Way forward for integration tests
20:25:37 <asalkeld> I think we have done this
20:25:47 <zaneb> that's what I thought ;)
20:26:02 <asalkeld> #topic Launchpad issues
20:26:22 <asalkeld> I think I have done that
20:26:23 <shardy> think this is sorted after last nights reorg
20:26:29 <stevebake> I'm attempting to flesh out my blueprints
20:26:50 <asalkeld> but keep checking bugs
20:27:00 <shardy> but for the benefit of everyone - new features == blueprint, bug==bug
20:27:10 <stevebake> zaneb: so is REST done now?
20:27:11 <asalkeld> and "weeding the garden" as steve would say
20:27:26 <zaneb> stevebake: to a first approximation, yes
20:27:40 <asalkeld> zaneb, set the state on that bp
20:27:45 <zaneb> ok
20:27:56 <zaneb> still stuff like XML support to add
20:28:06 <zaneb> but all the basic functionality is there
20:28:07 <asalkeld> all of you see if a bp matches the work you are doing
20:28:15 <asalkeld> and update the state
20:28:38 <asalkeld> #topic jpeeler to update re state of snapshot/prebuild investigation
20:28:39 * stevebake sees no xml bp
20:29:15 <jpeeler> i was surprised to see this on the agenda since i thought it was decided it was too much work
20:29:25 <jpeeler> especially after seeing this, which i didn't know existed: https://github.com/heat-api/heat-prebuild
20:29:27 <asalkeld> so this idea sucked and we are moving on?
20:29:50 <shardy> ok, I wasn't sure, I thought it was unresolved so added it to the agenda
20:30:11 <zaneb> that sounds like a good plan, but I don't think we'd actually _decided_ that before
20:30:31 <asalkeld> jpeeler, how would you summerize the idea/project
20:30:47 <asalkeld> so we had some grand ideas
20:30:47 <jpeeler> the snapshot or the prebuild?
20:30:53 <asalkeld> snapshot
20:31:37 <asalkeld> is it doable/too much work, what are the show stoppers
20:31:41 <jpeeler> the snapshotting was going to handle automatic caching with the option of allowing instances to launch either an exact clone or one that had all the packages installed, but would receive new user data
20:32:31 <jpeeler> it's doable, it is a bit of work. one problem is handling simulatenous caching operations gracefully and a way to signal when user data execution was about to begin
20:33:04 <zaneb> userdata comes from the nova metadata server?
20:33:11 <jpeeler> yeah
20:33:24 <asalkeld> so we want that to run each time
20:33:25 <shardy> you could use a waitcondition (or similar method) for the latter
20:33:27 <zaneb> ok, so no easy synchronisation there
20:33:44 <asalkeld> I think we can use our time better
20:33:50 <shardy> +1
20:34:03 <zaneb> jpeeler: what's your recommendation?
20:34:36 <asalkeld> jpeeler, it would  be good to write a brain bump on the wiki
20:34:56 <asalkeld> so we don't loose the info you have learned
20:34:57 <jpeeler> it is a lot of work, but at the same time i'm guessing part of the reason it was brought up was for me to dive into the code
20:35:11 <jpeeler> i can find other things to work on though
20:35:18 <asalkeld> cool
20:35:41 <zaneb> +1
20:36:00 <asalkeld> well we are getting to the end of topics, i suggest we go back to integration tests
20:36:05 <Sl0w> +1
20:36:18 <zaneb> asalkeld: PTL?
20:36:39 <asalkeld> #topic when do we need to choose a ptl
20:37:15 <asalkeld> so I was asked about it at project meeting
20:37:21 <zaneb> it would be nice to be able to wait until sdake is back on deck
20:37:28 <asalkeld> but bit sad as steve is sick
20:37:33 <asalkeld> yes
20:37:54 <asalkeld> so the qu. is when do we _have_ to do it by
20:37:58 <zaneb> otoh maybe there should be somebody as the designated email contact when the TC need to bug us
20:38:26 <asalkeld> sure, stand in
20:38:27 <Sl0w> how hard is it to change the PTL later?
20:38:29 <stevebake> when were re-elections? is it about 2 months before release?
20:38:46 <asalkeld> well elected every 6 months - no?
20:39:02 <asalkeld> just before each summit
20:39:08 <zaneb> not sure how the rules apply to incubated projects
20:39:19 <zaneb> since we don't affect the makeup of the TC, it may not matter
20:39:26 <asalkeld> #action ask at next project meeting
20:39:52 <asalkeld> (or just ask mark)
20:40:14 <asalkeld> should we wrap up?
20:40:21 <asalkeld> nice short meeting
20:40:35 <shardy> is anyone going to FOSDEM?
20:40:55 <shardy> I can't go, but would be good to get a heat talk there if anyone is going
20:41:03 <asalkeld> where is it?
20:41:04 <zaneb> I think somebody needs to at least propose a heat talk
20:41:08 <zaneb> asalkeld: Brussels
20:41:22 <asalkeld> ok zaneb it's right next to you
20:41:33 <shardy> it's a weekend, which is why I can't go (sons birthday)
20:41:44 <zaneb> shadower: any interest?
20:41:51 <stevebake> btw, can y'all start thinking about documentation, I'll put it on the agenda for next week
20:41:59 <asalkeld> zaneb, trying hard to avoid ;)
20:42:11 <asalkeld> I would like us to one day sort out the integration test
20:42:16 <zaneb> I went last year
20:42:24 <zaneb> it was freezing!
20:42:28 <shadower> zaneb, maybe
20:42:45 <asalkeld> (I am doing aussie linux conf in jan)
20:42:46 <shadower> I was thinking about talking Heat on the Devconf in Brno feb
20:43:12 <zaneb> shadower: that's not until the week after ;)
20:43:17 <asalkeld> ok - the end ...
20:43:27 <asalkeld> #endmeeting