21:01:23 <mattgriffin> #startmeeting HA-Guide-Update
21:01:24 <openstack> Meeting started Thu Mar 19 21:01:23 2015 UTC and is due to finish in 60 minutes.  The chair is mattgriffin. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:28 <openstack> The meeting name has been set to 'ha_guide_update'
21:01:32 <Shamail> Hi mattgriffin!
21:01:44 <nickchase> Hey all.
21:01:56 <mattgriffin> hi Shamail nickchase
21:02:12 <megm> Hi all
21:02:19 <Shamail> (I might have a little lag; on mobile)
21:02:24 <mattgriffin> hi megm
21:02:26 <mattgriffin> Shamail, np
21:02:44 <mattgriffin> looks like sam-i-am isn't around
21:02:52 <megm> Shamail, I partially updated https://wiki.openstack.org/wiki/HAGuideImprovements/TOC with the Storage Backend piece we discussed
21:02:57 <megm> I'll finish it after our meeting
21:03:10 <mattgriffin> megm, cool. let's get started on the agenda then
21:03:14 <mattgriffin> #topic Review action items from last meeting
21:03:40 <Shamail> megm: looks great
21:03:59 <mattgriffin> most of you reviewed and edited the email to the Docs team and megm's big edits. thank you!
21:04:01 <nickchase> sam-i-am has been occupied with the ops meetup
21:04:10 <nickchase> and he apologizes but he's overbooked right now.
21:04:11 <mattgriffin> nickchase, ack
21:04:25 <megm> Andreas seems pleased -- that seems like a good thing
21:04:26 <clouddon> im here sneaking
21:04:44 <Shamail> Hi clouddon
21:05:07 <nickchase> the email is a good philosophy but we do need a more detailed TOC.
21:05:09 <mattgriffin> megm, yeah. great overview getting everyone else up to speed
21:05:24 <mattgriffin> hi clouddon
21:05:32 <clouddon> hi all!
21:05:49 <mattgriffin> one action item that we had from last week (again, sorry for holding the meeting early) was "check with sam-i-am and nickchase on starting a "new" doc structure"
21:05:59 <megm> I thought the detailed outline was in the https://wiki.openstack.org/wiki/HAGuideImprovements/TOC file
21:06:12 <mattgriffin> heh... i can't remember what that was about
21:06:34 <megm> I remember
21:06:40 <mattgriffin> please share :)
21:06:50 <nickchase> Sam-I-Am and I were discussing...
21:06:55 <megm> The question is whether we try to modify within the current file structure in the repo or start a new doc for development
21:07:05 <megm> Perhaps eventually move the new doc back to the old title
21:07:17 <nickchase> (I'll wait.)
21:07:18 <mattgriffin> megm, ack
21:07:29 <clouddon> isnt the new structure for this?
21:07:36 <megm> so what did sam-i-am and nick conclude?
21:07:39 <nickchase> I think it depends on how close the new structure is to the old one.
21:07:48 <nickchase> we were discussing where/if we were going to talk about pacemaker.
21:07:52 <Shamail> The TOC is the new structure right?
21:08:02 <nickchase> We finally settled on...
21:08:13 <nickchase> the idea that there are basically 3 levels of HA in OpenStack:
21:08:29 <nickchase> 0)  None; you just install everything and hope for the best.
21:09:10 <nickchase> 1)  Basic HA:  you use the "traditional" means of HA, such as Galera for MySQL, redundant RabbitMQ clusters, etc.  If something breaks, it stays up -- unless it breaks again.
21:09:58 <nickchase> 3)  Nothing is going to take this sucker down:  you use more stringent HA such as Pacemaker, which proactively makes sure that everything stays up, and if it goes down, then it gets brought back up (if possible)
21:10:03 <nickchase> (sorry, that's 2)
21:10:11 <nickchase> So those are the 3 levels, and ...
21:10:20 <nickchase> we thought that one way to cover it would be...
21:10:57 <nickchase> to start with the "traditional" means, then talk about what you should do if you want level 2 (Nothing will take this down).
21:11:28 <nickchase> What do you guys think?
21:11:29 <mattgriffin> nickchase, +1
21:11:50 <Shamail> nickchase: +1
21:11:51 <megm> -1                                                                                                                                                                                                               nic
21:12:00 <clouddon> my only point with this sturcture would be the disticntion btweeen aactive/ active vs active/ apsssive
21:12:15 <Shamail> This is the control plane aspect though.  The data plane equivalent of this is out of scope, right?
21:12:19 <megm> I think this is a good structure for the introductory material, which really does need to be expanded significantly.
21:12:43 <megm> But I thought we had agreed that the bulk of the guide would be structured to parallel the Install Guide.
21:12:53 <nickchase> I confess that I can't answer either clouddon or shamail on this; both statements are beyond my knowledge and I lean on SMEs. :)
21:13:06 <nickchase> We can be parallel to the install guid3
21:13:09 <clouddon> How about this?
21:13:10 <nickchase> and still follow this
21:13:31 <clouddon> whoever has points comment on wiki
21:13:35 <nickchase> by basically doing what I've described as "level 1" here based on the install guide.
21:14:22 <Shamail> nickchase: on my question, I would say let's keep this to control plane HA for now to stay out of political stuff/stifling topics.  clouddon: good suggestion +1
21:14:39 <nickchase> clouddon +1
21:15:01 <clouddon> gr8. thanks
21:15:03 <nickchase> Shamail: I'm all for staying out of poltics; not sure what you mean by "stifling topics".
21:15:13 <mattgriffin> Shamail, i think +1 on control plane. likely more materials available elsewhere on data plane HA
21:15:28 <megm> Yes, Cloudon and everyone, muck with and comment on the outline
21:15:57 <Shamail> nickchase: by stifiling topics I meant trying to speak for third parties without their participation.
21:16:01 <mattgriffin> +1 for muck
21:16:46 <Shamail> Overall, the levels look great Nick.
21:16:47 <nickchase> Shamail:  I agree, but just so I understand, who are the third parties?  You mean the SMEs?
21:16:59 <nickchase> Shamail: great.
21:17:18 <mattgriffin> the other part of the "doc structure" issue is less about the TOC and more about how do we implement the large scale changes given the existing HA Guide, right?
21:17:21 <Shamail> Data plane would come down to how compute, network, storage vendors advise HA configuration/considerations for infrastructure resiliency
21:17:22 <megm> I think it's important that we address the data plane issues, at least conceptually.  Details are elsewhere but I don't know of anything that puts it all together
21:17:24 <mattgriffin> megm, ^
21:18:14 <nickchase> megm: +1
21:18:25 <Shamail> megm: I agree, we should address it at a high-level and say it's not our scope and to talk to your providers
21:18:34 <mattgriffin> megm, +1
21:18:40 <megm> keywords:  DON'T LOSE MY DATA!!!  ;-)
21:18:47 <nickchase> :)
21:18:55 <Shamail> Haha
21:19:38 <nickchase> And that, I assume, Shamail, is what you mean by "third parties".
21:20:09 <Shamail> If we can even add a summary of data plane resiliency technologies, etc. for each infrastructure layer.  Please look at the high-level summary I gave to Meg for "storage back ends" and poke at it. :)
21:20:14 <Shamail> nickchase: yep!
21:20:38 <Shamail> We could add one for network and compute as well
21:20:46 <megm> Ceph is a big player here, too -- not exactly what I would call a third-party but the concept is the same
21:20:53 <Shamail> Yep!
21:21:29 <nickchase> OK, I agree in principle.  But at some point we're going to have to take a stand and be specific, in order to be truly useful.
21:21:39 <mattgriffin> Shamail, i think we have a good plan here already. anything you'd alter? https://wiki.openstack.org/wiki/HAGuideImprovements/TOC#Storage_Backend
21:21:54 <mattgriffin> well maybe just comment in the wiki like clouddon suggested
21:22:23 <Shamail> Im going to modify it slightly mattgriffin, this was the result of a brief chat between Meg and I.
21:22:32 <mattgriffin> excellent
21:22:33 <megm> Specific about the concepts, not the procedures.  We point to the individual technologies for procedures but we need to explain what RAID does and does not do, etc
21:22:38 <Shamail> We should do something for network and compute.
21:23:04 <Shamail> But they also follow standard means of protection.  The point we should make is to consider protection at the infrastructure layer and give some standards that are used.  Leave the actual choice of protection to the user.
21:23:33 <Shamail> I'll comment on wiki.  Just wanted to raise the infrastructure question.  I think we all agree on how deep we should go.
21:23:41 <mattgriffin> ack
21:23:47 <megm> We also discussed that we would cover HAProxy but make a mention of Level 2 switches for load-balancing...
21:23:52 <nickchase> I'm nto sure I agree; I'll know it when I see it. :)
21:24:13 <Shamail> Fair enough. :)
21:24:26 <Shamail> What's up Mattgriffin?
21:25:01 <megm> It boils down to needing more conceptual material.  The current guide has a lot of sections that are nothing more than a sample config file and instructions to copy it.
21:25:24 <Shamail> megm: +11
21:25:29 <Shamail> Or +1
21:25:32 <mattgriffin> heh
21:25:35 <Shamail> What's an extra 1 or 0?
21:25:58 <mattgriffin> move on to next action item from last week?
21:26:20 <mattgriffin> btw... i'm using https://wiki.openstack.org/wiki/Documentation/HA_Guide_Update#Next_Meeting
21:26:25 <mattgriffin> #link https://wiki.openstack.org/wiki/Documentation/HA_Guide_Update#Next_Meeting
21:27:23 <mattgriffin> Are we ready to start assigning content or want to wait another week to leave comments on the wiki for any other potential changes?
21:27:53 <mattgriffin> sounds like we should give it another week. agree?
21:27:57 <nickchase> Does the current TOC track the install guide?
21:28:53 <nickchase> +1
21:28:54 <mattgriffin> nickchase, if we swap our project names with what they do, yes
21:28:56 <megm> I think pretty much
21:29:28 <nickchase> well, then I'd go either way; even if we add level 2, we'll likely keep what's here now.
21:29:29 <Shamail> mattgriffin: +1
21:30:10 <clouddon> If we are taking too long to confer, how about we put a date?
21:30:34 <megm> The old guide is arranged for active/active and active/passive.  The current TOC breaks that model.
21:30:41 <nickchase> Why don't we assign some topics we KNOW are going to get written?
21:30:46 <megm> I thought we had agreement but do we?
21:31:11 <nickchase> We agree we're going to break that model, I believe.
21:31:21 <mattgriffin> megm, nickchase yes
21:31:51 <megm> Where are the existing source files?  I don't seem to have them in the openstack-manual repo I downloaded
21:32:21 <Shamail> I like the new flow (vs. building the entire structure around A/A and A/P), however I think we still have to address A/A and A/P in each section.
21:32:33 <megm> Shamail +1
21:32:37 <nickchase> are they not in openstack-manualsdoc/ha-guide?
21:33:06 <megm> I didn't get that subdirectory
21:34:01 <megm> Also, when/how are we going to convert the existing docbook source to RST?
21:34:09 <nickchase> I'm not seeing it either.
21:34:21 <nickchase> OK, i give up, where is it?
21:34:59 <Shamail> https://github.com/openstack/ha-guide
21:35:01 <Shamail> This it?
21:35:29 <nickchase> so it as its own rep?
21:35:32 <nickchase> repo*
21:35:36 <Shamail> Apparently
21:35:42 <Shamail> Surprised.
21:35:50 <nickchase> I am too.
21:36:02 <megm> Interesting...
21:36:16 <nickchase> ok, well, if it does, it does.
21:36:23 <nickchase> we just needed to know where to find it.
21:36:46 <Shamail> Who has core here?
21:37:00 <nickchase> no idea.
21:37:08 <mattgriffin> megm, is this enough to understand a process for converting?
21:37:10 <megm> We should add this info to the wiki
21:37:27 <nickchase> I think the first question is "why does it have its own repo?"
21:37:48 <nickchase> I know how to create a new RST book in openstack-manuals but not in openstack.
21:38:24 <megm> Maybe this is a golden opportunity?  Leave the old guide where it is and create a new ha-guide in openstack-manuals?
21:38:45 <nickchase> We can certainly do that.
21:38:49 <megm> mattgriffin, I don't see info for converting that you reference.
21:39:01 <nickchase> I don't think info on converting is documented.
21:39:07 <nickchase> I only know because I did the network guide.
21:39:22 <nickchase> I take it back
21:39:29 <nickchase> info on converting specific files is documented
21:39:32 <nickchase> I'll find it in a moment
21:39:33 <megm> Nick, if you'll help me get started, I could convert and set up new files
21:39:36 <nickchase> just not creating a book.
21:40:12 <nickchase> Tell you what: I'll create a book and help you get started converting the existing files to drop into it.  OK?
21:40:20 <nickchase> (Just that it'll take longer to explain it than do it. :))
21:40:31 <nickchase> I'll have to do it to document it (which I will).
21:41:19 <megm> Sounds good -- you do what is easier for you to do, then hand off to me?
21:41:41 <clouddon> i need to sign off. thanks all
21:41:45 <Shamail> Same here
21:41:53 <mattgriffin> clouddon, Shamail later
21:41:59 <Shamail> I'll catch up on the meeting log, cya all
21:42:05 <mattgriffin> cool
21:42:09 <megm> Thanks!
21:42:13 <mattgriffin> will be posted to the wiki
21:42:40 <mattgriffin> megm, nickchase i think we need to wrap up
21:43:02 <nickchase> all sounds good
21:43:04 <nickchase> thanks
21:43:04 <mattgriffin> nickchase, you're going to do some documentation on converting, yes?
21:43:08 <nickchase> yes
21:43:09 <megm> Nick, do you know what we need to do?
21:43:13 <nickchase> yes.
21:43:33 <megm> And we're ready to start setting up ha-guide files in openstack-manuals and leave the old repo intact?
21:43:53 <nickchase> +1
21:43:58 <nickchase> that's the plan, right?
21:44:25 <megm> Nick, let me know when you need me...
21:44:37 <nickchase> will do
21:44:37 <nickchase> will do, Meg
21:44:47 <mattgriffin> megm, nickchase like here? https://github.com/openstack/openstack-manuals/tree/master/doc
21:45:04 <nickchase> yes, there.
21:45:10 <mattgriffin> cool
21:45:14 <megm> +1
21:45:29 <mattgriffin> quick documentation for action items...
21:45:47 <megm> I will update https://etherpad.openstack.org/p/ha-guide-march-2015-update about the repos
21:45:53 <mattgriffin> #action nickchase document how to convert
21:46:01 <mattgriffin> megm, cool
21:46:13 <mattgriffin> #action all: review TOC and comment
21:46:55 <mattgriffin> megm, i think that (repos info) would be better on the HA Guide wiki
21:46:56 <mattgriffin> ye?
21:46:58 <mattgriffin> yes?
21:47:07 <megm> +1
21:47:10 <mattgriffin> here: https://wiki.openstack.org/wiki/Documentation/HA_Guide_Update
21:47:45 <nickchase> yes, definitely
21:47:52 <nickchase> we should also let the mailing list know
21:47:54 <mattgriffin> #action megm update the HA Guide wiki with the right repos info
21:48:02 <nickchase> in case there was some reason that it was moved.
21:48:02 <mattgriffin> +1
21:48:26 <megm> Will do
21:48:35 <mattgriffin> ok. i think we're good until next week. anything else?
21:48:43 <megm> I'm good
21:49:32 <mattgriffin> i think we should still be thinking about who we might want to pull into this effort (at our company or another group) to write some of the content.. but that's an ongoing action item until we start assigning sections.
21:50:04 <nickchase> I have a list of people and topics
21:50:13 <mattgriffin> nickchase, great!
21:50:14 <nickchase> they're ready to tart
21:50:16 <nickchase> start*
21:50:26 <mattgriffin> if there's nothing else, i'm going to end
21:50:39 <mattgriffin> thanks megm & nickchase
21:50:44 <nickchase> later
21:50:52 <megm> Have a great week!
21:50:58 <mattgriffin> you too!
21:51:01 <mattgriffin> #endmeeting