20:04:40 <mattgriffin> #startmeeting ha-guide
20:04:41 <openstack> Meeting started Thu Jul 23 20:04:40 2015 UTC and is due to finish in 60 minutes.  The chair is mattgriffin. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:04:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:04:44 <openstack> The meeting name has been set to 'ha_guide'
20:05:06 <beekhof> howdy
20:05:26 <mattgriffin> let's get started in the HA Guide meeting. who's here for that chat?
20:05:36 <mattgriffin> here's the agenda...
20:05:39 <mattgriffin> #link https://wiki.openstack.org/wiki/Documentation/HA_Guide_Update#Next_Meeting
20:06:40 <mattgriffin> just a few things on the agenda today
20:07:00 <megm> Howdy, beekhof!
20:07:08 <mattgriffin> hey beekhof
20:07:11 <mattgriffin> welcome
20:07:17 * beekhof might still be waking up :)
20:07:23 <mattgriffin> :)
20:07:52 <mattgriffin> hey vnod. here for the ha guide meeting?
20:07:54 <megm> beekhof, we appreciate it!  ;-)
20:08:58 <vnod> nope. this my IRC client logging to all channels.
20:09:09 <mattgriffin> vnod, ah... we welcome  anyway :)
20:09:16 <mattgriffin> s/we/well
20:09:27 <mattgriffin> so first, both action items from last week's meeting are done
20:09:34 <mattgriffin> http://eavesdrop.openstack.org/meetings/ha_guide/2015/ha_guide.2015-07-16-20.07.html
20:09:38 <mattgriffin> #link http://eavesdrop.openstack.org/meetings/ha_guide/2015/ha_guide.2015-07-16-20.07.html
20:10:21 <mattgriffin> spreadsheet with progress is updated
20:10:40 <mattgriffin> and sent message to tell the rest of the docs team and ask for reviews help
20:11:08 <mattgriffin> next...
20:11:08 <megm> Hooray!
20:11:11 <mattgriffin> :)
20:11:23 <mattgriffin> the spreadsheet of progress...
20:11:24 <mattgriffin> #link https://docs.google.com/spreadsheets/d/17EApMTVzCgddR62ZYJC4qAs9imdZWDcSy81UNEae8WY/edit#gid=0
20:11:54 <mattgriffin> megm, i had one question about the keystone content
20:12:00 <megm> Just FYI, Jenkins is apparently overloaded so it is taking a LONG time for stuff to be processed.  Andreas advises patience ;-)
20:12:06 <mattgriffin> ah!
20:12:12 <mattgriffin> question answered then :)
20:12:24 <mattgriffin> likely
20:13:13 <mattgriffin> so just need to keep pushing to get reviews. i can email lana again and ask her to include a note in her next Docs update email
20:13:14 <megm> Yes, the specific question was about the Keystone piece -- it was merged almost 12 hours ago but is still not showing up in the draft ha-guide build
20:13:42 <mattgriffin> megm, i'll keep a look out for that update to the draft guide and update the link in the spreadsheet
20:14:04 <megm> Okay -- I'll watch for it as well.
20:14:25 <mattgriffin> cool.
20:15:51 <megm> So, we need content.  beekhof, are you interested in that?
20:16:04 <beekhof> reviewing?
20:16:30 <mattgriffin> beekhof, yes. reviewing and submitting bugs for content to update/add
20:16:35 <megm> reviewing, writing -- any of the above.
20:16:40 <beekhof> i can poke around :)
20:16:46 <megm> Wonderful!
20:16:46 <mattgriffin> excellent
20:16:51 <megm> Which areas interest you most?
20:16:52 <beekhof> should we talk about active/active and where pacemaker fits?
20:17:11 <beekhof> i dont want to go off and do stuff that people fundamentally disagree with :)
20:17:36 <megm> Pacemaker is central and crucial and the existing material certainly needs revision!
20:17:45 <mattgriffin> +1
20:17:56 <beekhof> ok then :)
20:18:10 <megm> I know that we have three open bugs against Pacemaker/Corosync
20:18:14 <beekhof> because a lot of people seem to be keepalived fans
20:18:25 <beekhof> and dont see the point of pacemaker
20:18:32 <megm> Related bugs are sorted by topic in https://etherpad.openstack.org/p/openstack-haguide-update-next-steps
20:18:48 * beekhof reads
20:19:02 <megm> So should we discuss both pacemaker and the keepalived options?
20:20:09 <beekhof> i’m happy to ignore keepalived
20:20:11 <beekhof> :)
20:20:19 <mattgriffin> is this something that was measured in the latest user survey?
20:20:22 <megm> If both are valid, it makes sense to mention them both and perhaps summarize the considerations/arguments
20:21:18 <beekhof> both are valid depending on the level of risk you’re prepared to tolerate. my argument would be that many/most people choosing keepalived don’t undertsand that risk
20:21:38 <megm> My opinion is that anyone who contributes gets to recommend what they think is correct.  Others can comment or augment if they choose.
20:22:01 <beekhof> so if we want to discuss both, there should be a discussion of risk at the start :)
20:22:34 <beekhof> i’d like to focus on the pacemaker side of things, there are others that posses more keepalived knowledge
20:22:35 <mattgriffin> i'm in agreement with megm :)
20:22:40 <megm> So maybe we could add a small section about keepalived that summarizes the risks and advantages of keepalived.
20:22:50 <beekhof> sure
20:22:53 <mattgriffin> +1
20:22:58 <megm> If a proponent of keepalived wants more coverage, they can add it, right?
20:23:02 <beekhof> so, stupid question… how do i make changes?
20:23:05 <mattgriffin> beekhof, thanks for the help
20:23:05 <beekhof> right
20:23:38 <megm> beekhof, feel free to rewrite any of this if you like -- sometimes it's easier to write it than to comment instructions that I can follow.
20:24:06 <megm> But I'm available for any scribal services that you need
20:24:30 <mattgriffin> beekhof, just put your name as the SME for Pacemaker/Corosync in the spreadsheet
20:24:39 <megm> If you want to do a CR with correct info and no RST coding, just make me a reviewer and add a comment that I need to grab it and code it.
20:24:54 <beekhof> i mean even at the level of, where is the git repo :)
20:25:04 <beekhof> this is my first contribution to the core
20:25:55 <megm> Aha!  I'm only a couple steps ahead of you here but I should be able to help you.
20:26:21 <megm> You can email me at DreidelLhasa@yahoo.com
20:26:28 <beekhof> is there a contribution process written up somewhere by any chance?
20:26:37 <beekhof> awesome
20:26:46 <megm> Yes, there is a contrib process writtten up for the OpenStack docs.
20:26:54 <megm> And ha-guide is its own repo.
20:27:53 <megm> What kind of system do you work on?  Ubuntu/RHEL/Windoze?
20:28:01 <mattgriffin> repo: https://github.com/openstack/ha-guide
20:28:54 <megm> Thanks, Matt.  I'm looking for the instructions for setting up the local doc builds and all
20:28:58 <beekhof> I’m either fedora/, rhel or Mac :)
20:29:36 <beekhof> ah, this looks like just the thing
20:30:24 <megm> Here are instructions for first-timers https://wiki.openstack.org/wiki/Documentation/HowTo/FirstTimers
20:30:38 <megm> As I recall, there are some holes that are covered elsewhere.
20:31:14 <megm> I think some of those were ubuntu-specific issues -- you may do better with fedora or Mac
20:31:51 <megm> are you comfortable with RST?
20:32:37 <beekhof> i’ve never used it, but how hard can it be?
20:33:05 <beekhof> how long do reviews usually take?
20:33:11 <megm> It has a few little quirks but it is pretty easy once you catch on to those.
20:33:14 <beekhof> oh, and is anyone going to tokyo?
20:33:56 <megm> Reviews are generally pretty fast.  The standard is that, when we get two +1's from our team, Andreas and others get stuff merged within a few hours.
20:34:02 <beekhof> nice
20:34:23 * beekhof might start small
20:34:44 <megm> Yeah, I have lived in a world where merges took several weeks and it was debilitating!
20:34:48 <beekhof> so i need an RST to fix these 3 doc bugs?
20:34:56 <mattgriffin> beekhof, yeah. start small... even look for some low hanging fruit (grammar bugs) in other Docs projects to get familiar with the process
20:35:35 <megm> It might be a good idea to put your name next to any area you are working on here https://docs.google.com/spreadsheets/d/17EApMTVzCgddR62ZYJC4qAs9imdZWDcSy81UNEae8WY/edit#gid=0
20:36:07 <megm> Ah, I see that you just did that -- great!
20:36:41 <beekhof> first name andrew btw :)
20:36:51 <beekhof> in case i slip and put that
20:36:53 <mattgriffin> welcome beekhof. thanks for your future help :)
20:37:04 <beekhof> you’re welcome :)
20:37:15 <mattgriffin> i need to run to another meeting. any other topics to discuss?
20:37:27 <megm> You might also want to swipe at http://docs.openstack.org/draft/ha-guide/intro-ha-controller.html
20:37:42 <mattgriffin> beekhof, please tell your friends that know the other OpenStack services
20:37:58 <beekhof> will do
20:37:59 <megm> This is introductory material that I think should probably be moved to the Controller section.  But it might be a good place to discuss keepalived for now
20:38:17 <beekhof> ok
20:38:30 <beekhof> mattgriffin: i’m good
20:38:30 <megm> Gee, I just noticed it doesn't even mention Pacemaker.  Gag!
20:39:16 <megm> My vision is that this piece should link to the sections with more info.  Actually, now that we have a skeleton populated and merged, I could go in and do that ;-)
20:39:28 <mattgriffin> :)
20:41:28 <megm> Matt, how do we track the open bugs?  Right now, they are in that very kludgy next-steps document
20:42:40 <mattgriffin> megm, hmm
20:43:05 <mattgriffin> thought we could use a filter but might be a challenge
20:43:23 <mattgriffin> though i think all bugs will have the url so we could filter on that
20:43:55 <megm> beekhof, did you see https://review.openstack.org/#/c/189957/?  I haven't seen activity from Radek lately -- I'll ping him when we're done.
20:44:10 <megm> But you might want to be aware of that one ;-)
20:45:19 <megm> Re: bugs...  we need to line them up with the subject sections so that people who are working on each section can easily find relevant bugs.
20:46:09 <beekhof> ok, i’ll look
20:46:14 <beekhof> just filling out forms :)
20:46:35 <mattgriffin> megm, ok. i'll look into an easy, repeatable, reliable way to do that
20:46:43 <megm> Is CloudDon going to be coming back to us sometime?
20:46:57 <mattgriffin> #action mattgriffin look into how to call out bugs for the HA Guide sections
20:46:59 <beekhof> oh, thats right up my alley :)
20:47:23 <mattgriffin> megm, don't know. haven't seen him lately
20:47:25 <mattgriffin> i'll poke him if i see him
20:48:00 <beekhof> i see a few +1’s, what is left to do there?
20:48:17 <megm> I'd like to work with him on the intro material -- one of the bugs is from him but he could no doubt help me with the othrs
20:49:08 <megm> beekhof, I'm not sure what the delay is there.  He made changes to the unconverted docbook stuff so now that needs to be folded into the RST version.
20:49:42 <beekhof> you really dont want to disable wait_for_all in a 2 node cluster
20:49:55 <beekhof> its about the only thing that makes it safe
20:50:13 <megm> ;-)
20:50:53 <mattgriffin> gotta run. thanks megm and beekhof !!!
20:51:17 <beekhof> np
20:51:40 <megm> As a general note, it seems to me that we get way too much stuff written about 2-node clusters. This guide should target 3+-node clusters that are appropriate for production systems, then add notes  with special info about the 2-node demo environments
20:52:06 <mattgriffin> +1
20:52:06 <beekhof> 2 nodes clusters suck
20:52:15 <megm> beekhof, write to me if you need help getting going.  I'm sure you won't pull as many stupid things as I did ;-)
20:52:23 <mattgriffin> #endmeeting