#openstack-meeting: HA

Meeting started by aspiers at 09:00:00 UTC (full logs).

Meeting summary

  1. Minutes and logs from previous meeting (aspiers, 09:01:12)
    1. minutes of previous meeting are at http://eavesdrop.openstack.org/meetings/ha__automated_recovery_from_hypervisor_failure/2015/ha__automated_recovery_from_hypervisor_failure.2015-11-16-09.00.html (aspiers, 09:01:41)

  2. Actions from previous meeting (aspiers, 09:02:49)
    1. ddeja has shared the mistral PoC code on github (aspiers, 09:03:18)
    2. https://github.com/gryf/mistral-evacuate (aspiers, 09:03:25)
    3. etherpad has been updated with more details of the mistral PoC (aspiers, 09:03:43)
    4. https://etherpad.openstack.org/p/automatic-evacuation (aspiers, 09:03:53)
    5. ACTION: masahito will review mistral code and start thinking about routes for convergence (aspiers, 09:05:41)

  3. Current status (progress, issues, roadblocks, further plans) (aspiers, 09:06:00)
    1. https://wiki.openstack.org/wiki/Mistral (aspiers, 09:07:03)
    2. _gryf and ddeja are preparing the simplest evac use case implemented via Mistral https://github.com/gryf/mistral-evacuate (aspiers, 09:11:22)
    3. ddeja working on a bug in the Mistral PoC (aspiers, 09:18:28)
    4. NovaCompute / NovaEvacuate RAs are now in openstack-resource-agents (aspiers, 09:18:32)
    5. https://git.openstack.org/cgit/openstack/openstack-resource-agents/ (aspiers, 09:18:48)
    6. naming is inconsistent with existing nova-* RAs, hopefully we can rename for consistency (aspiers, 09:20:51)
    7. ACTION: aspiers will talk to beekhof about the potential rename (or just submit a gerrit review) (aspiers, 09:23:14)
    8. IDEA: change OCF RAs so that they invoke service(8), in order to wrap around existing systemd / SysV services (aspiers, 09:25:50)
    9. https://review.openstack.org/#/projects/openstack/openstack-resource-agents,dashboards/important-changes:review-inbox-dashboard (aspiers, 09:28:03)
    10. aspiers is feeding his patches "upstream" to the new RAs (aspiers, 09:28:24)
    11. aspiers gave a presentation on compute node HA to OpenStack London Meetup (aspiers, 09:28:45)
    12. http://www.slideshare.net/adamspiers/compute-node-ha-current-upstream-development (aspiers, 09:29:02)
    13. new pacemaker_transaction Chef LWRP in progress (aspiers, 09:29:32)
    14. https://github.com/crowbar/crowbar-ha/compare/master...aspiers:transactions (aspiers, 09:29:52)
    15. https://github.com/openstack/fuel-library/tree/master/deployment/puppet/pacemaker (bogdando, 09:34:16)
    16. there are various ways to monitor the status of pacemaker_remote nodes, e.g. https://github.com/ClusterLabs/crmsh/issues/103 (aspiers, 09:36:39)

  4. Automatic VM resurrection - next steps (aspiers, 09:39:02)
    1. ACTION: everyone who's interested to look at the Mistral PoC code by _gryf and ddeja (aspiers, 09:40:11)
    2. https://github.com/gryf/mistral-evacuate (aspiers, 09:40:51)
    3. mistral workflows are explained at http://docs.openstack.org/developer/mistral/dsl/dsl_v2.html#direct-workflow (aspiers, 09:44:13)
    4. IDEA: start using some tool for shared collaboration on architecture diagrams? (aspiers, 09:45:40)
    5. IDEA: write an OCF RA which monitors libvirtd for VMs which fail (even when libvirtd/hypervisor are still healthy) (aspiers, 09:50:04)
    6. ACTION: masahito will start experimenting with pacemaker_remote (aspiers, 09:54:21)

  5. Open discussion (aspiers, 09:54:53)
    1. ACTION: masahito to look at converting masakari from using MySQLdb to SQLalchemy (aspiers, 09:55:37)
    2. quite a bit of activity on the ha-guide currently (aspiers, 09:58:09)
    3. https://review.openstack.org/#/projects/openstack/ha-guide,dashboards/important-changes:review-inbox-dashboard (aspiers, 09:58:13)
    4. Mistral team are starting to work on making Mistral HA (aspiers, 09:59:00)
    5. https://blueprints.launchpad.net/mistral/+spec/mistral-ha (aspiers, 09:59:03)


Meeting ended at 10:00:22 UTC (full logs).

Action items

  1. masahito will review mistral code and start thinking about routes for convergence
  2. aspiers will talk to beekhof about the potential rename (or just submit a gerrit review)
  3. everyone who's interested to look at the Mistral PoC code by _gryf and ddeja
  4. masahito will start experimenting with pacemaker_remote
  5. masahito to look at converting masakari from using MySQLdb to SQLalchemy


Action items, by person

  1. _gryf
    1. everyone who's interested to look at the Mistral PoC code by _gryf and ddeja
  2. aspiers
    1. aspiers will talk to beekhof about the potential rename (or just submit a gerrit review)
  3. ddeja
    1. everyone who's interested to look at the Mistral PoC code by _gryf and ddeja
  4. masahito
    1. masahito will review mistral code and start thinking about routes for convergence
    2. masahito will start experimenting with pacemaker_remote
    3. masahito to look at converting masakari from using MySQLdb to SQLalchemy


People present (lines said)

  1. aspiers (186)
  2. bogdando (41)
  3. _gryf (36)
  4. masahito (18)
  5. trinaths (7)
  6. ddeja (7)
  7. openstack (3)
  8. jklare (2)


Generated by MeetBot 0.1.4.