18:00:11 <bh526r_> #startmeeting gluon
18:00:12 <openstack> Meeting started Wed Apr 12 18:00:11 2017 UTC and is due to finish in 60 minutes.  The chair is bh526r_. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:15 <openstack> The meeting name has been set to 'gluon'
18:00:24 <bh526r_> #topic Roll Call
18:00:30 <bh526r_> #info Bin Hu
18:01:29 <krenczewski> #info Kamil Renczewski
18:01:41 <bh526r_> Hi Kamil
18:01:43 <jinli> Hi everyone
18:01:45 <georgk> #info Georg Kunz
18:01:47 <krenczewski> Hi Bin
18:01:47 <jinli> #info JinLi
18:01:55 <bh526r_> Hi Georg and Jin
18:02:16 <bh526r_> #topic Admin Update
18:02:29 <bh526r_> #info Our submission to Forum:
18:02:39 <georgk> hi all
18:02:49 <bh526r_> #link http://forumtopics.openstack.org/cfp/details/47
18:02:56 <bh526r_> #info was rejected
18:03:12 <bh526r_> #info details of reason can be found in above link
18:03:47 <bh526r_> #topic Status Update of PoC in OpenStack Summit
18:04:32 <bh526r_> #info 1. PoC Scenario Description was agreed a few weeks ago, and it stays the same
18:05:00 <bh526r_> #info But we need a documented demo script. Bin will draft it for everyone to review
18:05:21 <bh526r_> #action Bin draft demo script for PoC in OpenStack Summit
18:05:47 <bh526r_> #info 2. Lab in Germany - running stably
18:06:18 <bh526r_> georgk, do you want to add something more?
18:06:42 <georgk> yes, the Nova issues have been resolved
18:07:09 <bh526r_> #info Nova issue was resolved, and VM can be booted
18:07:09 <georgk> we had problems due to re-installing some OpenStack packages with pip while the services were running
18:07:18 <georgk> restarting the services solved the issue
18:07:41 <bh526r_> #info There were problems due to re-installing some OpenStack packages with pip while the services were running
18:07:51 <bh526r_> #info restarting the services solved the issue
18:08:18 <bh526r_> The dependency is always a headache
18:08:56 <bh526r_> #info 3. Contrail Status
18:09:35 <krenczewski> I was able to run Contrail
18:09:58 <bh526r_> #info Kamil was able to run Contrail
18:10:05 <krenczewski> and authenticate with keystone on 192.168.0.6 node
18:10:24 <bh526r_> #info and authenticate with keystone on 192.168.0.6 node
18:10:40 <bh526r_> So can Mechanism Driver work with Contrail now?
18:10:48 <krenczewski> problem was that one of interfaces was up without IP affress and zookeeper couldn't handle this
18:11:15 <krenczewski> Still need to resolve issue with Service Monitor service
18:11:26 <bh526r_> I see
18:11:30 <krenczewski> then I'll deploy mechanism driver
18:11:44 <bh526r_> #info Problem was that one of interfaces was up without IP affress and zookeeper couldn't handle this
18:12:01 <bh526r_> #info So still need to resolve issue with Service Monitor service
18:12:14 <bh526r_> #info Then Kamil will deploy Mechanism Driver
18:12:26 <bh526r_> Good progress, Kamil
18:12:30 <krenczewski> I don't want to do this without Contrail fully working because any issues woud be impossible to resolve
18:12:57 <bh526r_> That's right. So make sure Contrail fully working first.
18:13:18 <bh526r_> Then if there is any issue later, we can isolate the issue more easily
18:13:52 <bh526r_> Keep up your good work, Kamil. Thank you
18:14:02 <krenczewski> Thank you
18:14:26 <bh526r_> #info 4. L3VPN API - Parameter List for BGP Peering
18:14:54 <bh526r_> #link https://review.openstack.org/#/c/450917/
18:15:08 <bh526r_> #info Georg will update the patch based on Jin's comments
18:15:32 <bh526r_> #info 5. SFC YAML and API
18:15:57 <bh526r_> #info Georg is completing the draft, and under internal review
18:16:14 <bh526r_> #info Georg will submit this patch in a few days
18:16:35 <bh526r_> #info 6. P2P YAML and API
18:16:56 <bh526r_> #info Robert is working on it, and will submit the patch in a few days
18:17:12 <bh526r_> #info 7. ELAN YAML and API
18:17:36 <bh526r_> #info Eric has provided Ian with the ELAN YANG Model
18:17:56 <bh526r_> #info Bin will follow up with Ian on this subject
18:18:14 <bh526r_> #action Bin follows up with Ian on ELAN YAML and API
18:18:29 <bh526r_> #info 8. Misc
18:19:09 <bh526r_> #info There is a new patch to support all API YAML Models by default
18:19:21 <bh526r_> #link https://review.openstack.org/#/c/456283/
18:20:33 <bh526r_> #info Current code supports net-l3vpn as default. If we add new YAML model, we need to change proton.conf. If someone forgets to change proton.conf, even if new model is added, Proton Server will still only pick up net-l3vpn
18:22:15 <bh526r_> #info In order to improve usability and make adding new YAML model and API easier, this patch will support all models by default. Whenever a model is added, Proton Server will pick it up without having to change proton.conf
18:22:30 <bh526r_> #info All are encouraged to review and comment the code
18:23:04 <bh526r_> #info This will also make demo/PoC easier - only need to add/remove model, rebuild and restart proton-server without changing proton.conf
18:23:29 <bh526r_> any other thing / update for PoC?
18:24:31 <bh526r_> #topic Pike Release and Patches
18:24:52 <bh526r_> #info 1. New "Network Type" in Neutron
18:26:17 <bh526r_> #info Bin had conversation with Sukhdev yesterday. The idea that Sukhdev proposes will still lead to previous 2 RFEs, i.e. (1) optional Network and Subnet, and (2) new network characteristics attribute
18:27:31 <bh526r_> #info Sukhdev will document it, for further review and discussion. But previous 2 RFEs are needed based on conversation
18:27:52 <bh526r_> #info 2. Approved patches
18:28:14 <bh526r_> #info First is Remove unused import statements
18:28:29 <bh526r_> #link https://review.openstack.org/#/c/446776/
18:29:05 <bh526r_> #info It was approved and merged on March 22, and cherrypicked to stable/ocata (https://review.openstack.org/#/c/448775/)
18:29:25 <bh526r_> #info Second is Fixing DB test after sqlite_db config option was removed
18:29:38 <bh526r_> #link https://review.openstack.org/#/c/451989/
18:30:16 <bh526r_> #info It was approved and merged on March 31, and cherrypicked to stable/ocata (https://review.openstack.org/#/c/452268/)
18:30:35 <bh526r_> #info Third is Fixing broken import statement
18:30:49 <bh526r_> #link https://review.openstack.org/#/c/451722/
18:31:18 <bh526r_> #info It was approved and merged on March 31, and cherrypicked to stable/ocata (https://review.openstack.org/#/c/452357/)
18:31:34 <bh526r_> #info Fourth is Remove translation of log messages from gluon
18:31:54 <bh526r_> #link https://review.openstack.org/#/c/453970/
18:32:28 <bh526r_> #info It was approved and merged on April 6, and cherrypicked to stable/ocata (https://review.openstack.org/#/c/454286/)
18:34:33 <bh526r_> #info Fifth is Refined installation instructions
18:34:49 <bh526r_> #link https://review.openstack.org/#/c/452980/
18:35:28 <bh526r_> #info It was approved and merged on April 6, and cherrypicked to stable/ocata (https://review.openstack.org/#/c/454508/)
18:35:51 <bh526r_> #info Sixth is Base URI return values
18:36:03 <bh526r_> #link https://review.openstack.org/#/c/453929/
18:36:38 <bh526r_> #info It was approved and merged this morning (April 12), and cherrypicked to stable/ocata (https://review.openstack.org/#/c/456234/)
18:36:52 <bh526r_> #info 2. Outstanding Patches
18:37:06 <bh526r_> #info There are a few outstanding patches.
18:37:42 <bh526r_> #info Two were mentioned when we discussed PoC Status. Please review and comment
18:38:09 <bh526r_> #link https://review.openstack.org/#/c/450917/
18:38:28 <bh526r_> #link      https://review.openstack.org/#/c/456283/
18:38:41 <bh526r_> #info Others include
18:39:03 <bh526r_> #link https://review.openstack.org/#/c/453519/
18:39:22 <bh526r_> #link https://review.openstack.org/#/c/430446/
18:39:42 <bh526r_> #info https://review.openstack.org/#/c/404069/
18:40:15 <bh526r_> #info There are review comments and -1, so authors are expected to resolve the comments and update with new patches
18:40:36 <bh526r_> #topic AOB
18:40:45 <bh526r_> anything else you want to discuss?
18:41:28 <georgk> FYI: just pushed an update for the L3VPN model extension
18:41:42 <bh526r_> Great, and thank you Georg.
18:42:37 <bh526r_> I see Jin +1
18:42:43 <bh526r_> I suggest we approve it
18:44:10 <bh526r_> #info Georg updated the patch of Extending L3VPN model to configure BGP peerings.
18:44:29 <bh526r_> #info Group agreed to approve it, and Bin takes the action
18:45:02 <bh526r_> Anything else?
18:45:50 <bh526r_> If nothing else, we can adjourn the meeting and give back everyone 15 minutes
18:45:57 <bh526r_> #info Meeting adjourned
18:46:15 <bh526r_> thank you everyone, and bye all
18:46:19 <bh526r_> #endmeeting