18:04:59 <bh526r> #startmeeting gluon
18:05:00 <openstack> Meeting started Wed Jul 13 18:04:59 2016 UTC and is due to finish in 60 minutes.  The chair is bh526r. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:05:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:05:04 <openstack> The meeting name has been set to 'gluon'
18:05:17 <pcarver> hi
18:05:21 <bh526r> #hello, welcome to Gluon kick off meeting
18:05:25 <ALUVial> hi.  Vince here
18:05:30 <bh526r> Hi Paul,
18:05:33 <bh526r> Hi Vince
18:05:43 <georgk> Hi
18:06:05 <krenczewski> hi
18:06:06 <tomhamb> Hi
18:06:10 <bh526r> Hi Georg
18:06:16 <Jeffreyc42> Hi Guys
18:06:16 <kamal__> Hi All
18:06:18 <bh526r> Hi Tom
18:06:25 <bh526r> Hi all guys
18:06:58 <bh526r> The meeting agenda is https://wiki.openstack.org/wiki/Meetings/Gluon/Agenda-20160713
18:07:16 <bh526r> and welcome everybody
18:07:30 <bh526r> #topic Roll Call
18:07:41 <bh526r> #info Bin Hu
18:07:52 <tomhamb> #info Tom Hambleton
18:07:53 <georgk> #info Georg Kunz
18:07:54 <ALUVial> #info Vince Button
18:07:59 <Jeffreyc42> #info
18:08:08 <Jeffreyc42> #info Jeff Collins
18:08:13 <kamal__> #info kamal__
18:08:32 <pcarver> #info Paul Carver
18:08:41 <bh526r> #topic Admin Update
18:08:55 <krenczewski> #info Kamil Renczewski
18:09:03 <bh526r> This is our first, kick-off meeting
18:09:30 <bh526r> We will miss DJ because of his another overlapping meeting
18:09:40 <bh526r> Not sure if Ian is here or not
18:10:15 <bh526r> So we have had our repo setup
18:10:28 <bh526r> and wiki (skeleton) setup too.
18:10:47 <ALUVial> can we add stuff to today's agenda?
18:10:55 <bh526r> And we can start to work in our repo and wiki
18:11:02 <bh526r> Sure
18:11:10 <bh526r> what do you propose to discuss?
18:11:21 <ALUVial> Openstack Barcelona presentations
18:11:25 <ALUVial> Etherpad locations
18:11:39 <bh526r> Good suggestion.
18:11:41 <Jeffreyc42> yea, since they are do today
18:12:04 <bh526r> Let me finish quick admin update, and we can discuss your suggestion first
18:12:19 <ALUVial> great!
18:12:36 <bh526r> From admin perspective, we need to have official election of PTL
18:13:00 <anteaya> no you don't, you just have to decide within your group
18:13:22 <anteaya> you only have to participate in the official elections if you are listed in the governance/projects.yaml file
18:13:41 <bh526r> I see. Thank you for the information
18:13:47 <anteaya> welcome
18:14:18 <ALUVial> who wants the job?  put your name forward.
18:14:26 <bh526r> Ok, we can decide within our group
18:14:52 <bh526r> If no one else volunteer, perhaps I can volunteer to this job
18:14:56 <ALUVial> bin +1
18:14:57 <tomhamb> Bin, I thought you were the PTL
18:15:27 <bh526r> Thank you Vince and Tom
18:15:50 <bh526r> Any other suggestion or volunteer?
18:16:23 <Jeffreyc42> I would say Ian but I don't think he has time.  Bin I think you would be a good choice.
18:16:48 <bh526r> Thank you Jeff.
18:16:52 <Jeffreyc42> Bin +1
18:16:56 <georgk> same here
18:17:05 <kamal__> I'm fine with Bin being the PTL
18:17:16 <georgk> Bin +1
18:17:22 <tomhamb> Bin +1
18:17:39 <bh526r> Thank you everyone
18:17:41 <pcarver> Bin +1
18:18:22 <bh526r> And let us rotate every 6 month or so - the OpenStack way of operation
18:18:27 <Jeffreyc42> ok
18:18:38 <Jeffreyc42> Bin looks like you are PTL
18:18:41 <Jeffreyc42> whats next on the agenda?
18:18:49 <bh526r> Thank you.
18:19:11 <bh526r> #info Group unanimously elected Bin as PTL
18:19:39 <bh526r> #topic OpenStack Barcelona Presentation and Etherpad Location
18:20:01 <bh526r> Next topic is Barcelona presentation, becasue due time is midnight today
18:20:33 <bh526r> We have prepared 2 submissions
18:20:51 <bh526r> One is more strategic level and business oriented
18:21:12 <bh526r> And the other one is technical level and implementation-centric
18:21:54 <bh526r> Vince, I assume you want to discuss the strategic submission (Panel)?
18:22:03 <ALUVial> Sure
18:22:09 <ALUVial> #info https://www.openstack.org/summit/barcelona-2016/call-for-presentations/manage/15732/summary
18:22:23 <ALUVial> Haseeb created the original.
18:22:45 <ALUVial> I made some edits to make it less technical, and based on Ian's suggestion submitted it with Openstack
18:23:13 <ALUVial> Presenters should be able to edit, but the full verbage is in the email also
18:23:24 <Jeffreyc42> Is it actually submitted even though we can still edit it?
18:23:40 <ALUVial> Ian, me, Jeff and Marco can edit up till the deadline
18:23:49 <ALUVial> yes.  Please make updates right up to the deadline
18:24:02 <Jeffreyc42> ok, then it auto-finalizes?
18:24:02 <ALUVial> Toby as moderator for some reason cannot edit it.
18:24:17 <ALUVial> yes.  It finalizes at the deadline
18:24:24 <bh526r> I was about to ask if Toby can edit it or not
18:24:24 <Jeffreyc42> ok
18:24:45 <ALUVial> email us any edits if you are not a presenter
18:24:47 <bh526r> So he cannot, but I think he is fine with it
18:24:56 <georgk> can you post a link without the "mange" in the URL
18:25:05 <georgk> I cannot access it at all like this
18:26:10 <ALUVial> the latest email is current.  Please send edits via email and Jeff, me, Ian or Marco can add them.
18:26:36 <ALUVial> or if we have an etherpad we could edit collaboratively and periodically upload the changes
18:26:37 <Jeffreyc42> I don't see a link without the manage part
18:26:51 <bh526r> I think it is the system limitation. Once it is finalized and open for vote, everyone can see it
18:27:04 <georgk> ok, well
18:27:42 <bh526r> The technical one is https://www.openstack.org/summit/barcelona-2016/call-for-presentations/manage/15092/summary
18:28:13 <bh526r> It was drafted by me, and edited by Nikolas, Tom and commented by Ian
18:28:48 <bh526r> Let me share with you via email too because non-presenter cannot see it
18:29:04 <kamal__> thanks bh526r
18:29:05 <georgk> yes, please
18:29:21 <bh526r> after this meeting (I am off VPN now, and cannot send/receive email)
18:30:30 <bh526r> any other things on this topic?
18:30:33 <Jeffreyc42> Here is an ether for the panel
18:30:34 <Jeffreyc42> https://etherpad.opnfv.org/p/Gluon_OpenStack_Panel
18:31:55 <bh526r> cool, let me post it there too to save everyone's time
18:32:04 <Jeffreyc42> ok
18:32:29 <ALUVial> great jeff.  I was doing that simultaneously.  you type faster
18:32:43 <Jeffreyc42> :)
18:34:05 <ALUVial> Can everyone review both submissions and +1 by email later
18:34:21 <Jeffreyc42> yes
18:34:28 <georgk> yes, will do that
18:35:59 <bh526r> OK, just posted to Etherpad
18:36:53 <bh526r> Please review, and email any changes needed, or +1
18:37:15 <bh526r> ok, anything else on this topic?
18:37:56 <bh526r> move to next item
18:38:02 <bh526r> #topic Discussion of Repository Structure
18:38:36 <bh526r> We have old repo in github
18:38:55 <bh526r> when we move to new repo, some optimization/restructure is needed
18:39:10 <bh526r> Ian had some idea, and Tom had some suggestions
18:39:37 <bh526r> Because Ian is absent now, Tom, can you share your proposal?
18:39:57 <tomhamb> I think we need to talk about process.  I am new to the Openstack tools.
18:40:22 <tomhamb> I started documenting a proposal for the repo structure.
18:40:32 <bh526r> Great
18:40:49 <tomhamb> I think the correct approach is to create a blueprint and put it in the gluon-specs repo
18:41:02 <tomhamb> Then people can review it and provide feedback.
18:41:26 <tomhamb> We currently do not have a gluon-specs repo.
18:41:52 <tomhamb> Also, how are we going to track tasks within this project? Launchpad or Storyboard?
18:42:02 <bh526r> I think blueprint is hosted in Launchpad
18:42:37 <bh526r> I think other projects use Launchpad to track the tasks
18:43:08 <pcarver> I haven't used Storyboard, Launchpad does use the term blueprint and that is used by many projects.
18:43:21 <bh526r> So you can create BP in Launchpad for your proposal of repo structure, and everyone can review it, comment it, and eventually approve it
18:43:49 <Rockyg> task traacking is hard in Launchpad.
18:44:05 <Rockyg> Try storyboard.  Or look at trello.com
18:44:12 <tomhamb> I think we should have an audio conference to discuss how to get started.  Some projects have a -specs repository for such documents
18:44:19 <pcarver> blueprints are mostly intended to track what items fall into which release and/or milestone
18:44:46 <pcarver> blueprints aren't great as the primary container for detailed documentation
18:45:33 <pcarver> A use that's common in Neutron is for the blueprint to be basically a list of URLs to reviews on Gerrit for both specs and code
18:45:50 <bh526r> There are several types of documents
18:46:15 <bh526r> In our repo, there is a /docs directory that is intended for documentation
18:47:05 <bh526r> http://git.openstack.org/cgit/openstack/gluon/tree/
18:47:58 <bh526r> So if we meant the documentation of how to restrcutrue repo, it should be  relatively simple, and BP in Launchpad may be good enough
18:48:18 <tomhamb> Okay, I will put the document there (in the /docs directory)
18:48:26 <pcarver> perhaps rather than "restructure" we should think of it specifically as "structure"
18:48:37 <pcarver> Then it would be appropriate as a devref
18:48:50 <bh526r> If we meant other documentation (like install guide, user guide, etc.), it should go to doc
18:49:38 <bh526r> After we become offocial OpenStack project, documentation should be put central doc repo of OpenStack
18:49:44 <georgk> the repo structure can be considered part of a "developer guide" and hence be part of the docs
18:49:55 <pcarver> devref is normally in the projects own repo
18:50:27 <bh526r> So looks like "doc" directory is the place to put all documentation
18:50:40 <pcarver> e.g. in the Neutron repo there is doc/source/devref and doc/source/policies
18:50:55 <bh526r> Good reference, thank you Paul
18:51:00 <tomhamb> Okay, that makes sense
18:51:02 <pcarver> There are Jenkins jobs available to publish the docs from the project's own repo
18:51:44 <pcarver> for official projects the devref docs end up here http://docs.openstack.org/developer/openstack-projects.html
18:52:24 <bh526r> In this case, repo structure (Paul's term :) documentation should be part of doc/source/devref
18:52:53 <tomhamb> I will document it there
18:52:57 <pcarver> yes, instead of thinking of it as a one time thing, think of it as a guide for ongoing use by developers
18:53:24 <bh526r> That's right
18:54:36 <bh526r> BTW, there are exemplary .rst under doc/source already
18:55:30 <bh526r> we need to create devref etc. type of sub directory there, and put Tom's proposal of repo structure there
18:55:52 <tomhamb> I will do that and put it out for review
18:56:11 <bh526r> Great Tom, and let me document this action
18:57:06 <bh526r> #action Tom draft repo structure document as part of devref (developer guide) documentation under doc/resource/devref
18:57:50 <bh526r> Looks like we only have 3 minutes left.
18:58:27 <Jeffreyc42> What about the other doc we sent out last week for review?
18:58:34 <bh526r> So we can think about schedule, roadmap, next steps etc, discuss via email and next meeting
18:58:49 <bh526r> More important is whether or not we can have a release for Newton
18:58:49 <Jeffreyc42> The Description doc.
18:58:54 <Jeffreyc42> ok
18:59:22 <bh526r> The architecture and description?
18:59:41 <Jeffreyc42> we can discuss via email
18:59:51 <bh526r> Paul, usually what is the sub directory for architecture description doc?
19:00:20 <georgk> or we can just go ahead and push a proposal to the repo for review
19:00:23 <pcarver> I think that can be part of the devref if it's intended to describe the architecture to developers
19:00:33 <Jeffreyc42> yes
19:00:34 <Jeffreyc42> ok
19:00:53 <pcarver> user facing documentation of the architecture would be separate from docs intended for people writing Gluon itself
19:00:54 <bh526r> OK, good, so part of devref
19:01:35 <bh526r> Since Jeff already sent the doc out, please comment if possible.
19:01:45 <Jeffreyc42> I will
19:01:47 <Jeffreyc42> thanks
19:02:01 <bh526r> Great
19:02:06 <bh526r> any other business?
19:02:45 <bh526r> If no, thank you for the great discussion and talk to you via email and next Wednesday
19:03:01 <Jeffreyc42> sounds great!  Thanks Bin!
19:03:15 <tomhamb> Thanks Bin
19:03:22 <bh526r> Thank you everyone
19:03:25 <krenczewski> Great, thanks.
19:03:39 <bh526r> Meeting adjourned
19:03:47 <bh526r> #endmeeting