14:05:55 <nikhil_k> #startmeeting Glance Drivers
14:05:55 <openstack> Meeting started Tue Jul  7 14:05:55 2015 UTC and is due to finish in 60 minutes.  The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:06:00 <openstack> The meeting name has been set to 'glance_drivers'
14:06:07 <nikhil_k> Courtesy Glance Drivers' meeting reminder: nikhil_k, flaper87, sigmavirus24, rosmaita
14:06:08 <sigmavirus24> o/
14:06:12 <flaper87> o/
14:06:27 <nikhil_k> #topic Drivers definition
14:06:37 <nikhil_k> 1. Who is a Glance Driver?
14:06:57 <nikhil_k> #action nikhil_k to reply to flaper87's email
14:07:10 <flaper87> (side note: Do we have a place where we keep the agenda?)
14:07:29 <nikhil_k> oops
14:07:32 <nikhil_k> #link https://etherpad.openstack.org/p/glance-drivers-meeting-agenda
14:07:35 <nikhil_k> that's the agenda
14:07:39 <flaper87> ah, I knew there was one
14:07:40 <flaper87> thank you
14:07:46 <nikhil_k> #link http://eavesdrop.openstack.org/#Glance_Drivers_Meeting
14:07:53 <nikhil_k> that's the official page
14:08:07 <flaper87> yeah
14:08:19 <flaper87> I just called for help on the #lazyweb
14:08:25 <nikhil_k> :)
14:08:30 <sigmavirus24> So I think
14:10:03 * flaper87 holds his breath until sigmavirus24 explains what he thinks
14:10:09 <nikhil_k> #link http://eavesdrop.openstack.org/meetings/glance_drivers_/2015/glance_drivers_.2015-06-23-14.08.log.html
14:10:19 <nikhil_k> line: 14:20:44 <nikhil_k> #topic How to get involved?
14:10:34 <nikhil_k> We can also use that as context for further discussion
14:11:24 <nikhil_k> flaper87: btw, aren't you sup to be on vacay
14:11:26 <nikhil_k> ?
14:11:40 * nikhil_k thinks may be sigmavirus24 got disconnected
14:11:41 <flaper87> nikhil_k: I'm going on vacay in 1 day
14:11:46 * flaper87 is counting the days
14:11:53 <flaper87> :D
14:11:57 <nikhil_k> flaper87: ncie, have fun! where to?
14:12:12 <flaper87> Spain :)
14:12:15 <nikhil_k> ironically it could be "nice" :P
14:12:17 <nikhil_k> close
14:12:25 <flaper87> :P
14:12:25 <sigmavirus24> sorry yea
14:12:27 <nikhil_k> that's amazing
14:12:28 <sigmavirus24> ignore me
14:12:38 <nikhil_k> flaper87: you go now
14:12:39 <sigmavirus24> had to take out the trash last minute
14:12:44 <nikhil_k> :P
14:13:13 <flaper87> anyway, the drivers team oversees the whole project in terms of bugs, features and other areas
14:13:22 <sigmavirus24> tl;dr I'd like more community involvement in the specs process. I think we need to add Stuart at the first chance we get. We may also want to flush old drivers who aren't doing anything
14:13:23 <flaper87> I don't think the drivers team should stick just to specs
14:13:32 <sigmavirus24> == flaper87
14:13:43 <flaper87> That said, I think people in the drivers team should have knowledge of our code base
14:13:52 <flaper87> just reading specs isn't enough
14:14:10 <flaper87> I was going to send another email proposing to remove old drivers
14:14:18 <flaper87> but I first wanted to end the discussion I started
14:15:02 <sigmavirus24> Okay
14:15:23 <flaper87> (the m-l one, I mean)
14:15:25 <nikhil_k> So, I browsed quickly through the email
14:16:00 <nikhil_k> and prolly we won't have time to continue while flaper87 is on vacay. but we can take a firm decision next week's meeting. that said..
14:16:15 <nikhil_k> 1. The glance-drivers team is too smal
14:16:28 <nikhil_k> tbh, I don't agree or completely agree
14:16:34 <nikhil_k> we are a small project
14:16:35 <flaper87> yeah, I'll read emails anyway so, if we keep the discussion there (which I prefer for this specific one), I think it'd be better
14:16:53 <flaper87> that said, pls keep going
14:16:54 <nikhil_k> and people should be picky on proposing new features
14:17:28 <nikhil_k> I think we don't have enough cores , let alone specs
14:17:36 <nikhil_k> basically, we have the same problem Nova has
14:17:41 <nikhil_k> too low review bandwidth
14:17:51 <nikhil_k> for example this cycle
14:18:21 <nikhil_k> we had planned for stability and nova's port to v2 (glance team help support that cause) to start planning v1 deprecation
14:18:40 <nikhil_k> I think stability part has gone well, except for a few major bumps
14:19:09 <jokke_> ref that I just realized that we haven't been backporting anything to glance_store stable/kilo
14:19:12 <nikhil_k> Given that our priority, and we had communicated it well in the summit and prior
14:19:13 <flaper87> just to be clear, I'm not suggesting to not be careful with what features we add. The suggestion is that we should be pragmatic and move some of these "pickiness" to the code review rather than the spec review
14:19:17 <jokke_> pushing backports out as we speak
14:19:50 <nikhil_k> So, I think the first thing we need to do is communicate what we prioritize to review
14:20:06 <nikhil_k> may be start a priorities page?
14:20:31 <nikhil_k> once we have a plan, then we can think about the specs and how many people are needed to support both specs and code review
14:20:47 <nikhil_k> But I agree that drivers need to be familiar with the code
14:21:06 <nikhil_k> however, feel that Drivers should be subset of core reviewers
14:21:12 <flaper87> I think that'd be a good thing to have for M. Unfortunately, for Liberty, we don't have time left
14:21:18 <flaper87> we're half-way through L-2
14:21:20 <sigmavirus24> nikhil_k: we've tried categorizing priorities in the past with Trello but I'm not sure it's ever worked very well
14:21:27 <nikhil_k> yeah
14:21:35 <flaper87> if we keep stopping on "planning" stuff, we won't get anywhere
14:21:39 <flaper87> IMHO
14:21:39 <sigmavirus24> jokke_: have we had many backport-worthy bug fixes in glance_store? Most of the stuff for glance_store I've seen was py3 compat
14:21:42 <flaper87> as in, writing workflows
14:21:48 <nikhil_k> flaper87: that's my fear. we dont' have enough diversity dedicated reviewers
14:21:49 <flaper87> not saying we should approve all the things
14:22:20 <sigmavirus24> If a workflow grew organically, that'd be great, but the tools we use don't exactly lend themselves to that (gerrit+launchpad(+etherpad kind of))
14:22:35 <flaper87> we don't even have specs approved that would generate code to review :)
14:22:37 <sigmavirus24> Yeah
14:22:47 <sigmavirus24> Although we have the artifacts spec and have been merging that code
14:22:49 <nikhil_k> +1 on Stuart as Driver (if he still wants and has time to)
14:23:04 <jokke_> sigmavirus24: quite a few good ones
14:23:29 <sigmavirus24> jokke_: for glance_store? Yeah, I must be missing them then =(
14:23:58 <sigmavirus24> But yeah, I think we need to encourage people to involve themselves in specs + code, not just code
14:24:06 <nikhil_k> flaper87: I think we need to communicate that well too. Our practice has been to eveolve code and specs together so that things are coherent and stale stuff doesn't exist in specs. plus historic discussions are/can be documented
14:24:10 <sigmavirus24> I only became involved in specs because I was reviewing code and trying to understand the reasoning etc
14:24:28 <jokke_> nikhil_k: and that has been proven really bad approach ;)
14:24:34 <flaper87> nikhil_k: yeah, that practice is one of the things I was arguing against
14:24:38 <flaper87> Updating specs is fine
14:24:51 <flaper87> pretending that specs will be perfect is just fooling ourselves
14:24:55 <nikhil_k> what is the alternate practice and how do we ensure that specs are up to date?
14:24:56 <sigmavirus24> I can't remember if we merged specs before k-3 last cycle. I'd really like that to not happen again
14:25:07 <flaper87> Lets get those specs to a good enough state, let people work on code and then update the spec
14:25:18 <sigmavirus24> nikhil_k: moving specs to an approved directory and ensuring they're updated when they're moved to completed?
14:25:23 <jokke_> sigmavirus24: we're pretty much on that state again
14:25:26 <nikhil_k> yeah, but it's also a check on getting things to be wrong
14:25:28 <sigmavirus24> Alternatively, let's talk to Neutron about how they do it
14:25:33 <jokke_> L-2 is not that far away
14:25:38 <sigmavirus24> Or was it swift
14:25:57 <sigmavirus24> I forget which was talking about merging specs and then updating them to be correct as dev work matured
14:26:03 <nikhil_k> jokke_: I don't think we promised to deliver many specs this cycle
14:26:16 <flaper87> My suggestion in that email was to have specs in the "backlog" dir (or approved, whatever) and only when they've been implemented we'd move them into the release dir
14:26:16 <flaper87> sigmavirus24: it was swift (if you're referring to the backlog thing)
14:26:19 <jokke_> sigmavirus24: nova is apparently doing that now
14:26:21 <nikhil_k> we need to be selective
14:26:39 <jokke_> yeah swift has been on that approach for quite a while
14:26:46 <nikhil_k> flaper87: ok, let's try that
14:27:01 <nikhil_k> and see if it works or creates more work :-)
14:27:06 <sigmavirus24> flaper87: yeah swift. My memory of the summit is becoming worse by the day
14:27:17 <flaper87> nikhil_k: I'll update the specs that've gotten reviews and move those specs to backlog
14:27:24 * flaper87 ME, ACTIOOOOOON ME!
14:27:30 <nikhil_k> btw, nova needs a new spec each cycle
14:27:46 <nikhil_k> an approved spec doesn't meant it can be merged in that cycle
14:27:51 <nikhil_k> I think we don't follow that
14:27:56 <sigmavirus24> I don't know if we want that to be honest.
14:28:07 <nikhil_k> we then will need to monitor which ones to carry forward
14:28:24 <nikhil_k> another headache in keeping folks co-ordinated about priorities
14:28:26 <jokke_> I have one question for ye guys so would you all mind to pop down to # -glance after we run out of time? ;)
14:28:59 <flaper87> I guess that's the benefit of the backlog dir
14:29:05 <flaper87> it's release-free
14:29:10 <nikhil_k> #action nikhil_k : to determine which specs can be approved for liberty
14:29:13 <jokke_> nikhil_k: well to start with, you really can't ... unfortunately your priorities != others priorities always and people's priorities changed
14:29:16 <flaper87> we'll have to follow up on those
14:29:23 <jokke_> changes
14:29:39 <jokke_> it would be great if we were just one company with clear streamlined target ;)
14:29:56 <nikhil_k> we are one community :-)
14:30:09 <nikhil_k> anyways, let's roll over to prj channel
14:30:11 <flaper87> ... to rule them all
14:30:14 <nikhil_k> #endmeeting