14:00:19 <nikhil_k_> #startmeeting glance_artifacts_sub_team
14:00:21 <openstack> Meeting started Mon Nov 16 14:00:19 2015 UTC and is due to finish in 60 minutes.  The chair is nikhil_k_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:24 <openstack> The meeting name has been set to 'glance_artifacts_sub_team'
14:00:49 <nikhil_k_> mfedosin: dshakhray ativelkov: anyone around?
14:01:56 <mfedosin> o/
14:02:09 <kairat> o/
14:02:11 <nikhil_k_> hey
14:02:42 <nikhil_k_> glad to have you guys here
14:02:45 <mfedosin> Alex is busy, so I briefly describe the current status
14:03:08 <nikhil_k_> ok
14:03:14 <mfedosin> we discussed the implementation of Glare with Alex today
14:03:22 <nikhil_k_> #topic updates from mfedosin
14:03:36 <mfedosin> we're not going to remove the existing code from repo
14:04:15 <mfedosin> and the only one change is to create an additional endpoint for a new standalone server
14:04:35 <mfedosin> so, I have to write a spec for this change
14:04:47 <nikhil__> sounds good
14:05:06 <mfedosin> after that I assigned a task for Alex to write a spec about Glare architecture
14:05:16 <nikhil__> so I guess this will be a public api?
14:05:40 <mfedosin> it will discribe data model, api, plugins and all other things
14:05:48 <mfedosin> yes, api will be public
14:06:24 <mfedosin> but it's better to ask Alex, because I'm not privy to the details
14:08:30 <nikhil__> I had a thought if the endpoint addition needs to be collaborated with the standardization of service catalog effort
14:08:44 <nikhil__> not sure if it's relevant at this point
14:09:17 <Jokke_> at least we need to reserve the port for it
14:09:28 <Jokke_> I think 9393 looked clear
14:09:29 <mfedosin> what kind of standardization?
14:09:39 <mfedosin> ah, yes - port
14:09:51 <mfedosin> we used 9393 before :)
14:10:18 <mfedosin> 666 is taken by Doom :(
14:10:55 <nikhil__> #link https://www.mail-archive.com/openstack-dev@lists.openstack.org/msg65420.html
14:11:00 <nikhil__> that's one of the threads
14:11:38 <nikhil__> thanks for the updates mfedosin!
14:11:50 <mfedosin> welcome :)
14:11:56 <nikhil__> We were discussing some stuff about the summit etherpad last mtg
14:12:11 <nikhil__> I was hoping we continue the same
14:12:21 <mfedosin> if there are some question I'm glad to answer
14:12:21 <nikhil__> #topic review summit discussion
14:12:28 <nikhil__> #link https://etherpad.openstack.org/p/mitaka-glance-artifacts-review
14:12:36 <nikhil__> eh, something happened to the bot
14:13:55 <nikhil__> We had stopped at the point where we agreed to seek potential solutions from twisted, webob for the next phase of impl
14:13:55 <mfedosin> I don't know how Glare implementation will look like :)
14:14:16 <mfedosin> I wish Alex to write a spec about that
14:14:25 <mfedosin> about twisted, webob...
14:14:38 <mfedosin> wait a sec, I'm going to ask him
14:14:43 <nikhil__> Can we post some open questions here so that people can refer and maybe we start conversation elsewhere
14:14:50 <mfedosin> he is just behind me
14:15:56 <mfedosin> Alex: "We don't want to change too much"
14:16:32 <mfedosin> "If it's required in the future, we can add support of twisted or anything else"
14:16:36 <nikhil_k> yeah, we need to have these conversations on irc or ML somewhere public at least so that we can clarify all the doubts and plans
14:17:29 <nikhil_k> I will add an action item for seeking a better time and schedule where we can have Alex present
14:18:09 <mfedosin> It will be a long and hot conversation in spec commit on review.openstack.org :)
14:18:20 <nikhil_k> #action nikhil: send email to ML for a better proposal for a mtg time
14:18:23 <mfedosin> Alex's here
14:18:31 <mfedosin> but he's very busy
14:18:47 <mfedosin> I can ask him to join us right now if you want
14:19:04 <nikhil_k> sure, but it would be useful to have mtg with him rather than double our communication efforts
14:19:26 <nikhil_k> no, that's fine. let's give him his space
14:19:39 <nikhil_k> we just need wider collaborations in the mtg
14:20:20 <nikhil_k> #topic review client for glare code
14:20:21 <mfedosin> next week he will be here :)
14:20:52 <nikhil_k> np, I think it might be useful to move this mtg to tuesday or thursday (before glance)
14:21:26 <nikhil_k> we can save update time on thursdays as well
14:21:33 <Jokke_> is the half slot still free after the drivers meeting?
14:21:42 <nikhil_k> I think so, yes
14:21:44 <mfedosin> no, it's not possible
14:21:50 <nikhil_k> oh
14:22:02 <mfedosin> because we have inner meetings at that time
14:22:03 <Jokke_> would that suite everyone? That way we wouldn't break too many slots with our half an hour meetings
14:22:17 <nikhil_k> yeah, let's plan the schedule outside of this mtg on the review that I will propose today-ish
14:22:31 <mfedosin> I like this time :)
14:22:42 <nikhil_k> :)
14:23:31 <nikhil_k> can we discuss a bit about the client?
14:23:37 <mfedosin> yep
14:23:48 <nikhil_k> since we have a new release pattern, it would be best to start efforts on this early
14:24:19 <nikhil_k> Do people overall agree  that having the code in glanceclient is useful?
14:24:43 <mfedosin> I think it's better to have a separate client
14:24:53 <nikhil_k> since the code base is in the same repo and similar operators would be running it, it makes sense to keep things integrated
14:24:55 <mfedosin> but it was decided to leave in glanceclient
14:25:16 <nikhil_k> yeah, for simplicity sake (for the most part) is what I got
14:25:48 <nikhil_k> managing two clients besides the already complicated store lib would be adding more work
14:25:50 <mfedosin> it's much simpler, I agree
14:25:57 <nikhil_k> but if there are opinions other way..
14:26:35 <mfedosin> but logically GLANCEclient will be used to communicate with GLARE...
14:27:29 <nikhil_k> yeah
14:27:31 <mfedosin> whatever... I'm okay with glanceclient :) In the future we can separate them
14:27:37 <nikhil_k> and should we avoid having the CLI completely and make osc CLI a standard from the start
14:27:53 <nikhil_k> ?
14:28:05 <mfedosin> It was decided to implement CLI in openstackclient
14:28:30 <nikhil_k> right
14:28:39 <nikhil_k> and was it decided to avoid it in glanceclient?
14:29:04 <mfedosin> yes
14:29:10 <nikhil_k> ok, great!
14:29:16 <mfedosin> no CLI for Glare in glanceclient
14:29:47 <mfedosin> we have no time for open discussion :(
14:30:01 <nikhil_k> oh
14:30:14 <nikhil_k> we can continue on -glance if you want
14:30:22 <mfedosin> okay :)
14:30:31 <nikhil_k> Thanks and thanks all for joining!
14:30:34 <mfedosin> thanks
14:30:37 <nikhil_k> #endmeeting
15:50:38 <nikhil_k> #endmeeting