14:02:11 <nikhil_k> #startmeeting Glance Artifacts sub-team
14:02:12 <openstack> Meeting started Mon Jul 13 14:02:11 2015 UTC and is due to finish in 60 minutes.  The chair is nikhil_k. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:16 <openstack> The meeting name has been set to 'glance_artifacts_sub_team'
14:02:38 <nikhil_k> We have a no items in the agenda today.
14:03:06 <nikhil_k> Do we want to discuss anything important?
14:03:07 <ativelkov> yup, as we are in the middle of something, not much to discuss, just a quick summary
14:03:09 <mfedosin> sorry, my bad. spent all week on bugs in glance_store
14:04:11 <ativelkov> I've (almost) completed a large series of patches to oslo.versioned_objects which puts the needed functionality from artifacts' "declarative framework" there
14:04:13 <nikhil_k> #topic Summary ( ativelkov )
14:04:17 <sigmavirus24_awa> o/
14:04:52 <ativelkov> #info series of patches to oslo.versioned_objects awaiting the reviews
14:05:04 <ativelkov> #link https://review.openstack.org/#/c/197688/
14:05:09 <ativelkov> #link https://review.openstack.org/#/c/196041/
14:05:21 <mfedosin> Erno suggested new experimental branch in glanceclient... It would be awesome if he created it
14:05:22 <ativelkov> #link https://review.openstack.org/#/c/196819/
14:06:18 <ativelkov> These patches mostly await reviews from the oslo team, but if someone else looked at them at some moment, it would be great
14:06:36 <nikhil_k> mfedosin: Please send a email to ML with tag [all] if you wish to take that route. If Erno wants to we can put a action item on him
14:07:15 <nikhil_k> #action reviews for all. links suggested by ativelkov ^
14:07:40 <ativelkov> Also, I've made a patch which makes use of oslo.versioned_object in Glance to declare artifacts types
14:07:42 <ativelkov> #link https://review.openstack.org/#/c/198798/
14:07:59 <ativelkov> This one should replace "declarative framework" eventually
14:08:10 <mfedosin> nikhil_k, okay, I will
14:09:01 <mfedosin> ativelkov, do we need to create new artifact type example on oslo.vo?
14:09:03 <ativelkov> It needs more work ([de]serialization, plugin loader etc), but I'd like to get some reviews on the initial concept. Special attention for flaper87 's opinion
14:09:28 <ativelkov> mfedosin: I'll create "image" as an example, this should be fine
14:10:11 <ativelkov> #action ativelkov to create "image" artifact type based on oslo.vo as an example
14:10:12 <mfedosin> I would like to see something with blob list as example :)
14:10:56 <ativelkov> Also, we've started the work on performance testing of V3 with Rally
14:11:10 <mfedosin> Boris insisted
14:11:37 <ativelkov> We want to make sure that V3 does not decrease the performance of Glance compared to V1/V2
14:12:08 <nikhil_k> ++
14:12:08 <ativelkov> boris42 (Rally's PTL) is helping us with that
14:12:12 <sigmavirus24_awa> Silly question: Wouldn't that make more sense once we start re-implementing the images API on top of Artifacts?
14:12:24 <sigmavirus24_awa> Like, let's make it work first, then make it fast when we need to?
14:12:40 <sigmavirus24_awa> (Doesn't seem Boris is around here)
14:12:56 <nikhil_k> I guess we have to luxury to change the API atm
14:13:07 <mfedosin> I think Boris is sleeping
14:13:12 <ativelkov> sigmavirus24_awa: well, there are some early concerns about potential performance issues related to the concept of dependency relations (and especially transitive dependencies)
14:13:14 <nikhil_k> but yeah we can focus more on this when things are being wrapped
14:13:15 <sigmavirus24_awa> mfedosin: I'm jealous
14:13:59 <nikhil_k> Can we ask Boris to join us next week?
14:14:08 <ativelkov> sure
14:14:26 * sigmavirus24 just wants artifacts done before we start optimizing it
14:14:27 <mfedosin> It will be 7am in California
14:14:30 <nikhil_k> thanks, I will add that in the agenda then
14:14:30 <sigmavirus24> keyword: done
14:14:37 <ativelkov> he is US timezone now (west coast), but I'll try to ping him about that
14:14:57 <sigmavirus24> wait, you mean people don't start working at 0600 local time?
14:15:07 <sigmavirus24> I've been lied to.
14:15:10 <sigmavirus24> ;)
14:15:12 <nikhil_k> :)
14:15:26 <nikhil_k> or work till 0400 :)
14:15:38 <ativelkov> I've begun working on the "Open API issues to be addressed" document
14:15:41 <mfedosin> usually I go to bed at this time.
14:15:48 <ativelkov> But that's still in progress
14:16:03 <ativelkov> mfedosin and me will finalize it till the API WG meeting this week
14:16:10 <mfedosin> ativelkov, share it with me, please
14:16:18 <nikhil_k> ativelkov: umm, anyway you can share a google doc /etherpad with us?
14:17:10 <sigmavirus24> ++
14:17:12 <ativelkov> nikhil_k: will share as soon as I translate it ) Draft is a bit... ehmm.. untranslatable
14:17:22 <sigmavirus24> ativelkov: lots of cursing in it?
14:17:22 <nikhil_k> heh, ok :)
14:17:23 <sigmavirus24> =P
14:18:16 <ativelkov> sigmavirus24: lots of Russian and bullet-points like " - that shit about the drafts (explain later)"
14:18:23 <sigmavirus24> :D
14:18:29 <nikhil_k> ha
14:18:58 <nikhil_k> if we are done here..
14:18:59 <mfedosin> a little bit of offtop: I've translated the next part of documentation (got rid of cursing in it), now Lena's preparing it for gerrit review
14:19:05 <ativelkov> so, proably today or early tomorrow
14:19:12 <nikhil_k> :)
14:19:19 <nikhil_k> I guess one thing I wanted to discuss was anything remnant
14:19:33 <nikhil_k> like bugs and feature parity planning
14:19:42 <mfedosin> ativelkov, I will help, I'm not busy today
14:19:50 <nikhil_k> can we do that real quick if folks are up for it?
14:20:09 <ativelkov> yup
14:20:11 <nikhil_k> #topic bugs, remnant features
14:20:53 <nikhil_k> So that we communicate well and let people expect only certain features in liberty, it would be nice to put a expected timeline on them
14:21:11 <nikhil_k> even if that's "in next 5 years"
14:21:40 <nikhil_k> Are there any bugs that folks know of and need to be fixed asap?
14:21:42 <sigmavirus24> lol
14:22:04 <sigmavirus24> "in the next 5 years ... we expect nova to still be using glance v1" =P
14:22:34 <nikhil_k> And certain features for v2 api like sharing and tasks?
14:22:38 <nikhil_k> sigmavirus24: :)
14:22:49 <ativelkov> It's hard to plan that far
14:23:04 <mfedosin> It's easier to rewrite Nova, I think
14:23:05 <ativelkov> but in shorter range we need dynamic dependency relations and import/export
14:23:05 <sigmavirus24> I'd like to request a feature: I'd like to share images to twitter and facebook. kthnxbai
14:23:16 <ativelkov> That's what comes first
14:24:23 <nikhil_k> We need a single well defined API that needs to be used by all projects and users
14:25:01 <nikhil_k> DefCore wants that and we need v2 to be that
14:25:23 <nikhil_k> given v3 would be a wrapper on top of v2, we would need these api support
14:25:24 <sigmavirus24> nikhil_k: "we need v2 to be that... for the next 5 years"?
14:25:39 <nikhil_k> for next 15/20 years :)
14:26:01 <sigmavirus24> :D
14:26:02 <ativelkov> nikhil_k: how can v3 be a wrapper around v2? I am probably missing something
14:26:05 <nikhil_k> but if v3 mimicks v2 we can afford the support
14:26:49 <nikhil_k> ativelkov: how can that be possible is a great question :)
14:27:00 <nikhil_k> ativelkov: but the push for it is strong
14:27:01 <sigmavirus24> ativelkov: I think nikhil_k got that a little backwards? v2 wrapping v3, right?
14:27:29 <nikhil_k> no, v3 wrapping v2 and v1
14:27:42 <mfedosin> v3 is going to be an adapter to v2
14:28:00 <nikhil_k> we can move away from v2 by communicating that upgrade to v3 would _only_ be a version change in the url string
14:28:36 <nikhil_k> I need to confirm more on the requirements
14:29:06 <nikhil_k> but that would mean something with the endpoint being different for each artifact
14:29:41 <nikhil_k> we all seem divided on this and I assumed so will be the rest of the openstack
14:30:07 <nikhil_k> good topic for CPL meeting once we have a draft ready for the outstanding questions
14:30:10 <mfedosin> btw, folks, about the client - we have a bug with exports there - it's the reason why tests don't pass. can you review my fix https://review.openstack.org/#/c/199061/ ? thanks
14:30:47 <nikhil_k> we are out of time
14:30:52 <nikhil_k> Thanks all for joining!
14:30:54 <mfedosin> thanks all :)
14:30:59 <nikhil_k> #endmeeting