14:00:14 <abhishekk> #startmeeting glance
14:00:15 <openstack> Meeting started Thu May  6 14:00:14 2021 UTC and is due to finish in 60 minutes.  The chair is abhishekk. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:19 <openstack> The meeting name has been set to 'glance'
14:00:21 <abhishekk> #topic roll call
14:00:28 <abhishekk> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:30 <abhishekk> o/
14:00:59 <rosmaita> o/
14:01:13 <jokke> o/
14:01:16 <abhishekk> lets wait couple of minutes for others
14:02:05 <abhishekk> I guess we have majority now, dansmith and sean can join us any time now
14:02:08 <abhishekk> lets start
14:02:10 <rosmaita> ok
14:02:14 <dansmith> sorry was waiting in the wrong channel
14:02:26 <abhishekk> no worries
14:02:30 <abhishekk> #topic Updates
14:03:04 <abhishekk> I have sent the Xena PTG summary on openstack-discuss ML and same is available on the blog as well
14:03:16 <abhishekk> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-May/022240.html
14:03:47 <abhishekk> I was late this time
14:04:16 <abhishekk> Summary includes recap of what we discussed during PTG and the links to recordings as well
14:04:23 <abhishekk> Lets move to next topic
14:04:31 <abhishekk> #topic release/periodic jobs update
14:04:40 <abhishekk> Milestone 1 is 3 weeks away
14:05:06 <abhishekk> jokke, I guess by next week we should start working on Cache-APi as we decided during the PTG
14:05:38 <abhishekk> periodic jobs all green so far
14:05:39 * Steap thinks he has an old spec Cache API under review
14:05:52 <rosmaita> also, you pinged me yesterday about looking at something (which i did not do yet) ... do you remember what you wanted me to look at?
14:06:06 <jokke> abhishekk: yeah, lets get it done. I'll try to spend few days looking through rajivmucheli's swift bugs, but I'm on it after
14:06:08 <abhishekk> it was about the quota specs
14:06:23 <abhishekk> jokke, cool, thank you
14:06:36 <abhishekk> rosmaita, dansmith just pushed up the new revision
14:06:36 <dansmith> rosmaita: https://review.opendev.org/c/openstack/glance-specs/+/788037
14:06:42 <rosmaita> thanks
14:06:53 <abhishekk> Lets move forward
14:07:02 <abhishekk> #topic Multi-format images
14:07:13 <abhishekk> dansmith, was not present during this discussion
14:07:36 <abhishekk> to go ahead with it we need to understand the nova side regression if we decided to implement the same
14:08:23 <abhishekk> dansmith, if possible please let me know your convenient time before or after M1 release so that we can discuss this
14:08:45 <dansmith> I have done no thinking about this since the last time we talked, FWIW
14:08:51 <jokke> yeah, so dansmith my biggest concern here is is it even possible to get Nova consuming "same" image in mltiple formats. Say in one AZ you have ceph in use and the image is in raw an you want to migrate the instance to another where it would be in qcow. Is that ever even doable?
14:09:08 <dansmith> but throw me something that fits on my calendar and I'm sure it'll be fine
14:09:37 <dansmith> jokke: generally no migration across AZs unless you're an admin and can force it to break the rules
14:09:57 <abhishekk> ack, we will decide this offline and let you know
14:10:25 <jokke> Based on the PTG discussions Cinder is not a problem asthey don't use image as base anywhere and migrte just delta, but not sure how Nova handles for example migrtions and snapshots on that regard
14:10:36 <abhishekk> #action abhishekk, jokke to decide date for multi-format discussion
14:10:45 <dansmith> jokke: and definitely no *live* migration from one ceph-having compute to a non-ceph one.. cold migration maybe, but that's going to be a snap/reupload and not a rebase I think
14:11:20 <jokke> dansmith: so at that point the snap would be flattened and no delta moved around there either?
14:12:00 <dansmith> a snapshot in ceph will be a CoW, but I think if we're moving from one mechanism to the other (in the cases where that even works) we would flatten and upload to whatever that backend is,
14:12:08 <dansmith> but tbh, I don't know if that even works
14:12:33 <dansmith> there's also shelve/unshelve which does an *actual* snapshot in glance and re-download which is very sanitizing
14:12:52 <abhishekk> jokke, could you please write down these points somewhere, so that we can investigate those
14:12:53 <dansmith> but yeah, I'd have to research all the horrific nova code around this to even answer questions
14:13:14 <jokke> yeah, I don't think currently at least but I was more concerned about general assumptionsin nova side and if it's even viable to lok at. Sounds like there's no hard requirements anyways in that regard.
14:14:17 <abhishekk> I guess as decided we should have a separate discussion over this sometime around M1 release
14:14:51 <abhishekk> dansmith, I will let you know 2-3 slots from which we could finalize the one
14:15:00 <dansmith> okay
14:15:02 <abhishekk> moving ahead
14:15:17 <abhishekk> #topic Quotas in glance
14:15:25 <jokke> mhm ... I think it makes sense to convene again and lay down the basic concept how we would parent-child track those images and see what usecases they would initially solve and any immediate red fags
14:15:43 <abhishekk> #link https://review.opendev.org/c/openstack/glance-specs/+/788037
14:15:53 <abhishekk> jokke, ++
14:16:23 <abhishekk> So as promised in PTG dansmith has put a design/spec for implementing quota in glance
14:16:42 <abhishekk> the plus side of this is we can turn it off if we don't want to use it
14:17:01 <abhishekk> also there are no database related changes as we are using keystone limits for the same
14:17:03 <dansmith> also code and tests showing how and that it works: https://review.opendev.org/q/topic:%22bp%252Fglance-unified-quotas%22+(status:open%20OR%20status:merged)
14:17:34 <abhishekk> On the other hand we need to harden the documentation around it so that everyone knows how to use/configure the same
14:17:50 <dansmith> yep, and I'm happy to do that once we're settled on this
14:18:01 <abhishekk> I would like to other core reviewers to have a look at this proposal
14:18:21 <rosmaita> ack
14:18:37 <abhishekk> If we agree and get this done in early in the cycle then we have lots of time to restructure our policies
14:18:56 <abhishekk> So please have a look at the spec and give your suggestions at the earliest
14:19:02 <dansmith> yes, especially since it's mostly done (needs more tests), I'd love to get this merged and out of the way so we can focus on the policy stuff
14:19:14 <dansmith> having two large series in flight at the same time will be a challenge
14:19:16 <abhishekk> ++
14:19:57 <abhishekk> I am expecting this will be moving till our next meeting
14:20:02 <abhishekk> moving ahead
14:20:15 <abhishekk> #topic Bugs discussion in next meeting
14:20:39 <abhishekk> So as discussed in the meeting we will start discussing our bug backlogs from next meeting
14:20:54 <abhishekk> I will be coordinating with Steap for the same
14:21:00 <Steap> \o/
14:21:15 <abhishekk> I can see Steap has added some more bugs to our tracker, thank you Steap
14:21:28 <abhishekk> #link https://etherpad.opendev.org/p/glance-bug-tracker
14:21:59 <abhishekk> also jokke is working on analyzing some swift related issues, so we have already started on this
14:22:25 <abhishekk> and hopefully this cycle we will be able to reduce our bug backlog considerably
14:22:43 <abhishekk> anything here to add, Steap ??
14:23:19 <Steap> nah, let's close a lot of bugs :)
14:23:23 <abhishekk> cool
14:23:34 <abhishekk> #topic Open discussion
14:23:42 <abhishekk> I don't have anything today
14:23:45 <dansmith> I do,
14:23:53 <abhishekk> stage is yours
14:23:53 <dansmith> I've got a set of stuff up for the policy refactor: https://review.opendev.org/q/topic:%22policy-poc%22+(status:open%20OR%20status:merged)
14:24:00 <dansmith> last patch in the series hits image update
14:24:16 <dansmith> most of it is refactoring tests so they actually work with the default policy :/
14:24:40 <abhishekk> ack
14:24:42 <dansmith> definitely need some eyes from more experienced people on those refactors, especially property protections, to make sure they're legit
14:25:01 <abhishekk> I didn't got much time to have a look at it, but I will try to spend some time early next week
14:25:03 <dansmith> there are several refactors at the bottom of those that should be merge-able now, by the way
14:25:14 <dansmith> so it would be great to get those landed so the series is smaller if possible
14:25:20 <abhishekk> jokke, rosmaita please have a look if you have some free time
14:25:23 <dansmith> the ones without WIP in the front should be obvious
14:25:35 <rosmaita> ack
14:25:37 <abhishekk> ack
14:25:55 <jokke> is that current default policies or what they are going to be?
14:26:13 <dansmith> the functional tests all run with all policies set to ""
14:26:15 <jokke> And do we just feed some testing blanket policy atm?
14:26:27 <jokke> yeah, I thought that's the case
14:26:34 <dansmith> these refactors make it so that in the last patch I can set the test policy to what our actual default is at runtime
14:28:10 <abhishekk> Ok, anything else
14:29:51 <abhishekk> Would like to wrap this early so we can utilize this time in reviewing the spec
14:30:06 <abhishekk> So our priorities for this week would be;
14:30:06 <abhishekk> 1. Review Quotas specs
14:30:06 <abhishekk> 2. Have a look at policy refcator patches.
14:30:36 <abhishekk> great, thank you all for joining
14:30:47 <abhishekk> Have a great weekend ahead
14:30:49 <jokke> thanks, good to have you back abhishekk
14:30:54 <dansmith> ++
14:30:59 <abhishekk> thank you :D
14:31:16 <abhishekk> #endmeeting