14:00:15 <abhishekk> #startmeeting glance
14:00:16 <openstack> Meeting started Thu Feb  4 14:00:15 2021 UTC and is due to finish in 60 minutes.  The chair is abhishekk. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:19 <openstack> The meeting name has been set to 'glance'
14:00:20 <abhishekk> #topic roll call
14:00:25 <abhishekk> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:26 <abhishekk> o/
14:00:28 <dansmith> o/
14:00:45 <abhishekk> lets wait for others for couple of minutes
14:02:24 <rosmaita> sorry i'm late
14:02:25 <jokke> o/
14:02:36 <abhishekk> cool, everyone is here
14:02:41 <abhishekk> rosmaita, no worries
14:02:47 <abhishekk> lets start
14:02:49 <jokke> just out of previous call
14:02:58 <abhishekk> ack
14:03:07 <abhishekk> #topic release/periodic jobs update
14:03:12 <abhishekk> Final release of non-client libraries - 3 weeks
14:03:30 <abhishekk> No changes yet in glance-store, so we don't need to worry much about this
14:03:33 <dansmith> so we need to get those glanceclient scope patches in before that yeah?
14:03:47 <abhishekk> Milestone 3 - 4 weeks
14:04:03 <jokke> dansmith: it's non-client deadline. I think client has couple of weeks more
14:04:09 <abhishekk> right
14:04:12 <dansmith> oh sorry, non-client heh :)
14:04:26 <abhishekk> But it's good to have get those reviewed in time
14:04:46 <abhishekk> 4 weeks and we have lot much to do here
14:04:51 <abhishekk> Periodic jobs - 1 failure related to scrubber
14:05:22 <abhishekk> It is in delayed delete test, didn't go deep to look actual failure yet
14:05:31 <abhishekk> #topic Important specs reviews
14:05:42 <abhishekk> Distributed image import
14:06:01 <abhishekk> So we have PoC posted by jokke
14:06:33 <abhishekk> even though its not on top of dansmith's patch its there to get idea of what jokke is proposing
14:07:31 <abhishekk> As I stated last week, we need to take decision this week
14:08:09 <abhishekk> So I would like to proceed based on the voting here
14:08:35 <abhishekk> #startvote Should we use reserved property for proxy calls in this cycle and go ahead with location in Xena? Yes, No
14:08:35 <openstack> Begin voting on: Should we use reserved property for proxy calls in this cycle and go ahead with location in Xena? Valid vote options are Yes, No.
14:08:36 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
14:09:07 <abhishekk> #vote yes
14:09:15 <dansmith> #vote yes
14:09:19 <jokke> I'm just gonna use my veto here, if we're pushing it to Xena, I'm happy to use my -2 to make the whole change happen in Xena
14:09:24 <jokke> #vote no
14:09:41 <rosmaita> yeah, yeah, i am thinking
14:10:53 <rosmaita> i'm going to go with the cherished glance tradition of change now, hopefully refactor later
14:10:58 <rosmaita> #vote yes
14:11:27 <abhishekk> #endvote
14:11:28 <openstack> Voted on "Should we use reserved property for proxy calls in this cycle and go ahead with location in Xena?" Results are
14:11:30 <openstack> Yes (3): abhishekk, dansmith, rosmaita
14:11:31 <openstack> No (1): jokke
14:12:21 <abhishekk> So based on the voting, I would suggest dansmith to propose new spec for distributed image import and mention all the factors about refactoring the same in next cycle
14:12:54 <dansmith> okay, and revert the code to PS9...
14:13:21 <dansmith> jokke: if you're going to -2 it, I'd ask that you wait until I do that ^
14:13:36 <jokke> sure
14:14:12 <abhishekk> Yes, we will revisit the same in Xena and file separate spec which says "Refactor staging to use locations with stores" or something like that
14:14:39 <jokke> we all know that we won't
14:15:00 <dansmith> why not? aren't you going to do that work? I said I'd review it
14:15:13 <abhishekk> I am sorry jokke, your approach is also good but it consists lots of refactoring which is hard/not easy at this moment
14:15:40 <dansmith> and if we're not going to do the refactor, isn't it important to actually make sure that we fix this problem?
14:15:54 <abhishekk> we will
14:16:08 <abhishekk> I am taking that responsibility on my shoulder
14:16:32 <abhishekk> #action dansmith to file new spec for distribute image import
14:17:08 <abhishekk> moving ahead
14:17:32 <abhishekk> 2nd spec, Task show API
14:17:41 <abhishekk> dansmith, I have made changes as per your suggestion
14:17:42 <dansmith> I've been looking at the code this morning,
14:17:51 <dansmith> have some draft comments
14:18:00 <abhishekk> cool
14:18:22 <dansmith> i see the new spec revision, will hit that too
14:18:38 <abhishekk> ohh
14:18:55 <abhishekk> So it might gonna wait as I will be on leave for rest of the week :(
14:19:17 <dansmith> we should get the spec merged today then,
14:19:26 <abhishekk> right
14:19:29 <dansmith> because IIRC I said "let's make these cleanups after" anyway
14:19:43 <dansmith> right after the meeting then, I'll start looking
14:19:50 <abhishekk> ack
14:19:52 <abhishekk> moving ahead
14:19:59 <abhishekk> next big and important thing
14:20:12 <abhishekk> #topic Secure RBAC status
14:20:28 <abhishekk> https://review.opendev.org/q/project:openstack/glance+topic:secure-rbac
14:20:40 <abhishekk> SO we have base patches ready for reviews
14:20:50 <abhishekk> passing all the tests
14:21:11 <abhishekk> lbragstad, is working on adding/fixing new unit tests
14:21:19 <abhishekk> Functional tests against devstack - https://review.opendev.org/c/openstack/glance-tempest-plugin/+/773568
14:21:22 <abhishekk> we have this as well
14:21:30 <dansmith> these kinda scare me
14:21:47 <jokke> yeah, got update from him last night that lots of the failures were dependency version issues he's got fixed
14:22:07 <abhishekk> I would like all off you to add your reviews/concerns on the patches to get this rolling
14:22:25 * lbragstad is around if anyone has specific questions
14:22:37 <dansmith> my concerns aren't specific, just that I think they require a lot of detailed and careful review
14:22:45 <lbragstad> yeah - for sure
14:22:48 <dansmith> and I want someone more familiar with glance to go in front of me :P
14:23:15 <lbragstad> fwiw - i am working on a series of tests with glance's tempest plugin
14:23:38 <abhishekk> jokke, rosmaita ^^ (as I will be mostly away till next Tuesday)
14:24:08 <lbragstad> i'm hoping that makes things more clear - and i'm worried i implemented things properly with the ammount of mocking and stubs in glance's unit tests
14:24:09 <rosmaita> ack, but i have my own problems in this area
14:24:33 <abhishekk> yeah, I know
14:25:21 <abhishekk> lbragstad, I guess you are also working on releasing new oslo.policy version
14:25:37 <lbragstad> yes - we're hoping to do that today
14:26:12 <abhishekk> lbragstad, I guess it is better to use that version instead of fixing unit tests in glance (this is my opinion though)
14:26:31 <abhishekk> because glance has highest level of mocking in tests
14:26:42 <lbragstad> yeah - i figured that out last night :)
14:26:51 <abhishekk> :D
14:26:56 <dansmith> highest level... that would be .... 11?
14:27:17 <abhishekk> hehe
14:27:19 <jokke> not enough, on scale of 1-5
14:27:49 <lbragstad> i'm not opposed to waiting it it means we don't have to refactor a pile of tests to get them to run in parallel
14:28:01 <abhishekk> So I would like all of us to spend some time on this rbac stuff as well
14:28:02 <Steap> jokke: crnak it up to 6
14:28:45 <abhishekk> And thanks to lbragstad for driving this in glance
14:29:10 <lbragstad> thanks for the reviews - i apologize in advance :)
14:29:22 <abhishekk> :)
14:29:35 <abhishekk> moving ahead
14:29:41 <abhishekk> #Open discussion
14:29:53 <abhishekk> ohh
14:29:57 <abhishekk> #topic Open discussion
14:30:07 <jokke> There might be quite a cascade of failues incoming when we bump the oslo.policy minimum version up. So might be well in next week before we have anything gating again if we do that today
14:30:27 <abhishekk> Thank you jokke for carrying out bug scrubbing on his own
14:30:47 <abhishekk> I was away this week as well, so couldn't lend hand in that
14:31:27 <jokke> There is bunch that potentially needs attention. Not sure when I any of us can put some time to investigate.
14:31:53 <dansmith> abhishekk: I +2d that spec, I think you should push that through
14:31:57 <jokke> Some that looked like potentially deployment specific issues, some that might need deeper digging
14:32:08 <abhishekk> dansmith, ack
14:32:27 <abhishekk> jokke, ack, will try to go through them early next week
14:34:57 <abhishekk> Anything else for discussion?
14:36:29 <abhishekk> jokke, dansmith, rosmaita, Steap ??
14:36:33 <dansmith> nope
14:37:10 <abhishekk> going once
14:37:14 <rosmaita> nothing from me
14:37:21 <abhishekk> going twice
14:37:22 <jokke> I don't think so
14:37:25 <abhishekk> sold
14:37:29 <abhishekk> thank you all
14:37:37 <abhishekk> have a nice week ahead
14:38:04 <abhishekk> I will not be around, please drop me a mail if something needs to have quick attention
14:38:15 <abhishekk> #endmeeting